Subject: Non-idempotent operations

From: Peter Åstrand <[email-masked]>
Date: Tue, 4 Dec 2001 12:07:18 +0100 (CET)

Which NFSv4 operations are not idempotent? My guess: CLOSE, CREATE,
DELEGRETURN, LINK, LOCK, LOCKU, OPEN, OPENATTR, OPEN_CONFIRM,
OPEN_DOWNGRADE, REMOVE, RENAME and SETATTR. True?

-- 
Peter Åstrand                Telephone: +46-13-21 46 00
Cendio Systems               E-mail: [email-masked]
Teknikringen 3
583 30 Linköping
Sweden

---

From: "Khan, Saadia" <[email-masked]>
Date: Wed, 5 Dec 2001 11:11:20 -0800

u are right, lockt is idempotent.

Saadia

-----Original Message-----
From: Peter Åstrand [mailto:[email-masked]]
Sent: Wednesday, December 05, 2001 6:36 AM
To: [email-masked]
Subject: RE: Non-idempotent operations

On Tue, 4 Dec 2001, Khan, Saadia wrote:

> Also commit, delegpurge, lockt, setclientid and setclientid_confirm.

In what way is LOCKT not idempotent?