Subject: RE: Non-idempotent operations

From: "Khan, Saadia" <[email-masked]>
Date: Tue, 4 Dec 2001 10:48:30 -0800

Also commit, delegpurge, lockt, setclientid and setclientid_confirm.

Saadia

-----Original Message-----
From: Peter Åstrand [mailto:[email-masked]]
Sent: Tuesday, December 04, 2001 3:07 AM
To: [email-masked]
Subject: Non-idempotent operations

Which NFSv4 operations are not idempotent? My guess: CLOSE, CREATE,
DELEGRETURN, LINK, LOCK, LOCKU, OPEN, OPENATTR, OPEN_CONFIRM,
OPEN_DOWNGRADE, REMOVE, RENAME and SETATTR. True?

-- 
Peter Åstrand                Telephone: +46-13-21 46 00
Cendio Systems               E-mail: [email-masked]
Teknikringen 3
583 30 Linköping
Sweden

---

From: Mike Eisler <[email-masked]>
Date: Tue, 04 Dec 2001 18:11:48 -0800

Also WRITE and any other state changing operation, with exception of
those that implicitly modify access time (e.g. READ).

---

From: Peter Åstrand <[email-masked]>
Date: Wed, 5 Dec 2001 15:36:16 +0100 (CET)

> Also commit, delegpurge, lockt, setclientid and setclientid_confirm.

In what way is LOCKT not idempotent?