Subject: Re: Delegations mandatory?

From: [email-masked]
Date: Wed, 24 Jul 2002 07:00:37 -0500

Interesting that you mentioned the idea of a way for a client to tell the
server "don't consider delegations for me". I was thinking about posting on
this just yesterday. It would be nice to have a way for the client to
indicate on the SETCLIENTID call that it does not want to be considered for
delegatons. That way, the server does not have to bother with the CB_NULL
call to see if the callback path works. Seems like the idea of NULLing out
the callback info is reasonable. Also if one considers Mike E's recent idea
of a seperate SETCALLBACK operation, then a client just doesn't bother
sending callback info.

Carl

Carl Burnett
AIX Kernel Architecture - Distributed File Systems
(512) 838-8498, TL 678-8498
(please reply to [email-masked])

                      Peter Åstrand                                                                                                                 
                      <[email-masked].          To:       [email-masked]                                                         
                      se>                            cc:                                                                                            
                      Sent by: owner-nfsv4-          Subject:  Delegations mandatory?                                                               
                      [email-masked]                                                                                                        

                      07/24/2002 05:49 AM                                                                                                           

Is it mandatory for clients to support delegations? The description of
OPEN makes it look like that:

    "Note that delegation is up to the server to decide.  The client
    should never assume that delegation will or will not be granted in a
    particular instance.  It should always be prepared for either case."

Also, the description of SETCLIENTID:

    "The callback information provided in this operation will be used if
    the client is provided an open delegation at a future point.
    Therefore, the client must correctly reflect the program and port
    numbers for the callback program at the time SETCLIENTID is used."

I think it's a bit strange if the spec says that clients must implement
support for delegations. Simple clients, without delegation support, are
often useful.

In practice, one way of "preventing" delegations is to specify an
"invalid" cb_client4 in SETCLIENTID. This seems to work at least with the
CITI Linux server. The only problem is that the spec does not describe how
an "invalid" cb_client4 looks like. I think it should. We could say that
if SETCLIENTID4args.callback.cb_program == 0 and
SETCLIENTID4args.callback.cb_location.r_netid == "" and
SETCLIENTID4args.callback.cb_location.r_addr == "", then the server
promises not to grant delegations. Or something like that.

--
/Peter Åstrand <[email-masked]>

---

From: "Brian Mccorkle" <[email-masked]>
Date: Wed, 24 Jul 2002 08:22:44 -0500

My recollection of recent discussions is that the server tests the callback
path with CB_NULL and if that doesn't work, it doesn't delegate to that
client.

------------------------------------
Brian McCorkle
[email-masked]
IBM Corporation/Austin

                      Carl                                                                                                              
                      Burnett/Austin/IBM@IBMU        To:       Peter Åstrand <[email-masked]>                                   
                      S                              cc:       [email-masked]                                             
                      Sent by:                       Subject:  Re: Delegations mandatory?                                               
                      owner-nfsv4-wg@sunroof.                                                                                           
                      eng.sun.com                                                                                                       

                      07/24/2002 07:00 AM                                                                                               

Carl

Carl Burnett

(Embedded image moved to file: pic32314.gif)Peter Åstrand
<[email-masked]>

 (Embedd (Embedded image moved to file: pic04751.gif)  (Embedded image     
 ed                              Peter Åstrand         moved to file:      
 image                           <[email-masked]. pic07662.gif)       
 moved                           se>                                       
 to                              Sent by:              To:                 
 file:                           owner-nfsv4-wg@sunroo [email-masked] 
 pic2621                         f.eng.sun.com         g.sun.com           
 3.gif)                                                cc:                 
                                                       Subject:            
                                 07/24/2002 05:49 AM   Delegations         
                                                       mandatory?