Subject: RE: Issue 202: POSIX_ACL_MASK special user

From: "Khan, Saadia" <[email-masked]>
Date: Fri, 19 Jul 2002 10:48:04 -0700

What exactly does the posix acl mask stand for and does it hold any significance for a server that is not mapping POSIX acls to NFSV4 acls?

Saadia

> -----Original Message-----
> From: William A.(Andy) Adamson [mailto:[email-masked]] 
> Sent: Friday, July 19, 2002 10:40 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Issue 202: POSIX_ACL_MASK special user
> 
> 
> i think this is a small addition to the draft that makes a 
> large contribution 
> to interoperability. the ability to set the posix acl mask is 
> essential for 
> file systems that support posix acl's. the additon to this 
> special user makes 
> this possible. we have coded it, and it works. can it please 
> be included in 
> rfc 3010.
> 
> the issue should be reworded from:
> 
>   Issue202: 
> It may be possible to map a POSIX draft ACL to and from the 
> NFSv4 ACL with the 
> addition of a POSIX_ACL_MASK@ special user.
> 
> 
> to 
>  Issue202:
> It is possible to map a POSIX MASK ACL to and from the NFSv4 
> ACL with the 
> addition of a POSIX_ACL_MASK@ special user.
> 
> 
> -->Andy
> 
> 
>

---

From: [email-masked]
Date: Mon, 22 Jul 2002 16:36:06 -0700

>>>>> "SK" == Saadia Khan <Khan> writes:

    SK> What exactly does the posix acl mask stand for 

ACL_MASK is an additional bitmask that is defined in some drafts of
the POSIX ACL spec.  Its purpose in life is so that things like "chmod
600 foo" will do the Right Thing (in this example, disable access for
everyone except the owner) without changing individual ACL entries.

    SK> and does it hold any significance for a server that is not
    SK> mapping POSIX acls to NFSV4 acls?

ACL_MASK affects how the rest of the ACL is enforced, so I guess the
answer is "yes".

mike