Subject: RE: NFSv4 over SCTP ?

From: "Noveck, Dave" <[email-masked]>
Date: Fri, 6 Dec 2002 08:23:31 -0800

The issue is not the griping.  The guy who deployed the 
equipment may be long gone, and may not know enough 
about SCTP or RDDP to gripe.  It doesn't matter.

The issue is whether the existence of such boxes would
prevent RDDP adoption.  If it does, then the RDDP group
will wind up accommodating them, no matter what they 
think about them, or the people who deployed them.

-----Original Message-----
From: RJ Atkinson [mailto:[email-masked]]
Sent: Friday, December 06, 2002 10:22 AM
To: [email-masked]
Cc: nfsv4-wg
Subject: Re: NFSv4 over SCTP ?

On Thursday, Dec 5, 2002, at 20:03 America/Montreal, Brent Callaghan 
wrote:
> To quote Caitlin Bestler, one of the RDDP participants:
>
>     "SCTP is indeed a superior protocol to MPA/TCP for DDP, as it
>     is for many applications.
>
>     Realistically, however, if DDP relied solely upon SCTP it
>     would *not* meet the objective to work with IP networks *as
>     they are*. There are too many environments where middleboxes
>     have no SCTP capability, or at least no SCTP ability that
>     has been enabled."

A pox on middleboxes.  Just makes operational life more complicated.
Folks silly enough to deploy them don't have room to gripe.  Rather
like someone complaining about their foot hurting right after they
shot themselves in the foot deliberately...

Mumble.

Ran

---

From: "Noveck, Dave" <[email-masked]>
Date: Fri, 6 Dec 2002 11:01:23 -0800

Mike Eisler wrote: 
> SCTP seems to have lots of synergy
> with RDMA. If this wg pursues NFS/RDMA,
> it should confine itself
> to SCTP rather than pursing the
> futile task of adding record
> marks to TCP. The ips WG tried it
> and failed, the rddp wg tried it
> and failed, and so we will fail too.
> Therefore, support for
> RDMA implies support for SCTP.

Rather than get into a big discussion of
what the exact current state of play in the 
RDDP group is regarding the TCP issue, let's 
leave that issue to the RDDP group and see 
what develops.

Clearly, if the RDDP is not defined for 
TCP (and there are difficulties certainly),
we should certainly not attempt to define
RDMA with RDDP.  Similarly if they do define
RDDP on TCP, we can and should take advantage
of that work and use that facility to improve
NFS-v4, on TCP as well as SCTP.