Subject: Comments on draft-thurlow-nfsv4-repl-mig-design-00.txt

From: Mike Eisler <[email-masked]>
Date: Fri, 13 Dec 2002 13:52:36 -0800

Comments on draft-thurlow-nfsv4-repl-mig-design-00.txt

The introduction ought to mention that AFS and DCE/DFS have been
doing the replication and migration thing for years.

In the section 1.3 Current practice:

CHANGE:

	MacOS's HFS or NTFS

TO:

	MacOS's HFS or Windows's NTFS"

Under section 3, "What the protocol will not do", it
says:

	o being a tool to permit unprivileged users to copy file
`		trees may not be practical.

I don't understand why it would be impractical. It's just a matter
of authentication, authorization, and whatever policies exist on

the source and target file servers.

---

From: Robert Thurlow <[email-masked]>
Date: Wed, 18 Dec 2002 16:43:55 -0700 (MST)

Hi Mike,

Thanks for the comments; respoonses inline.

> doing the replication and migration thing for years.

Agreed.

> 	MacOS's HFS or Windows's NTFS"

Agreed.

> the source and target file servers.

This is in there to indicate that we're not interested in
bending the protocol to solve this problem.  Some would
like it solved, and it may wind up being fine to do if free,
but it's not a goal.  Does that clarify, or should I make a
change to the wording?  (BTW, your quote is coming from a
copy that looks different from the one in the IETF I-D
repository, so you might check that wording.)

I'll try to respin this before the break, since it's due to
expire soon.

Rob T

---

From: Brent Callaghan <[email-masked]>
Date: Wed, 18 Dec 2002 18:25:44 -0800

> repository, so you might check that wording.)

It's good to keep the goals focused, rather than "world hunger"
general, but I agree with Mike, restricting use of the protocol
to privileged users seems overly restrictive.  I recommend
it be removed.

	Brent

---

From: Mike Eisler <[email-masked]>
Date: Thu, 19 Dec 2002 09:57:00 -0800

>change to the wording?  (BTW, your quote is coming from a

Rob,

The trouble with way you are putting it is that if the protocol is 
designed in such a
way to make it hard for mortal users to use, then it becomes harder to 
add it later.

I believe we are under estimating the demand for such a capability and
so am against the protocol specifying something that prevents it from being
a tool for users. I also believe that we need to move rapidly,
and agree it is non-requirement for version 1.0 of the protocol.
I suggest changing the title of section 3 to "Non-requirements", and
altering the wording of the bullet item to:

    - the protocol will not explicitly include the capability to permit
        unprivileged users to copy file trees. Neither will the protocol 
preclude
        such capability.

>repository, so you might check that wording.)

Yes you are correct. I've no idea where the phrase "may not be 
practical" came from,
but it doesn't change my argument.

Thanks for following up.

    -mre

---

From: Robert Thurlow <[email-masked]>
Date: Thu, 19 Dec 2002 11:53:31 -0700 (MST)

>         unprivileged users to copy file trees. Neither will the protocol 

This works for me; something like it will go in the next draft.

Thanks,
Rob T