Subject: Re: [nfsv4] NFS Version 4 Minor Revisions

From: Mike Eisler <[email-masked]>
Date: Mon, 12 May 2003 15:17:03 -0700 (PDT)

> At what point does a too full train become NFSv5?

This is an excellent question to start asking and answering now.

I've some screens for when a minor version should be morphed to
a major version, and of course others may have different screens:

	1. when the total number of obsolete operations
		in all the minor versions reaches a certain
		threshold ( personally don't know what that might
		be but I'll know when I see it).
		Depending on we do directory delegations, we could
		hit such a threshold immediately. I.e. if we have to
		add a stateid to every operation that modifies a
		directory, or reads one (READDIR, LOOKUP, etc.), then
		it passes my threshold of tolerance. But there are
		ways to inject a stateid without changing every
		op.

	OR

	2.  when the total number of lines of re-written (as aopposed to
		added or deleted ... added is OK, deleted is desirable)
		text in all the minor versions reaches a certain percentage of
		original specification.

When it gets too graphically offensive, do v5 (and hope the death
march doesn't start again).
_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Trond Myklebust <[email-masked]>
Date: 13 May 2003 02:29:47 +0200

>>>>> " " == Mike Eisler <[email-masked]> writes:

     > 1. when the total number of obsolete operations
<snip>

     > 2.  when the total number of lines of re-written (as aopposed

Sounds like what you are really advocating is "be very very stingy
about adding cool-sounding new features". No?
  No quarrels with that...

This same question was asked during the Cthon, and IIRC the answer
then was that we bump the major number:

  1) If we need to add a new mandatory feature.
  2) If we need to remove support for existing features.

Cheers,
  Trond