Subject: RE: [nfsv4] re: re: yet more on ReleaseLockOwner

From: "Noveck, Dave" <[email-masked]>
Date: Tue, 9 Sep 2003 10:13:04 -0700

> > 
> > IOW the relationship has to be
> > 
> >    <open_on_a_file/seq#/lock_owner>
> 
> That's fine with me (it's what my server code currently implements), but
> given the hierarchy:
> 
> 		OpenOwner "P1"
> 		with open seqid#
> Open "a" <-StateidOa
> Open "b" <-StateidOb
>				LockOwner "P1"
>				seqid# N	<-StateidL1
> 						LockOwner "P1"
>						seqid# L	<- StateidL2
> 
> I would simply say that the "associated Open" (which holds the share/deny bits)
> is the Open for the correct file ("a" or "b" as indicated by the CFH for Read,
> Write or Setattr) off the same OpenOwner. (You only need one Open
> for each file for each OpenOwner, so that isn't ambiguous.)

You can't have more than open for each open owner for each file, but you can
have fewer (i.e. zero).  What if that file isn't opened by that open owner?

> For Close, you simply go over
> and check for locks on all the LockOwners off the same OpenOwner.

> Seems to me the required association exists?  

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Spencer Shepler <[email-masked]>
Date: Wed, 10 Sep 2003 22:19:21 -0500

> have fewer (i.e. zero).  What if that file isn't opened by that open owner?

Our server will return NFS4ERR_BAD_STATEID if the current-filehandle
does not match the stateid.

Spencer