Subject: RE: [nfsv4] FYI: Readdir not allowed on NFS pseudo root

From: "Noveck, Dave" <[email-masked]>
Date: Sun, 16 May 2004 14:02:52 -0700

NFS4ERR_NOENT is not listed as a valid error for READDIR.

-----Original Message-----
From: Jim Rees [mailto:[email-masked]]
Sent: Sunday, May 16, 2004 4:29 PM
To: [email-masked]
Subject: Re: [nfsv4] FYI: Readdir not allowed on NFS pseudo root 

  The current plan is to return NFS4ERR_NOENT for a READDIR of the NFSv4 
  pseudo root.

That seems wrong to me.  It would imply that the root does not exist, and in
my opinion would violate the spec.  I think you want something more like
NFS4ERR_ACCESS.

Other than that, an unreadable root seems acceptable, although unfriendly.
Why not put your flat file system somewhere below the root, and make that
unreadable?

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Spencer Shepler <[email-masked]>
Date: Sun, 16 May 2004 20:44:56 -0500

Seems like the server would return an "empty" response for READDIR
on this special server.

This also implies that clients must use LOOKUP to traverse the
server's namespace on things like traditional mount operations that
a client would do.  I know is very unlikely and bizarre that a client
would choose READDIR to peruse the server's namespace for
something like mount; I am just being pedantic.

Spencer