Subject: RE: [nfsv4] Some stuff on referrals/migration

From: "Yoder, Alan" <[email-masked]>
Date: Fri, 21 May 2004 06:27:13 -0700

>   I just don't think file server admins
> are going to move stuff around - unless there's some kind
> of accomodation for existing NFS clients.

   My understanding is different.  People are doing this
today, using tools to manage automount.  Not the ideal
solution, but the fact that it's happening shows there's
a need. 

Alan

===============================================================
Alan G. Yoder                                    [email-masked]
Technical Staff                          
Network Appliance, Inc.                            408-822-6919
===============================================================  

> -----Original Message-----
> From: Brent Callaghan [mailto:[email-masked]] 
> Sent: Thursday, May 20, 2004 10:02 PM
> To: Noveck, Dave
> Cc: [email-masked]
> Subject: Re: [nfsv4] Some stuff on referrals/migration
> 
> 
> Hi Dave,
> 
> I think we had a referrals/migration discussion a year or so
> back, where there issue came down to some fundamentals of a
> global namespace: should it be implemented at the client or
> at the server.  Currently it's based at the client, via automounters,
> and NFSv4 referrals are an attempt to base it at the server.
> But I don't think we're going to resolve that here.
> 
> I think NFS4ERR_MOVED and fs_locations was proposed with a more
> modest goal of allowing server admins to shuffle NFS filesystems
> around and the back end and not have to tell the clients, i.e.
> the clients would just automagically follow the referrals,
> mounts could stay in place, and files stay open.  I believe
> it was inspired by the AFS filesystem, which could quite
> easily relocate filesystems on the fly via some clever
> snapshotting and simple Volume Location Database updates.
> However, I don't think NFS is anywhere near as monolithic
> as AFS was, with its VLDB, cells, and special filesystems.
> 
> There are some issues that NFSv4 cannot have its own way,
> and filesystem relocation is probably one of them.  How
> do you make it work on a multi-protocol NAS server ?
> How do the CIFS, AFP and NFSv2,v3 clients follow a filesystem
> that's been moved ?  I just don't think file server admins
> are going to move stuff around - unless there's some kind
> of accomodation for existing NFS clients.
> 
> 	Brent
> 
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nfsv4
> 

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Peter Staubach <[email-masked]>
Date: Fri, 21 May 2004 15:53:35 -0600

> solution, but the fact that it's happening shows there's

Actually, I think that that was kind of the point.  Admins are doing
it today, hence there is a need.  I don't think that there has been
a question of the need.

The fact that the need is there, today, and not just when NFSv4 gets
around to its support, indicates that the other protocols, NFSv2/v3,
CIFS, what have you, need to be taken into account when designing
a namespace and the associated support to create, manipulate, and
monitor it.

		ps