Subject: RE: [nfsv4] pNFS security

From: [email-masked]
Date: Thu, 18 Nov 2004 18:13:15 -0500

> > >I should note that this "fallback to NFSv4 without pNFS" for
> > >interoperability is not a uniformly held view, among other reasons
> > >because there's an IBM SAN filesystem that can't do that
> > 
> > I don't understand how this is at all relevant to the discussion?
> > 
> > pNFS will be an NFSv4 minor revision, not a proprietary solution.

Actually, it has to do with ability of existing technology
to be modified to support the standard.  Making this easier
reduces the effort required to implement the standard.  OTOH,
there are points at which it makes sense to draw a line and
say that a certain class of system is outside the scope of
what the standard is intended for (e.g., when RDDP started,
there was a proposal to do it directly over IP, and that was
declared to be out of scope for the new WG).   My preference
is for the "fallback to NFSv4" approach to interoperability
(i.e., a pNFS server MUST be able to serve up all files
via NFSv4 to a client that can't or won't speak pNFS), and
this is consistent with Dave Noveck's views on what is
allowed in an NFSv4 minor revision.

> The one proposal we have to date contains a method of passing
> undisclosed layout information via the NFSv4 minor version.
> Depending on your definition, that could be considered proprietary.

While that's true of the currently available drafts, that's not
the intention of those who have worked on pNFS.  Although the
layout information isn't discussed in the operations draft, the
intent of those who have brought pNFS to the IETF is that the
layout information format and contents will be standardized for
the important classes/types of layout (block, file, object).

If the WG chairs want those layout format drafts soon, please
say so.

Thanks,
--David
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Spencer Shepler
> Sent: Thursday, November 18, 2004 5:26 PM
> To: [email-masked]
> Subject: Re: [nfsv4] pNFS security
> 
> 
> On Thu, Talpey, Thomas wrote:
> > At 11:42 AM 11/17/2004, [email-masked] wrote:
> > >I should note that this "fallback to NFSv4 without pNFS" for
> > >interoperability is not a uniformly held view, among other reasons
> > >because there's an IBM SAN filesystem that can't do that
> > 
> > I don't understand how this is at all relevant to the discussion?
> > 
> > pNFS will be an NFSv4 minor revision, not a proprietary solution.
> 
> The one proposal we have to date contains a method of passing
> undisclosed layout information via the NFSv4 minor version.  Depending
> on your definition, that could be considered proprietary.
> 
> Spencer
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nfsv4
> 

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: "Talpey, Thomas" <[email-masked]>
Date: Thu, 18 Nov 2004 21:13:36 -0500

>reduces the effort required to implement the standard.

I agree with this, but what I don't agree with is dismissing
the pNFS over NFSv4 approach: pNFS *is* NFSv4.

>If the WG chairs want those layout format drafts soon, please

Well, I'm not a WG chair, but I absolutely believe we should see
drafts for all layout types which we propose to support. Including
NFSv4.

Tom.