Subject: RE: [nfsv4] Another pNFS issue

From: [email-masked]
Date: Thu, 7 Jul 2005 13:43:18 -0400

> Julian Satran wrote:
> > 
> > Benny,
> > 
> > The only point I was trying to make is that the spec should only refer 
> > to what the server should do and not do and the exclusion of locks and 
> > outstanding layouts with conflicting ranges is probably the simplest way

> > to state it. As for enforcing it for object it can be enforced at 
> > whatever granularity you want - even on individual objects. A range 
> > credential is still being contemplated by the working group (prompted by

> > requests from at least two companies - Panasas being one of them AFAIR 
> > ;-)).
> > For SCSI block storage it is probably impractical and so it is for file 
> > unless file follows the ObS model in this case (as David Black's note 
> > appears to indicate).
> > 
> > Julo
> > 
> I'm not sure that we want to make this a strict requirement (rejecting 
> layoutgets due to a conflicting lock).  I can imagine file 
> implementations that can handle enforcing mandatory locks at the data 
> servers.  We've tried very hard to separate locking and other access 
> control mechanisms from layouts.  I understand that this may be the only 
> way to go in some situations (e.g., the current block proposal takes 
> this one step further) and the spec should be clear about the 
> possibilities.
> 
> -Garth

I would make this doubly conditional:

IF the pNFS server supports mandatory byte range locks
THEN byte range locks must behave as specified (as seen by users of files)
AND
	IF a Storage Device does not block access by a pNFS client who
		does not hold a required mandatory byte range lock.
	THEN the server must not grant layouts for that Storage Device
		to a client that permit access that conflicts with 
		a mandatory byte range lock held by another client.

This requires the pNFS server to understand the capabilities of its
Storage Devices, which is a perfectly reasonable requirement, IMHO.

Thanks,
--David
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Julian Satran <[email-masked]>
Date: Fri, 8 Jul 2005 09:25:28 +0300

That is a fair statement except that
the second IF refers to  "blocking" which you may want to
say as:

IF a Storage Device does not block access by other
means by a pNFS client who

does
not hold a required mandatory byte range lock...

Regards,

Julo

[email-masked]

Sent by: [email-masked]

07/07/2005 20:43

To

[email-masked], [email-masked]

cc

Subject

RE: [nfsv4] Another pNFS issue

AND

does
not hold a required mandatory byte range lock.

to
a client that permit access that conflicts with

a
mandatory byte range lock held by another client.

Thanks,

--David

+1 (508) 293-7953             FAX: +1 (508)
293-7786

nfsv4 mailing list

[email-masked]