Subject: RE: [nfsv4] Sleepy clients

From: Mike Eisler <[email-masked]>
Date: Thu, 25 Aug 2005 17:09:46 -0700 (PDT)

> -----Original Message-----
> From: Gordon Waidhofer [mailto:[email-masked]] 
> Sent: Thursday, August 25, 2005 4:55 PM
> To: [email-masked]; Noveck, Dave
> Cc: [email-masked]; Brent Callaghan
> Subject: RE: [nfsv4] Sleepy clients
> 
> 
> 
> What about itinerant laptops as well as sleepy?
> Is it possible, even likely, that when a laptop
> goes to sleep that when it wakes up it will be
> in a different place and negotiate a new IP address?

Could happen if the dhcp lease expires.

> Doesn't this complicate preservation of client
> state on the server side? And recovery?

It shouldn't. NFSv4 ties all state to clientids. If the
client wants to be itinerant or sleep, it had best use long hand
client ids that don't incorporate IP addresses. And the server
shouldn't be associating the long hand client id with
the source IP address either.

_______________________________________________
nfsv4 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nfsv4

---

From: Robert Gordon <[email-masked]>
Date: Fri, 26 Aug 2005 00:48:36 -0500

OP_ZZZ seems like the top of the very high slippery slop of a client
working in a 'disconnected' mode... There's a nasty tar pit at the
bottom of that slop..

-- Robert

---

From: "Talpey, Thomas" <[email-masked]>
Date: Fri, 26 Aug 2005 15:16:47 -0400

>the source IP address either.

I will add that the v4.1 session defines exactly this facility.

Because the session is client-created and client-destroyed,
it is able (with the server's permission) to survive for a very
long time indeed, and pick up where it left off regardless of
the connection address, type or network attribute that the
client may return with.

Tom.