Subject: [nfsv4] User level access control for a NFS share

From: <[email-masked]>
Date: Fri, 8 Apr 2011 05:12:12 -0400

Hi all,

I am working on a project wherein, we are migrating from NFS3 to NFS4.

In the NFS3, we can control the share access with IP address to make readwrite(rw) or readonly(ro)

For NFSV4, I would like to know, whether it supports user level access control for a NFS share.

i.e., for a NFS share  "share1", I want to set user1 to have readwrite(rw) access, where as user2 to have read only (ro).

Is there any documentation on this?

Awaiting your reply

Thanks & Regards,
Pavan

---

From: "Mike Eisler" <[email-masked]>
Date: Fri, 8 Apr 2011 07:02:21 -0700

NFSv4 has no impact on whether the NFS server's "share" model applies or not.

On Fri, April 8, 2011 2:12 am, [email-masked] wrote:
> i.e., for a NFS share  "share1", I want to set user1 to have readwrite(rw)
> access, where as user2 to have read only (ro).
>
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>

-- 
Mike Eisler, Senior Technical Director, NetApp, 719 599 9026,
http://blogs.netapp.com/eislers_nfs_blog/

---

From: Robert Thurlow <[email-masked]>
Date: Fri, 08 Apr 2011 08:07:30 -0600

> For NFSV4, I would like to know, whether it supports user level access control for a NFS share.

This is an alias dealing with NFSv4 standards.  Your equipment
vendor participates here to make that happen.  It is not a
great place for end-user support of this type.

Pertinent to your question, nothing in the NFSv4 standard means
there needs to be a difference share access lists, but only
your vendor knows for sure.

> Is there any documentation on this?

Your NFSv4 vendor should be able to provide plenty of documentation.

Rob T

---

From: sfaibish <[email-masked]>
Date: Fri, 08 Apr 2011 10:19:02 -0400

All in EMC Bangalore,

Please stop asking this kind of questions to this list. I believe I already
made this clear in t he past as this is embarassing to EMC. In the future  
send these
questions first to EMC experts: Sorin Faibish, David Black, Peter Staubach
and David Noveck. We are all members in the ietf WG and have the knowledge
to answer your questions.

/Sorin

On Fri, 08 Apr 2011 05:12:12 -0400, <[email-masked]> wrote:

> i.e., for a NFS share  "share1", I want to set user1 to have  
> readwrite(rw) access, where as user2 to have read only (ro).
>

-- 
Best Regards

Sorin Faibish
Corporate Distinguished Engineer
Unified Storage Division
         EMC²
where information lives

Phone: 508-249-5745
Cellphone: 617-510-0422
Email : [email-masked]