Subject: [nfsv4] SRV Protocol wording suggestions?

From: "Everhart, Craig" <[email-masked]>
Date: Tue, 28 Feb 2012 18:37:31 +0000

Positing that NFSv4 is defined for TCP, and that someday there might be an SCTP definition but there certainly isn't today.

The only defined values for a Protocol in the SRV record are "_tcp" and "_udp", with the apparently-understood semantics that "_tcp" is used to describe a service reachable via TCP and "_udp" means a service reachable over anything else (i.e., SCTP, should it ever come to pass).

Does anybody have a problem with the following text, for the SRV document about NFS access to a published domain root?

The Protocol name used is "_tcp", for NFS service over TCP.  Future NFS services using other protocols
MUST use another Protocol label.

                                Craig

---

From: Spencer Shepler <[email-masked]>
Date: Tue, 28 Feb 2012 18:39:09 +0000

That is fine with me.

Spencer

From: [email-masked] [mailto:[email-masked]] On Behalf Of Everhart, Craig
Sent: Tuesday, February 28, 2012 10:38 AM
To: [email-masked]
Subject: [nfsv4] SRV Protocol wording suggestions?

                                Craig

---

From: Robert Thurlow <[email-masked]>
Date: Tue, 28 Feb 2012 14:33:20 -0700

Everhart, Craig wrote:

> Does anybody have a problem with the following text, for the SRV 
> document about NFS access to a published domain root?
> 
>  
> 

Works for me.

Rob T

---

From: Nico Williams <[email-masked]>
Date: Tue, 28 Feb 2012 18:27:07 -0600

Me three.