Subject: [nfsv4] Returning NFS4ERR_NOSPC from REMOVE

From: Saul Tamari <[email-masked]>
Date: Thu, 23 Feb 2012 09:02:50 -0800

Hi,

Currently the RFC3530 doesn't list NFS4ERR_NOSPC as a possible return code
for REMOVE.
In an environment that supports writable snapshots or volume cloning there
could be a case where we do not have disk space for removing a directory
entry.

Could this be added to the BIS?

Thanks,
Saul

---

From: Benny Halevy <[email-masked]>
Date: Thu, 23 Feb 2012 15:22:34 -0800

On 2012-02-23 09:02, Saul Tamari wrote:
> Hi,
> 
> Currently the RFC3530 doesn't list NFS4ERR_NOSPC as a possible return code for REMOVE.
> In an environment that supports writable snapshots or volume cloning there could be a case where we do not have disk space for removing a directory entry.

Agreed.  Although it is not Posix compliant either, I've seen this need too.

Benny

> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4