Subject: [nfsv4] [PATCH 0/2] Address two comments from LDAP OID expert review

From: Chuck Lever <[email-masked]>
Date: Tue, 30 Oct 2012 10:39:20 -0400

Result of LDAP OID expert review:

"I approve the request contingent on the appropriate resolution of
the above two issues and Standards Action."

This patch series proposes changes that address these issues.

---

Chuck Lever (2):
      LDAP OID expert review: 'deprecated' -> 'historic'
      LDAP OID expert review: update Change Controller

 nsdb-proto.xml |   53 +++++++++++++++++++++++++++++------------------------
 1 files changed, 29 insertions(+), 24 deletions(-)

-- 
Chuck Lever

---

From: Chuck Lever <[email-masked]>
Date: Tue, 30 Oct 2012 10:39:29 -0400

The request says Author/Change Controller is the authors.  As this
document is being considered for the Standards Track, change control
(or owner) should be specified as the IESG.
---

 nsdb-proto.xml |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/nsdb-proto.xml b/nsdb-proto.xml
index f1c4eb9..2e0b32c 100644
--- a/nsdb-proto.xml
+++ b/nsdb-proto.xml
@@ -2886,7 +2886,7 @@
         <t hangText="Person &amp; email address to contact for further information:">
             See "Author/Change Controller" </t>
         <t hangText="Specification:"> draft-ietf-nfsv4-federated-fs-protocol </t>
-        <t hangText="Author/Change Controller:"> [document authors] </t>
+        <t hangText="Author/Change Controller:"> IESG ([email-masked]) </t>
         </list>
     </t>

---

From: Chuck Lever <[email-masked]>
Date: Tue, 30 Oct 2012 10:39:38 -0400

The request provides the usage 'deprecated' for a number of
descriptors to be registered.  No such usage is described in BCP 64
nor is used in the registry.  It is unclear to me exactly what is
meant by this term as the I-D doesn't provide any guidance.
However, the registry does support marking registrations as being
'historic in nature'.  Assuming these descriptors are not used in
the specification and are otherwise truly historic in nature, I
would suggest replacing 'deprecated' with 'historic'.  Otherwise,
I suggest removing 'deprecated' from the registration requests.
---

 nsdb-proto.xml |   51 ++++++++++++++++++++++++++++-----------------------
 1 files changed, 28 insertions(+), 23 deletions(-)

diff --git a/nsdb-proto.xml b/nsdb-proto.xml
index 2e0b32c..8e13726 100644
--- a/nsdb-proto.xml
+++ b/nsdb-proto.xml
@@ -2815,6 +2815,11 @@
     the registry should be sorted numerically by OID value. The initial contents of the
     FedFS Object Identifiers registry are given in <xref target="oid_registry"/>. </t>
 
+    <t> Note: A descriptor designated below as "historic" reserves an OID
+    used in a past version of the NSDB protocol.  Registering such OIDs
+    retains compatibility among existing implementations of the NSDB
+    protocol.  This document does not otherwise refer to historic OIDs. </t>
+
     <t><cref>
     RFC Editor: please replace RFC-TBD1 with this specification's RFC number.
     </cref></t>
@@ -2825,23 +2830,23 @@
         <ttcol align='left' >Reference</ttcol>
 
         <c> 1.3.6.1.4.1.31103.1.1    </c> <c> fedfsUuid               </c> <c> RFC-TBD1 </c>
-        <c> 1.3.6.1.4.1.31103.1.2    </c> <c> fedfsNetAddr            </c> <c> deprecated </c>
-        <c> 1.3.6.1.4.1.31103.1.3    </c> <c> fedfsNetPort            </c> <c> deprecated </c>
+        <c> 1.3.6.1.4.1.31103.1.2    </c> <c> fedfsNetAddr            </c> <c> historic </c>
+        <c> 1.3.6.1.4.1.31103.1.3    </c> <c> fedfsNetPort            </c> <c> historic </c>
         <c> 1.3.6.1.4.1.31103.1.4    </c> <c> fedfsFsnUuid            </c> <c> RFC-TBD1 </c>
-        <c> 1.3.6.1.4.1.31103.1.5    </c> <c> fedfsNsdbName           </c> <c> deprecated </c>
-        <c> 1.3.6.1.4.1.31103.1.6    </c> <c> fedfsNsdbPort           </c> <c> deprecated </c>
-        <c> 1.3.6.1.4.1.31103.1.7    </c> <c> fedfsNcePrefix          </c> <c> deprecated </c>
+        <c> 1.3.6.1.4.1.31103.1.5    </c> <c> fedfsNsdbName           </c> <c> historic </c>
+        <c> 1.3.6.1.4.1.31103.1.6    </c> <c> fedfsNsdbPort           </c> <c> historic </c>
+        <c> 1.3.6.1.4.1.31103.1.7    </c> <c> fedfsNcePrefix          </c> <c> historic </c>
         <c> 1.3.6.1.4.1.31103.1.8    </c> <c> fedfsFslUuid            </c> <c> RFC-TBD1 </c>
-        <c> 1.3.6.1.4.1.31103.1.9    </c> <c> fedfsFslHost            </c> <c> deprecated </c>
-        <c> 1.3.6.1.4.1.31103.1.10   </c> <c> fedfsFslPort            </c> <c> deprecated </c>
-        <c> 1.3.6.1.4.1.31103.1.11   </c> <c> fedfsFslTTL             </c> <c> deprecated </c>
+        <c> 1.3.6.1.4.1.31103.1.9    </c> <c> fedfsFslHost            </c> <c> historic </c>
+        <c> 1.3.6.1.4.1.31103.1.10   </c> <c> fedfsFslPort            </c> <c> historic </c>
+        <c> 1.3.6.1.4.1.31103.1.11   </c> <c> fedfsFslTTL             </c> <c> historic </c>
         <c> 1.3.6.1.4.1.31103.1.12   </c> <c> fedfsAnnotation         </c> <c> RFC-TBD1 </c>
         <c> 1.3.6.1.4.1.31103.1.13   </c> <c> fedfsDescr              </c> <c> RFC-TBD1 </c>
         <c> 1.3.6.1.4.1.31103.1.14   </c> <c> fedfsNceDN              </c> <c> RFC-TBD1 </c>
         <c> 1.3.6.1.4.1.31103.1.15   </c> <c> fedfsFsnTTL             </c> <c> RFC-TBD1 </c>
-        <c> 1.3.6.1.4.1.31103.1.100  </c> <c> fedfsNfsPath            </c> <c> deprecated </c>
-        <c> 1.3.6.1.4.1.31103.1.101  </c> <c> fedfsNfsMajorVer        </c> <c> deprecated </c>
-        <c> 1.3.6.1.4.1.31103.1.102  </c> <c> fedfsNfsMinorVer        </c> <c> deprecated </c>
+        <c> 1.3.6.1.4.1.31103.1.100  </c> <c> fedfsNfsPath            </c> <c> historic </c>
+        <c> 1.3.6.1.4.1.31103.1.101  </c> <c> fedfsNfsMajorVer        </c> <c> historic </c>
+        <c> 1.3.6.1.4.1.31103.1.102  </c> <c> fedfsNfsMinorVer        </c> <c> historic </c>
         <c> 1.3.6.1.4.1.31103.1.103  </c> <c> fedfsNfsCurrency        </c> <c> RFC-TBD1 </c>
         <c> 1.3.6.1.4.1.31103.1.104  </c> <c> fedfsNfsGenFlagWritable </c> <c> RFC-TBD1 </c>
         <c> 1.3.6.1.4.1.31103.1.105  </c> <c> fedfsNfsGenFlagGoing    </c> <c> RFC-TBD1 </c>
@@ -2902,7 +2907,7 @@
         <list style="hanging">
         <t hangText="Object Identifier:"> 1.3.6.1.4.1.31103.1.2 </t>
         <t hangText="Descriptor (short name):"> fedfsNetAddr </t>
-        <t hangText="Usage:"> attribute type, deprecated </t>
+        <t hangText="Usage:"> attribute type (historic) </t>
         </list>
     </t>
 
@@ -2910,7 +2915,7 @@
         <list style="hanging">
         <t hangText="Object Identifier:"> 1.3.6.1.4.1.31103.1.3 </t>
         <t hangText="Descriptor (short name):"> fedfsNetPort </t>
-        <t hangText="Usage:"> attribute type, deprecated </t>
+        <t hangText="Usage:"> attribute type (historic) </t>
         </list>
     </t>
 
@@ -2918,7 +2923,7 @@
         <list style="hanging">
         <t hangText="Object Identifier:"> 1.3.6.1.4.1.31103.1.4 </t>
         <t hangText="Descriptor (short name):"> fedfsFsnUuid </t>
-        <t hangText="Usage:"> attribute type </t>
+        <t hangText="Usage:"> attribute type (historic) </t>
         </list>
     </t>
 
@@ -2926,7 +2931,7 @@
         <list style="hanging">
         <t hangText="Object Identifier:"> 1.3.6.1.4.1.31103.1.5 </t>
         <t hangText="Descriptor (short name):"> fedfsNsdbName </t>
-        <t hangText="Usage:"> attribute type, deprecated </t>
+        <t hangText="Usage:"> attribute type (historic) </t>
         </list>
     </t>
 
@@ -2934,7 +2939,7 @@
         <list style="hanging">
         <t hangText="Object Identifier:"> 1.3.6.1.4.1.31103.1.6 </t>
         <t hangText="Descriptor (short name):"> fedfsNsdbPort </t>
-        <t hangText="Usage:"> attribute type, deprecated </t>
+        <t hangText="Usage:"> attribute type (historic) </t>
         </list>
     </t>
 
@@ -2942,7 +2947,7 @@
         <list style="hanging">
         <t hangText="Object Identifier:"> 1.3.6.1.4.1.31103.1.7 </t>
         <t hangText="Descriptor (short name):"> fedfsNcePrefix </t>
-        <t hangText="Usage:"> attribute type, deprecated </t>
+        <t hangText="Usage:"> attribute type (historic) </t>
         </list>
     </t>
 
@@ -2958,7 +2963,7 @@
         <list style="hanging">
         <t hangText="Object Identifier:"> 1.3.6.1.4.1.31103.1.9 </t>
         <t hangText="Descriptor (short name):"> fedfsFslHost </t>
-        <t hangText="Usage:"> attribute type, deprecated </t>
+        <t hangText="Usage:"> attribute type (historic) </t>
         </list>
     </t>
 
@@ -2966,7 +2971,7 @@
         <list style="hanging">
         <t hangText="Object Identifier:"> 1.3.6.1.4.1.31103.1.10 </t>
         <t hangText="Descriptor (short name):"> fedfsFslPort </t>
-        <t hangText="Usage:"> attribute type, deprecated </t>
+        <t hangText="Usage:"> attribute type (historic) </t>
         </list>
     </t>
 
@@ -2974,7 +2979,7 @@
         <list style="hanging">
         <t hangText="Object Identifier:"> 1.3.6.1.4.1.31103.1.11 </t>
         <t hangText="Descriptor (short name):"> fedfsFslTTL </t>
-        <t hangText="Usage:"> attribute type, deprecated </t>
+        <t hangText="Usage:"> attribute type (historic) </t>
         </list>
     </t>
 
@@ -3014,7 +3019,7 @@
         <list style="hanging">
         <t hangText="Object Identifier:"> 1.3.6.1.4.1.31103.1.100 </t>
         <t hangText="Descriptor (short name):"> fedfsNfsPath </t>
-        <t hangText="Usage:"> attribute type, deprecated </t>
+        <t hangText="Usage:"> attribute type (historic) </t>
         </list>
     </t>
 
@@ -3022,7 +3027,7 @@
         <list style="hanging">
         <t hangText="Object Identifier:"> 1.3.6.1.4.1.31103.1.101 </t>
         <t hangText="Descriptor (short name):"> fedfsNfsMajorVer </t>
-        <t hangText="Usage:"> attribute type, deprecated </t>
+        <t hangText="Usage:"> attribute type (historic) </t>
         </list>
     </t>
 
@@ -3030,7 +3035,7 @@
         <list style="hanging">
         <t hangText="Object Identifier:"> 1.3.6.1.4.1.31103.1.102 </t>
         <t hangText="Descriptor (short name):"> fedfsNfsMinorVer </t>
-        <t hangText="Usage:"> attribute type, deprecated </t>
+        <t hangText="Usage:"> attribute type (historic) </t>
         </list>
     </t>