Subject: [nfsv4] Terminology: "File system" vs "Filesystem"

From: Christoph Hellwig <[email-masked]>
Date: Tue, 29 Apr 2014 20:38:25 +0200

We probably should decide on one spelling, 3530 seems to prefer
"filesystem", while the newer specs like to have it spelled using two words:

RFC	filesystem	file system
3530	       252		  4
5661		 0		680
5662		 6		  1
5663		 0		 11
5664		 0		 33
NFSv4.2		 3		 20

---

From: Tom Haynes <[email-masked]>
Date: Tue, 29 Apr 2014 11:47:47 -0700

On Apr 29, 2014, at 11:38 AM, Christoph Hellwig <[email-masked]> wrote:

> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

It is “file system”.

I’ll fix these in 3530bis:

KinSlayer:3530bis loghyr$ grep filesystem *xml
nfsv4_middle_i18n.xml:      server-side physical filesystem. It is common for servers
nfsv4_middle_i18n.xml:      and physical filesystems to be configurable as to the behavior shown.
nfsv4_middle_i18n.xml:      in the same way for all accesses to a particular filesystem.
nfsv4_middle_i18n.xml:      subset of the physical filesystems exported, component names
nfsv4_middle_i18n.xml:      a server to use UTF-8-unaware physical filesystems that treat

---

From: "McDonald, Alex" <[email-masked]>
Date: Tue, 29 Apr 2014 18:56:25 +0000

Google n-gram

https://books.google.com/ngrams/graph?content=filesystem%2Cfile+system&year_start=1940&year_end=2014&corpus=15&smoothing=3&share=&direct_url=t1%3B%2Cfilesystem%3B%2Cc0%3B.t1%3B%2Cfile%20system%3B%2Cc0

File system is a winner.

Alex McDonald
Standards & Industry Associations Group
CTO Office
NetApp
+44 7795 046686 Mobile Phone
[email-masked]
twitter: @alextangent
Follow us: 

> -----Original Message-----
> From: nfsv4 [mailto:[email-masked]] On Behalf Of Tom Haynes
> Sent: 29 April 2014 19:48
> To: Christoph Hellwig
> Cc: [email-masked]
> Subject: Re: [nfsv4] Terminology: "File system" vs "Filesystem"
> 
> 
> It is "file system".
> I'll fix these in 3530bis:
>

---

From: Benny Halevy <[email-masked]>
Date: Wed, 30 Apr 2014 16:02:33 +0300

To make sense out of the two I always considered "file system" to be the software
running on the server while "filesystem" to be the entity that is served by that software.

Benny