Subject: [nfsv4] NFSv4.2 WG LC (is over)

From: Tom Haynes <[email-masked]>
Date: Tue, 2 Dec 2014 10:54:11 -0800

The only “open” issue I see is what do we do about inter-server SSC, specifically with regards to RPCSEC_GSSv3?

I.e., there is a normative reference on the RPCSEC_GSSv3 I-D and this I-D will not get published until that one is published.

There are two proposals:

1) Keep the normative reference in place and let the process take however much longer it needs.

2) Remove inter-server copy, creating a new document to track it, and leverage the new minor versioning proposal to get inter-server copy in place as soon as the RPCSEC_GSSv3 work is done. This approach will most likely require an additional WG review of the changes.

Comments?

---

From: Spencer Shepler <[email-masked]>
Date: Tue, 2 Dec 2014 18:56:11 +0000

Can the remaining work be summarized for RPCSEC_GSSv3 to inform this discussion?

> -----Original Message-----
> From: nfsv4 [mailto:[email-masked]] On Behalf Of Tom Haynes
> Sent: Tuesday, December 2, 2014 10:54 AM
> To: NFSv4
> Subject: [nfsv4] NFSv4.2 WG LC (is over)
> 
> I.e., there is a normative reference on the RPCSEC_GSSv3 I-D and this I-D will
> not get published until that one is published.
> 
> There are two proposals:
> 
> 2) Remove inter-server copy, creating a new document to track it, and leverage
> the new minor versioning proposal to get inter-server copy in place as soon as
> the RPCSEC_GSSv3 work is done. This approach will most likely require an
> additional WG review of the changes.
> 
> Comments?
> 
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4

---

From: "Adamson, Andy" <[email-masked]>
Date: Tue, 2 Dec 2014 19:01:55 +0000

> On Dec 2, 2014, at 1:54 PM, Tom Haynes <[email-masked]> wrote:
> 

I just submitted a draft (argh, I called it draft-ietf-nfsv4-rpcsec-gssv3-09 - it should have been draft-ietf-nfsv4-rpcsec-gssv3-01) that responded to all concerns. The only comment I have is to flatten some of the XDR.

AFAICS we can go to last call on gssv3.

> 
> I.e., there is a normative reference on the RPCSEC_GSSv3 I-D and this I-D will not get published until that one is published

> 1) Keep the normative reference in place and let the process take however much longer it needs.

If gssv3 goes to WGLC then how does the timing work out?

> 2) Remove inter-server copy, creating a new document to track it, and leverage the new minor versioning proposal to get inter-server copy in place as soon as the RPCSEC_GSSv3 work is done. This app…

You would also need to remove Full mode LNFS - a _highly_ desired feature as guest-mode LNFS leaves a very large security hole.

—>Andy

---

From: Tom Haynes <[email-masked]>
Date: Tue, 2 Dec 2014 11:04:09 -0800

> On Dec 2, 2014, at 11:01 AM, Adamson, Andy <[email-masked]> wrote:
> 
> 

That was removed some time ago. :-)

---

From: "Adamson, Andy" <[email-masked]>
Date: Tue, 2 Dec 2014 19:07:57 +0000

> On Dec 2, 2014, at 2:04 PM, Tom Haynes <[email-masked]> wrote:
> 
>> 

Well, it shouldn’t be! All VM implementations (Red Hat Open Stack for one) really need it.

—>Andy

---

From: "Adamson, Andy" <[email-masked]>
Date: Tue, 2 Dec 2014 19:23:07 +0000

> On Dec 2, 2014, at 2:07 PM, Adamson, Andy <[email-masked]> wrote:
> 
> 

Oh - I see, it is mentioned as the solution for Full mode, but the NFSv4.2 draft does not REQUIRE it. Fair enough.

—>Andy

---

From: "Adamson, Andy" <[email-masked]>
Date: Tue, 2 Dec 2014 19:52:53 +0000

> On Dec 2, 2014, at 1:56 PM, Spencer Shepler <[email-masked]> wrote:
> 
> 

The latest draft (draft-ietf-nfsv4-rpcsec-gssv3-09) addressed these issues in  draft-ietf-nfsv4-rpcsec-gssv3-00 discussed on the Kitten WG and NFSv4 WG lists.

1) multi-principal assertion:
The draft-ietf-nfsv4-rpcsec-gssv3-00 use of a nonce and MIC of a nonce was found to be open to attack. The use of the nonce/MIC of nonce was replaced by the use of a MIC over RPC header data (includiing the credential) using the inner context handle for both the arg and response.

2) assertion critical bit:
This bit was removed in favor of always returning accepted assertions in the rcr_assertions field of the RPCSEC_GSS_CREATE response, rgss3_create_res.

3) Miscelaneous cleanups and word crafting.

Changes I have so far for the next draft: 

1) flatten rgss3_assertion, just use rgss3_assertion_u
2) Some more miscelaneous cleanups including removing the “.txt” from the title :)

Note that at the last bakeathon in Boston, I went over (in great detail) the use of GSSv3 label assertions to enable Full mode LNFS with both Open Stack and SELinux engineers from Red Hat.  The scaling and use of the design was approved - and welcomed as Full mode LNFS is a highly desired feature.

So if I don’t get anymore comments, I would say the next draft would be ready for WGLC.

—>Andy

---

From: <[email-masked]>
Date: Tue, 2 Dec 2014 21:08:04 +0000

Thanks, Andy.  Do you have a timeline for the next update?

Spencer

From: Adamson, Andy
Sent: ‎Tuesday‎, ‎December‎ ‎2‎, ‎2014 ‎11‎:‎52‎ ‎AM
To: Spencer Shepler
Cc: NFSv4

—>Andy

---

From: "Adamson, Andy" <[email-masked]>
Date: Tue, 2 Dec 2014 21:52:39 +0000

> On Dec 2, 2014, at 4:08 PM, [email-masked] wrote:
> 
> 

I’ll submit the next update by Monday Dec 8 2014.

—>Andy