Subject: [nfsv4] Is it time for a -00 for the IETF96 wg meeting draft agenda?

From: David Noveck <[email-masked]>
Date: Wed, 15 Jun 2016 09:27:31 -0400

First a warning.  I'm going to be discussing schedules.

Now for people who are have not hit delete and are still reading, my answer
to the above question is "Yes, we need it soon"

Let me provide some background here:

   - Spencer originally wanted to get a start on a draft agenda by 5/20.
   While people did provide information about things they might talk about,
   there were not specific talk proposals with titles and durations that
   Spencer could use as the basis for an early draft agenda .  In any case,
   that target date went by nearly four weeks ago.
   - The critical target date is 7/7 by which time an actual agenda has to
   be provided.  Given the discussion that has already gone on regarding
   things that might talked about (by me, Chuck, and Christoph) it is pretty
   clear that some sort of draft can be provided by that date, given that we
   have the option, since it is a "draft", of making needed changes later.
   - If we want an agenda that truly reflects the working group's needs, we
   need to have a draft that we can discuss and possibly update before the
   official draft agenda is ready for submission.  Given that the target date
   is about three weeks off, I think we need to have that -00 for the draft
   within the next week.

I'm going to propose a couple of talks below.  I think it makes sense for
anyone with a talk proposal to add theirs to the list.  If those fit in 150
minutes, we have our -00.  If not, we may need some working group
discussion to get to a -00.  While I expect the working group to try to
accommodate late-arriving proposals, I'd hope that people would get their
proposals in as soon as possible.

Anyway, my proposed talks would be:

   - A discussion about the NFSv4 extension stuff, *NFSv4 Extension
   Paradigm: What Next?.*  The documents to be discussed would be
*draft-ietf-nfsv4-versioning-04
   *and *draft-dnoveck-nfsv4-extension-00* (TBD).  The goal was to resolve
   current disagreements about whether we should go on as we have, with the
   existing standards-track document, convert the existing working-group
   document to be informational, or to split the document into standards-track
   and informational documents.  I'd allocate 30 minutes for this.
   - A presentation about currently proposed extensions to RPC-over-RDMA
   Version Two, *Updating RPC-over-RDMA: Next steps.* The documents to be
   discussed would be *draft-dnoveck-nfsv4-rpcrdma-**xcharext-00*,
   *draft-dnoveck-nfsv4-rpcrdma-rtissues-00*, and
   *draft-dnoveck-nfsv4-rpcrdma-rtrext-00.*  The goal here would be to
   present and discuss current extension proposals, see what the working group
   response is, and decide where we want to go next in this area.  I'd
   allocate 30 minutes for this.

---

From: Christoph Hellwig <[email-masked]>
Date: Wed, 15 Jun 2016 15:45:24 +0200

FYI, I'd really be able to lock in a Date as I've travel line up on
both end of the schedule, and I'd love to buy tickets to Berlin
rather sooner than later.

---

From: David Noveck <[email-masked]>
Date: Wed, 15 Jun 2016 10:39:28 -0400

- *2016-06-17 (Friday):* Preliminary agenda published for comment.
   - *2016-06-22 (Wednesday):* Cutoff date for requests to reschedule
   Working Group and BOF meetings UTC 23:59.
   - *2016-06-24 (Friday):* Final agenda to be published.

If you are talking about buying tickets I guess you'll have to wait until
6/24.

Maybe you'll have enough information from the preliminary agenda on 6/17 to
make a talk proposal.

---

From: Spencer Shepler <[email-masked]>
Date: Wed, 15 Jun 2016 15:01:00 +0000

To: all

All working groups have been asked by the secretariat to review their meeting plans – time/schedule is “tight” for this IETF.

The meeting will be scheduled but the question is if we need the full 2.5 hours.  So, pulling together the agenda would be prudent.

Also, if you plan in attending in person, please send me direct email.

Spencer

From: nfsv4 [mailto:[email-masked]] On Behalf Of David Noveck
Sent: Wednesday, June 15, 2016 7:39 AM
To: Christoph Hellwig <[email-masked]>
Cc: [email-masked]
Subject: Re: [nfsv4] Is it time for a -00 for the IETF96 wg meeting draft agenda?

  *   2016-06-17 (Friday): Preliminary agenda published for comment.
  *   2016-06-22 (Wednesday): Cutoff date for requests to reschedule Working Group and BOF meetings UTC 23:59.
  *   2016-06-24 (Friday): Final agenda to be published.
If you are talking about buying tickets I guess you'll have to wait until 6/24.

Maybe you'll have enough information from the preliminary agenda on 6/17 to make a talk proposal.

On Wed, Jun 15, 2016 at 9:45 AM, Christoph Hellwig <[email-masked]<mailto:[email-masked]>> wrote:
FYI, I'd really be able to lock in a Date as I've travel line up on
both end of the schedule, and I'd love to buy tickets to Berlin
rather sooner than later.

---

From: Chuck Lever <[email-masked]>
Date: Thu, 16 Jun 2016 11:09:30 -0400

> On Jun 15, 2016, at 9:27 AM, David Noveck <[email-masked]> wrote:
> 
> Now for people who are have not hit delete and are still reading, my answer to the above question is "Yes, we need it soon"
> 
> 	• Spencer originally wanted to get a start on a draft agenda by 5/20.  While people did provide information about things they might talk about, there were not specific talk proposals with titles and durations that Spencer could use as the basis for an early draft agenda .  In any case, that target date went by nearly four weeks ago.
> 	• The critical target date is 7/7 by which time an actual agenda has to be provided.  Given the discussion that has already gone on regarding things that might talked about (by me, Chuck, and Christoph) it is pretty clear that some sort of draft can be provided by that date, given that we have the option, since it is a "draft", of making needed changes later.
> 	• If we want an agenda that truly reflects the working group's needs, we need to have a draft that we can discuss and possibly update before the official draft agenda is ready for submission.  Given that the target date is about three weeks off, I think we need to have that -00 for the draft within the next week.
> I'm going to propose a couple of talks below.  I think it makes sense for anyone with a talk proposal to add theirs to the list.  If those fit in 150 minutes, we have our -00.  If not, we may need some working group discussion to get to a -00.  While I expect the working group to try to accommodate late-arriving proposals, I'd hope that people would get their proposals in as soon as possible. 
> 
> 	• A discussion about the NFSv4 extension stuff, NFSv4 Extension Paradigm: What Next?.  The documents to be discussed would be draft-ietf-nfsv4-versioning-04 and draft-dnoveck-nfsv4-extension-00 (TBD).  The goal was to resolve current disagreements about whether we should go on as we have, with the existing standards-track document, convert the existing working-group document to be informational, or to split the document into standards-track and informational documents.  I'd allocate 30 minutes for this.  
> 	• A presentation about currently proposed extensions to RPC-over-RDMA Version Two, Updating RPC-over-RDMA: Next steps. The documents to be discussed would be draft-dnoveck-nfsv4-rpcrdma-xcharext-00, draft-dnoveck-nfsv4-rpcrdma-rtissues-00, and draft-dnoveck-nfsv4-rpcrdma-rtrext-00.  The goal here would be to present and discuss current extension proposals, see what the working group response is, and decide where we want to go next in this area.  I'd allocate 30 minutes for this.

As an introduction to the second talk above, I can give
an introduction to rpcrdma-version-two in about 10
minutes.

I can also give a presentation soliciting input and
answering questions about the current status and end-game
for rfc5666bis, rpcrdma-bidirection, and rfc5667bis.
That would take about 10 minutes.

--
Chuck Lever