Subject: [nfsv4] [Technical Errata Reported] RFC5661 (4712)

From: RFC Errata System <[email-masked]>
Date: Thu, 16 Jun 2016 05:43:54 -0700 (PDT)

The following errata report has been submitted for RFC5661,
"Network File System (NFS) Version 4 Minor Version 1 Protocol".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5661&eid=4712

--------------------------------------
Type: Technical
Reported by: Trond Myklebust <[email-masked]>

Section: 6.2.1.3.1.

Original Text
-------------
   ACE4_DELETE

      Operation(s) affected:

         REMOVE

Corrected Text
--------------
   ACE4_DELETE

      Operation(s) affected:

         REMOVE

         RENAME

Notes
-----
ACE4_DELETE on the source file may allow a rename to proceed in cases where the user does not have ACE4_DELETE_CHILD on the source directory. It may also affect the ability of the user to be able to RENAME if there is an existing file in the target directory with the target name.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5661 (draft-ietf-nfsv4-minorversion1-29)
--------------------------------------
Title               : Network File System (NFS) Version 4 Minor Version 1 Protocol
Publication Date    : January 2010
Author(s)           : S. Shepler, Ed., M. Eisler, Ed., D. Noveck, Ed.
Category            : PROPOSED STANDARD
Source              : Network File System Version 4
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: David Noveck <[email-masked]>
Date: Fri, 17 Jun 2016 13:55:13 -0400

Proposed corrections look OK to me.

On Thu, Jun 16, 2016 at 8:43 AM, RFC Errata System <
[email-masked]> wrote:

> ACE4_DELETE on the source file may allow a rename to proceed in cases
> where the user does not have ACE4_DELETE_CHILD on the source directory. It
> may also affect the ability of the user to be able to RENAME if there is an
> existing file in the target directory with the target name.
>
> Instructions:
> -------------
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>