Subject: [nfsv4] Stephen Farrell's No Objection on draft-ietf-nfsv4-scsi-layout-08: (with COMMENT)

From: "Stephen Farrell" <[email-masked]>
Date: Thu, 01 Sep 2016 05:21:17 -0700

Stephen Farrell has entered the following ballot position for
draft-ietf-nfsv4-scsi-layout-08: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-nfsv4-scsi-layout/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

- 1.4: (A question for the IESG/RFC editor and not the
document authors.) How will shell scripts like this be
affected by new RFC formats?  Have we thought about whether
that'll work? Maybe the text here (and in similar cases) ought
in future say that it's the plain ascii form of the RFC that
needs to be fed into the script, as odd things may happen with
other formats. (Note: I don't think this document ought be
held up while that is discussed, if discussion is needed.)

- 2.4.10: MDS is used without expansion or reference. A very
quick search didn't help me figure out for sure what that
means btw;-) Is it metadata-server?

- 2.4.10: is "device device ID" a typo?

- section 6: Is the SAM-5 reference correct? Is the XXXXX
something that the RFC editor will need to fix? If so, that
probably should be noted in the document so it's not
forgotten. If the XXXXX means that that's a draft that's not
yet final then you probably also need to tell the RFC editor
to wait until the final document is published.

---

From: Christoph Hellwig <[email-masked]>
Date: Sun, 4 Sep 2016 15:20:03 +0200

> means btw;-) Is it metadata-server?

It is.  It's common terminology in recent NFS documents, but we
should introduce it neverless.

> - 2.4.10: is "device device ID" a typo?

yes.

> to wait until the final document is published.

David Black asked me to update the SAM-4 refernece to SAM-5,
but given that SAM-5 hasn't been through the whole ISO pipeline
I didn't know how to quote it.  Here is the reference to the
disccusion:

   https://www.ietf.org/mail-archive/web/nfsv4/current/msg14855.html

I don't really know how to best handle this situation, so any guidance
is welcome.

---

From: Stephen Farrell <[email-masked]>
Date: Sun, 4 Sep 2016 16:18:52 +0100

> I don't really know how to best handle this situation, so any guidance

I guess the generic choices are to replace that with the currently
published reference, or to wait for the updated one to be published.
You seem to have decided for the latter, which is fine, but then
it'd be good to tell the RFC editor about that. (Either via a note
in the draft if you update it again, or else in an RFC editor note,
or both.)

If it turns out to take too long for the updated reference to be
published, you can back-down to the currently published one - I'd
say your AD would be ok with that if it's a reasonable thing to do.

Cheers,
S.

---

From: "Black, David" <[email-masked]>
Date: Mon, 5 Sep 2016 23:17:08 +0000

> in the draft if you update it again, or else in an RFC editor note,

Referencing SAM-5 (publication expected in 2016) is a significant improvement over referencing SAM-4 (published in 2008).  Given that SAM-5 is technically complete with standards publication in progress, it would be helpful to insert a note to the RFC Editor saying this (the following text could be inserted in the draft near the reference):

[RFC Editor:  This draft has a normative dependence on SAM-5, whose publication as a standard is in progress.  Publication of this draft as an RFC has to wait for publication of SAM-5 including availability of a reference to the published standard.  The author will be able to advise the RFC Editor when SAM-5 is published and supply the necessary reference.]

> say your AD would be ok with that if it's a reasonable thing to do.

Thanks, --David

> -----Original Message-----
> From: nfsv4 [mailto:[email-masked]] On Behalf Of Stephen Farrell
> Sent: Sunday, September 04, 2016 11:19 AM
> To: Christoph Hellwig
> Cc: [email-masked]; The IESG; [email-masked]; draft-ietf-nfsv4-scsi-
> [email-masked]
> Subject: Re: [nfsv4] Stephen Farrell's No Objection on draft-ietf-nfsv4-scsi-
> layout-08: (with COMMENT)
> 
> 
>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 6 Sep 2016 15:24:24 -0500

Just for the record ...

On Mon, Sep 5, 2016 at 6:17 PM, Black, David <[email-masked]> wrote:

> Referencing SAM-5 (publication expected in 2016) is a significant
> improvement over referencing SAM-4 (published in 2008).  Given that SAM-5
> is technically complete with standards publication in progress, it would be
> helpful to insert a note to the RFC Editor saying this (the following text
> could be inserted in the draft near the reference):
>
> [RFC Editor:  This draft has a normative dependence on SAM-5, whose
> publication as a standard is in progress.  Publication of this draft as an
> RFC has to wait for publication of SAM-5 including availability of a
> reference to the published standard.  The author will be able to advise the
> RFC Editor when SAM-5 is published and supply the necessary reference.]
>
> I'll work w/Christoph on this, which can all be sorted out before or
> during AUTH48, including considering this possible course of action, if
> necessary:
>

I'm fine with this (assuming that the WG is OK to wait on final publication
of the RFC), and have a pretty strong preference for "before AUTH48"
(considering that I haven't sent an Approval e-mail to the secretariat for
this one pending comment resolution, Really Soon would be awesome :-)

Spencer