Subject: Re: [nfsv4] Question on NFSv4.1 RFC 5661 - inconsistency in destroy-clientid being first op

From: "Noveck, David" <[email-masked]>
Date: Thu, 8 Jun 2017 21:22:52 +0000

It appears that the list in the first paragraph you quote is incomplete.

  *   Am I misunderstanding something here?

No.

From: Price, Jonathan [mailto:[email-masked]]
Sent: Thursday, June 8, 2017 5:03 PM
To: [email-masked]; Noveck, David <[email-masked]>; [email-masked]
Subject: Question on NFSv4.1 RFC 5661 - inconsistency in destroy-clientid being first op

Hi All,

I'm implementing a NFSv4.1 server and stumbled upon the following incongruent sections in RFC 5661.  The section below indicates the other ops besides SEQUENCE which may appear as the first and only op in a compound. Cool - no problem there.

      SEQUENCE MUST appear as the first operation of any COMPOUND in which
   it appears.  The error NFS4ERR_SEQUENCE_POS will be returned when it
   is found in any position in a COMPOUND beyond the first.  Operations
   other than SEQUENCE, BIND_CONN_TO_SESSION, EXCHANGE_ID,
   CREATE_SESSION, and DESTROY_SESSION, MUST NOT appear as the first
   operation in a COMPOUND.  Such operations MUST yield the error
   NFS4ERR_OP_NOT_IN_SESSION if they do appear at the start of a
   COMPOUND.

But, I find destroy_clientid also says it can be first and only op:

   If DESTROY_CLIENTID is not prefixed by SEQUENCE, it MUST be the only

   operation in the COMPOUND request (otherwise, the server MUST return

   NFS4ERR_NOT_ONLY_OP).  If the operation is sent without a SEQUENCE

   preceding it, a client that retransmits the request may receive an

   error in response, because the original request might have been

   successfully executed.

Am I misunderstanding something here?

Thanks,
Jonathan Price
Senior Software Engineer - Dell/EMC

---

From: "Price, Jonathan" <[email-masked]>
Date: Fri, 9 Jun 2017 13:20:26 +0000

Cool - thanks David!  I appreciate the quick feedback.

Cheers,
Jonathan

From: Noveck, David [mailto:[email-masked]]
Sent: Thursday, June 08, 2017 5:23 PM
To: Price, Jonathan; [email-masked]
Cc: [email-masked]
Subject: RE: Question on NFSv4.1 RFC 5661 - inconsistency in destroy-clientid being first op

No.

From: Price, Jonathan [mailto:[email-masked]]
Sent: Thursday, June 8, 2017 5:03 PM
To: [email-masked]<mailto:[email-masked]>; Noveck, David <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Question on NFSv4.1 RFC 5661 - inconsistency in destroy-clientid being first op

Hi All,

   successfully executed.

Thanks,
Jonathan Price