Subject: [nfsv4] [Technical Errata Reported] RFC5661 (5040)

From: RFC Errata System <[email-masked]>
Date: Mon, 12 Jun 2017 10:29:17 -0700 (PDT)

The following errata report has been submitted for RFC5661,
"Network File System (NFS) Version 4 Minor Version 1 Protocol".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5040

--------------------------------------
Type: Technical
Reported by: Jonathan Price <[email-masked]>

Section: 18.46.3

Original Text
-------------
Operations other than SEQUENCE, BIND_CONN_TO_SESSION, EXCHANGE_ID,
CREATE_SESSION, and DESTROY_SESSION, MUST NOT appear as the first
operation in a COMPOUND.  

Corrected Text
--------------
Operations other than SEQUENCE, BIND_CONN_TO_SESSION, 
EXCHANGE_ID, DESTROY_CLIENT_ID, CREATE_SESSION, and 
DESTROY_SESSION, MUST NOT appear as the first 
operation in a COMPOUND.  

Notes
-----
In the section for DESTROY_CLIENTID (18.50.3), the following text exists (see snipped section below).
This means that DESTROY_CLIENTID must also be in the list for operations that are allowed
in the first operation of a compound.

<...snip...>
   If DESTROY_CLIENTID is not prefixed by SEQUENCE, it MUST be the only
   operation in the COMPOUND request (otherwise, the server MUST return
   NFS4ERR_NOT_ONLY_OP).  If the operation is sent without a SEQUENCE
   preceding it, a client that retransmits the request may receive an
   error in response, because the original request might have been
   successfully executed.
<...snip...>

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5661 (draft-ietf-nfsv4-minorversion1-29)
--------------------------------------
Title               : Network File System (NFS) Version 4 Minor Version 1 Protocol
Publication Date    : January 2010
Author(s)           : S. Shepler, Ed., M. Eisler, Ed., D. Noveck, Ed.
Category            : PROPOSED STANDARD
Source              : Network File System Version 4
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: "Noveck, David" <[email-masked]>
Date: Mon, 12 Jun 2017 17:49:10 +0000

Should be verified.  Leaving out DESTROY_CLIENT_ID in 18.46.13 was an oversight.

-----Original Message-----
From: RFC Errata System [mailto:[email-masked]] 
Sent: Monday, June 12, 2017 1:29 PM
To: [email-masked]; [email-masked]; Noveck, David <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Technical Errata Reported] RFC5661 (5040)

The following errata report has been submitted for RFC5661, "Network File System (NFS) Version 4 Minor Version 1 Protocol".

Section: 18.46.3

Original Text
-------------
Operations other than SEQUENCE, BIND_CONN_TO_SESSION, EXCHANGE_ID, CREATE_SESSION, and DESTROY_SESSION, MUST NOT appear as the first operation in a COMPOUND.  

Corrected Text
--------------
Operations other than SEQUENCE, BIND_CONN_TO_SESSION, EXCHANGE_ID, DESTROY_CLIENT_ID, CREATE_SESSION, and DESTROY_SESSION, MUST NOT appear as the first operation in a COMPOUND.  

Notes
-----
In the section for DESTROY_CLIENTID (18.50.3), the following text exists (see snipped section below).
This means that DESTROY_CLIENTID must also be in the list for operations that are allowed in the first operation of a compound.

<...snip...>

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please use "Reply All" to discuss whether it should be verified or rejected. When a decision is reached, the verifying party can log in to change the status and edit the report, if necessary.

---

From: "Price, Jonathan" <[email-masked]>
Date: Mon, 12 Jun 2017 17:56:19 +0000

Errata to  my errata - mea culpa:

It should be "DESTROY_CLIENTID", not "DESTROY_CLIENT_ID" as I have in my errata submission.

-----Original Message-----
From: RFC Errata System [mailto:[email-masked]] 
Sent: Monday, June 12, 2017 1:29 PM
To: [email-masked]; [email-masked]; Noveck, David <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Technical Errata Reported] RFC5661 (5040)

Section: 18.46.3

Original Text
-------------

Corrected Text
--------------

Notes
-----

<...snip...>

Instructions:
-------------

---

From: Megan Ferguson <[email-masked]>
Date: Mon, 12 Jun 2017 22:18:55 -0700

Hi Jonathan,

We have updated the corrected text to use DESTROY_CLIENTID.

Thank you.

RFC Editor/mf