Subject: [nfsv4] I-D Action: draft-ietf-nfsv4-flex-files-13.txt

From: [email-masked]
Date: Mon, 07 Aug 2017 16:00:12 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network File System Version 4 WG of the IETF.

        Title           : Parallel NFS (pNFS) Flexible File Layout
        Authors         : Benny Halevy
                          Thomas Haynes
	Filename        : draft-ietf-nfsv4-flex-files-13.txt
	Pages           : 40
	Date            : 2017-08-07

Abstract:
   The Parallel Network File System (pNFS) allows a separation between
   the metadata (onto a metadata server) and data (onto a storage
   device) for a file.  The flexible file layout type is defined in this
   document as an extension to pNFS which allows the use of storage
   devices in a fashion such that they require only a quite limited
   degree of interaction with the metadata server, using already
   existing protocols.  Client side mirroring is also added to provide
   replication of files.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-nfsv4-flex-files/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-nfsv4-flex-files-13
https://datatracker.ietf.org/doc/html/draft-ietf-nfsv4-flex-files-13

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-nfsv4-flex-files-13

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Thomas Haynes <[email-masked]>
Date: Tue, 8 Aug 2017 00:09:23 +0000

This is a result of the earlier reviews in the WGLC and a desire for an update by said reviewers.

> On Aug 7, 2017, at 4:00 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>

---

From: David Noveck <[email-masked]>
Date: Tue, 8 Aug 2017 06:16:36 -0400

I can't see reviewing this by 8/11.  I think we will need to reset the WGLC
clock.

I thibk it should be extended  to 8/21 to give us two weeks to review the
new draft.  Other opinions?

In any case, Spencer S should announce a new date, so everybody is in sync.

---

From: spencer shepler <[email-masked]>
Date: Tue, 8 Aug 2017 11:26:57 -0700

Thanks for the suggestion, Dave.  However, we will let the timer run on the
current last call (ends on Friday).

Once that is complete, we will start another last call on the version of
the I-D that is available then.

Note that this is always the case - if there has been enough change during
a last call to warrant another round, then we do another last call.  Not a
big deal.

Spencer

On Tue, Aug 8, 2017 at 3:16 AM, David Noveck <[email-masked]> wrote:

> I can't see reviewing this by 8/11.  I think we will need to reset the
> WGLC clock.
>

---

From: David Noveck <[email-masked]>
Date: Tue, 15 Aug 2017 07:00:26 -0400

There is a need to adress the issue of a last call for flex-files-13.

I previously suggested extending the -12 LC to encompass the -13 and ending
on 8/21, but Spencer on 8/8 responded:.

> Thanks for the suggestion, Dave.  However, we will let the timer run on
the current last call (ends on Friday).

Since that last call ended on 8/11, the version available now is -13.so we
have to start that new last call.

> Note that this is always the case - if there has been enough change
during a last call to warrant another round, then we do another last call.
Not a big deal.

I think it is pretty clear that there has been enough change.  If there is
anyone who disagrees, please speak up..

The only remaIning issue is the the end date.  I previously proposed a
two-week last call period to enable me to do
a comprehensive review.  Others might want to focus on the security changes
in -13 but I skipped a comprehensive
review of -12 because it was always pretty clear there would have to be a
-13.

Two weeks from today would be 8/29.  However, it may be simpler to make the
end date the following Fridiay, which is 9/1.
Is Tom and the rest of the working group OK with that end date for the -13
WGLC?

On Tue, Aug 8, 2017 at 2:26 PM, spencer shepler <[email-masked]>
wrote:

>
>
> Thanks for the suggestion, Dave.  However, we will let the timer run on
> the current last call (ends on Friday).
>

---

From: Thomas Haynes <[email-masked]>
Date: Tue, 15 Aug 2017 16:20:11 +0000

On Aug 15, 2017, at 4:00 AM, David Noveck <[email-masked]<mailto:[email-masked]>> wrote:

I previously suggested extending the -12 LC to encompass the -13 and ending on 8/21, but Spencer on 8/8 responded:.

> Thanks for the suggestion, Dave.  However, we will let the timer run on the current last call (ends on Friday).

> Once that is complete, we will start another last call on the version of the I-D that is available then.

Since that last call ended on 8/11, the version available now is -13.so we have to start that new last call.

Wait, I would have held off shipping a v-13 if I had known it reset the last call.

I sent out v-13 as a courtesy to the reviewers.

> Note that this is always the case - if there has been enough change during a last call to warrant another round, then we do another last call.  Not a big deal.

I think it is pretty clear that there has been enough change.  If there is anyone who disagrees, please speak up..

The only remaIning issue is the the end date.  I previously proposed a two-week last call period to enable me to do
a comprehensive review.  Others might want to focus on the security changes in -13 but I skipped a comprehensive
review of -12 because it was always pretty clear there would have to be a -13.

Two weeks from today would be 8/29.  However, it may be simpler to make the end date the following Fridiay, which is 9/1.
Is Tom and the rest of the working group OK with that end date for the -13 WGLC?

On Tue, Aug 8, 2017 at 2:26 PM, spencer shepler <[email-masked]<mailto:[email-masked]>> wrote:

Thanks for the suggestion, Dave.  However, we will let the timer run on the current last call (ends on Friday).

Once that is complete, we will start another last call on the version of the I-D that is available then.

Note that this is always the case - if there has been enough change during a last call to warrant another round, then we do another last call.  Not a big deal.

Spencer

On Tue, Aug 8, 2017 at 3:16 AM, David Noveck <[email-masked]<mailto:[email-masked]>> wrote:
I can't see reviewing this by 8/11.  I think we will need to reset the WGLC clock.

I thibk it should be extended  to 8/21 to give us two weeks to review the new draft.  Other opinions?

On Mon, Aug 7, 2017 at 8:09 PM, Thomas Haynes <[email-masked]<mailto:[email-masked]>> wrote:
This is a result of the earlier reviews in the WGLC and a desire for an update by said reviewers.

> On Aug 7, 2017, at 4:00 PM, [email-masked]<mailto:[email-masked]> wrote:
>
>
> until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.
>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
nfsv4 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nfsv4

_______________________________________________
nfsv4 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nfsv4

---

From: David Noveck <[email-masked]>
Date: Tue, 15 Aug 2017 14:19:38 -0400

> Wait, I would have held off shipping a v-13 if I had known it reset the
last call.

It didn't reset anything.  However, last call ended on 8/11 and now we all
have to figure  out what to do about this document.

> I sent out v-13 as a courtesy to the reviewers

OK, thanks.  But I'm really unclear what you want the reviewers to do with
it.

There seems to be no point in continung with the review of -12 as if
nothing has happened.  My assumption was that you decided to go with a new
approach to security in -13 and wanted the review to proceed on that basis,
as Spencer indicated should happen given that -13 substantially changed
what was in -12.

If that isn't right, it would be best if you supply a -14 that has the
document that you would like to get reviewed as the basis for WGLC and if
not tell the working group that the document is now no longer ready for
WGLC review.

On Tue, Aug 15, 2017 at 12:20 PM, Thomas Haynes <[email-masked]>
wrote:

>
> On Aug 15, 2017, at 4:00 AM, David Noveck <[email-masked]> wrote:
>
> I previously suggested extending the -12 LC to encompass the -13 and
> ending on 8/21, but Spencer on 8/8 responded:.
>
> a comprehensive review.  Others might want to focus on the security
> changes in -13 but I skipped a comprehensive
> Two weeks from today would be 8/29.  However, it may be simpler to make
> the end date the following Fridiay, which is 9/1.
> On Tue, Aug 8, 2017 at 2:26 PM, spencer shepler <[email-masked]
> > wrote:
>
>>
>>

---

From: Thomas Haynes <[email-masked]>
Date: Tue, 15 Aug 2017 21:44:25 +0000

> Wait, I would have held off shipping a v-13 if I had known it reset the last call.

It didn't reset anything.  However, last call ended on 8/11 and now we all have to figure  out what to do about this document.

> I sent out v-13 as a courtesy to the reviewers

OK, thanks.  But I'm really unclear what you want the reviewers to do with it.

There seems to be no point in continung with the review of -12 as if nothing has happened.  My assumption was that you decided to go with a new approach to security in -13 and wanted the review to proceed on that basis, as Spencer indicated should happen given that -13 substantially changed what was in -12.

If that isn't right, it would be best if you supply a -14 that has the document that you would like to get reviewed as the basis for WGLC and if not tell the working group that the document is now no longer ready for WGLC review.

The changes in v13 were in response to the WGLC, including the ones to the security. And
while the churn to the document was substantial, the effective changes to the protocol
were not that substantial.

I do not want to see what would effectively be an open ended WGLC that gets reset
every time a review is made. That sets a precedent I do not want to endorse.

On Tue, Aug 15, 2017 at 12:20 PM, Thomas Haynes <[email-masked]<mailto:[email-masked]>> wrote:

Spencer

---

From: David Noveck <[email-masked]>
Date: Tue, 15 Aug 2017 21:57:00 -0400

> were not that substantial.

I interpreted  "if there has been enough change during a last call to
warrant another round" as
meaning change to the document since that is what we are reviewing.  I
realize that the protocol
has not been changing that much recently, and that is a good thing.

> every time a review is made.

I don't want to see that either, but here we have a WGLC that has been
reset because, in
response to WGLC comments, you issued a new version with significant
changes, in my
opinion, with good reason.  If that doesn't happen again, there would be no
reason for any
further resets and subsequent last calls.

I know that last call for this document has been going on for quite some
time.  If you llook
at data tracker. it seems that, officially at least, this has been going on
for two years.  I don't
believe that has been because I or anyone else has been asking for constant
resets.

Regardless of all that, the path forward is clear.  We have a document with
significant change
and it needs to be reviewed.  If it can be reviewed and the review comments
can be dealt with
without major document change, and I don't see why they couldn't be, we can
now have the
absolutely-final-never-to-be-repeated-and-I-mean-it-last-call.

I suggest that you indicate to Spencer that the doument is ready for WGLC,
if you think that is
the case.  The sooner we get this started, the sooner it can be finished.

> That sets a precedent I do not want to endorse.

I don't see that this sets any precedent.  This is the way things have
always been done, as Spencer
indicated.

Asking for a last call does not set a precedent and does not cnstitute any
sort of enorsement of anyone
or any thing.  It is just a way of getting this document a chance to move
forward.

I'd like to thank you for your important work on this document and on
layout-types.  I realize it has been
frustrating, but, if you are up for it, you can go on to the further
experience of dealing with the  IESG.
Good luck.

On Tue, Aug 15, 2017 at 5:44 PM, Thomas Haynes <[email-masked]>
wrote:

>
> On Aug 15, 2017, at 11:19 AM, David Noveck <[email-masked]> wrote:
>
>> I think it is pretty clear that there has been enough change.  If there
>> is anyone who disagrees, please speak up..
>>
>> On Tue, Aug 8, 2017 at 2:26 PM, spencer shepler <
>> [email-masked]> wrote:
>>
>>>
>>>