Subject: [nfsv4] [PATCH] Rewording of XDR instructions

From: Thomas Haynes <[email-masked]>
Date: Tue, 29 Aug 2017 10:04:29 -0700

From: Tom Haynes <[email-masked]>

Signed-off-by: Tom Haynes <[email-masked]>
---
 umask_middle_xdr.xml | 13 +++++++------
 1 file changed, 7 insertions(+), 6 deletions(-)

diff --git a/umask_middle_xdr.xml b/umask_middle_xdr.xml
index f6450e9..9e900ea 100644
--- a/umask_middle_xdr.xml
+++ b/umask_middle_xdr.xml
@@ -3,10 +3,10 @@
 
 <section anchor="xdr" title="XDR Extraction">
   <t>
-    The external data representation (XDR)
+    The additional lines of external data representation (XDR)
     <xref target='RFC4506' /> description 
     embedded in this document can be extracted
-    into a ready-to-compile by feeding this document
+    by feeding this document
     into the following shell script:
   </t>
 
@@ -42,10 +42,11 @@ sh extract.sh &lt; umask.txt &gt; umask.x
   </t>
 
   <t>
-    Note that the XDR code contained in this document depends on
-    types from the NFSv4.2 nfs42_prot.x file <xref target='RFC7863' />.
-    As such, the reader will need to add the generated XDR to
-    that from <xref target='RFC7863' />.
+    Once that extraction is done, these added lines need to be
+    inserted into an appropiate base XDR of the generated
+    XDR from <xref target="RFC7863">, together with XDR from
+    any additional extensions to be recognized by the implementation.
+    This will result in a ready-to compile XDR file.
   </t>
 
 </section>
-- 
2.3.6

---

From: David Noveck <[email-masked]>
Date: Tue, 29 Aug 2017 14:01:29 -0400

Looks good to me.  Now that Tom has done the patch with the agreed-upon
changes, it is just a matter
of Bruce turning whatever crank needs to be turned and submitting -05,
assuming the Spencers approve of a new version being submitted now.
Currently the document is stuck in a bogus MISSREF   Once that is cleared
up, the document will be in the hands of the RFC editor and submitting a
new version
might be more disruptive.

On Tue, Aug 29, 2017 at 1:04 PM, Thomas Haynes <
[email-masked]> wrote:

> _______________________________________________
> nfsv4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nfsv4
>

---

From: "J. Bruce Fields" <[email-masked]>
Date: Wed, 30 Aug 2017 12:47:18 -0400

> might be more disruptive.

Thanks, Tom!

Applied, fixed some minor typos, updated acknowledgements, and I'll
upload -5 soon.

--b.