Subject: [Nfvrg] FW: New Version Notification for draft-unify-nfvrg-challenges-00.txt

From: Róbert Szabó <[email-masked]>
Date: Thu, 23 Oct 2014 10:34:00 +0000

Hello All,

We would like to inform you that we have submitted the "Unifying Carrier and Cloud Networks: Problem Statement and Challenges" draft. 

Your review and feedback are really appreciated.

Regards,
Robert 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, October 23, 2014 12:26 PM
To: Mario Kind; Diego Daino; András Császár; Kostas Pentikousis; Mario Kind; Diego Daino; András Császár; Róbert Szabó; Kostas Pentikousis; Róbert Szabó
Subject: New Version Notification for draft-unify-nfvrg-challenges-00.txt

A new version of I-D, draft-unify-nfvrg-challenges-00.txt
has been successfully submitted by Robert Szabo and posted to the IETF repository.

Name:		draft-unify-nfvrg-challenges
Revision:	00
Title:		Unifying Carrier and Cloud Networks: Problem Statement and Challenges
Document date:	2014-10-22
Group:		Individual Submission
Pages:		12
URL:            http://www.ietf.org/internet-drafts/draft-unify-nfvrg-challenges-00.txt
Status:         https://datatracker.ietf.org/doc/draft-unify-nfvrg-challenges/
Htmlized:       http://tools.ietf.org/html/draft-unify-nfvrg-challenges-00

Abstract:
   The introduction of network and service functionality virtualization
   in carrier-grade networks promises improved operations in terms of
   flexibility, efficiency, and manageability.  In current practice,
   virtualization is controlled through orchestrator entities that
   expose programmable interfaces according to the underlying resource
   types.  Typically this means the adoption of, on the one hand,
   established data center compute/storage and, on the other, network
   control APIs which were originally developed in isolation.  Arguably,
   the possibility for innovation highly depends on the capabilities and
   openness of the aforementioned interfaces.  This document introduces
   in simple terms the problems arising when one follows this approach
   and motivates the need for a high level of programmability beyond
   policy and service descriptions.  This document also summarizes the
   challenges related to orchestration programming in this unified cloud
   and carrier network production environment.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: ramki Krishnan <[email-masked]>
Date: Thu, 23 Oct 2014 07:52:44 -0700

Many thanks Robert for the interesting draft. Some initial comments/thoughts below.

>> We argue that given the multi-level virtualization of compute,
   storage and network domains, automation of the corresponding resource
   provisioning needs a recursive programmatic interface.  Existing
   separated compute and network programming interfaces cannot provide
   such recursions and cannot satisfy key requirement for multi-vendor,
   multi-technology and multi-provider interoperability environments.
   Therefore we foresee the necessity of a recursive programmatic
   interface for joint compute, storage and network provisioning.

Ramki: I believe energy is an as aspect which is worth mentioning explicitly. Some examples are -- NFV PoPs may have constraints on maximum energy consumption, idle power consumption has dependency on server-type etc.

Thanks,
Ramki

-----Original Message-----
From: Nfvrg [mailto:[email-masked]] On Behalf Of Róbert Szabó
Sent: Thursday, October 23, 2014 3:34 AM
To: [email-masked]
Subject: [Nfvrg] FW: New Version Notification for draft-unify-nfvrg-challenges-00.txt

Hello All,

Regards,
Robert 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, October 23, 2014 12:26 PM
To: Mario Kind; Diego Daino; András Császár; Kostas Pentikousis; Mario Kind; Diego Daino; András Császár; Róbert Szabó; Kostas Pentikousis; Róbert Szabó
Subject: New Version Notification for draft-unify-nfvrg-challenges-00.txt

Abstract:

The IETF Secretariat

_______________________________________________
Nfvrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/nfvrg

---

From: Róbert Szabó <[email-masked]>
Date: Thu, 23 Oct 2014 18:16:41 +0000

Hi Ramki,
Sounds good!
Thanks,
Robert

-----Original Message-----
From: ramki Krishnan [mailto:[email-masked]] 
Sent: Thursday, October 23, 2014 4:53 PM
To: Róbert Szabó; [email-masked]
Subject: RE: [Nfvrg] FW: New Version Notification for draft-unify-nfvrg-challenges-00.txt

Thanks,
Ramki

-----Original Message-----
From: Nfvrg [mailto:[email-masked]] On Behalf Of Róbert Szabó
Sent: Thursday, October 23, 2014 3:34 AM
To: [email-masked]
Subject: [Nfvrg] FW: New Version Notification for draft-unify-nfvrg-challenges-00.txt

Hello All,

Regards,
Robert 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, October 23, 2014 12:26 PM
To: Mario Kind; Diego Daino; András Császár; Kostas Pentikousis; Mario Kind; Diego Daino; András Császár; Róbert Szabó; Kostas Pentikousis; Róbert Szabó
Subject: New Version Notification for draft-unify-nfvrg-challenges-00.txt

Abstract:

The IETF Secretariat