Subject: [Nfvrg] NFVRG meeting at IETF 91 -- call for presentations and drafts

From: ramki Krishnan <[email-masked]>
Date: Wed, 1 Oct 2014 07:51:43 -0700

Dear All,

The proposed Network Functions Virtualization Research Group (NFVRG) will hold its next meeting in conjunction with IETF 91,  November 9-14 in Honolulu, Hawaii. The NFVRG Program Committee is now
seeking proposals for presentations and drafts for the IETF 91 agenda, details are below.

For presentations please contact Ram (Ramki) Krishnan (Brocade - ​[email-masked]<mailto:[email-masked]>), Dilip Krishnaswamy (IBM Research - ​[email-masked]<mailto:[email-masked]>), Diego Lopez (Telefonica - ​[email-masked]<mailto:[email-masked]>)
For drafts, please post them to the NFVRG mailing list ​([email-masked]<mailto:[email-masked]>). An exemplary NFVRG draft is -- http://tools.ietf.org/html/draft-krishnan-nfvrg-open-nfv-virality-00.
Call for Presentations -- Areas of Interest (from http://trac.tools.ietf.org/group/irtf/trac/wiki/nfvrg)
• Network and service function chaining: architecture and implementation (e.g. automation of service chain building)
• Autonomous service orchestration and optimization
• New operational aspects of network and service virtualization, as well as new operational models required by virtualization
• Infrastructure and service function description and programming (languages, APIs, frameworks for combined processing, network and storage programming)
• Virtualized network economics and business modeling
• Security, trust and service verification
• Real-time big data analytics and data-centric management of virtualized infrastructure
• New application domains enabled by virtualized infrastructure and services
• System wide optimization of compute, storage, network and energy efficiency
• Explore infrastructure and service abstractions enabled by virtualization
• Autonomic and real-time orchestration enabled by network function virtualization
Call for Drafts -- Based on Near Term Charter (from http://trac.tools.ietf.org/group/irtf/trac/wiki/nfvrg)
For each of the near term charter areas mentioned below, the goal is to explore system architecture and optimization with open interfaces across components and explore research through simulations and/or real-world implementations.
Policy based Resource Management: NFV DCs are often constrained in compute and storage capacity. Since practically all NFV DCs are foreseen to be distributed, inter-DC network capacity is also a constraint. Additionally, energy is also a constraint, both as a general concern for NFV operators, and for specific-purpose NFV DCs such as those in mobile base stations, enterprise branch offices that often have power limitations. Hence, optimized resource management and workload distribution based on policy is a relevant area to focus on.
Analytics for Visibility and Orchestration: Network functions should be supportable on general purpose commodity hardware. Real-time analytics providing insight into various components such as compute (e.g. dynamic CPU utilization), storage (e.g. dynamic capacity usage), network (e.g. dynamic bandwidth utilization), energy (e.g. dynamic power consumption) is key to not only providing visibility into the NFV infrastructure but also optimizing resource usage for the purposes of orchestration. This is a relevant area to focus on.
Virtual Network Function (VNF) Performance Modelling to facilitate transition to NFV: While migrating from hardware network appliances, which are typically custom and monolithic, to virtualized software appliances running on commodity hardware a challenge which is often faced is to come up with an equivalence model especially in terms of performance. This is a relevant area to focus on.
Security and Service Verification: NFV configuration is expected to be dynamic especially in the edge NFV DCs where capacity is limited; a very good example is handling a viral event such as mobile gaming application. While autonomic networking techniques could be used to automate the configuration process including modular updates, it is important to take into account that incomplete and/or inconsistent configuration may lead to security issues. Additionally, events such as distributed denial of service (DDoS) attacks could be an additional source of compromise with additional implications due to the dependency of NFV on a distributed infrastructure. Finally, elasticity of VNFs entails dynamic scale up/down/out with awareness of the resiliency considerations, completely different with the approach of monolithic implementations. Security issues and relevant solutions related to the elastic nature of VNFs is a potential area to consider.
Thanks,
Ramki (on behalf of the co-chairs)

---

From: 이승익 <[email-masked]>
Date: Tue, 28 Oct 2014 02:49:59 +0000

Ramki,

Can I have a 5min slot for an update of service chain adaptation with http://www.ietf.org/internet-drafts/draft-lee-nfvrg-resource-management-service-chain-00.txt ?
And I could also give its applicability to SFC.

Regards,
Seung-Ik.

From: Nfvrg [mailto:[email-masked]] On Behalf Of ramki Krishnan
Sent: Wednesday, October 01, 2014 11:52 PM
To: [email-masked]
Cc: DIEGO LOPEZ GARCIA ([email-masked]); [email-masked]'
Subject: [Nfvrg] NFVRG meeting at IETF 91 -- call for presentations and drafts

Dear All,

---

From: ramki Krishnan <[email-masked]>
Date: Mon, 27 Oct 2014 21:39:25 -0700

Certainly Seung-Ik. In fact, I am thinking 10 minutes.

Thanks,
Ramki

From: 이승익 [mailto:[email-masked]]
Sent: Monday, October 27, 2014 7:50 PM
To: ramki Krishnan
Cc: DIEGO LOPEZ GARCIA ([email-masked]); [email-masked]'; [email-masked]
Subject: RE: [Nfvrg] NFVRG meeting at IETF 91 -- call for presentations and drafts

Ramki,

Regards,
Seung-Ik.

From: Nfvrg [mailto:[email-masked]] On Behalf Of ramki Krishnan
Sent: Wednesday, October 01, 2014 11:52 PM
To: [email-masked]<mailto:[email-masked]>
Cc: DIEGO LOPEZ GARCIA ([email-masked]<mailto:[email-masked]>); [email-masked]'
Subject: [Nfvrg] NFVRG meeting at IETF 91 -- call for presentations and drafts

Dear All,