Subject: [Nfvrg] Trying to organize the live documents in NFVRG

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Tue, 8 Sep 2015 22:21:54 +0000

Hi,

Ramki and I have been discussing how to organize the live documents we have in the NFVRG, with the idea of maximizing productivity and avoiding the dispersion of efforts by a multiplicity of unrelated documents. Since the RG charter is wide enough to accommodate many different contributions, we have agreed to structure most documents around the following classes, according with the long-term goals:

* Those addressing one of the special interest areas and aimed at becoming a permanent contribution. We propose to keep one document per each area, intended to become an RFC once the work in that area is considered complete. Authors of such documents will be required to merge them with other related documents once they are adopted by the RG. The chairs will identify editors for each of these documents.
Just for you to remember, the four interest areas (identified in the RG wiki) are "Policy based Resource Management", "Analytics for Visibility and Orchestration", "Virtual Network Function (VNF) Performance Modeling to facilitate transition to NFV", and “Security and Service Verification”. The lack of proposals in the area of performance modeling is making us think of changing this area for another one (though this is something we need to discuss on a separate thread)

* Those addressing general issues of interest to the community, but related with a concrete points in time. Typical examples ara gap analysis or challenge reports (live documents per se) or project reports (associated to the project lifecycle) They will be acknowledged by adopting them once the community thinks they are mature enough to provide a clear value.

* General documents (specific findings, updates, etc) presented for information to and assessment by the community

We hope you’ll find this proposal agreeable, so Ramki and I can start structuring the agenda of our coming meetings around it, and begin to prepare a proposal to classify the live documents, and take the other necessary actions to apply the proposal.

Any kind of comments, suggestions and expression of support would be extremely welcome, specially the latter ones…

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: <[email-masked]>
Date: Wed, 16 Sep 2015 12:15:25 -0500

Dear All,

A gentle reminder, we would love to hear your comments on this topic. We also put down our thoughts on individual drafts and we got several responses from the authors; would like to hear from the authors of the other drafts too.

Thanks,
Ramki

From: Nfvrg [mailto:[email-masked]] On Behalf Of DIEGO LOPEZ GARCIA
Sent: Tuesday, September 08, 2015 3:22 PM
To: [email-masked]
Subject: [Nfvrg] Trying to organize the live documents in NFVRG

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

---

From: "Saurabh Chattopadhyay - ERS, HCL Tech" <[email-masked]>
Date: Fri, 25 Sep 2015 11:09:29 +0000

Dear Diego, Ramki,

Thanks for your kind response, I’ll be working on preparing a draft on the topic I explained below.

+NFVRG – I should have included NFVRG in my previous mail itself.

Regards,
Saurabh

From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, September 22, 2015 7:21 PM
To: [email-masked]; Saurabh Chattopadhyay - ERS, HCL Tech
Subject: RE: Trying to organize the live documents in NFVRG

I second Diego. Saurabh -- looking forward to your contribution(s) on VNF performance optimization. Besides Data plane, Control plane and OAM plane would be areas of interest.

Thanks,
Ramki

From: DIEGO LOPEZ GARCIA [mailto:[email-masked]]
Sent: Tuesday, September 22, 2015 4:05 AM
To: Saurabh Chattopadhyay - ERS, HCL Tech
Cc: Krishnan, Ramki
Subject: Re: Trying to organize the live documents in NFVRG

Hi Saurabh,

First of all, I’d really appreciate if you share this over the whole NFVRG list. It is important that all these discussions happen in the open, especially when they are dealing with issues that must be considered by the community at large, and cannot be decided by the RG chairs.

Second, take into account the area is not focused on VNF performance optimization per se, but on how to make consistent performance comparisons among VNFs and PNFs, and among VNFs themselves. I am aware of several works on VNF optimization, and even a Technical Report on this from the ETSI NFV (available at )

Third,  VNF performance optimization (and in general, design and implementation best practices) is an extremely interesting matter and any contribution you think you can make on this matter would be extremely welcome.

Be goode,

On 21 Sep 2015, at 13:47 , Saurabh Chattopadhyay - ERS, HCL Tech <[email-masked]<mailto:[email-masked]>> wrote:

Dear Diego & Ramki,

>> "Virtual Network Function (VNF) Performance Modeling to facilitate transition to NFV" - The lack of proposals in the area of performance modeling is making us think of changing this area for another one..

I think substantial amount of research is happening around this area, and we / NFVRG members can start developing proposals around this if we get a bit of clarity on how would you advise to maintain NFVRG’s focus on this topic.
Towards this, can you please advise if the following topic aligns to NFVRG’s interest area?

While we look at the work happening in IETF Benchmarking WG and ETSI NFV, we understand that the focus is to develop the methodologies to test and model the performance characterization of the VNFs (over NFVI) against end to end execution scenarios. While this is extremely useful for benchmarking the current performance, it doesn’t necessarily point towards the directions for further performance optimization. To assess the directions for possible performance optimization, perhaps the Engineering & Deployment SMEs both will need to have a next level of view on how the performance characterization will look like at each layer of the VNF deployment architecture – Hypervisor, OS, Interface Modules, Switch Fabric, hardware assisted Packet Processor layers etc. If this level of performance characterization data is available, from what we have learnt from our experimentations, a systematic analysis process can be developed to deduce the course of further performance optimization. And this should benefit in following ways –

(i)                  The Deployment SMEs shall get definitive view on how to improvise the VNF Descriptors and other aspects of deployment environment for better performance
(ii)                The Engineering SMEs from VNF team will get a view on the specific areas where they can work upon to improvise the performance
(iii)               The Platform Engineering SMEs will get a view on the specific areas that can be addressed by them for improving performance in given deployment scenarios

I couldn’t find much of detailed work / draft proposal around this topic, and I’m not sure if aligns to NFVRG’s charter or not. Will you please advise if it makes sense to develop a draft on this topic and submit to NFVRG?

Warm Regards,
Saurabh

From: Nfvrg [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Wednesday, September 16, 2015 10:45 PM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Nfvrg] Trying to organize the live documents in NFVRG

Dear All,

Thanks,
Ramki

From: Nfvrg [mailto:[email-masked]] On Behalf Of DIEGO LOPEZ GARCIA
Sent: Tuesday, September 08, 2015 3:22 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Nfvrg] Trying to organize the live documents in NFVRG

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

::DISCLAIMER::
----------------------------------------------------------------------------------------------------------------------------------------------------
The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
E-mail transmission is not guaranteed to be secure or error-free as information could be intercepted, corrupted,
lost, destroyed, arrive late or incomplete, or may contain viruses in transmission. The e mail and its contents
(with or without referred errors) shall therefore not attach any liability on the originator or HCL or its affiliates.
Views or opinions, if any, presented in this email are solely those of the author and may not necessarily reflect the
views or opinions of HCL or its affiliates. Any form of reproduction, dissemination, copying, disclosure, modification,
distribution and / or publication of this message without the prior written consent of authorized representative of
HCL is strictly prohibited. If you have received this email in error please delete it and notify the sender immediately.
Before opening any email and/or attachments, please check them for viruses and other defects.
----------------------------------------------------------------------------------------------------------------------------------------------------

Dr Diego R. Lopez
Telefonica I+D