Subject: Re: [NGO] NETCONF Data Modeling BoF (NDM) proposal

From: "tom.petch" <[email-masked]>
Date: Thu, 13 Sep 2007 12:46:24 +0200

----- Original Message -----
From: "McDonald, Ira" <[email-masked]>
To: "Ladislav Lhotka" <[email-masked]>; "tom.petch" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, September 12, 2007 9:18 PM
Subject: RE: [NGO] NETCONF Data Modeling BoF (NDM) proposal

> Hi Tom,
>
> Characterizing RELAX NG versus XSD as "not powerful enough"
> intrigues me.  Even the W3C now develops many new standards
> in RELAX NG and machine translates them to XSD *only* when
> their standards development work is complete (last draft).
>

Which demonstrates that XSD is at least as powerful as RELAX NG.

Now if all valid XSD could be machine translated into RELAX NG,
I would have to reconsider:-)

Tom Petch

> Just wondering...
>
> Cheers,
> - Ira
>
> Ira McDonald (Musician / Software Architect)
> Chair - Linux Foundation Open Printing WG
> Blue Roof Music / High North Inc
> PO Box 221  Grand Marais, MI  49839
> phone: +1-906-494-2434
> email: [email-masked]
>
> -----Original Message-----
> From: Ladislav Lhotka [mailto:[email-masked]]
> Sent: Wednesday, September 12, 2007 9:46 AM
> To: tom.petch
> Cc: [email-masked]
> Subject: Re: [NGO] NETCONF Data Modeling BoF (NDM) proposal
>
>
> tom.petch píše v St 12. 09. 2007 v 14:10 +0200:
> > <tp>
> > Not powerful enough
>
> Can you be more specific? What do you miss? RELAX NG is now used for the
> most complex beasts such as DocBook or Open Document Format.
>
> Lada
>
> > Tom Petch
> > </tp>
> --
> Ladislav Lhotka, CESNET
> PGP Key ID: E74E8C0C
>
>
>
> _______________________________________________
> NGO mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ngo
>
> No virus found in this outgoing message.
> Checked by AVG Free Edition.
> Version: 7.5.485 / Virus Database: 269.13.15/1003 - Release Date: 9/12/2007
10:56 AM

_______________________________________________
NGO mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ngo

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 13 Sep 2007 14:54:38 +0200

> Which demonstrates that XSD is at least as powerful as RELAX NG.

No, it just demonstrates that it is easier to communicate the data model
(and develop the schemas) in RELAX NG than in XSD. Even Tim Bray now
recommends to convert to RELAX NG:
http://www.tbray.org/ongoing/When/200x/2006/11/27/Choose-Relax

> I would have to reconsider:-)

You can make up XSD schemas that cannot be translated to RELAX NG and
vice versa. However, for most real-life situations, and especially with
the restrictions placed on NETCONF data (no mixed content, wrapper
elements enclosing repeated children), it is IMO fair to say that both
languages have comparable expressive power and the schemas can be
generally translated in both directions.

Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: "tom.petch" <[email-masked]>
Date: Fri, 14 Sep 2007 09:20:36 +0200

----- Original Message -----
From: "Ladislav Lhotka" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, September 13, 2007 2:54 PM
Subject: Re: [NGO] NETCONF Data Modeling BoF (NDM) proposal

<tp>

OK, I will go and do my homework on RELAX NG and maybe then admit defeat.

But I do think that Andy's points in favour of XSD are valid, namely that we
need the skills to produce an interoperable standard, and that we have in XSD.
(It would have been interesting at the previous WG meeting to have asked those
understood RELAX NG to identify themselves and see if it were more than seven).
And to change horses at this point would, for me, imply an RFC4741bis in RELAX
NG.

Tom Petch
</tp>

Lada

Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C