Subject: [NGO] NETMOD charter

From: Andy Bierman <[email-masked]>
Date: Sun, 16 Mar 2008 17:30:08 -0700

Hi,

I would like to get a NETMOD WG chartered before the next IETF,
not keep having BoFs that may eventually lead to a WG some year.

I strongly support a NETCONF MIB language as the highest priority,
and next step in a workable NETCONF-based CM solution.  However,
there needs to be some agreement and clarity on what the
finished NETCONF-managed system looks like.

Just because CLI development tends to be an organic, ad-hoc,
uncontrolled process, does not mean the IETF standards process should
be the same.  Full support for vendor innovation is important,
but this must coexist with an (anticipated) ever-increasing set
of standard modules.

First the base protocol. Then notifications. Then partial locking, etc.
I really don't see much of a system-oriented development plan here,
if the end goal is supposed to be standards-based *configuration*.

Andy

_______________________________________________
NGO mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ngo

---

From: "Randy Presuhn" <[email-masked]>
Date: Sun, 16 Mar 2008 22:29:44 -0800

Hi -

> From: "Andy Bierman" <[email-masked]>
> To: "NETCONF Goes On" <[email-masked]>
> Sent: Sunday, March 16, 2008 4:30 PM
> Subject: [NGO] NETMOD charter
...
> not keep having BoFs that may eventually lead to a WG some year.
...

The folks from the rcdml design team (along with folks from other teams)
have been asked by Dan to come up with a charter proposal for discussion.
Our goal is to have it ready within two weeks.  (Holy week stretches out
what would otherwise have been on a shorter timeline.)

A very broad outline (and please, let's hold off on the detail discussion
until we've come up with a proposal with enough detail to support a
discussion!) of the deliverables is this:
  - an operator-friendly data modeling language, based on the yang
    proposal
  - the modeling language would provide basic support for object-oriented
    modeling concepts (no intentions of getting carried away!)
  - a lossless transform into a tool-friendly representation, probably
    built on the DSDL proposal

(I gave a more detailed account of my personal view of how things might
proceed on Friday morning at the nmrg meeting.)

There's obviously more to this all, but the good news is that our AD was
able to get a bunch of people into a room and hammer out what appears
to be a reasonable way forward that folks can live with.

Randy

---

From: Andy Bierman <[email-masked]>
Date: Mon, 17 Mar 2008 01:26:38 -0700

>     built on the DSDL proposal

This is generally good news.

We have not used object-oriented data models for network configuration
before in the IETF.  I do not understand why this change in policy
is needed now.  There is no doubt that OO can help describe some
really complicated conceptual models.  IMO, however, it makes
simple tasks far more complicated.  These 'mundane' data models
(e.g., schema-discovery, partial-lock, create-subscription, etc.)
far outnumber the massive DIFFSERV type of data models.
OO just makes these simple models way too complicated.

We have also been using XSD for the canonical XML syntax
representation in protocol documents for quite some time.
I strong object to changing this policy to RelaxNG or DSDL
without IETF Approval first.

Andy

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 17 Mar 2008 14:45:54 +0100

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Andy Bierman
> 

Allow me to express shortly my view as a contributor. 

I do not believe that we deal here with a change in policy. The
canonical XML syntax representation stays with us as the 'on the wire'
interoperability level. We are introducing an operator-friendly language
that is described by Randy in his preliminary charter draft and the
mapping between the operator-friendly level and the XML. These would be
the mandatory-to-implement elements of the framework

We also recognize that there is a place for a machine-friendly
representation that would accommodate existing tools and allow for
import of existing XML schemes already defined by other WGs in the IETF
or other SDOs, in RelaxNG or DSDL or other. Mappings between the
operator-friendly language and RelaxNG or DSDL would be optional, but at
least one of them will be a loss-less translation. 

See the below. I am not too strong in ASCII art, maybe somebody can
help. 

---------------------------
|Operator Friendly |
---------------------------
|
|  |  |
|    |    |
|      |      |
|        |        |
|          |         |
|  --------------  -----------
| | RelaxNG| | DSDL|
|  --------------  ----------
|          |         |
|        |         |
|      |       |
|    |      |
-------------
|  XML   |
-------------

Does this make sense? 

Dan

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 17 Mar 2008 15:19:59 +0100

> without IETF Approval first.

XSD only deals with grammar, so mapping from YANG could be lossless only
with quite considerable appInfo extensions that would IMO beg the
question of mapping to *standard* validation languages - I believe this
was the requirement expressed by Chris Newman on behalf of application
area. Standard DSDL can capture most of YANG semantics and the necessary
domain-specific extensions will be relatively minor - e.g., signatures
of RPC operations.

Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: Andy Bierman <[email-masked]>
Date: Mon, 17 Mar 2008 08:11:46 -0700

> least one of them will be a loss-less translation. 

This sounds fine from a policy POV.
In practical terms, it seems that document reviewers
will have a lot more work to do, verifying that:

   - all these mappings are well-formed
   - they match the semantics of the high-level model
   - there are no conflicts between any of the machine-mappings
   - all DM variants in the document describe the exact same set of XML

Since the IETF track record for validating XSD correctness
is so poor already, how will the box score look when 3 complicated
DMLs need to be reviewed, instead of 1?

Or is the intent to fill up NETCONF data model drafts will lots
of pages that nobody will review?

Andy

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 17 Mar 2008 16:24:10 +0100

> From: Andy Bierman [mailto:[email-masked]] 
> Sent: Monday, March 17, 2008 5:12 PM
> To: Romascanu, Dan (Dan)
> Cc: Randy Presuhn; NETCONF Goes On
> Subject: Re: [NGO] NETMOD charter
> 
> >> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of 
> >> Andy Bierman
> >>
> >> I strong object to changing this policy to RelaxNG or DSDL without 
> >> IETF Approval first.
> >>
> >>
> > 
> > interoperability level. We are introducing an operator-friendly 
> > language that is described by Randy in his preliminary 
> charter draft 
> > and the mapping between the operator-friendly level and the 
> XML. These 
> > would be the mandatory-to-implement elements of the framework
> > 
> > import of existing XML schemes already defined by other WGs in the 
> > IETF or other SDOs, in RelaxNG or DSDL or other. Mappings 
> between the 
> > operator-friendly language and RelaxNG or DSDL would be 
> optional, but 
> > at least one of them will be a loss-less translation.
> > 
> 
> 
> In practical terms, it seems that document reviewers will 
> have a lot more work to do, verifying that:
> 
> Since the IETF track record for validating XSD correctness is 
> so poor already, how will the box score look when 3 
> complicated DMLs need to be reviewed, instead of 1?
> 
> Or is the intent to fill up NETCONF data model drafts will 
> lots of pages that nobody will review?
> 
> 
> 
> Andy
> 

If you refer to what happens after all this is defined, I do not think
that each DM document needs to be written (and reviewed) in the three
formats. The mandatory format is the one expressed in the
operator-friendly DML, other are optional and MAY be defined from case
to case. 

Dan

---

From: "Bert Wijnen - IETF" <[email-masked]>
Date: Mon, 17 Mar 2008 16:27:56 +0100

>    - all DM variants in the document describe the exact same set of XML
The way I had understood our discussion last week is a bit
less heavy. My understanding was:

- WG develops a User/Operator friendly readbale DML (YANG would
  be our starting point, so I will use that for now).
  This will be a stds track doc.
- WG defines mapping rules from YANG to XML (for the on the wire
  encoding). This will be a stds track doc.
- WG defines mapping rules from YANG to XSD (and/or RELAXNG or DSDL).
  This will be a (or more) stds track document(s)
- When WGs write a datamodel, they just include the YANG-module(s)
  as normative.
- All the other derivations can be generated by (multiple and
  possibly competing) tools based on the stds track mapping rules.
  The tools themselves would be out of scope of the WG (similar
  to tools like SMICng, smilint, ASN.1 verifier; ABNF validation,
  XSD and XML validation tools).
- Any additional tools (like the example XSD to graphical representation
  tool that Sharon showed; but also many others) are out of scope
  of this WG.

So that would mean we have some extra work now (namely specing out
all the mapping rules). But once the DML and the mapping rules have
been published, the actual Data Model documents themselves can be
straight forward and simpell with just a YANG module.

We can (in my view) also decide to do just one mapping rule document
in our initial release.

Bert Wijnen

> -----Oorspronkelijk bericht-----
> Van: [email-masked] [mailto:[email-masked]]Namens Andy
> Bierman
> Verzonden: maandag 17 maart 2008 16:12
> Aan: Romascanu, Dan (Dan)
> CC: NETCONF Goes On
> Onderwerp: Re: [NGO] NETMOD charter
>
>

---

From: Andy Bierman <[email-masked]>
Date: Mon, 17 Mar 2008 08:32:07 -0700

Romascanu, Dan (Dan) wrote:
>.....

It has not been my experience that the IESG will give you a free pass
because the text on certain pages is 'optional'.  I'm pretty sure
if you include RNG and/or DSDL documents in a standards-track
document, that text will need to be reviewed, even though it
is in non-normative sections.

Andy

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 17 Mar 2008 16:36:09 +0100

> Sent: Monday, March 17, 2008 5:32 PM
> To: Romascanu, Dan (Dan)
> It has not been my experience that the IESG will give you a 
> free pass because the text on certain pages is 'optional'.  
> I'm pretty sure if you include RNG and/or DSDL documents in a 
> standards-track document, that text will need to be reviewed, 
> even though it is in non-normative sections.

Yes - I agree. Many people think however that these formats are useful,
so I guess they will provide their support for writing and reviewing
such pieces of code when they show up in the documents. 

Dan

---

From: "David Harrington" <[email-masked]>
Date: Mon, 17 Mar 2008 17:03:03 -0400

Hi,

We have photographs of the architecture, don't we? ;-)

dbh 

> Behalf Of Romascanu, Dan (Dan)
> Sent: Monday, March 17, 2008 9:46 AM
> To: Andy Bierman; Randy Presuhn
> Cc: NETCONF Goes On
> optional, but at

---

From: "David Harrington" <[email-masked]>
Date: Mon, 17 Mar 2008 17:08:02 -0400

I understanbd there are lots of tools available for these
machine-friendly DMLs. (wink!)

dbh 

> Sent: Monday, March 17, 2008 11:36 AM
> To: Andy Bierman
> Cc: NETCONF Goes On

---

From: Balazs Lengyel <[email-masked]>
Date: Tue, 18 Mar 2008 11:32:50 +0100

I agree with Bert. For me this also means we do not need to debate now whether YANG will be 
mapped to DSDL or XSD.  Clearly the first step is to standardize YANG (the operator friendly 
language). Once we have that, if there is enough interest, a mapping to XSD/DSDL will be 
standardized. The two do not exclude each other!!! If there is interest both can be done.

- first step: define what we are mapping (YANG)
- second step: once you have something to map (YANG) decide where and how to map it.

Balazs

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]
_______________________________________________
NGO mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ngo