Subject: [NGO] URGENT - please post CANMOD BOF agenda

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 2 Mar 2008 09:30:37 +0100

Randy,

Please post the CANMOD BOF agenda on the list and on the Web page.

Thanks and Regards,

Dan
 
_______________________________________________
NGO mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ngo

---

From: Martin Bjorklund <[email-masked]>
Date: Sun, 02 Mar 2008 14:39:44 +0100 (CET)

> Please post the CANMOD BOF agenda on the list and on the Web page.

I found two web pages, with different info, which is confusing.

outdated:

http://www3.tools.ietf.org/bof/trac/wiki

and a newer:

http://www3.tools.ietf.org/area/ops/trac/wiki/WikiStart

Neither includes the newer drafts:

  http://www.ietf.org/internet-drafts/draft-bjorklund-yang-requirements-00.txt
  http://www.ietf.org/internet-drafts/draft-ersue-netconf-kalua-dml-00.txt
  http://www.ietf.org/internet-drafts/draft-mahy-canmod-dsdl-00.txt
  http://www.ietf.org/internet-drafts/draft-chisholm-netconf-model-08.txt

I hope these gets added to the required reading list.

/martin

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 2 Mar 2008 14:52:23 +0100

I updated the list of drafts on the two wiki pages. 

Still, we need a more precise agenda, with exact time allocation. What
is out there on the OPS area wiki is only a preliminary version.  

Dan

> -----Original Message-----
> From: Martin Bjorklund [mailto:[email-masked]] 
> Sent: Sunday, March 02, 2008 3:40 PM
> To: Romascanu, Dan (Dan)
> Cc: [email-masked]; [email-masked]
> Subject: Re: [NGO] URGENT - please post CANMOD BOF agenda
>

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 3 Mar 2008 00:27:51 -0800

Hi -

> From: "Romascanu, Dan (Dan)" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>
> Cc: "NGO" <[email-masked]>
> Sent: Sunday, March 02, 2008 12:30 AM
> Subject: URGENT - please post CANMOD BOF agenda
>

> Please post the CANMOD BOF agenda on the list and on the Web page.

I've uploaded it, and as requested, here is a copy.
Since the BOF description doesn't seem to be accesible,
I included the most recent text David Partain sent in on behalf of the
design team.  I hope that that's reasonably close to whatever was approved.

Comparing Approaches to NETCONF Modeling (CANMOD) BOF
BOF length: 2.5 hours
Chair:  Randy Presuhn <[email-masked]>
Discussion: On the NETCONF Goes On list ([email-masked])

The NETCONF Working Group has completed a base protocol to be
used for configuration management.  The current specifications do
not include a modeling language or accompanying rules for how to
model management information to be configured and monitored using
NETCONF.  A data modeling framework is needed to support ongoing
development of IETF and vendor-defined management information
modules.

The goal of the BOF is to determine whether there is sufficient
interest and cohesion to form a working group to standardize a
data modeling language for NETCONF.  The BOF will discuss and
assess data modeling requirements and use cases for NETCONF
documented by design teams in the form of internet drafts.
Specific proposals documented as internet drafts will be used to
explain the potential technical consequences of meeting specific
proposed requirements.

The target is for the BOF to recommend how NETCONF data modeling
work should procede.

Design teams collected, clarified and categorized requirements
for a data modeling language from a broad group of IETF
participants. Many of these requirements have broad agreement.
These requirements, and a collection of use-cases motivating the
requirements where broad agreement was not reached, are
documented in Internet Drafts. Design teams have also prepared
annotated examples of instance documents to illustrate many of
the requirements.  All BOF participants are expected to read
these documents and to understand the basic concepts of the
NETCONF protocol.

In order to ensure productive discussion, the BOF chairs will
only grant agenda time to discuss requirements and illustrative
proposals which have been made available in internet drafts.
Discussion will focus on gaining clarity about the requirements
and the use cases.  As time permits, we will also look at whether
and how the specific proposals address the requirements and use
cases.

Though the BOF's initial focus will be on the discussion and
validation of the requirements gathered, it is expected that this
will lead to discussions within the NETCONF community of the
technology implications of the requirements and to a comparison
of specific solution proposals.

Input Documents:
 http://www.ietf.org/internet-drafts/draft-ietf-opsawg-smi-datatypes-in-xsd-00.txt
 http://www.ietf.org/internet-drafts/draft-linowski-netconf-dml-requirements-01.txt
 http://www.ietf.org/internet-drafts/draft-presuhn-rcdml-03.txt
 http://www.ietf.org/internet-drafts/draft-xiao-evaluate-dml-01.txt
 http://www.ietf.org/internet-drafts/draft-chisholm-netconf-model-08.txt
 http://www.ietf.org/internet-drafts/draft-bjorklund-yang-requirements-00.txt
 http://www.ietf.org/internet-drafts/draft-ersue-netconf-kalua-dml-00.txt
 http://www.ietf.org/internet-drafts/draft-mahy-canmod-dsdl-00.txt

Note Well:
  Participants are expected to have read the input documents and to
  be familiar with the NETCONF protocol (RFC 4741).  There is much
  to discuss, so no time will be spent on tutorial material.

AGENDA:

1. Administrative matters (10 minutes)
   1.1 introductions
   1.2 selection of minute-taker
       PLEASE read http://www.ietf.org/instructions/minutes.html
       volunteers PRIOR to the meeting greatly appreciated!
   1.3 selection of jabber scribe(s)
       volunteers PRIOR to the meeting greatly appreciated!
   1.4 circulation of sign-up sheet
   1.5 Review of Agenda
   1.6 Adjustment of time allocations

2. Highlights of Requirements (These presentations should focus on
   a small number of high-impact issues, rather than attempting to
   cover everything.)  Discussion limited to clarifying questions.  (One hour - 
   fifteen minutes maximum for each draft)
   2.1 http://www.ietf.org/internet-drafts/draft-ietf-opsawg-smi-datatypes-in-xsd-00.txt
   2.2 http://www.ietf.org/internet-drafts/draft-linowski-netconf-dml-requirements-01.txt
   2.3 http://www.ietf.org/internet-drafts/draft-presuhn-rcdml-03.txt
   2.4 http://www.ietf.org/internet-drafts/draft-xiao-evaluate-dml-01.txt

3. Detailed examples of how key requirements are addressed
   by specific proposals:  Discussion limited to clarifying questions.
   (One hour - fifteen minutes maximum for each draft)
   3.1 http://www.ietf.org/internet-drafts/draft-chisholm-netconf-model-08.txt
   3.2 http://www.ietf.org/internet-drafts/draft-bjorklund-yang-requirements-00.txt
   3.3 http://www.ietf.org/internet-drafts/draft-ersue-netconf-kalua-dml-00.txt
   3.4 http://www.ietf.org/internet-drafts/draft-mahy-canmod-dsdl-00.txt

4. Discussion. (Twenty-five minutes, plus any needed unused time from above.)

5. Getting a sense of the room - a little humming: (10 minutes)
   5.1 Are the requirements adequately understood?
   5.2 Is there a need for this work?
   5.3 Is there sufficient agreement on the requirements
       to permit progress?
   5.4 Should an IETF working group be formed?
   5.5 Would additional time spent on requirements gathering
       and analysis be well-spent?
   5.6 Which of the proposals should serve as the
       starting point for a working group?

6. Wrap-up (5 minutes)
   6.1 review of action items
   6.2 reminders to minute-takers and presenters
       PLEASE read http://www.ietf.org/instructions/minutes.html
       and http://www.ietf.org/instructions/slides.html, respectively.
       http://www.ietf.org/instructions/meeting_materials.html
   6.3 retrieval of sign-up sheet

Randy