Subject: [NGO] reboot & shutdown

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 04 Apr 2008 08:40:21 +0200

Hi,

is there any (envisioned) way for instructing the managed device via
NETCONF to reboot or shut down?

Thanks, Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

_______________________________________________
NGO mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ngo

---

From: Phil Shafer <[email-masked]>
Date: Fri, 04 Apr 2008 12:04:47 -0400

>NETCONF to reboot or shut down?

This would be an RPC, like:

    rpc request-reboot {
        description "Reboot the system";
        input {
            leaf at {
                type date-time;
                description "Time at which to perform the reboot";
            }
            leaf in {
                type uint16;
                description "Number of minutes to delay before reboot";
                units minutes;
            }
            leaf message {
                type string;
                description "Message to be displayed to all users";
            }
            leaf media {
                description "Boot media for next boot";
                type string;  // should be enumeration?
            }
        }
    }

Media will need to be extensible, so perhaps a choice is
more appropriate.

We need to build a basic "system management" YANG module.

Thanks,
 Phil

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 04 Apr 2008 21:16:26 +0200

Hi Phil,

is something like this underway? We need this capability for our FlowMon
probe.

Thanks, Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: Phil Shafer <[email-masked]>
Date: Fri, 04 Apr 2008 15:23:57 -0400

>is something like this underway? We need this capability for our FlowMon

No, but we can start writing this YANG module.

Why do you need to reboot the device?

Thanks,
 Phil

---

From: Ladislav Lhotka <[email-masked]>
Date: Sat, 05 Apr 2008 11:46:10 +0200

> No, but we can start writing this YANG module.

Yes, I think we could help with it. Is there any precursor (MIB)?

> Why do you need to reboot the device?

When exchanging firmware. We have different images for various sets of
fields in the flow record and they are user-selectable.

Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C