Subject: RE: [Nsis-imp] Assigned numbers for version GIMPS -06

From: "Hancock, Robert" <[email-masked]>
Date: Thu, 7 Jul 2005 14:30:58 +0100

hi,

the PI is only ever carried inside the NLI TLV, which includes
size information for it. i'm not clear if there is any need to
define a special TLV for it or a particular syntax (it is only
ever compared by exact matching).

i'm not sure what your question about the RAO value is. 
- the RAO is present in any query-encapsulated datagram
  message (including all Queries, and Data messages forwarded
  by stateless nodes)
- the RAO value of 0 is not realistic and in principle would
  be NSLPID dependent. but exactly what the values should be
  is a question for John's draft - or something like it ;-)

cheers,

robert h.

> -----Original Message-----
> From: Xiaoming Fu [mailto:[email-masked]] 
> Sent: 07 July 2005 14:19
> To: Hancock, Robert
> Cc: [email-masked]
> Subject: Re: [Nsis-imp] Assigned numbers for version GIMPS -06
> 
> 
> Hi Robert,
> Thanks for the work. 2 small questions:
> 
> - Is PI assigned with a TLV type? Otherweise currently there is no 
> fixed size & format for it (as part of NLI).
> - GIMPS RAO as *0* for Query?
> 
> Cheers,
> Xiaoming
> 
> 
> Hancock, Robert wrote:
> 
> > Hi all,
> > 
> > we have made a page of assigned numbers for the various 
> bits of GIMPS 
> > at http://nsis.srmr.co.uk/nsis/assigned-numbers_06.html. 
> > 
> > these could be useful for implementors aiming at 
> interoperability :-)
> > 
> > Robert H.
> > 
> > _______________________________________________
> > NSIS-imp mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/nsis-imp
> 

_______________________________________________
NSIS-imp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis-imp

---

From: Xiaoming Fu <[email-masked]>
Date: Thu, 07 Jul 2005 18:02:29 +0200

Hi Robert,

> ever compared by exact matching).
My point was, to rely on NLI TLV to determine the size of PI (by 
minus other fields) may be simple but not efficient for processing.

>   message (including all Queries, and Data messages forwarded
I thought stateless mode is not part of the current spec (?).

>   is a question for John's draft - or something like it ;-)
That's what I also guessed but there was a question of being "0".
I like John's statement "An NSLPID must be associated with a unique 
RAO value." Assuming a preliminary one for basic testing would be 
needed, possibly using e.g., "diagnostics/ping/traceroute" function.

Cheers,
Xiaoming