Subject: RE: [Nsis-imp] NSIS/NTLP Interoperability Event before IETF in Paris

From: "Lang, Christopher" <[email-masked]>
Date: Mon, 25 Jul 2005 16:12:18 +0100

Hi all,

It would be useful for all of us who are attending the interop to have
an idea of what GIMPS features we wish to test. I have therefore drawn
up a possible list of tests we could perform:

1)	Stateless Operation (no stack proposals sent, no routing state
stored, no Confirm sent):
	a)	Intercept and decode a Query msg at RNode.
	b)	Receive and decode a Response msg at QNode.
2)	Stateful D-Mode operation (still without stack proposals):
	a)	Configure Rnode to store state on reception of Query and
not request a Confirm. Install routing state at each node. Send a data
message using the routing state.
	b)	Configure Rnode to store state on reception of Query and
request a Confirm and repeat (a).
	c)	Configure Rnode to store state on reception of a Confirm
and repeat (a).
3)	Repeat test 2 but advertise and create a TCP Forward C-Mode
connection.
4)	Refresh existing routing state created in (5) by sending a Q/R
sequence.

Each test should be run 3 times: with the Qnode acting as an endpoint
and the Rnode acting as a router; with the Qnode acting as a router and
the Rnode acting as an endpoint; with the two nodes having swapped
Q/Rnode roles.

Note that we aren't currently intending to test any particular NSLP data
formats. Does anyone have any comments on the proposed tests? Is there
anything missing which we people feel we should test?

If we have time (and we have implementations which support it) we could
also repeat test (3) using TLS instead of TCP. Is anyone planning to
bring an implementation which supports TLS?

Best regards,

Chris Lang

> -----Original Message-----
> From: Martin Stiemerling [mailto:[email-masked]] 
> Sent: 29 April 2005 09:32
> To: [email-masked]
> Subject: [Nsis-imp] NSIS/NTLP Interoperability Event before 
> IETF in Paris
> 
> 
> Hi all,
> 
> This is an announcement for the NSIS/NTLP interoperability 
> testing event to be held July 28 to July 30 in Paris. July 28 
> to July 30, Thursday to Saturday, is right before the 63rd 
> IETF meeting in Paris. The interoperability venue is at the 
> same venue as the IETF meeting is going to be, Palais des 
> Congres (<http://www.palaisdescongres-paris.com/gb/index.asp>).
> 
> The interoperability event focuses on testing of the NTLP 
> between different implementations, but is not necessary 
> limited to the NTLP only.
> 
> The venue will provided by NEC and the EU IST project 
> Eurolabs (<http://www.ist-eurolabs.org/>).  Participation for 
> implementers is free of charge and only implementers are 
> allowed to join the event.
> 
> Further information about registration, times, shipping, 
> modalities, etc will be provided soon.
> 
> This event will be co-located with the interoperability 
> testing event of the IST MOME project 
> (<http://www.ist-mome.org/events/interop/>)
> 
> With best regards,
> 
>     Martin Stiemerling
> 
> NEC Europe Ltd. -- Network Laboratories [email-masked]
> PGP Key at:        http://www.stiemerling.org/stiemerling_nec.gpg
> WWW: http://www.netlab.nec.de
> 
> _______________________________________________
> NSIS-imp mailing list
> [email-masked] 
> https://www1.ietf.org/mailman/listinfo/nsis-imp
> 

_______________________________________________
NSIS-imp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis-imp

---

From: Luís Cordeiro <[email-masked]>
Date: Mon, 25 Jul 2005 17:01:29 +0100

Hi all,

I agree with the proposal.

Our implementation it's only working with TCP yet, so we can't test the
TLS support.

What do you think about testing message interception and forwarding?

Best regards,

--

Luís Cordeiro

Department of Informatics Engineering

University of Coimbra

Portugal

Lang, Christopher wrote:

Hi all,

Best regards,

Chris Lang

-----Original Message-----
From: Martin Stiemerling [mailto:[email-masked]]
Sent: 29 April 2005 09:32
To: [email-masked]
Subject: [Nsis-imp] NSIS/NTLP Interoperability Event before
IETF in Paris

Hi all,

With best regards,

Martin Stiemerling

---

From: Martin Stiemerling <[email-masked]>
Date: Tue, 26 Jul 2005 09:01:32 +0200

Hi Christopher and all,

The propose test scenarios are excellent. However, we should consider
a slow start approach, i.e., running first very simple, easy tests between
RNode and QNode  (as NI and NR). The first tests are taking quite some
time at the beginning due to bug finding in different implementations.

I suggest to sit together on Wednesday morning and to talk about the
actual tests and configurations in detail.

| Note that we aren't currently intending to test any particular NSLP data
| formats. Does anyone have any comments on the proposed tests? Is there
| anything missing which we people feel we should test?

I think these tests are enough for the first place and will keep us
busy for quite some time :)

|
| If we have time (and we have implementations which support it) we could
| also repeat test (3) using TLS instead of TCP. Is anyone planning to
| bring an implementation which supports TLS?

NEC's implementation does not yet support TLS but might support TCP
depending on far I can get until Thursday.

Best regards,

  Martin

|
| Best regards,
|
| Chris Lang
|
|> -----Original Message-----
|> From: Martin Stiemerling [mailto:[email-masked]]
|> Sent: 29 April 2005 09:32
|> To: [email-masked]
|> Subject: [Nsis-imp] NSIS/NTLP Interoperability Event before
|> IETF in Paris
|>
|>
|> Hi all,
|>
|> This is an announcement for the NSIS/NTLP interoperability
|> testing event to be held July 28 to July 30 in Paris. July 28
|> to July 30, Thursday to Saturday, is right before the 63rd
|> IETF meeting in Paris. The interoperability venue is at the
|> same venue as the IETF meeting is going to be, Palais des
|> Congres (<http://www.palaisdescongres-paris.com/gb/index.asp>).
|>
|> The interoperability event focuses on testing of the NTLP
|> between different implementations, but is not necessary
|> limited to the NTLP only.
|>
|> The venue will provided by NEC and the EU IST project
|> Eurolabs (<http://www.ist-eurolabs.org/>).  Participation for
|> implementers is free of charge and only implementers are
|> allowed to join the event.
|>
|> Further information about registration, times, shipping,
|> modalities, etc will be provided soon.
|>
|> This event will be co-located with the interoperability
|> testing event of the IST MOME project
|> (<http://www.ist-mome.org/events/interop/>)
|>
|> With best regards,
|>
|>     Martin Stiemerling
|>
|> NEC Europe Ltd. -- Network Laboratories [email-masked]
|> PGP Key at:        http://www.stiemerling.org/stiemerling_nec.gpg
|> WWW: http://www.netlab.nec.de
|>
|> _______________________________________________
|> NSIS-imp mailing list
|> [email-masked]
|> https://www1.ietf.org/mailman/listinfo/nsis-imp
|>
|
| _______________________________________________
| NSIS-imp mailing list
| [email-masked]
| https://www1.ietf.org/mailman/listinfo/nsis-imp

---

From: Martin Stiemerling <[email-masked]>
Date: Tue, 26 Jul 2005 09:03:46 +0200

Hi Luis,

--On Montag, 25. Juli 2005 17:01 Uhr +0100 Luís Cordeiro 
<[email-masked]> wrote:

| Hi all,
|
| I agree with the proposal.
|
| Our implementation it's only working with TCP yet, so we can't test the
| TLS support.
|
| What do you think about testing message interception and forwarding?

I see message interceptions as an enhanced feature for testing. The message
interception does not influence the basic behaviour of the protocol and
we definitely will burn some time with NTLP back-to-back tests. Forwarding
is a good option for the second or third day when the easy things work.

See you

  Martin

|
| Best regards,
|
| --
| Luís Cordeiro
| Department of Informatics Engineering
| University of Coimbra
| Portugal
|
|
| Lang, Christopher wrote:
|
|
| Hi all,
|
| It would be useful for all of us who are attending the interop to have
| an idea of what GIMPS features we wish to test. I have therefore drawn
| up a possible list of tests we could perform:
|
| 1)	Stateless Operation (no stack proposals sent, no routing state
| stored, no Confirm sent):
| 	a)	Intercept and decode a Query msg at RNode.
| 	b)	Receive and decode a Response msg at QNode.
| 2)	Stateful D-Mode operation (still without stack proposals):
| 	a)	Configure Rnode to store state on reception of Query and
| not request a Confirm. Install routing state at each node. Send a data
| message using the routing state.
| 	b)	Configure Rnode to store state on reception of Query and
| request a Confirm and repeat (a).
| 	c)	Configure Rnode to store state on reception of a Confirm
| and repeat (a).
| 3)	Repeat test 2 but advertise and create a TCP Forward C-Mode
| connection.
| 4)	Refresh existing routing state created in (5) by sending a Q/R
| sequence.
|
| Each test should be run 3 times: with the Qnode acting as an endpoint
| and the Rnode acting as a router; with the Qnode acting as a router and
| the Rnode acting as an endpoint; with the two nodes having swapped
| Q/Rnode roles.
|
| Note that we aren't currently intending to test any particular NSLP data
| formats. Does anyone have any comments on the proposed tests? Is there
| anything missing which we people feel we should test?
|
| If we have time (and we have implementations which support it) we could
| also repeat test (3) using TLS instead of TCP. Is anyone planning to
| bring an implementation which supports TLS?
|
| Best regards,
|
| Chris Lang
|
|
|
|
| -----Original Message-----
| From: Martin Stiemerling [mailto:[email-masked]]
| Sent: 29 April 2005 09:32
| To: [email-masked]
| Subject: [Nsis-imp] NSIS/NTLP Interoperability Event before
| IETF in Paris
|
|
| Hi all,
|
| This is an announcement for the NSIS/NTLP interoperability
| testing event to be held July 28 to July 30 in Paris. July 28
| to July 30, Thursday to Saturday, is right before the 63rd
| IETF meeting in Paris. The interoperability venue is at the
| same venue as the IETF meeting is going to be, Palais des
| Congres (<http://www.palaisdescongres-paris.com/gb/index.asp>).
|
| The interoperability event focuses on testing of the NTLP
| between different implementations, but is not necessary
| limited to the NTLP only.
|
| The venue will provided by NEC and the EU IST project
| Eurolabs (<http://www.ist-eurolabs.org/>).  Participation for
| implementers is free of charge and only implementers are
| allowed to join the event.
|
| Further information about registration, times, shipping,
| modalities, etc will be provided soon.
|
| This event will be co-located with the interoperability
| testing event of the IST MOME project
| (<http://www.ist-mome.org/events/interop/>)
|
| With best regards,
|
|     Martin Stiemerling
|
| NEC Europe Ltd. -- Network Laboratories [email-masked]
| PGP Key at:        http://www.stiemerling.org/stiemerling_nec.gpg
| WWW: http://www.netlab.nec.de
|
| _______________________________________________
| NSIS-imp mailing list
| [email-masked]
| https://www1.ietf.org/mailman/listinfo/nsis-imp
|
|
|
|
|
| _______________________________________________
| NSIS-imp mailing list
| [email-masked]
| https://www1.ietf.org/mailman/listinfo/nsis-imp
|
|
|