Subject: RE: [NSIS] Automatic Discovery of QCs

From: [email-masked]
Date: Fri, 1 Mar 2002 22:56:15 +0200

Hi Roland,

> I would add another point to section 5.3 of draft-ietf-nsis-req-00:
> 5.3.8 Automatic discovery of QoS Controllers.
>       This will allow some degree of auto configuration which can
>       be useful in many scenarios. For instance, hosts (especially 
>       mobile ones) will be able to find out the next adjacent 

Could we blur your requirement somewhat?  My suggest is:
 
  5.3.8 Discovery of QoS Controllers

	NSIS SHOULD support a simple mechanism for discoverying
	QoS entities.

This means that, for example, on-path signaling could be one
option - meaning that as the host signals the network, the
network can eavesdrop and setup signaling to off-path 
QoS entities; or access routers could proxy the QoS 
controllers and interact with them and allow some 
sort of seamoby context transfer for mobility, etc.

For me, a key issue with this topic is how does an end user
discover QoS entities?  Does it employ a protocol like SLP,
or DNS? Does the network do it via a proxy model; is there
some pre-configured home QoS entitity that negotiates
with the visitied network... or something else?

I favor a minimal approach, which allows service providers
to implement more complex schemes - but yet still allows the
minimal approach to work.

John

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Roland Bless <[email-masked]>
Date: Mon, 04 Mar 2002 15:55:48 +0100

Hi John,

> 	NSIS SHOULD support a simple mechanism for discoverying

This sounds better.

> with the visitied network... or something else?

This was the issue I tried to bring up. In my [maybe too
concrete and not simple enough] proposal, the signaling protocol
supports the discovery directly.
 
> minimal approach to work.

This would be fine.

Regards,
 Roland
-- 
Roland Bless -- e-Mail: [email-masked]
Institute of Telematics, University of Karlsruhe, Germany  
Zirkel 2, D-76128 Karlsruhe -- Office: Bld. 20.20, 3rd floor, R 358
Phone: +49 721 608-6413 Fax: +49 721 388097