Subject: SV: [NSIS] proposal to add requirement text

From: [email-masked]
Date: Fri, 22 Mar 2002 00:36:50 +0100

Jukka, 
 
I guess our difference is just what the requirement should be used for. The architectural requirement is to be able to control the message intensity (for denial of service reasons) and control the signaling delay (for express forwarding). The protocol requirement is exactly what you state. 
 
So this depends only on what kind of requirements we want to state. I tried to capture the architectural requirement, and also write some words about what the impact this will have on the protocol design. 
 
If you and others want to state it the other way around, I have no major objections to it - just as long as everything is stated. 

Anders
ps, resent because I missed to send it to the list. 

	-----Ursprungligt meddelande----- 
	Från: Jukka MJ Manner [mailto:[email-masked]] 
	Skickat: to 2002-03-21 11:17 
	Till: Bergsten, Anders P. /Research /0920-754 50, 070-661 44 98 
	Kopia: [email-masked]; [email-masked] 
	Ämne: Re: [NSIS] proposal to add requirement text

	        Hi,
	
	        the first req sounds good, but the second, IMO, is written the
	wrong way:
	
	        "The signalling messages must be identifiable in an efficient 
	way (with some definition of "efficient":)."
	
	        This then allows a network operator to assign priorities etc. to
	those signalling packets. So, don't mandate what to do with the packets,
	but make it (easily) possible to handle these packets in a specific way.
	
	        Cheers,
	
	        JiM

	On Thu, 21 Mar 2002 [email-masked] wrote:
	
	> All,
	>  off line discussions revealed that the scalability sections (5.6) could
	> be slightly updated.
	> 
	> I suggest wording along these lines:
	>  The nsis architecture should give the ability to constrain the load
	> (CPU load, memory space, signaling bandwidth consumption and signaling
	> intensity) on devices where it is needed. This can be achieved by many
	> different methods, for example message aggregation, by ignoring
	> signaling message, header compression or minimizing functionality. The
	> architecture may choose any of these methods as long as the requirement
	> is met.
	
	>  (the reasoning behind the words are the following, if I have the
	> ability to control the load the protocol(s) generate in a singel device,
	> the protocol will "scale". And the words does not mandate any particular
	> solution)
	
	>  A related requirement that was discussed was transport quality for the
	> signaling protocol where I propose the following text.
	
	>  The nsis architecture should allow the network operator to assign the
	> nsis protocol messages a certain transport quality. As signaling opens
	> up for possible denial-of-service attacks, this requirement gives the
	> network operator a mean, but also the obligation, to trade-off between
	> signaling latency and the impact (from the signaling messages) on
	> devices within his/her network. From protocol design this requirement
	> states that the protocol messages should be detectable, at least where
	> the control and assignment of the messages priority is done.
	> 
	> Anders
	>
	> _______________________________________________
	> nsis mailing list
	> [email-masked]
	> https://www1.ietf.org/mailman/listinfo/nsis
	>

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Schneider, Marco" <[email-masked]>
Date: Fri, 22 Mar 2002 17:27:35 -0600

Jukka,

I agree with your wording. It is up to the operator as to how to handle the
signaling packets in whatever matter we see fit. What is required is that we
be able to identify them as such and also that we be able to distinguish
between the different types of signaling messages (for possibly different
handling). Finally of course this must be achieveable in an efficient
manner. 

Marco

> -----Original Message-----
> From: Jukka MJ Manner [mailto:[email-masked]]
> Sent: Thursday, March 21, 2002 5:18 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [NSIS] proposal to add requirement text
> 
> 
> 
> 	Hi,
>