Subject: RE: [NSIS] section 3.5 in nsis-req-00.txt

From: [email-masked]
Date: Fri, 8 Mar 2002 10:36:38 +0100

John and Roland, 

I agree with Roland to a large extent (ie this is too complex). 

I would like the draft to state requirements that the model that should be supproted is: 

- Provider offers a service (describe by some parameters)
- Customer buy from this service (described by some parameters) 

Thus a behaviour like: 
Provider A: I have service X, Y, Z (described in some way)
Customer B: I want b amount of the service X.
Provider A: Ok. 

So the requirements would be something like: 

NSIS SHOULD support the advertisement of services from a provider to a customer.
NSIS MUST support an instantiation of a service from a customer towards a provider. 
Furthermore: 
NSIS MUST NOT restrict the way that a provider is describing the service. 
NSIS SHOULD support globally well-known service, if such services exists.

Anders

> > to enable some sort sort of dialog like:
> > 
> > 	Provider A:  Hey, do you 10k bandwidth and 50 ms delay?
> > 	Provider B:  Sorry, no.
> > 	Provider A:  Well howabout just 10k bandwidth?
> > 	Provider B:  I do.
> > 	Provider A:  Then I will take it.
> > 
> > Or do you want something more complex?
> 
> No, definitely not. I think that your example may be even too 
> complex. The set of service parameters should be fixed and only depend
> on the service (so either always bandwidth and delay or only 
> bandwidth).
> To avoid several iterations of requests, parameter intervals 
> should be 
> allowed within service parameter objects:
> Provider A: Can I get service X towards destination z with bandwidth
>             between 32k and 128k?
> Provider B: Service X with 64k is available now.
> 
> So in the request a range of acceptable parameter values is
> specified. Any value within the range will be acceptable
> for the requester, so the last dialogue of your example will
> not be necessary.
> 
> Regards,
>  Roland
> 
> -- 
> Roland Bless -- e-Mail: [email-masked]
> Institute of Telematics, University of Karlsruhe, Germany  
> Zirkel 2, D-76128 Karlsruhe -- Office: Bld. 20.20, 3rd floor, R 358
> Phone: +49 721 608-6413 Fax: +49 721 388097
> 
> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Roland Bless <[email-masked]>
Date: Fri, 08 Mar 2002 12:11:01 +0100

Hi Anders,

> Customer B: I want b amount of the service X.

I don't think we need the service advertisement now (can be an option,
but is not a requirement). This can be agreed out of nsis. I would
prefer: if customer requests a service (e.g. identified by a unique ID)
and if this service is not supported by a provider it rejects the
requests with a "service not supported" reply.

Roland