Subject: RE: [NSIS] section 3.5 in nsis-req-00.txt

From: [email-masked]
Date: Fri, 8 Mar 2002 11:44:19 +0200

Hi Anders,

> - Provider offers a service (describe by some parameters)
> - Customer buy from this service (described by some parameters) 

Isn't this the current model in RSVP?  How does this work on 
a peer-to-peer case?  If I call you, do I have to see
what kind of QoS you are advertising?

Shouldn't service advertisement be handled at the application
level, not the transport (NSIS) level?

In my (non-chair) opinion, I'd prefer this model

1) higher-level service information exchange happens
   (or is preconfigured / pre-known)
2) Consumer: I want X
3) Provider: Can't fufill X

Then the consumer can think if they would like to ask for y ...
(note: x may not be able to be fufilled for many reasons, one
could be because of a lack of resources, etc.)

John
 
> Thus a behaviour like: 
> Provider A: I have service X, Y, Z (described in some way)
> Customer B: I want b amount of the service X.
> Provider A: Ok. 
> 
> So the requirements would be something like: 
> 
> NSIS SHOULD support the advertisement of services from a 
> provider to a customer.
> NSIS MUST support an instantiation of a service from a 
> customer towards a provider. 
> Furthermore: 
> NSIS MUST NOT restrict the way that a provider is describing 
> the service. 
> NSIS SHOULD support globally well-known service, if such 
> services exists.

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Roland Bless <[email-masked]>
Date: Fri, 08 Mar 2002 16:12:56 +0100

Hi John,

> level, not the transport (NSIS) level?

Yes.

> 3) Provider: Can't fufill X

Great, I share this view.
 
> could be because of a lack of resources, etc.)

Exactly.

Regards,
 Roland

-- 
Roland Bless -- e-Mail: [email-masked]
Institute of Telematics, University of Karlsruhe, Germany  
Zirkel 2, D-76128 Karlsruhe -- Office: Bld. 20.20, 3rd floor, R 358
Phone: +49 721 608-6413 Fax: +49 721 388097