Subject: RE: [NSIS] section 3.5 in nsis-req-00.txt

From: [email-masked]
Date: Fri, 8 Mar 2002 10:47:32 +0200

Roland,

> I strongly suggest that nsis should work now on interdomain 
> QoS signaling. This is a major piece missing in global QoS support. A main 
> feature of the Internet is its global connectivity (availability of the 
> "same" basic service), so it would be nice to have at least a few globally 
> available public/standardized services (aggreement on them is a 
> business issue, so out of scope). But nsis signaling would allow to request resources of
> such services on demand between arbitrary sources and destinations.

What are your requirements?  Remember, we are not going into how
service providers actually provision network resources.  Do you want
to enable some sort sort of dialog like:

	Provider A:  Hey, do you 10k bandwidth and 50 ms delay?
	Provider B:  Sorry, no.
	Provider A:  Well howabout just 10k bandwidth?
	Provider B:  I do.
	Provider A:  Then I will take it.

Or do you want something more complex?

John

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Roland Bless <[email-masked]>
Date: Fri, 08 Mar 2002 10:20:34 +0100

Hi John,

> service providers actually provision network resources.  Do you want

Right, this is a local matter. My last phrase could be misinterpreted, 
sorry.

> Or do you want something more complex?

No, definitely not. I think that your example may be even too 
complex. The set of service parameters should be fixed and only depend
on the service (so either always bandwidth and delay or only bandwidth).
To avoid several iterations of requests, parameter intervals should be 
allowed within service parameter objects:
Provider A: Can I get service X towards destination z with bandwidth
            between 32k and 128k?
Provider B: Service X with 64k is available now.

So in the request a range of acceptable parameter values is
specified. Any value within the range will be acceptable
for the requester, so the last dialogue of your example will
not be necessary.

Regards,
 Roland

-- 
Roland Bless -- e-Mail: [email-masked]
Institute of Telematics, University of Karlsruhe, Germany  
Zirkel 2, D-76128 Karlsruhe -- Office: Bld. 20.20, 3rd floor, R 358
Phone: +49 721 608-6413 Fax: +49 721 388097