Subject: [NSIS] Some charter scoping / restrictions

From: [email-masked]
Date: Sun, 19 May 2002 20:12:54 +0300

Hi all,

Even before the last few email discussions on NSIS & its charter, 
the Area Directors and I had a small chat.  There is some worry
that some of the discussion on the list is distinctly out of
scope, and here is the scoping that we have come up with:

NSIS will work on signaling from an end system that follows a path 
through the net that is determined by the normal L3 routing and is 
used to convey per-flow information to the devices the signals pass 
through - the signaling can install soft state (maintained by repetition) 
in the devices it passes through.

An end system could be a device along the path that signals for a data
flow that passes through it.

There is no requirement that the per-flow information be QoS related i.e.
NSIS should only worry about how to do the signaling - what the  signaling
conveys should be opaque to NSIS.  QoS has been thought of the first 
application of such a system, and used to help focus discussion.
However, it seems that QoS has done the opposite, and created divergence
from the charter.

This rules out bandwidth brokers, 3rd party QoS controllers, hard state,
etc.  After we fufill the above stated goals, the WG could move on to 
other things (like BBs).

This is as definitive statement as can be made.  

Best regards
John, Scott & Allison

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Praveen Muley"<[email-masked]>
Date: Sun, 19 May 2002 11:58:10 -0700

Hi John,
       Does that mean that we will be also dealing with autoneogtiation of
services ( different applications) between the mobile device and the edge
offering services in this charter ? 

Thanks,
Praveen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Sunday, May 19, 2002 10:13 AM
To: [email-masked]
Subject: [NSIS] Some charter scoping / restrictions

Hi all,

Best regards
John, Scott & Allison

---

From: [email-masked]
Date: Mon, 20 May 2002 08:13:45 +0300

Hi Praveen,

> Does that mean that we will be also dealing with autoneogtiation 
> of services (different applications) between the mobile device and 
> the edge offering services in this charter ? 

That is out of scope for the current NSIS charter.  

John

---

From: "Shaheen, Kamel M." <[email-masked]>
Date: Mon, 20 May 2002 08:46:53 -0400

Hi John,
 
Does this mean that NSIS is moving toward a direction similar to what SIP is
doing?

Regards,

Kamel Shaheen, Ph.D.

InterDigital Communications

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Sun, May 19, 2002 1:13 PM
To: [email-masked]
Subject: [NSIS] Some charter scoping / restrictions

Hi all,

Best regards
John, Scott & Allison

---

From: "Glenn Morrow"<[email-masked]>
Date: Wed, 22 May 2002 12:44:07 -0500

First of all, thank you very much for re-affirming the scope. 

I could use a little more elaboration on this sentence, though. Can you give

> flow that passes through it.

I.e. do you mean "should initially be considered to" instead of "could".

I'm just trying to hammer down exactly where the line in the sand has been
drawn for immediate attention.

Thanks,

Glenn

---

From: [email-masked]
Date: Wed, 22 May 2002 21:38:23 +0300

Hi Glenn,
 
> I could use a little more elaboration on this sentence, though. Can you give an example of 
> what you mean, exactly by this:
> > 
 
NSIS, hopefully, will come up with a modular framework, which will allow
a device along the path to signaling on behalf of a flow that passes through it.
It should also allow the endpoint to do the signaling itself.
 
It seems that your question is alot more deployment oriented, and deployment
is not within scope of NSIS.  So, the term you use 'should initially be' is 
inappropriate for the charter, but could possibly find its way into the framework
if there was support for it.
 
John

---

From: "Geib, Ruediger" <[email-masked]>
Date: Thu, 23 May 2002 09:36:13 +0200

Hi John

> NSIS, hopefully, will come up with a modular framework, which 
> will allow a device along the path to signaling on behalf of
> a flow that passes through it.

If proxies and centralised service management are out of scope
the endpoint must signal for itself. Is it possible to trigger
an endpoint externally to start some NSIS signaling? I'm only
asking because that's how RSVP-TE signaling is used.
 
"Endpoint" is some kind of service termination point. The data
flow on which "service" is applied could transit through that
signaling/service endpoint. The charter should explain this 
optional difference between service termination and data 
flow termination.

I'd too appreciate if the next charter clearly says what's in
scope of NSIS and what isn't.

Regards, Rüdiger

---

From: [email-masked]
Date: Fri, 24 May 2002 09:35:11 +0300

Hi Rüdiger

> asking because that's how RSVP-TE signaling is used.

Proxies are not out of scope & the ADs have expressed concerns
that centralized service management is outside of the initial
scope of the WG.  There may be some use in documenting some
of the needs of centralized resource management on signaling,
perhaps in the framework and can be used to note future work
needed.

> optional difference between service termination and data 

I'm not sure that the charter is the right place, but I think
the framwork document would be appropriate.

John

---

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Mon, 27 May 2002 15:13:49 +0200

Hi Rudiger and John

The NSIS protocol can be used for 
QoS signaling on Layer 3 routers (please see e-mail 
archived at the URL:

http://www1.ietf.org/mail-archive/working-groups/nsis/current/msg01328.html)

Best Regards,
Georgios

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: vrijdag 24 mei 2002 8:35
To: [email-masked]
Cc: [email-masked]
Subject: RE: [NSIS] Some charter scoping / restrictions

Hi Rüdiger

John