Subject: [NSIS] Flow related signaling

From: "Geib, Ruediger" <[email-masked]>
Date: Mon, 27 May 2002 11:07:04 +0200

Hello John

while I read the minutes of the interim meeting I thought
about the "flow related signaling" issue. What exactly is
required by NSIS signaling?

- in a connectionless network, network service is always
  offered to a flow.
- without prior knowledge of what identifies a flow, 
  "service" is applied to all traffic passing a point
  which supports "service".
- "flow" could probably be very fine grained (e.g. 
  source/destination address, port and application)
  or rather corse (the entire traffic passing the
  service supporting device) or something in between.
  NSIS apply constraints here, but I'm not sure whether
  this is useful.

It probably has to be the service specification which 
determines the level of signaled information required
to identify a flow. NSIS however must be able to carry
the information identifying the service specific flow.
Would NSIS define a kind of abstract Flow ID toolbox? 
Some kind of flexible Flow ID TLV, data formats 
and protocol layers (e.g. IP information only) which may
be used to identify a flow?  

Regards, Rüdiger

PS: The URL to "Edited Charter (Word, with changebars)"
    is indicated as invalid by my browser. 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "SHEN, Qi (Charles)" <[email-masked]>
Date: Tue, 28 May 2002 18:34:05 +0800

Hi,

I think NSIS should allow a very flexible flow (or flow aggregate) 
identification. Besides the traditional IP five-tuple, the IPv6 Flow Label 
should possibly be incorporated. Moreover, should we consider using higher 
level identities like what RFC 2872 defines: the "Application and Sub 
Application Identity for use with RSVP"?

Charles

·       To: ·   [email-masked]
·       Subject: [NSIS] Flow related signaling
·       From: "Geib, Ruediger" <·       [email-masked]>
·       Date: Mon, 27 May 2002 11:07:04 +0200
·       Cc: ·   [email-masked]
·       List-Id: Next Steps in Signaling <nsis.ietf.org>
·       Sender: ·       [email-masked]

Hello John

Regards, Rüdiger

---

From: [email-masked]
Date: Wed, 29 May 2002 08:28:20 +0300

Hi all,

In the interim meeting, there was some discussion of a 'flow'
I think we should at least define (for NSIS) what a flow is
and some abstract representation of it.  There may be some
places where the flow may not be needed, however.  This would
be good to discuss some more on the list.

thanks,
John

> -----Original Message-----
> From: ext SHEN, Qi (Charles) [mailto:[email-masked]]
> Sent: 28 May, 2002 13:34
> To: Loughney John (NRC/Helsinki); [email-masked]
> Cc: [email-masked]
> Subject: Re: Flow Related Signaling
> 
> 
> Hi,
>