Subject: [NSIS] RE: Admission control relevant routing information

From: "Geib, Ruediger" <[email-masked]>
Date: Thu, 2 May 2002 13:26:58 +0200

Hello Roland

> I fully understand your requirement, but I don't think that 
> the protocol has to specify the underlying admission 
> control model. 

That's not quite what I expect. The developres of a signaling protocol should however have a rationale which types of QoS admission control could be supported by the protocol they defined.

> The real requirement seems to be: the protocol should be
> able to carry a great variety of address information
> objects, such as IPv4/v6 host addresses, IP network
> addresses, IP addresses + ports, AS numbers, etc. If 
> there is a possibility in the signaling protocol to
> carry address information of the ingress node/router
> in request messages, it should match your requirement. 

Yes, that's the basisic requirement.

> If this address information is considered optional,
> we are independent of the actual admission control model.

I'm not sure. The more service specific we get, the closer we come to a mandatory requirement whether or not to provide which address information. NSIS doesn't specify the services and their admission control. It should provide a discussion on how to make use of a protocol. I wouldn't like a situation where two domains can't interoperate because one doesn't transmit the optional address information the other domain requires to do admission control.

I'd suggest to stop the discussion on the latter now. It's to far from todays NSIS issues. Above formulation to allow NSIS to  carry a variety of address information seems sufficient by now. 

Regards, Rüdiger

>  
> > let's take the example of RSVP: the RSVP node must store 
> the IP address of the prior RSVP signaling node in order to 
> provide the service requested.
> > 
> > let's take a centralized system supporting RSVP in a 
> diffserv cloud: it must know by which gateway a specific RSVP 
> reservation entered in order to provide the requested 
> service. Note that the centralized unit may have to tap 
> intradomain routing to provide service (out of scope of NSIS 
> - but relevant to operators willing to make use of the 
> particular NSIS protocol as part of their solution).
> > 
> > There may be different situations where NSIS may have to 
> transport some kind of address information only relevant to 
> adjacent NSIS signaling units. That's why the designers of an 
> NSIS protocol must describe, whether and how admission 
> control for the services supported by their signaling 
> protocol is influenced by routing.
> > 
> > Regards, Rüdiger   
> > 
> > > -----Original Message-----
> > > From: Marcus Brunner [mailto:[email-masked]]
> > > Sent: Thursday, May 02, 2002 11:46 AM
> > > To: Geib, Ruediger
> > > Cc: [email-masked]
> > > Subject: Re: Admission control relevant routing information
> > > 
> > > 
> > > Ruediger,
> > > 
> > > I think I have understood your point. However, we added 
> an assumption 
> > > saying, that a NSIS protocol user already knows about the 
> > > service types 
> > > before the nsis protocol even starts. And we do not specify 
> > > how this is 
> > > achieved (e.g. by web page, in the customer-provider 
> contract, etc.)
> > > 
> > > What I am not sure about is what exactly you mean by 
> > > admission control 
> > > model  how is it different from a part of the service 
> > > definition (service 
> > > model)?
> > > 
> > > Marcus
> > > 
> > > --On Thursday, May 02, 2002 10:50 AM +0200 "Geib, Ruediger" 
> > > <[email-masked]> wrote:
> > > 
> > > > Dear Markus,
> > > >
> > > > I'd like to suggest the following requirement to be added to the
> > > > requirements draft.
> > > >
> > > > 5.8.11 The QoS signaling protocol must specify which model 
> > > of admission
> > > > control it is supporting and whether and which adress 
> > > information has to
> > > > be carried by it. QoS service provisioning may depend on 
> > > service type and
> > > > provider philosophy. A purely qualitative service may 
> not require
> > > > definition of a specific destination being serviced. In 
> contrast, a
> > > > resource intensive real time service may require detailed 
> > > information on
> > > > the route of the traffic for the purpose of admission 
> > > control. In the
> > > > latter case, the NSIS protocol may e.g. have to 
> transport IP address
> > > > information of some kind between adjacent QC nodes. An NSIS 
> > > protocol must
> > > > therefore specify, whether and how IP routing is relevant 
> > > to the service
> > > > supported.
> > > >
> > > > I hope it's getting clear what I mean. If somebody is able 
> > > to provide a
> > > > more comprehensive explanation, go ahead.
> > > >
> > > > Regards, Rüdiger
> > > >
> > > >
> > > > Rüdiger Geib
> > > > Senior Expert
> > > > T-Systems Nova GmbH
> > > > Technologiezentrum
> > > > Am Kavalleriesand 3, 64295 Darmstadt
> > > > Germany
> > > > Fon: +49 6151 832138
> > > > Fax: +49 6151 838103
> > > > mailto:[email-masked]
> > > > http://www.t-nova.de
> > > >
> > > 
> > > 
> > > 
> > > --------------------------------------
> > > Dr. Marcus Brunner
> > > Network Laboratories
> > > NEC Europe Ltd.
> > > 
> > > E-Mail: [email-masked]
> > > WWW:    http://www.ccrle.nec.de/
> > > personal home page: http://www.brubers.org/marcus
> > > 
> > > 
> > 
> > _______________________________________________
> > nsis mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/nsis
> 
> -- 
> Roland Bless -- e-Mail: [email-masked]
> Institute of Telematics, University of Karlsruhe, Germany  
> Zirkel 2, D-76128 Karlsruhe -- Office: Bld. 20.20, 3rd floor, R 358
> Phone: +49 721 608-6413 Fax: +49 721 388097
> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Thu, 2 May 2002 14:57:52 +0200

Hi Geib

Please receive my comments in line!

>> 5.8.11 The QoS signaling protocol must specify which model of 
>> admission control it is supporting and whether and which adress 
>> information has to be carried by it.
>> QoS service provisioning may depend on service type and provider 
>> philosophy. A purely qualitative service may not require definition 
>> of a specific destination being serviced. In contrast, a resource 
>> intensive real time service may require detailed information 
>> on the route of the traffic for the purpose of admission control. 
>> In the latter case, the NSIS protocol may e.g. have to transport 
>> IP address information of some kind between adjacent QC nodes. 
>> An NSIS protocol must therefore specify, whether and how IP routing 
>> is relevant to the service supported.

How a QoS initiator could specify the admission control 
mechanisms, since different parts 
of the network and during the same session (flow) might use different  
types of admission control mechanisms, or they will not use 
any admission control at all!
This is an issue that should be left over to network providers.

Moreover, regarding IP routing, how a QoS initiator (sender)
will be able to know what kind of
IP routing is used by a network provider?

Best Regards,
Georgios

---

From: "Geib, Ruediger" <[email-masked]>
Date: Thu, 2 May 2002 15:23:36 +0200

Hi Georgios,

my reply to Roland Bless comment on this list should clarify the point. 

Regards, Rüdiger

---

From: "Geib, Ruediger" <[email-masked]>
Date: Thu, 2 May 2002 15:45:27 +0200

Georgios,

> Sorry Geib, I have looked to your reply to the comment 
> of Roland Bless but it did not clarify the point I made!

Please clarify which part of your comment wasn't 
answered by Rolands suggestion and my reply.

Regards, Rüdiger

---

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Thu, 2 May 2002 15:36:09 +0200

Hi Geib

Best Regards,
Georgios

-----Original Message-----
From: Geib, Ruediger [mailto:[email-masked]]
Sent: donderdag 2 mei 2002 15:24
To: [email-masked]
Cc: [email-masked]
Subject: RE: [NSIS] Admission control relevant routing information

Hi Georgios,

Regards, Rüdiger

---

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Thu, 2 May 2002 16:42:20 +0200

Hi Rudiger

Okay, you answered:

R>That's not quite what I expect. The developers of 
R>a signaling protocol should however have a rationale 
R>which types of QoS admission control could be supported 
R>by the protocol they defined.

I do not see how this answer justifies the need of 
specifying (in the NSIS protocol messages) 
the used admission control model,
when more than one admission control 
models (during the same session), might be used 
in different parts of the network!

Regarding routing:

G> Moreover, regarding IP routing, how a QoS initiator (sender)
G> will be able to know what kind of
G> IP routing is used by a network provider?

This question was not answered in the e-mail sent to Roland!

Best regards,
Georgios

-----Original Message-----
From: Geib, Ruediger [mailto:[email-masked]]
Sent: donderdag 2 mei 2002 15:45
To: [email-masked]
Cc: [email-masked]
Subject: RE: [NSIS] Admission control relevant routing information

Georgios,

Regards, Rüdiger

---

From: "Geib, Ruediger" <[email-masked]>
Date: Thu, 2 May 2002 16:59:07 +0200

Hi Georgios

please find my comments below.

> in different parts of the network!

Certainly a difficult issue. As the QoS signaling protocol
must provide sufficient information to allow admission 
control, addresses of upstream inter domain gateways or 
of the sending QC may be part of the admission control 
decision. As this information must be signaled, it has to 
be part of the protocol design. It is however part of
the service specific protocol. As I mentioned in my response
to Roland, I'd like to go on with this discussion once we
finished the basic part of NSIS and start to get service
specific.    
 
G> Moreover, regarding IP routing, how a QoS initiator (sender)
G> will be able to know what kind of IP routing is used 
G> by a network provider?

The routing protocol used by a provider is of no relevance 
to the requirement I stated. I do not suggest any changes to
or interoperability with routing protocols.

Regards, Rüdiger

---

From: [email-masked]
Date: Fri, 3 May 2002 10:45:26 +0300

Georgios,

> IP routing is used by a network provider?

This is exactly correct.  Admission control and routing are
outside of the scope for NSIS.  What may be needed later
is some document describing some relationship between them,
but that document is not the requirements document.

John