Subject: RE: [NSIS] comments Issue (8) included in draft-ietf-nsis-req-01

From: Bob Braden <[email-masked]>
Date: Fri, 3 May 2002 23:32:48 GMT

*> 
  *> Let me use this requirement as an example of the aspects of NSIS work that
  *> confuse me over and over again. I hope somebody will help me to sort it out:
  *> 
  *> What are we trying to say here? In my mind we want that protocol(s) be able
  *> to express an idea of bi-directional reservation. In addition we want to say
  *> that support by the QCs of the bi-directional reservation is optional. But
  *> combination of these ideas is not properly expressed neither by the
  *> statement proposed by John not by Georgios.
  *> 
  *> Regards,
  *> Ilya

I am sure I am missing something, but I don't know what you mean by
a "bidirectional reservation".  If you mean that both directions use
the same path, that won't work for the Internet, where the data may
use different paths.

What am I missing?

Bob Braden

  *> 
  *> -----Original Message-----
  *> From: Georgios Karagiannis (ELN)
  *> [mailto:[email-masked]]
  *> Sent: Monday, April 22, 2002 10:49 AM
  *> To: [email-masked]'; [email-masked]
  *> Cc: [email-masked]
  *> Subject: RE: [NSIS] comments Issue (8) included in draft-ietf-nsis-req-01
  *> 
  *> Hi John
  *> 
  *> Yes, I agree the bi-directional requirement is an optional requirement!
  *> 
  *> Best regards,
  *> Georgios
  *> 
  *> -----Original Message-----
  *> From: [email-masked] [mailto:[email-masked]]
  *> Sent: maandag 22 april 2002 15:35
  *> To: [email-masked]; [email-masked]
  *> Cc: [email-masked]
  *> Subject: RE: [NSIS] comments Issue (8) included in
  *> draft-ietf-nsis-req-01
  *> 
  *> 
  *> Hi,
  *> 
  *> > Please receive my comments on Issue (8) included in the
  *> > NSIS WG draft: draft-ietf-nsis-req-01.txt
  *> >
  *> > Comment on Issue (8):
  *> >
  *> > >    8) (OPEN) bi-directional data path setup with one QoS request
  *> > >    I have not seen consensus on whether to require
  *> > bi-directional data
  *> > >    path setup with QoS.
  *> > >    - How can we actually perform bi-directional
  *> > reservations when the
  *> > >    forward and reverse paths are not reciprocal, with respect to
  *> > >    routing topology and routing policy of network domains between
  *> > >    sender and receiver?
  *> > >    - The need to ensure that the return path is the same as the
  *> > >    forwarding path is one of the problems with RSVP,
  *> > particularly in a
  *> > >    mobile environment.
  *> >
  *> > [GK] The bi-directional data path setup does not need to use the same
  *> > [GK] return path as the forwarding path. The only requirement
  *> > to achieve
  *> > [GK] a bi-directional reservation is that the sender for the
  *> > forwarding path
  *> > [GK] is also the receiver for the return path and that the
  *> > receiver for the
  *> > [GK] forwarding path is also the sender for the return path.
  *> > [GK] Therefore, I think that the bi-directional option should not be
  *> mandatory
  *> > [GK] but at least optional;
  *> 
  *> Perhaps 'Bi-directional QoS requests MAY be possible' is enough.
  *> 
  *> John
  *> 
  *> _______________________________________________
  *> nsis mailing list
  *> [email-masked]
  *> https://www1.ietf.org/mailman/listinfo/nsis
  *> 
  *> _______________________________________________
  *> nsis mailing list
  *> [email-masked]
  *> https://www1.ietf.org/mailman/listinfo/nsis
  *> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Marcus Brunner <[email-masked]>
Date: Mon, 06 May 2002 10:44:16 +0200

--On Friday, May 03, 2002 11:32 PM +0000 Bob Braden <[email-masked]> wrote:

>   *>
>   *> Let me use this requirement as an example of the aspects of NSIS
> work that   *> confuse me over and over again. I hope somebody will help
> me to sort it out:   *>
>   *> What are we trying to say here? In my mind we want that protocol(s)
> be able   *> to express an idea of bi-directional reservation. In
> addition we want to say   *> that support by the QCs of the
> bi-directional reservation is optional. But   *> combination of these
> ideas is not properly expressed neither by the   *> statement proposed by
> John not by Georgios.
>   *>
>   *> Regards,
>   *> Ilya
>

The meaning behind bi-directional as far as I have understood is that both 
ends (data sender resv 1 == data receiver of stream 2) and vice versa.
IMO, the bi-directional setup is an optimization towards low setup delays, 
however it adds complexity in the end-system stacks. Whether it adds 
complxity in the core as well is an open question for me.

Marcus

> draft-ietf-nsis-req-01   *>
>   *> Hi John
>   *>
>   *> Yes, I agree the bi-directional requirement is an optional
> requirement!   *>
>   *> Best regards,
>   *> Georgios
>   *>
>   *> > [GK] The bi-directional data path setup does not need to use the
> same   *> > [GK] return path as the forwarding path. The only requirement
>   *> > to achieve
>   *> > [GK] Therefore, I think that the bi-directional option should not
> be   *> mandatory

--------------------------------------
Dr. Marcus Brunner
Network Laboratories
NEC Europe Ltd.

E-Mail: [email-masked]
WWW:    http://www.ccrle.nec.de/
personal home page: http://www.brubers.org/marcus