Subject: RE: [NSIS] Errored situation signaling requirements

From: "Geib, Ruediger" <[email-masked]>
Date: Thu, 2 May 2002 15:21:37 +0200

Georgios

Comments in line.

Regards, Rüdiger

R >> 5.3.2 Release after failure
R >> After detection of a failure or stale state, any QoS 
R >> controller/initiator must be able to release a 
R >> reservation it is involved in. This may require signaling 
R >> of the "Release after Failure" message upstream as well as 
R >> downstream.
G> Is this requirement not similar to 5.3.2?

Exactly. Your interpretation that I suggest to replace 5.3.2 with this text is correct. Note that I numbered it as "5.3.2".
 
R >> 5.3.6 Error notification and error location
R >> An NSIS signaling node rejecting or releasing a reservation 
R >> must indicate its identity. NSIS signalling should indicate 
R >> why a requested resource is not or no longer available. 
G> Is this not similar to Requirement 5.3.4 and open issue (53)!

I'd like to repeat 3.4: "Prompt notification of QoS violation in case of error / failure to QoS Initiator and QoS Controller."
QoS violation / failure happens on the data plane. My suggestion for 5.3.6 is about problems on the control plane.

R >> (5.3.7 Explicit request of resources
R >> NSIS signaling must support the explicit request of resources.)
G> Is this not similar to Requirement 5.3.1!

5.3.1 is: Explicit release of resources. 
My suggestion is about establishment of resources. I can see a difference.

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Marcus Brunner <[email-masked]>
Date: Thu, 16 May 2002 20:09:33 +0200

Ruediger,

Do you feel that there are implicit requests of resources?
And I would say more it is a request for service (the ressource management 
needs to be done within a domain)

Marcus

> My suggestion is about establishment of resources. I can see a difference.

--------------------------------------
Dr. Marcus Brunner
Network Laboratories
NEC Europe Ltd.

E-Mail: [email-masked]
WWW:    http://www.ccrle.nec.de/
personal home page: http://www.brubers.org/marcus