Subject: RE: [NSIS] RE: What's in the charter of NSIS

From: [email-masked]
Date: Mon, 20 May 2002 08:37:54 +0300

Hi Melinda,

> I've written a document describing the use of RSVP for firewall
> traversal and NAT traversal (which I'll be sending to the secretariat
> next week) and another describing the use of of RSVP for IPSec
> tunnel endpoint discovery and rudimentary SDB management ("don't
> encapsulate this").  The latter will probably not be submitted
> in its current form but was interesting to write.
> 
> What I found was 1) the RSVP protocol machinery is *extremely*
> well suited to addressing generic middlebox problems, and 2) exactly
> what you're saying - some of the required data are inapplicable
> to generic middlebox problems (this may apply to the rich variety
> of reservation styles, as well).

I agree, I think that as a pure signaling protocol, RSVP is not
so bad.  If one can seperate IntServ from it, and maybe multicast,
and add support for some sort of signaling request (maybe
some sort of opaque blob) then we'd already have a nice
tool for doing some interesting things.  

In my opinion, NSIS should try to think modestly about the results
of our work. I think that producing a nice 'tool' which allows
service providers to be able to start offering some services
and allowing end-systems to signaling robustly for these
services would be a good step forward.

John

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Martin Karsten <[email-masked]>
Date: Mon, 20 May 2002 15:28:19 +0200 (CEST)

> tool for doing some interesting things.  

I fully agree. We have once built a small prototype to use RSVP as a
firewall signalling protocol:
http://www.kom.e-technik.tu-darmstadt.de/publications/abstracts/RGKS01-1.html
Longer version at:
http://www.kom.e-technik.tu-darmstadt.de/publications/abstracts/RGKS00-1.html

Starting with RSVP, thinking again carefully about group communication
(multicast, multi-sender and filter styles) and adding new features in a
modular way. That seems to be a very reasonable mixture.

Martin