Subject: RE: [NSIS] To BB or not to BB

From: Ping Pan <[email-masked]>
Date: Mon, 13 May 2002 01:20:55 -0700 (PDT)

On Mon, 13 May 2002, Geib, Ruediger wrote:

> Hello Ping,
>
> > Hence, could any *non-research* provider please please tell me if and
> > when they will deploy BB to their customers?
>
> Yes, there is interest in having QoS signaling
> architecture removing signaling support from
> routers. The charm of a BB like QoS resource
> administration is that it removes dependancies
> of carriers from router vendors - and will work
> with a heterogeneous router environment. BB's
> may be developed and changed independant from
> router operating systems. Of course this doesn't
> come for free. The BB must provide a management
> access to a router, which of course depends on
> router operating systems.
>

After developed COPS multiple times in the past, my experience has been
that BB is to simply lift all the work from a distributed system (router
network) to a centralized system (BB network). Instead making things
simple, BB's will do the same amount of message processing, state
management etc. as the routers, but BB's will now have to somehow knowing
the entire network AND to sync up states with the routers. At the end,
BB's just make the whole thing more complex.

> I'm not sure what you mean by "deploying a BB
> to my customer". I guess a first step in
> supporting automated QoS resource negotiation
> will some kind of Web based access to a policy
> management system.
> It wouldn't change if a BB
> is introduced. Between domains, BB's may talk
> directly with each other.
>
> In some cases, like support of mobile wireless
> terminals, a hybrid solution may be best.
> Mobile signals to edge router, edge router
> signals to BB.
> This allows core routers to
> stay out of signaling business. Of course the
> argument of vendor independance gets lost.
> However the required signaling functionalities
> are still limited: simply forward message to
> the BB and forward replies to the mobile.
>

Hoe about this: mobile devices create a session with some policy servers
for billing. The packets may go through routers, and the routers don't
have to do much about it. Only when the mobile devices want to get network
resource, it can ask the routers, and routers can signal the rest of the
network. In this case, routers don't have to care anything about BB or not
BB, and mobile devices can talk to the servers without worrying about if
routers will do something crazy to the packets. :-)

> What I'd expect from NSIS on BB's is to allow
> for specifications of inter domain signaling
> specifications supporting a centralised QoS
> resource administration.

What kind of inter-domain are you referring to? Please tell me how to run
centralised XYZ administration in the inter-domain enviornment in the
Internet? :-)

- Ping

> Nothing else. This
> at least should (better must) interwork with
> a purely router based signaling protocol
> developed by NSIS.
>
> Regards,
>
> Rüdiger
>
> PS: T-Systems is part of Deutsche Telekom.
> That's a *non-research* provider. I'm talking
> here as an individual, however.
>
>
> Rüdiger Geib
> Senior Expert
> Systems Integration
> T-Systems Nova GmbH
> Technologiezentrum
> Am Kavalleriesand 3, 64295 Darmstadt
> Germany
> Fon: +49 6151 832138
> Fax: +49 6151 838103
> mailto:[email-masked]
> http://www.t-nova.de
>
>
>
>
>
>
>
>

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Geib, Ruediger" <[email-masked]>
Date: Mon, 13 May 2002 09:08:22 +0200

Hello Ping,

management system. It wouldn't change if a BB 

signals to BB. This allows core routers to 

resource administration. Nothing else. This 

Regards,

Rüdiger

Rüdiger Geib
Senior Expert
Systems Integration
T-Systems Nova GmbH
Technologiezentrum

---

From: Roland Bless <[email-masked]>
Date: Tue, 14 May 2002 10:44:29 +0200

Hi Ping,

see comments inline

> BB's just make the whole thing more complex.

I disagree here. BBs will take very much processing burden from routers
which could instead fully concentrate on data path forwarding and
processing routing protocol/management information. A logically
centralized system has also a lot advantages and may even save signaling
messages, too, e.g. by making resource-based and policy-based decisions
at the same place. BBs can be also redundant SMP systems with scalable
processing power to cope with all their tasks.

> centralised XYZ administration in the inter-domain enviornment in the

:-) Surely not a centralized solution for the whole Internet.
Maybe centralized within a single domain, but all domains negotiate
on their own with their adjacent domains, thus an overall distributed
architecture.

[turning off BB political discussion, coming back to NSIS issues]
I would expect an NSIS solution that works for both models router-based
or BB-based.

Regards,
 Roland

-- 
Roland Bless -- e-Mail: [email-masked]
Institute of Telematics, University of Karlsruhe, Germany  
Zirkel 2, D-76128 Karlsruhe -- Office: Bld. 20.20, 3rd floor, R 358
Phone: +49 721 608-6413 Fax: +49 721 388097