Subject: [NSIS] middlebox drafts

From: Melinda Shore <[email-masked]>
Date: Wed, 10 Jul 2002 10:29:28 -0400

I was a little surprised to see the middlebox draft show
up on the agenda for the Yokohama meeting.  Those interested
in that topic may want to have a look at my drafts on using
an RSVP-like protocol for middlebox communications, which I
think, frankly, are more detailed and contain more analysis
and evaluation.  They are:
http://search.ietf.org/internet-drafts/draft-shore-friendly-midcom-01.txt
http://search.ietf.org/internet-drafts/draft-shore-tist-prot-00.txt

The protocol draft is not offered up for standardization 
purposes but more as a proof-of-concept exercise.

As a reminder, the TIST BOF, which focuses on using an RSVP-
like protocol for middlebox communication, will be Monday
evening from 19:30-2200.

Thanks,

Melinda

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Marcus Brunner <[email-masked]>
Date: Wed, 10 Jul 2002 17:06:02 +0200

Melinda,

My middlebox draft was intended for NSIS, because it discusses some issues 
we have in requirements and framework discussion. I see using NSIS for 
middlebox communication as a different application, where NSIS might work, 
and therefore we have to look into it.

That your drafts is much better from a middlebox point of view is clear. 
E.g., in NSIS we do not care what service we signal for, so the data we 
need to ship around does not belong into NSIS scope.

Marcus

> like protocol for middlebox communication, will be Monday

--------------------------------------
Dr. Marcus Brunner
Network Laboratories
NEC Europe Ltd.

E-Mail: [email-masked]
WWW:    http://www.ccrle.nec.de/
personal home page: http://www.brubers.org/marcus

---

From: Melinda Shore <[email-masked]>
Date: Wed, 10 Jul 2002 11:12:08 -0400

At 05:06 PM 7/10/02 +0200, Marcus Brunner wrote:
>That your drafts is much better from a middlebox point of view is clear. E.g., in NSIS we do not care what service we signal for, so the data we need to ship around does not belong into NSIS scope.

I absolutely agree with that, but there are some considerations
with regard to signaling and NAT, as well as security.  The
"Network-Friendlier Midcom" draft provides a generalized framework
rather than being a specific proposal.

Melinda