Subject: RE: [NSIS] QoS framework.

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Mon, 8 Jul 2002 15:14:00 +0200

Hi Cedric and Hemant

I have read your draft. In my opinion 
this draft is too much oriented on seamoby and mobileip WG solutions.

In the draft "draft-hancock-nsis-fw-00.txt" we describe similar 
mobility issues to what you tried to describe in your draft, but 
we presented the solutions in a more general way without excluding 
other solutions then seamoby and mobileip WG like solutions.
Probably this draft is more suitable to be 
used as a solution specific draft.

In my opinion the framework draft should be open to 
more than one type of solutions.

Best Regards,
Georgios

-----Original Message-----
From: Cedric Westphal [mailto:[email-masked]]
Sent: Monday, June 24, 2002 7:47 PM
To: [email-masked]
Cc: [email-masked]
Subject: [NSIS] QoS framework.

Hi all,

we put together a document representing our perspective on a
NSIS qos signaling framework.

Here is the abstract:

Abstract

   This draft provides a framework for QoS signaling that is optimized
   for Mobile IP handoffs. It covers the horizontal signaling between
   access routers (ARs) as well as the vertical signaling along the
   packet data path, both of which are triggered by handoff of mobile
   node (MN). The key design goals are wireless bandwidth economy,
   fast QoS establishment along the new data path after handoff and
   secure protocol operation.

The document will eventually be available from the i-d editor queue. However,
only after Yokohama meeting. You can find it at:
http://people.nokia.net/~cedric/Papers/draft-westphal-nsis-qos-mobileip-00.txt
in the meantime.
Please send your comments,

Cedric & Hemant.

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: [email-masked]
Date: Mon, 8 Jul 2002 11:09:13 -0400

Hi Georgios:

Please see inline:

-----Original Message-----
From: ext Georgios Karagiannis (ELN)
[mailto:[email-masked]]
Sent: 08. July 2002 9:14
To: Weshphal Cedric (IPRG/MtView); Chaskar Hemant (NRC/Boston)
Cc: [email-masked]
Subject: RE: [NSIS] QoS framework.

Hi Cedric and Hemant

[Hemant] Thanks for reading the draft and subsequent comments. I am inclined to diagree with your assessment that the draft has specific (too much!) orientation towards Seamoby or Mobile IP. The only place where I see some connection to Seamoby is the proposal to use CIN message for MN-AR signaling. But, we can always substitute it with NSIS message (as we have been discussing on the NSIS list for past few days). Beyond that, there isn't much, if any, orientation towards Seamoby or MobileIP. I think that the draft is in good agreement with NSIS framework document.

[Hemant] IMHO, draft-hancock is a very high level view at the framework issues (which is invaluable anyway). Proceeding to solution may require much deeper look at individual signaling tools optimized to specific use cases. Thus, the intent of draft-westphal was to present a framework for specific use case of layer 3 handoff. It can serve as intermediary between high level framework and specific solution for layer 3 handoff case. 

[Hemant] As we move along with discussions and revisions, I can foresee this draft becoming a solution draft for layer 3 handoff case in the future.

[Hemant] I agree with you on this.

Best Regards,
Georgios

[Hemant] Thanks, Hemant

-----Original Message-----
From: Cedric Westphal [mailto:[email-masked]]
Sent: Monday, June 24, 2002 7:47 PM
To: [email-masked]
Cc: [email-masked]
Subject: [NSIS] QoS framework.

Hi all,

Here is the abstract:

Abstract

Cedric & Hemant.

---

From: "Hancock, Robert" <[email-masked]>
Date: Tue, 9 Jul 2002 08:35:13 +0100

Hi Hemant,

I think it's clear that a higher level view of these issues is helpful as a prelude to discussion of particular potential protocols.

What I'd really like to do is work out a clear boundary between CT and NSIS considered as black boxes, to see how they can support (or conversely work without) each other. Then we (in NSIS) could abstract that interaction into a requirement for more generic NSIS capability and reflect it in the framework, so it should be useful whatever specific protocol(s) NSIS was being used with.

Unfortunately, I have difficulty working out the details of this boundary from pure requirements documents and have to try to reverse engineer it from protocols; hence my 'confusion' about things like whether CIN is a CT message or a proposed part of the NSIS solution.

Any comments you could make on our (nb individual submission) framework draft  would be helpful insights in this direction. In particular, I can imagine options as to whether:
a) CT is used to transfer resource specific information (e.g. QoS) and then trigger NSIS to re-establish it in the network (and over the air if necessary), or
b) CT is used to transfer protocol state (e.g. NSIS and whatever state information it is maintaining), and then let the protocol do its worst, or
c) CT can be used to transfer anything.
There are probably similar questions about CARD, but I haven't looked at it so closely. Actually, CARD seems to bring in questions about pre-authorisation and negotiation (maybe along the rest of the data path), so it's probably a much much harder issue. Oh dear...

Cheers,

Robert H.

PS I guess these questions could be aimed at the wider seamoby community as well as NSIS; however, I'm posing it first at you and Cedric as people who are clearly interested in both.

> From: [email-masked] [mailto:[email-masked]]
> Sent: 08 July 2002 16:09
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> [Hemant] Thanks for reading the draft and subsequent 
> comments. I am inclined to diagree with your assessment that 
> the draft has specific (too much!) orientation towards 
> Seamoby or Mobile IP. The only place where I see some 
> connection to Seamoby is the proposal to use CIN message for 
> MN-AR signaling. But, we can always substitute it with NSIS 
> message (as we have been discussing on the NSIS list for past 
> few days). Beyond that, there isn't much, if any, orientation 
> towards Seamoby or MobileIP. I think that the draft is in 
> good agreement with NSIS framework document.
> 
> [Hemant] IMHO, draft-hancock is a very high level view at the 
> framework issues (which is invaluable anyway). Proceeding to 
> solution may require much deeper look at individual signaling 
> tools optimized to specific use cases. Thus, the intent of 
> draft-westphal was to present a framework for specific use 
> case of layer 3 handoff. It can serve as intermediary between 
> high level framework and specific solution for layer 3 handoff case. 
> 
> [Hemant] As we move along with discussions and revisions, I 
> can foresee this draft becoming a solution draft for layer 3 
> handoff case in the future.
> 
in the meantime.

Cedric & Hemant.

========================================================================================
Permission is hereby granted to pass the contents of this communication to third parties and any restrictions regarding confidentiality do not apply.

---

From: [email-masked]
Date: Tue, 9 Jul 2002 11:51:31 -0400

Hi,

A picture is worth thousand words :-). What do you think about the following picture as a depiction of CT-NSIS relationship, with the side note that both of these models MUST be possible. 

Legend: ----  NSIS signaling     ---  CT        
        ----

1. No CT-NSIS interaction

          ^           ^
          ||         ||
          ||         ||
        Old AR     New AR
          ||         ||
    MN(Initiator) MN (Initiator)

2. CT as optimization for NSIS: Here CT merely empowers new AR to be NSIS message initiator on behalf of arriving MN.

           ^           ^
          ||          ||
          ||    CT    ||
        Old AR---->New AR (Initiator)
          ||          
    MN (Initiator)    MN

(Here, CT is merely transfering QoS description at old AR to new AR and new AR initiates NSIS signaling using this description. But, what if new path can support better or worse QoS than the old one? Then, NSIS should adapt while MN is connected to new AR.)  

Hemant

-----Original Message-----
From: ext Hancock, Robert [mailto:[email-masked]]
Sent: 09. July 2002 3:35
To: Chaskar Hemant (NRC/Boston); Weshphal Cedric (IPRG/MtView)
Cc: [email-masked]
Subject: RE: [NSIS] QoS framework.

Hi Hemant,

Cheers,

Robert H.

in the meantime.

Cedric & Hemant.