Subject: RE: [NSIS] commentson on draft-ietf-nsis-req-03.txt

From: [email-masked]
Date: Thu, 11 Jul 2002 09:25:46 +0300

Hi All,

First off, I would say that the requirements MUST be restricted
to on-path signaling, as this is all we are chartered to do.  If
we try to do more, we will hear about it during last call.

Second, I think the framework draft & the analysis draft can
contain issues related to off-path signaling.

> how precisely does the body of the requirements text have to 
> track the w.g. charter? if the charter were (hypothetically) 
> to be extended at a later date to include (just as an 
> example) off path signalling, would we want to update the 
> requirements RFC just to reflect that?

Procedurally, it should be a seperate document.  I think we should
restrict the requirements to on-path signaling, as this is what
the WG is charted for.  If we try to do more, the ADs will most
likely ask us to remove the material that is out of scope 
during last call time. 
 
> a suggestion:
> 
> what about adding a section near the start explaining that 
> any subsequent work we do is constrained by these 
> requirements and the current charter, and then in particular 
> explaining the initial restriction to on-path signalling and 
> the reasoning behind it. i would have thought we could leave 
> the rest of the document as it is.

Well, this is implicit in the IETF process. However, howabout 
something like a note saying that off-path signaling is important,
there is interest in it, but it is out of scope of the
requirements document.
 
> [Note: such a section could also define just what the on-path 
> restriction actually was. I've seen at least 4 different 
> incompatible views on that.]

Want to provide a summary of the 4 views?

John

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Marcus Brunner <[email-masked]>
Date: Thu, 11 Jul 2002 16:02:01 +0200

> Want to provide a summary of the 4 views?

Ok, I give it a try

1) exclusive on path
The NSIS initiator and NSIS receiver are the data receiver and sender

2) proxy on path
The NSIS initiator is some where on the data path but not at the sending 
nor receiving side (only part of the data path is covered by signaling)

3) IP-hop-by-IP-hop
The signaling message travels IP-hop-by-IP-hop. Where the hops are chosen 
by  the destination addr

4) NSIS-hop-by-NSIS-hop
The signaling message follows NSIS hops, where intermediate IP hops are not 
visited. The NSIS hop has to choose the next hop, here the data path migh 
follow a different path for a shsort segment.

5) in advance reservation in hand-over cases
If a new access router has been chosen, where a mobile will newly connect 
to and a reservation should be done in advance, the data flows still on the 
old path. At the point in time data is flowing along the new path (after 
handoff) the reservation has already been setup.

Marcus
--------------------------------------
Dr. Marcus Brunner
Network Laboratories
NEC Europe Ltd.

E-Mail: [email-masked]
WWW:    http://www.ccrle.nec.de/
personal home page: http://www.brubers.org/marcus