Subject: RE: [Seamoby] RE: what is edge signalling? (was: RE: [NSIS] Re: C omments on draft-westphal-nsis-qos-mobileip-00.txt)

From: "Gary Kenward" <[email-masked]>
Date: Fri, 5 Jul 2002 13:16:49 -0400

Charlie:

(I am cross posting this to NSIS to correct the misconception that
I generated concerning the wg requirements. This will be my last
cross post).

> -----Original Message-----
> From: Charlie Perkins [mailto:[email-masked]]
> Sent: July 5, 2002 12:37
> To: Kenward, Gary [WDLN2:AN10:EXCH]
> Cc: [email-masked]; Seamless Mobility Working Group
> Subject: Re: [Seamoby] RE: what is edge signalling? (was: RE: 
> [NSIS] Re:
> Comments on draft-westphal-nsis-qos-mobileip-00.txt)
> 
> 
> 
> Hello Gary,
> 
> I was startled by a statement in your message:

I didn't mean to startle you, honest...

> 
> Gary Kenward wrote:
> 
> > Indeed, if you examine the CT requirements,
> > signalling from the MN to the access network is prohibited.
> 
> What if the mobile node wants to tell the access network
> that it's time to do a context transfer?  Surely that's not
> prohibited.  If so, then this is a major problem with the
> requirements draft and I just missed it.

Well, can you elaborate on the "what if"? There has to be a purpose,
and the situations that I can imagine the MN might want to perform
such an action can be covered (better, IMHO) within the network
(or between networks).

I was incorrect concerning the wg requirements draft. There was a
requirement in the draft at one time. It was removed simply because
the controversy could not be resolved during requirements definition.
I appologize for the confusion.

However, there seems to be a growing belief, particularly within
NSIS, that CT is MN centric. While I must concede that this option
meets the requirements, it is by no means the best approach (IMHO),
and at the very least, is not the wg consensus (at least, so far) and
should not be represented as such. My main purpose of posting to the
NSIS working group was to clarify this misconception, which was leading
to further misconceptions of the relationship between CT and NSIS as 
bearer path signalling solutions.

> 
> Besides that:
> 
> > In your discussion of CT, you are presupposing a wg solution
> > for CT that does not exist. The work on the CT protocol has 
> not begun
> > in Seamoby.
> 
> That's a pretty strong statement.  We've done a lot of
> work on a CT protocol, and we have tried to represent
> that work in the [seamoby] group.  Maybe you meant
> that there isn't yet a working group document that
> specifies any CT protocol.

That is what I meant, of course. There are a number of us that have 
been working on CT solutions, some of us are waiting for the proper 
opportunity to submit drafts to the wg for consideration as wg solutions 
It is my understanding that these drafts cannot be considered until the 
requirements draft is approved, or, perhaps, until the wg chairs say so 
(I don't know which is the gating function).

> 
> 
> > The
> > reason being is that the sole purpose of CT is to enable a fast,
> > smooth,
> > seamless handover. Signalling over the air simply takes too 
> much time,
> >
> > and the value of signalling from MN to AR has never been clearly
> > identified.
> 
> If the mobile node is the only node that "knows" that
> it's time to do the handover, then it has to use a few
> bits to deliver the indication to one of the access routers.

I am curious as to how the mobile node can be the only node that
"knows". Since in order for an MN to "know" that there is a network
to handover to, communications with the network must be possible, 
which means that the AP at the new network has to "know", *and*
the MN has to know that the AP knows and visa versa. It is not
a big step to assume that if the AP knows, the AR knows (this is
the case for cellular networks).

In addition, in order to complete a "seamless" handover between
networks, the networks must have a trust relationship, and must be
able to exchange information on accounting etc. Thus, there must
be a communications path between the networks, at the very least.

IEEE 802.11 APs currently do not support handover, but this is
situation is being changed with a new standard for inter-AP signalling.

Cheers,
Gary

> Regards,
> Charlie P.

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Charlie Perkins <[email-masked]>
Date: Fri, 05 Jul 2002 10:44:10 -0700

Hello Gary,

> such an action can be covered (better, IMHO) within the network

Suppose the mobile node hears an advertisement
from a new access router, and wants to ask its
old access router to transfer some context.  That
is something we should allow.

> the case for cellular networks).

It is a big step.  What about my example above?
The handover could be between different physical
media.  IP provides a nice communications path,
but it may not be profitable to spend a lot of time
trying to define "the network" in this case.

Regards,
Charlie P.