Subject: RE: [NSIS] additional comment on draft-ietf-nsis-req-03.txt

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Thu, 11 Jul 2002 11:38:04 +0200

Hi Robert

What I proposed is related to modularity and is similar to
the concept described in draft-braden-2level-signal-arch-00.txt
and in Section 5.5 in draft-hancock-nsis-fw-00, also draft-westberg-nsis-edge-edge-framework-00.

The concept in all these drafts is the same, namely, separate the protocol functionality 
in more than one layers.
In draft-braden-2level-signal-arch-00.txt this separation is done in two layers
were the functionality is split between transport and application functionality. 
In Section 5.5 in draft-hancock-nsis-fw-00 and also draft-westberg-nsis-edge-edge-framework-00 
the protocol functionality is split in three layers. 

Therefore, I think that the proposed bullet is relevant and its right place is the 
modularity section.

Best Regards,
Georgios

-----Original Message-----
From: Hancock, Robert [mailto:[email-masked]]
Sent: Thursday, July 11, 2002 1:04 AM
To: [email-masked]; Georgios Karagiannis (ELN);
[email-masked]'; [email-masked]
Subject: RE: [NSIS] additional comment on draft-ietf-nsis-req-03.txt

hi,

i'm slightly baffled by this.

i was taking a wild guess that georgios was referring to nsis-triggering-nsis scenarios (e.g. 5.5 in draft-hancock-nsis-fw-00, also draft-westberg-nsis-edge-edge-framework-00). if that's the case, isn't it covered by 5.3.6? [actually, i'm not certain that this turns into a feature visible in the protocol, it could be just a way of using the protocol; but we'll discover that during the framework.]

if georgios is referring to transport/application layering as in draft-braden-2level-signal-arch-00.txt then isn't this covered by 5.1.4 (although we should probably refer to something more general than QoS...). i certainly don't like the term 'hierarchical' for this.

georgios, what is your concern?

robert

> -----Original Message-----
> From: Marcus Brunner [mailto:[email-masked]]
> Sent: 10 July 2002 17:09
> To: Georgios Karagiannis (ELN); [email-masked]'; 
> [email-masked]
> Subject: RE: [NSIS] additional comment on draft-ietf-nsis-req-03.txt
> 
> 
> John is right I aslo don't like multi-level XXX difficult to 
> understand. I 
> regard modularity as the right word in the title, but I will 
> go over the 
> text such that in really includes what Georgios means.
> 
> Marcus
> 
> --On Mittwoch, 10. Juli 2002 17:46 +0200 "Georgios Karagiannis (ELN)" 
> <[email-masked]> wrote:
> 
> > Hi John
> >
> > What about muliu level signaling?
> >
> > best regards,
> > Georgios
> >
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Wednesday, July 10, 2002 5:45 PM
> > To: [email-masked]; [email-masked];
> > [email-masked]
> > Subject: RE: [NSIS] additional comment on draft-ietf-nsis-req-03.txt
> >
> >
> > Hi Marcus,
> >
> >> Ok, I agree I will do some polishing of this for -04
> >> Marcus
> >>
> >> --On Mittwoch, 10. Juli 2002 15:58 +0200 "Georgios 
> Karagiannis (ELN)"
> >> <[email-masked]> wrote:
> >>
> >> > Hi Marcus
> >> >
> >> > The hierarchical levels are refering to protocol
> >> functionality levels.
> >> > A similar concept is presented in
> >> draft-braden-2level-signal-arch-00.txt
> >> > where two levels of protocol functionality are defined.
> >
> > I think this is OK, however I don't like the term 'hierarchical'
> > in this case.
> >
> > John
> >
> > _______________________________________________
> > nsis mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/nsis
> 
> 
> 
> --------------------------------------
> Dr. Marcus Brunner
> Network Laboratories
> NEC Europe Ltd.
> 
> E-Mail: [email-masked]
> WWW:    http://www.ccrle.nec.de/
> personal home page: http://www.brubers.org/marcus
========================================================================================
Permission is hereby granted to pass the contents of this communication to third parties and any restrictions regarding confidentiality do not apply.

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Marcus Brunner <[email-masked]>
Date: Thu, 11 Jul 2002 12:00:23 +0200

Georgios,

Do you think we need more than two layers. If you say hierarchical do you 
mean N layers?

Marcus

--On Donnerstag, 11. Juli 2002 11:38 +0200 "Georgios Karagiannis (ELN)" 
<[email-masked]> wrote:

> and in Section 5.5 in draft-hancock-nsis-fw-00, also
> draft-westberg-nsis-edge-edge-framework-00.
>
> The concept in all these drafts is the same, namely, separate the
> protocol functionality  in more than one layers.
> In draft-braden-2level-signal-arch-00.txt this separation is done in two
> layers were the functionality is split between transport and application
> functionality.  In Section 5.5 in draft-hancock-nsis-fw-00 and also
> draft-westberg-nsis-edge-edge-framework-00  the protocol functionality is
> split in three layers.
>
> Therefore, I think that the proposed bullet is relevant and its right
> place is the  modularity section.
>
> Best Regards,
> Georgios
>
>
> i was taking a wild guess that georgios was referring to
> nsis-triggering-nsis scenarios (e.g. 5.5 in draft-hancock-nsis-fw-00,
> also draft-westberg-nsis-edge-edge-framework-00). if that's the case,
> isn't it covered by 5.3.6? [actually, i'm not certain that this turns
> into a feature visible in the protocol, it could be just a way of using
> the protocol; but we'll discover that during the framework.]
>
> if georgios is referring to transport/application layering as in
> draft-braden-2level-signal-arch-00.txt then isn't this covered by 5.1.4
> (although we should probably refer to something more general than
> QoS...). i certainly don't like the term 'hierarchical' for this.
>
> =========================================================================
> =============== Permission is hereby granted to pass the contents of this
> communication to third parties and any restrictions regarding
> confidentiality do not apply.