Subject: RE: what is edge signalling? (was: RE: [NSIS] Re: Comments on dra ft-westphal-nsis-qos-mobileip-00.txt)

From: "Hancock, Robert" <[email-masked]>
Date: Fri, 5 Jul 2002 10:34:48 +0100

Hi all,

I don't think there's any disagreement that CT is a tool that NSIS could use (as an optimisation).

What's entirely unclear to me is what sort of tool CT is: is it a hammer or a screwdriver or a combination of the two? I guess this is more a question for the seamoby people, but we need to know the answer to know how to use it.

More formally, there seem to be two extremes:

a) NSIS is used for MN-AR resource (QoS) signalling, and AR-rest of world signalling; CT can be used to transfer state (both resource state and NSIS protocol state) between ARs at handover, but if this involves any MN-AR messages (e.g. CTIN) they aren't QoS related. NSIS-CT interaction can occur at the ARs to do state transfer at handover time.

b) CT messages (e.g. CIN) can be used by the MN to set up QoS context in the AR, which it can then later transfer to a new AR. NSIS is used to signal QoS for AR-rest of network. NSIS-CT interaction takes place at the AR to interwork flow setup and resource descriptions, and this interaction takes place at flow setup time. (Essentially, CT provides a QoS signalling protocol for the edge of the network, which NSIS would have to interwork with, in the same way that it has to interwork with RSVP/Intserv.)

our framework draft-hancock-nsis-fw-00.txt basically assumes (a).
this draft-westphal-nsis-qos-mobileip-00.txt basically assumes (b) so far as I can tell.

I'm not trying to argue which of (a) or (b) is 'correct' at this stage, just establish that they are not the same. (And so we probably have to make a choice, although I suppose you could allow both models...)

Cheers,

Robert H.

> -----Original Message-----
> From: Marcus Brunner [mailto:[email-masked]]
> Sent: 05 July 2002 10:05
> To: [email-masked]; Hancock, Robert; [email-masked];
> [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: what is edge signalling? (was: RE: [NSIS] Re: Comments on
> draft-westphal-nsis-qos-mobileip-00.txt)
> 
> 
> I see CT as an optimization only and not required for NSIS. 
> However, since 
> there is a tendency to support only on-path signaling, this 
> would not work 
> anyway (because CT would need off-path signaling for at least 
> some time).
> 
> Marcus
> 
> --On Donnerstag, 4. Juli 2002 11:33 +0300 
> [email-masked] wrote:
> 
> > Hi Robert,
> >
> >> On the 'edge signalling' case, I guess the main point is that
> >> I'm confused about the scope of seamoby CT. Specifically
> >> regarding MN-AR signalling (no issue about the AR-AR part):
> >
> > From my viewpoint, CT is not required for NSIS. I view CT as
> > one tool that an NSIS solution could use.  So, I definately think
> > that at some point, we will need some sort of applicability
> > statement describing how to use CT for NSIS.
> >
> > John
> >
> > _______________________________________________
> > nsis mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/nsis
> 
> 
> 
> --------------------------------------
> Dr. Marcus Brunner
> Network Laboratories
> NEC Europe Ltd.
> 
> E-Mail: [email-masked]
> WWW:    http://www.ccrle.nec.de/
> personal home page: http://www.brubers.org/marcus
> 
> 
========================================================================================
Permission is hereby granted to pass the contents of this communication to third parties and any restrictions regarding confidentiality do not apply.

---

From: Marcus Brunner <[email-masked]>
Date: Fri, 05 Jul 2002 12:22:21 +0200

Actually, I have so far assumed (a) as well. And I like (a) because NSIS is 
not influenced by CT.

Marcus

--On Freitag, 5. Juli 2002 10:34 +0100 "Hancock, Robert" 
<[email-masked]> wrote:

> What's entirely unclear to me is what sort of tool CT is: is it a hammer
> or a screwdriver or a combination of the two? I guess this is more a
> question for the seamoby people, but we need to know the answer to know
> how to use it.
>
> a) NSIS is used for MN-AR resource (QoS) signalling, and AR-rest of world
> signalling; CT can be used to transfer state (both resource state and
> NSIS protocol state) between ARs at handover, but if this involves any
> MN-AR messages (e.g. CTIN) they aren't QoS related. NSIS-CT interaction
> can occur at the ARs to do state transfer at handover time.
>
> b) CT messages (e.g. CIN) can be used by the MN to set up QoS context in
> the AR, which it can then later transfer to a new AR. NSIS is used to
> signal QoS for AR-rest of network. NSIS-CT interaction takes place at the
> AR to interwork flow setup and resource descriptions, and this
> interaction takes place at flow setup time. (Essentially, CT provides a
> QoS signalling protocol for the edge of the network, which NSIS would
> have to interwork with, in the same way that it has to interwork with
> RSVP/Intserv.)
>
> I'm not trying to argue which of (a) or (b) is 'correct' at this stage,
> just establish that they are not the same. (And so we probably have to
> make a choice, although I suppose you could allow both models...)
>
> Cheers,
>
> Robert H.
>
> =========================================================================
> =============== Permission is hereby granted to pass the contents of this
> communication to third parties and any restrictions regarding
> confidentiality do not apply.