Subject: RE: [NSIS] new drafts

From: [email-masked]
Date: Tue, 29 Oct 2002 21:58:43 +0200

Hi Hannes,

> i have submitted a few new drafts (draft updates).
> 
> in case you want to read them now please look at the links 
> provided below:
> 
> RSVP Security Properties 
> http://www.ersue.de/nsis/draft-ietf-nsis-rsvp-sec-properties-00.txt
> 
> NSIS Threats 
> http://www.ersue.de/nsis/draft-ietf-nsis-threats-00.txt
> 
> A Firewall/NAT Traversal Client for CASP
> http://www.ersue.de/nsis/draft-tschofenig-nsis-casp-midcom-00.txt
> http://www.ersue.de/nsis/draft-tschofenig-nsis-casp-midcom-00.pdf
> 
> please send me comments if you have some.

It would be helpful if you could send a list of what has changes (for
updated documents) and list of open issues to discuss on all of the
drafts.

Thanks!
John
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Melinda Shore <[email-masked]>
Date: Tue, 29 Oct 2002 15:20:48 -0500

> updated documents) and list of open issues to discuss on all of the

Not all of them, I hope.  I apologize for continuing to harp
on this but CASP is *not* the NSIS protocol.  It's being
marketed a little too enthusiastically, and frankly I find
it rather off-putting.  Let's save CASP for consideration
*after* we have agreed-upon requirements and framework
documents (and let's not tailor the framework and
requirements to CASP, either).

Melinda

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Wed, 30 Oct 2002 08:57:56 +0100

hi john!

thanks for mentioning the open issues in the nsis threat draft.

i was asked to whether a separation between the transport and the
application part should be made. currently the nsis threat document is
focused on the application layer part and not on transport issues. i can add
an additional threat covering this issue.
two examples:
- an adversary would modify ip headers of the signaling messages (if ip used
used for message transport)
- in case of a transport protocol: an adversary could terminate an
established tcp connection.
however these threats are not special for nsis signaling protocols.

an important issue i see is that some people have no opinion on particular
security issues.
for example:
- is non-repudiation necessary/required or not important at all.
- how important is a threat caused by a malicious nsis entity?
- is network topology hiding a desired property?
- what about signaling message confidentiality?
- do we worry about the reservation (or session) ownership problem?
- etc.

if someone is aware of additional threats currently not mentioned in the
draft please let me know.

in the next version i try to classify some threats as deployment threats
(for example cost control)
i also saw an issue about sending errors/notifications directly from an
intermediate node to the source. this would also be a deployment threat
since it will be quite difficult to have the security associations in place.

ciao
hannes

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, October 29, 2002 8:59 PM
> To: [email-masked]; [email-masked]
> Subject: RE: [NSIS] new drafts
>
-- snip - snip --