Subject: RE: [NSIS] framework discussion

From: "Hancock, Robert" <[email-masked]>
Date: Mon, 21 Oct 2002 22:01:48 +0100

hi melinda,

[snip]
> > [sven] I think there would be merit in having a
> > separate discovery phase (which does not have to be
> > per-flow). 
> 
> [melinda] This working group is very focused on QoS.  There are other
> applications for which the protocol will be used, and for
> some of those protocols topology is an important issue (if
> not the defining issue).  Examples include firewall/NAT
> traversal and tunnel endpoint discovery/communication.
> Indeed, any NSIS protocol which is expected to be able to
> talk to NATs and traverse them intelligently is going to
> have to concern itself with topology.  Accretion of
> topological information and returning it to the NSIS
> initiator to sort through and build appropriate messages
> is not going to be as effective, I would argue, as the
> current RSVP model where each node has information about
> adjacent hops and the message's success is not dependent on
> someone having knowledge of the entire end-to-end path.  At
> a very minimum it's going to need adjacent hope information,
> anyway.
> 
> Melinda
> 

[robert] actually, i'm not clear that there's any disagreement here.

as i understand it, all discussions involving the term 'discovery' are about peer (next-NSIS-hop) discovery, not complete-path-discovery - i.e. essentially the same as what the RSVP PATH mechanism does. i've certainly never seen an explicit suggestion that all this information should get sent back to the NI.

have i been deluding myself?

cheers,

robert h.

========================================================================================
Permission is hereby granted to pass the contents of this communication to third parties and any restrictions regarding confidentiality do not apply.

---

From: "Marcus Brunner" <[email-masked]>
Date: Sun, 27 Oct 2002 17:40:15 +0100

[...]
> as i understand it, all discussions involving the term 'discovery' are about
peer (next-NSIS-hop) discovery, not complete-path-discovery - i.e. essentially
the same as what the RSVP PATH mechanism does. i've certainly never seen an
explicit suggestion that all this information should get sent back to the NI.

I think the disagreement is whether we only use IP routing tables/forwarding
table to find the next hop, or whether there are other mechnisms allowed. Other
mechnisms naturally need another type of topology discovery. For IP address
based nesxt hop discovery we have the mechnisms already in place.

Marcus

> have i been deluding myself?
================================================================================
========
> Permission is hereby granted to pass the contents of this communication to
third parties and any restrictions regarding confidentiality do not apply.
-------
Marcus Brunner
Network Labs
NEC Europe Ltd
Heidelberg, Germany

E-Mail: [email-masked]
WWW: www.brubers.org/marcus
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis