Subject: RE: [NSIS] on-path versus off-path discussion

From: [email-masked]
Date: Fri, 18 Oct 2002 14:46:28 +0300

Hi Roland,

> Oops, this is third-party/proxy signaling in my understanding.

Yes, the ADs don't like 3rd party signaling.  If there is a
proxy somewhere, it should be on the (rough) data path.  My
feeling is that they don't want us to work on discovery.  Discovery
should come automatically, due to the signaling.

> What is A and B? sender, receiver?
> Although the above example may be simple, I thought on-path means
> that the signaling messages follow the same path (forward or reverse)
> router-hop by router-hop as the data of the corresponding flow 
> (which the signaling is about). 
> So obviously the notion "on-path" is interpreted differently 
> and we need a 
> clear definition (maybe from A-Ds) _what_ they don't want to 
> see in NSIS and why (or did I miss a statement on the list).

Here you go!
John

------- Forwarded Message

Date:    Thu, 16 May 2002 08:58:44 -0400
From:    Scott Bradner <[email-masked]>
To:      [email-masked]

my take on what NSIS should be working on now is:

signaling from an end system that follows a path through the net that is
determined by the normal L3 routing and is used to convey
per-flow information to the devices the signals pass through - the
signaling can install soft state (maintained by repetition) in the devices
it passes through

an end system could be a device along the path that signals for  a data
flow that passes through it  

there is no requirement that the per-flow information be QoS related i.e.
NSIS should only worry about how to do the signaling - what the  signaling
conveys should be opaque to NSIS

this rules out bandwidth brokers, 3rd party QoS controllers, hard state,
etc

after they do this, NSIS could move on to other things (like BBs)
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Roland Bless <[email-masked]>
Date: Fri, 18 Oct 2002 14:15:16 +0200

> should come automatically, due to the signaling.

While I know that discovery may be an issue that may need
a lot of discussion and work:
Resolving hostnames is also an essential service and needs
automatic or static configuration of DNS server's addresses.
Is thus DNS broken?

I also had the consensus in mind that we concentrate on on-path
while not excluding off-path completely.

> > see in NSIS and why (or did I miss a statement on the list).

Ok, I knew that mail, but I thought after the interim-meeting
the should be an additional clarification...

Regards,
 Roland

-- 
Roland Bless -- e-Mail: [email-masked]
Institute of Telematics, University of Karlsruhe, Germany  
Zirkel 2, D-76128 Karlsruhe -- Office: Bld. 20.20, 3rd floor, R 358
Phone: +49 721 608-6413 Fax: +49 721 388097