Subject: [NSIS] new framework (was: RE: I-D ACTION:draft-ietf-nsis-fw-00.txt)

From: "Hancock, Robert" <[email-masked]>
Date: Tue, 15 Oct 2002 14:36:38 +0100

Hi all,

I'd like to highlight the existence of this draft to the wg, in the hope of stimulating some discussion before Atlanta.

It's an updated (mainly structurally re-arranged) version of our framework document discussed in Yokohama. It contains just as many open issues and discussion points as then, but the terminology has been cleaned up and the open issues highlighted in their own special section.

I am aware of printouts of earlier framework versions, covered with comments and questions and objections ... maybe some of these could see daylight at last ...

If people want to pick on one of the open issues to start off with, I would highlight the question of the function split between the 'basic' NSIS protocol, and the signalling applications which operate somehow above it. There may be lessons for the framework coming out of some of the protocol proposals which have been made recently. Obviously, all the other open issues are just as open to comment as well.

If there is rapid progress, we could even imagine an update before Atlanta.

Cheers,

Robert Hancock (ed)

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: 04 October 2002 12:29
> Cc: [email-masked]
> Subject: I-D ACTION:draft-ietf-nsis-fw-00.txt
> 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> This draft is a work item of the Next Steps in Signaling 
> Working Group of the IETF.
> 
> 	Title		: Next Steps in Signaling: Framework
> 	Author(s)	: I. Freytsis et al.
> 	Filename	: draft-ietf-nsis-fw-00.txt
> 	Pages		: 49
> 	Date		: 2002-10-3
> 	
> The NSIS working group is considering protocols for signaling for 
> resources for a traffic flow along its path in the network. The 
> requirements for such signaling are being developed in [2]; this 
> Internet Draft will propose a framework for such signaling. 
> This initial version provides a model of the entities that take part 
> in the signaling. It discusses the considerations that must be taken 
> into account in developing the framework, particularly the 
> structural  
> options for the structure of such a protocol, and the interactions 
> between NSIS and other protocols and functions, including security 
> issues. Finally, it includes background material on how NSIS could 
> support particular signaling applications. 
> It is expected that future versions of this document will distill 
> these structural options into a concrete technical framework, and 
> material on particular signaling applications and deployment 
> scenarios will be moved into separate NSIS applicability statements.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-nsis-fw-00.txt
> 
> To remove yourself from the IETF Announcement list, send a message to 
> ietf-announce-request with the word unsubscribe in the body 
> of the message.
> 
> Internet-Drafts are also available by anonymous FTP. Login 
> with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-ietf-nsis-fw-00.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-nsis-fw-00.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
========================================================================================
Permission is hereby granted to pass the contents of this communication to third parties and any restrictions regarding confidentiality do not apply.

---

From: [email-masked]
Date: Tue, 15 Oct 2002 19:51:04 +0300

Hi All,

I would second Robert's request.  Remember that if you
point to specific text & submit text to replace it,
you stand a better chance of effecting things ...

thanks,
John

> From: ext Hancock, Robert [mailto:[email-masked]]
> Sent: 15 October, 2002 16:37
> To: [email-masked]
> Subject: [NSIS] new framework (was: RE: I-D
> ACTION:draft-ietf-nsis-fw-00.txt)
> 
> 
> Hi all,
> 
> I'd like to highlight the existence of this draft to the wg, 
> in the hope of stimulating some discussion before Atlanta.
> 
> It's an updated (mainly structurally re-arranged) version of 
> our framework document discussed in Yokohama. It contains 
> just as many open issues and discussion points as then, but 
> the terminology has been cleaned up and the open issues 
> highlighted in their own special section.
> 
> I am aware of printouts of earlier framework versions, 
> covered with comments and questions and objections ... maybe 
> some of these could see daylight at last ...
> 
> If people want to pick on one of the open issues to start off 
> with, I would highlight the question of the function split 
> between the 'basic' NSIS protocol, and the signalling 
> applications which operate somehow above it. There may be 
> lessons for the framework coming out of some of the protocol 
> proposals which have been made recently. Obviously, all the 
> other open issues are just as open to comment as well.
> 
> Permission is hereby granted to pass the contents of this 
> communication to third parties and any restrictions regarding 
> confidentiality do not apply.
> 
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis