Subject: terminology: "peer" or "neighbo[u]r"? (was: RE: [NSIS] framework discussion)

From: "Hancock, Robert" <[email-masked]>
Date: Thu, 24 Oct 2002 23:01:46 +0100

hi all,

The framework currently uses the term 'peer' to refer to an NSIS entity that is communicating directly with another NSIS entity. There is some desire to use the term 'neighbour' (or 'neighbor') instead.

I'm not wedded to any particular terminology (although my suggestion to drop the term 'session' has so far met only with shocked silence).

I think the term 'peer' is pretty widely used in IETF discussions (diameter, ntp, ldp, l2tp, ppp, bgp, beep, ike, ...) and emphasises that NSIS is not about client server architectures; also, 'neighbour' (to me) has a strong connotation of 'on the same link as' or generally 'topologically close to'.

However, if the term 'peer' is causing obscurity/confusion, I can change it. (nearly the simplest change for an editor to make, after all.)

views?

robert h.

> -----Original Message-----
> From: Bob Braden [mailto:[email-masked]]
> Sent: 24 October 2002 17:51
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [NSIS] framework discussion
> 
> 
>   *> 
>   *> > [Sven] I have the same understanding as you have (just 
> peer discovery, not
>   *> > path/NI discovery). If this resolves the issue that 
> would be great.
>   *> 
>   *> Routing problems tend to be very difficult, and in the
>   *> context of this protocol I'm unclear on what it means to
>   *> talk about peer discovery without also talking about path
>   *> discovery.  Peer relationships *by themselves* really aren't
>   *> very meaningful.
>   *> 
>   *> Melinda
> 
> Melinda,
> 
> Hmmm. I believe that Sven was using the term "peer" for what we
> in the Internet world customarily call a "neighbor".  Neighbor
> discovery is pretty fundamental to many routing protocols, right?  And
> I believe it will be fundamental to a signaling protocol.  (See my
> earlier message about "session").  Perhaps we are talking about
> different things here, or am I just misunderstanding?
> 
> Bob Braden
> 
>   *> _______________________________________________
>   *> nsis mailing list
>   *> [email-masked]
>   *> https://www1.ietf.org/mailman/listinfo/nsis
>   *> 
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Melinda Shore <[email-masked]>
Date: Fri, 25 Oct 2002 08:54:30 -0400

> I'm not wedded to any particular terminology (although my
> suggestion to drop the term 'session' has so far met only
> with shocked silence).

I find the word "session" a little misleading when used to
describe traffic that's simply in transit.  It may be
applicable for a CASP-type protocol but not for an RSVP-
type protocol.

> However, if the term 'peer' is causing
> obscurity/confusion, I can change it. (nearly the simplest
> change for an editor to make, after all.)

I'm not that fond of "peer," but I think that its use in
this context could be explained fairly easily (while it
would take some contortions to explain the use of the word
"session," as above).  "Neighbor" is easily understood in
the context of the NSIS layer and might become confusing
*only* if you have trouble keeping your layers straight
(however, of course, people involved with the IETF never
have trouble keeping their layers sorted out, right? :-)).

Melinda