Subject: RE: [NSIS] on-path versus off-path discussion

From: "Hancock, Robert" <[email-masked]>
Date: Sun, 20 Oct 2002 00:18:10 +0100

Hi Bob,

[snip]
> RSVP established a meaning for "path".  I fail to see why NSIS should
> try to (re-)invent terminology.  
[reh] I don't think NSIS is trying to invent a new definition.

> 
>   *> what the *nsis* w.g. needs to be clear about (as melinda 
> has pointed out) is what definition we agree on, and then 
> (implicitly) what is currently in or out of NSIS scope. (i 
> guess this would also be useful input to discussing the scope 
> of any complementary or additional activity.)
>   *> 
>   *> a proposed definition is on the table in 3.2.1 of 
> draft-ietf-nsis-fw-00.txt ("path coupled/decoupled"). as a 
> teaser, this definition would classify both RSVP PATH and 
> RESV messages as path coupled, and therefore legitimately in 
> NSIS scope (even though the latter uses what we call 
> peer-session and not end-to-end addressing).
> 
> I believe that your term has the same meaning as the term I already
> introduced in my 2-level signaling I-D, "path-directed [signaling]".
> Again, why should we have to keep re-inventing terminology?

[reh] there is no intended difference, just an attempt to pin down some of the corner cases which some people were unclear about. (the only reason for using 'path-coupled' is that 'path-decoupled' sounds OK as a term for the opposite, which we also needed.) 
> Bob Braden

cheers,

robert h.

========================================================================================
Permission is hereby granted to pass the contents of this communication to third parties and any restrictions regarding confidentiality do not apply.

---

From: Ping Pan <[email-masked]>
Date: Sun, 20 Oct 2002 10:53:02 -0700

Actually why not take a look what GMPLS has done? In optical networks, a 
control channel is used to control multiple data channels. In GMPLS, 
RSVP and OSPF messages are going back and forth to deal with a bunch of 
physical trunks. In cases where NSIS are trying to do, this can be 
helpful... I know, people will think of SS7... sorry! :-)

In terms of reinventing wheels, try not to reinvent both terminology 
(which personally I don't think any engineer really cares), and mechanisms.

Thanks!

- Ping

Hancock, Robert wrote:
> ------------------------------------------------------------------------
> 
> Registered Office: Roke Manor Research Ltd, Siemens House, Oldbury, Bracknell, 
> Berkshire. RG12 8FZ
> 
> The information contained in this e-mail and any attachments is confidential to Roke 
> Manor Research Ltd and must not be passed to any third party without permission. This 
> communication is for information only and shall not create or change any contractual 
> relationship.

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis