Subject: [NSIS] yet another terminology proposal

From: "Hancock, Robert" <[email-masked]>
Date: Mon, 28 Oct 2002 13:44:24 -0000

hi all,

I suppose it's best to get these firmly settled before the real work starts...

I believe we have general consensus to look at a 2 layer (or 'level') architecture for NSIS signalling, as prefigured in draft-braden-2level-signal-arch-00.txt, and reflected (I hope) in the 00 framework draft (e.g. section 4.3.1), and some other protocol proposals.

However, we don't have good names for these layers. The framework avoided using terms from any existing work, to ensure there was no danger that we were prejudging the protocol choice or even prejudging the inter-layer split. If you accept this argument, we need new terms.

The following have been proposed (for framework use, and "what role is protocol XXXP supposed to perform?" type discussions):

NSIS Transport Layer Protocol (NTLP): the lower layer, responsible for moving messages around, for which we hope there will be a single protocol (at least in any network type); may or may not be based on or include underlying 'standard' transport protocols; independent of the signalling application.

NSIS Signalling Layer Protocol (NSLP): the upper layer, which defines messages (and maybe states or message sequences) which are specific to a particular signalling application. We therefore expect there to be several of these (e.g. 1 or even >1 per signalling application).

Comments? Objections?

Robert H.
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Melinda Shore <[email-masked]>
Date: Mon, 28 Oct 2002 08:59:24 -0500

NTLP is fine with me (and has a precedent in secsh's
"transport layer protocol").  It may be worth pointing out
that there will be no such protocol as "NSIS Signaling Layer
Protocol" - it's a generic term to describe what the NSIS
Transport Layer Protocol carries.  As such it may be
sufficient to either refer to it as the NSIS Signaling Layer
or to just put the whole thing in lower case, it being not
quite a proper noun.

Melinda