Subject: RE: [NSIS] yet another terminology proposal

From: [email-masked]
Date: Tue, 29 Oct 2002 21:58:47 +0200

Hi all,

> NTLP is fine with me (and has a precedent in secsh's
> "transport layer protocol").  It may be worth pointing out
> that there will be no such protocol as "NSIS Signaling Layer
> Protocol" - it's a generic term to describe what the NSIS
> Transport Layer Protocol carries.  As such it may be
> sufficient to either refer to it as the NSIS Signaling Layer
> or to just put the whole thing in lower case, it being not
> quite a proper noun.

I forget if I replied or not, but I agree.  Perhaps we should
use the term 'a NSIS signaling layer' to mean a generic one.

John
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Hancock, Robert" <[email-masked]>
Date: Tue, 29 Oct 2002 22:03:04 -0000

ok, let's go for it.

at the moment, i can easily imagine a nice diagram which showed an 'NSIS signalling layer' above the NTLP, with the NSIS signalling layer containing a small herd of NSLPs. i'm not certain my ascii-art talents are up to it before the 01 cutoff, but you can only hope.

robert h.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: 29 October 2002 19:59
> To: [email-masked]; Hancock, Robert
> Cc: [email-masked]
> Subject: RE: [NSIS] yet another terminology proposal 
> 
> 
> Hi all,
>

---

From: Bob Braden <[email-masked]>
Date: Tue, 29 Oct 2002 19:31:56 -0800

>
>
>
>NSIS Transport Layer Protocol (NTLP): the lower layer, responsible for 
>moving messages around, for which we hope there will be a single protocol 
>(at least in any network type); may or may not be based on or include 
>underlying 'standard' transport protocols; independent of the signalling 
>application.
>
>NSIS Signalling Layer Protocol (NSLP): the upper layer, which defines 
>messages (and maybe states or message sequences) which are specific to a 
>particular signalling application. We therefore expect there to be several 
>of these (e.g. 1 or even >1 per signalling application).

OK, except I think the N is dumb.  How about:

ISTP  Internet signaling transport protocol
ISCP Internet signaling control protocol

?? Any takers?

>(Choosing a good name is not an idle exercise)

Bob Braden

---

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Wed, 30 Oct 2002 16:09:46 +0100

Hi

I think Bob is right on the issue of "N is dumb".

Best Regards,
Georgios

-----Original Message-----
From: Bob Braden [mailto:[email-masked]]
Sent: woensdag 30 oktober 2002 4:32
To: Hancock, Robert; [email-masked]
Subject: Re: [NSIS] yet another terminology proposal

?? Any takers?

Bob Braden

---

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Thu, 31 Oct 2002 10:38:17 +0100

Hi all 

I think that the suggestions of Bob and Melinda could help us in 
finalizing the framework draft.

Particularly, it will be very useful if Bob could help us 
on describing and writing why and how the protocol should be separated 
in protocol levels.

Best Regards,
Georgios

-----Original Message-----
From: Bob Braden [mailto:[email-masked]]
Sent: woensdag 30 oktober 2002 4:32
To: Hancock, Robert; [email-masked]
Subject: Re: [NSIS] yet another terminology proposal

?? Any takers?

Bob Braden

---

From: "Glenn Morrow" <[email-masked]>
Date: Thu, 31 Oct 2002 12:50:41 -0600

I'd like to suggest:

NSTP - Network Services Transport Protocol
NSCP - Network Services Control Protocol

and I mean "network" in that services that layer 3 network entities have to
be involved in order to provide the service.

-----Original Message-----
From: Bob Braden [mailto:[email-masked]] 
Sent: Tuesday, October 29, 2002 9:32 PM
To: Hancock, Robert; [email-masked]
Subject: Re: [NSIS] yet another terminology proposal

?? Any takers?

Bob Braden