Subject: [NSIS] RE: I-D ACTION:draft-ietf-nsis-qos-nslp-00.txt

From: "Ash, Gerald R (Jerry), ALABS" <[email-masked]>
Date: Fri, 24 Oct 2003 14:24:59 -0500

Nice document, well done IMO.

I'd like to clarify a point in the draft:

Section 2.2 defines a 'QoS model' and Section 2.1 states that the QSpec object contains the QoS parameters defined in the QoS model.  Also Section 2.2 proposes a QSpec template that would allow specification of common QoS parameters in different QoS models.

It seems that this NSLP model envisions multiple QoS models being defined for use by the NSLP.  Is that correct?  If so, are there any examples yet of proposed QoS models, and if so, is there an I-D defining the QoS model?  

Also, is it intended that folks would now start to propose Standards Track QoS Models in the NSIS working group?  Or if not, what is the intention to develop QoS models?

Thanks in advance,
Jerry Ash
AT&T

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, September 22, 2003 2:46 PM
Cc: [email-masked]
Subject: I-D ACTION:draft-ietf-nsis-qos-nslp-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Next Steps in Signaling Working Group of the IETF.

	Title		: NSLP for Quality-of-Service signaling
	Author(s)	: S. Van den Bosch et al.
	Filename	: draft-ietf-nsis-qos-nslp-00.txt
	Pages		: 30
	Date		: 2003-9-22
	
This draft describes an NSIS Signaling Layer Protocol (NSLP) for 
signaling QoS reservations in the Internet. It is in accordance with 
the framework and requirements developed in NSIS. 
Together with the NTLP, it provides functionality similar to RSVP and 
extends it. The QoS-NSLP is independent of the underlying QoS 
specification or architecture and provides support for different 
reservation models. It is simplified by the elimination of support 
for multicast flows. 
This version of the draft focuses on the basic protocol structure. It 
identifies the different message types and describes the basic 
operation of the protocol to create, refresh, modify and teardown a 
reservation or to obtain information on the characteristics of the 
associated data path.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-nsis-qos-nslp-00.txt

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: [email-masked]
Date: Mon, 27 Oct 2003 11:33:26 +0200

Hi Jerry,

> Section 2.2 defines a 'QoS model' and Section 2.1 states that 
> the QSpec object contains the QoS parameters defined in the 
> QoS model.  Also Section 2.2 proposes a QSpec template that 
> would allow specification of common QoS parameters in 
> different QoS models.
> 
> It seems that this NSLP model envisions multiple QoS models 
> being defined for use by the NSLP.  Is that correct?  If so, 
> are there any examples yet of proposed QoS models, and if so, 
> is there an I-D defining the QoS model?  
> 
> Also, is it intended that folks would now start to propose 
> Standards Track QoS Models in the NSIS working group?  Or if 
> not, what is the intention to develop QoS models?

My opinion about this is that there are already a number of
QoS models specified outside of the IETF, for example the 
ITU, 3GPP, etc.  I do not think it wise for the IETF to make
there own QoS model, but to allow consenting peers to use the QoS NSLP 
with particular QoS models.  I think one way to acheive this is to
use IANA registries to register QoS models, and the QoS NSLP
to signal these.

John

---

From: [email-masked]
Date: Mon, 27 Oct 2003 12:15:14 +0100

Hi Jerry,

Thanks for your comment. I have replied inline.

Best regards,
Sven

"Ash, Gerald R (Jerry), ALABS" <[email-masked]>@ietf.org on 24/10/2003
21:24:59

Sent by:    [email-masked]

To:    <[email-masked]>
cc:    "Ash, Gerald R (Jerry), ALABS" <[email-masked]>
Subject:    [NSIS] RE: I-D ACTION:draft-ietf-nsis-qos-nslp-00.txt

Section 2.2 defines a 'QoS model' and Section 2.1 states that the QSpec
object contains the QoS parameters defined in the QoS model.  Also Section
2.2 proposes a QSpec template that would allow specification of common QoS
parameters in different QoS models.

It seems that this NSLP model envisions multiple QoS models being defined
for use by the NSLP.  Is that correct?  If so, are there any examples yet
of proposed QoS models, and if so, is there an I-D defining the QoS model?

Sven>> Correct. We want the QoS-NSLP to be capable of signaling for
multiple (all?) QoS models. There are essentially two ways to support
multiple QoS models:
1. By example: with every new QoS models that is defined, new parameters
and extensions are needed for QoS NSLP
2. By template: we define a framework now in which currently known QoS
models (IntServ, DiffServ, RMD, ...) can be fit. Hopefully, this will
reduce or eliminate the need for extensions later on.
Currently, there is an QoS model appendix in the draft. The QoS model
itself is not a part of the QoS-NSLP specification per se but I believe the
NSIS QoS work is not finished without it. Until we get a better feel of the
WG preference on this, we intend to keep it as an appendix.

Also, is it intended that folks would now start to propose Standards Track
QoS Models in the NSIS working group?  Or if not, what is the intention to
develop QoS models?

Sven>> This is WG/chair/charter discussion. We haven't gone there (yet).

Thanks in advance,
Jerry Ash
AT&T

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, September 22, 2003 2:46 PM
Cc: [email-masked]
Subject: I-D ACTION:draft-ietf-nsis-qos-nslp-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Next Steps in Signaling Working Group of
the IETF.

---

From: [email-masked]
Date: Mon, 27 Oct 2003 13:19:38 +0200

Hi,

> Sven>> This is WG/chair/charter discussion. We haven't gone 

Right now, NSIS is not chartered to work on QoS models.  After we have achieved
our initial charter goals, rechartering to do new work is always possible.

thanks,
John

---

From: "Hancock, Robert" <[email-masked]>
Date: Mon, 27 Oct 2003 11:30:19 -0000

hi john, jerry, all,

my personal view is that there is not a big value in
the ietf repeating the (very extensive) QoS definition
work that has been done in other bodies.

*however*, working out how to support this work using
the protocols defined by NSIS may not be a totally trivial
activity. to give one example, there is some requirements
work which identifies the need to indicate qos ranges,
or to indicate pre-emption, etc. should those requirements be
mapped into the NSLP, or into the QoS model?

in other words, while I agree that the standardisation
aspects of this problem should be soluble by having the
right IANA considerations defined in the NSLP, there is
actually a very important validation activity (which ideally
should take place during NSLP design) to make sure that 
it is feasible to use the NSLP to signal these things -
in other words, that the IANA considerations have been
written correctly in the first place (e.g we have the right
registries available).

how, when and where this validation should be done is
of course another question.

robert h.

> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, October 27, 2003 09:33
> To: [email-masked]; [email-masked]
> Subject: RE: [NSIS] RE: I-D ACTION:draft-ietf-nsis-qos-nslp-00.txt
> 
> 
> Hi Jerry,
>