Subject: RE: [NSIS] Questions regarding <draft-baker-tsvwg-mlpp-that-works-01.txt >

From: "Roy, Radhika R, ALABS" <[email-masked]>
Date: Thu, 15 Apr 2004 11:39:54 -0400

Hi, all:

I do not think that things will be just like what has been stated below. Here are the points:

1. In SIP INVITE message, SDP describes what codecs are. For example, it may be G.711 codec. Per specifications of G.711 codec, there is a standard what are the performance characteristics of G.711 in terms of end-to-end delay between the codec, bandwidth, delay jitter and losses.

2. Like all other functional requirements, a SIP UA also expects that the commitment of the above performance requirements must be met.

3. If the quality between the codecs is not delivered, there is a breach of "contract" so far acceptance of the call is concerned.

So, before acceptance of the call the following needs to happen:

a. The SIP Layer entities (e.g., proxies) need to make sure that there are sufficient resources (e.g., CPU capacity, ports) in the end-to-end path.

b. The IP network layer needs to make sure that ingress access network, backbone network, and egress access network all together in the end-to-end path has the resources to meet the performance requirements (end-to-end delay/bandwidth/jitter/losses).

c. It is important to note that item c does not have the end-to-end knowledge of delay/jitter/losses. That is, an entity that has the knowledge of end-to-end SIP/application layer performance requirements will divide the QoS requirements into three areas (access network, backbone network, and egress network) so that end-to-end performance requirements at the SIP layer is met.

The above description clearly shows where and how the NSIS protocol needs to play the role acting bridging the gap between the SIP application layer and the IP network layer.

Best regards,

Radhika R. Roy
AT&T SoIP Network Architect
732 420 1580

> From: James M. Polk [mailto:[email-masked]]
> Sent: Tuesday, April 13, 2004 10:57 PM

>SIP, if it is the only means of call establishment and control, will set up the call, thereby reducing the quality of all 4 calls traversing that
>circuit. The users won't know what happened, just that voice reception quality just tanked. 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: David Oran <[email-masked]>
Date: Mon, 19 Apr 2004 15:25:14 -0400

--On Thursday, April 15, 2004 11:39 AM -0400 "Roy, Radhika R, ALABS" 
<[email-masked]> wrote:

> 1. In SIP INVITE message, SDP describes what codecs are. For example, it
> may be G.711 codec. Per specifications of G.711 codec, there is a
> standard what are the performance characteristics of G.711 in terms of
> end-to-end delay between the codec, bandwidth, delay jitter and losses.
>
There is? Even if I'm streaming to/from a file store, like a voicemail 
server? I don't think so -please point me to the part of G.711 which 
specifies these things.

> 2. Like all other functional requirements, a SIP UA also expects that the
> commitment of the above performance requirements must be met.
>
Well, just to quibble, but I think it's the application on top of the SIP 
UA that cares, not the SIP UA itself, since the UA has no idea whether SIP 
is being used for realtime-constrained applications.

> 3. If the quality between the codecs is not delivered, there is a breach
> of "contract" so far acceptance of the call is concerned.
>
> a. The SIP Layer entities (e.g., proxies) need to make sure that there
> are sufficient resources (e.g., CPU capacity, ports) in the end-to-end
> path.
>
How can the SIP proxies ascertain this? Are you assuming a bandwidth-broker 
architecture where the proxies have close-coupled state with the bandwidth 
brokers?

Dave.

> b. The IP network layer needs to make sure that ingress access network,
> backbone network, and egress access network all together in the
> end-to-end path has the resources to meet the performance requirements
> (end-to-end delay/bandwidth/jitter/losses).
>
> c. It is important to note that item c does not have the end-to-end
> knowledge of delay/jitter/losses. That is, an entity that has the
> knowledge of end-to-end SIP/application layer performance requirements
> will divide the QoS requirements into three areas (access network,
> backbone network, and egress network) so that end-to-end performance
> requirements at the SIP layer is met.
>
> The above description clearly shows where and how the NSIS protocol needs
> to play the role acting bridging the gap between the SIP application
> layer and the IP network layer.
>
> Best regards,
>
> Radhika R. Roy
>> SIP, if it is the only means of call establishment and control, will set
>> up the call, thereby reducing the quality of all 4 calls traversing that