Subject: RE: [NSIS] About GIMPS!

From: "Elena Scialpi" <[email-masked]>
Date: Tue, 6 Apr 2004 18:28:34 +0200

Figure 4 (http://www.ietf.org/internet-drafts/draft-ietf-nsis-ntlp-01.txt ) shows message sequence 
at state setup.

The draft says that Gimps-query is sent downstream and Gimps-response upstream.

in sender-initiated case Gimps-query is sent upstream and Gimps-response downstream.

Are you agree with me?

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Wed, 7 Apr 2004 10:44:53 +0200

Hi Elena

The GIMPS query and response messages are used to
support the interaction between two neighboring NTLP
hops. This can occur in both scenarios, i.e., sender and receiver initiated.
GIMPS does not use the sender initiated and receiver initiated concpets in
its operation.
There is however, a possible requirement on GIMPS in case of receiver
initiated
operation (see also section 8.14 of the GIMPS draft):

"Receiver initiated signaling applications need to have reverse
 path state set up in the network. Should this be done by GIMPS
 carrying out the discovery for the specific signaling application
 (which requires the flow sender to know what signaling
  applications are going to be used), or should the discovery
 attempt to find every GIMPS node and the signaling applications
 they support?"

The sender-initiated and receiver-initiated concepts are mainly used
by the QoS-NSLP operation and applied among the NI (NSIS Initiator),
the NFs (NSIS Forwarders) and NR (NSIS Responder).

Best Regards,
Georgios

----- Original Message ----- 
From: "Elena Scialpi" <[email-masked]>
To: "attila.bader" <[email-masked]>
Cc: "nsis" <[email-masked]>
Sent: Tuesday, April 06, 2004 6:28 PM
Subject: RE: [NSIS] About GIMPS!

> Figure 4
(http://www.ietf.org/internet-drafts/draft-ietf-nsis-ntlp-01.txt ) shows
message sequence