Subject: RE: [NSIS] About GIMPS!

From: Attila Báder (IJ/ETH)<[email-masked]>
Date: Wed, 7 Apr 2004 13:57:27 +0200

Hi Takako Sanda,

Yes, I think you are right, if sender would like to receive RESPONSE transported back by NTLP pear-to-pear, QUERY should contain SESSION_ID. But RESPONSE can also be sent directly to sender, if sender address is known by e.g. NSLP layer. 

Best regards, Attila 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Takako Sanda
> Sent: Wednesday, April 07, 2004 10:53 AM
> To: [email-masked]
> Subject: Re: [NSIS] About GIMPS!
> 
> 
> Hi all,
> 
> I have an additional questions about GIMPS state.
> 
> Section 4.1 of GIMPS draft says the GIMPS layer maintains message
> routing state by using primary key consists of {flow routing info,
> session id, signaling application id}.
> However, when a signaling application data is QUERY, which used for
> finding out available resources, it may not contain flow 
> information or
> session id. This case GIMPS cannot maintain routing state as above
> though QUERY message requires RESPONSE which should be forwarded
> peer-to-peer back to QUERY sender by using NSLP level routing
> association (section 3.5.2 of QoS NSLP draft).
> So, I think alternative state management method may be required.
> 
> If I have any misunderstandings, please point them out.
> 
> Best Regards,
> Takako Sanda
> 
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Thanh Tra LUU" <[email-masked]>
Date: Wed, 7 Apr 2004 16:30:19 +0200

hi Attila,

if i dont miss something, QoS-NSLP can use other protocols than NTLP as a
transport protocol (ex UDP, TCP). in the case you mention, NSLP receiver (or
any signaling entities) can directly send a message to sender (or any
signaling entities) using  TCP,UDP, SCTP.

Nary Tra,
ENST, Paris.

----- Original Message -----
From: "Attila Báder (IJ/ETH)" <[email-masked]>
To: "'Takako Sanda'" <[email-masked]>; <[email-masked]>
Sent: Wednesday, April 07, 2004 1:57 PM
Subject: RE: [NSIS] About GIMPS!

>
> Hi Takako Sanda,
>
> Yes, I think you are right, if sender would like to receive RESPONSE
transported back by NTLP pear-to-pear, QUERY should contain SESSION_ID. But
RESPONSE can also be sent directly to sender, if sender address is known by
e.g. NSLP layer.