Subject: RE: [NSIS] qos-nslp: query and response request

From: "Geib, Ruediger" <[email-masked]>
Date: Wed, 19 May 2004 12:32:12 +0200

Hi Georgios,

thanks for your response,

R> the response_request mainly serves to transport
R> an RII. It further distinguishes a Query from a
R> PATH(Query) message in the case of a receiver
R> initiated reservation.
|
R> The RII must be created and maintained locally.
R> If there's just a single dialogue at a time
R> requiring a response, the RII could be omitted
R> and a local timer could control the response
R> process. This would reduce the number of
R> parameters to be signaled (a flag bit will do)
R> and further reduce the state to be maintained
R> (the timer is foreseen anyway, but no RII must
R> be created, stored or processed).
|
|Georgios: I am not sure what you mean by "created and 
|maintained locally."

Rudi: Sorry, by locally I mean the original creator 
of the message with response request

|Georgios: The RII is not created and maintained 
|locally. It can be used to send RESPONSE messages
|back to a node that initiated a QUERY/RESERVE message 
|and  required to receive a RESPONSE message from the 
|last node in the downstream path. A downstream
|node that desires responses may keep track of this 
|RII to identify the RESPONSE when it passes back 
|through it.

Rudi: Fine, as you say the downstream node which
created the message requiring a response doesn't 
need the RII to be aware of that (...may keep 
track of this RII...).

|Georgios: In particular, regarding the QUERY message, 
|see Section 5.4.2 of the QOS-NSLP draft,
|a RESPONSE message is sent back to the node that 
|required the RESPONSE, only by the last downstream
|node that has to process the QUERY message
[snipped]

Rudi: But the last downstream node doesn't need the 
RII to know that he's the last downstream node. 
And a set flag would be sufficient to tell him that 
a response is required.

I still don't understand why the RII is required.

Regards, Rüdiger

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: [email-masked]
Date: Wed, 19 May 2004 17:30:43 +0200 (CEST)

> Hi Rudiger
>
> Please see my comments in line!
>
> ----- Original Message -----
> From: "Geib, Ruediger" <[email-masked]>
> To: <[email-masked]>
> Cc: <[email-masked]>
> Sent: Wednesday, May 19, 2004 12:32 PM
> Subject: RE: [NSIS] qos-nslp: query and response request
>
>
>> Hi Georgios,
>>
> Georgios: Yes, you are right, but if the RESPONSE message will not carry
> the
> RII, then this
> node (the node that initiated the QUERY message) will not be able to
> associate the sent (original)
> QUERY message with the received RESPONSE message.
> Consider the following scenario:
>
> NodeE-------NodeA --------------------NodeB -----------------------NodeC
>                      QUERY
> |                         |----------------------------->|        QUERY
> |
> |                         |
> |---------------------------->|
> |                         |                                              |
> RESPONSE                 |
> |                         |  RESPONSE
> |<----------------------------|
> |                         | <---------------------------  |
> |
>
>
> Consider that:
> * NodeC is a last downstream node in the path (Note that the definition of
> the last downstream
>     node is given in the QoS-NSLP draft).
> * Node A sends a QUERY that carries a REQUEST_RESPONSE object (with a RII
> inside).
>   At the same time this RII is stored by NodeA.
> * NodeB receives, via NTLP, the QUERY message, but since this node is not
> the last downstream
>    node it will process it and via NTLP it will forarded further
> downstream.
> * NodeC is the last downstream node. Therefore, this message will check
> the
> RESPONSE_REQUEST object
>   and will generate a RESPONSE message that have to be sent back to NodeA.
> Note however, that
>   this RESPONSE message is sent using the Connection mode of NTLP. Thus
> this
> message will
>   be sent peer-to-peer upstream, using the NTLP reverse state. This
> message,
> however, has to be
>   scoped up to NodeA. The only way of doing that is by using the  RII that
> was carried by the
>   RESPONSE_REQUEST object. In this way each (upstream) node that receives
> the
>   RESPONSE message will have to check the RII in the RESPONSE message and
> the stored (if there is any) RII.
>
> The matching of this two RII's (the one carried by the RESPONSE message
> and
> the stored one)
> occurs only in NodeA. Therefore, NodeA can deduce that the received
> RESPONSE
> message
> is associated to the QUERY message that was initiatedd by NodeA.
>
>>
> Georgios: I hope that the explanation above made it more clear!
>
> Best Regards,
> Georgios
>
>

 Hi Georgios

I just want to extend the example you've given by adding the fact that
node B stores the RII because it is interested in the result of th Query
(it is said in the draft that it is possible to do that). In that case,
Node B will check the RII of the response and the one it has stored wich
are the same so not only node A could match thr two RII that's why I would
like that you explain to me how we could make the difference between a
node wich stores the RII because it is interested in the response and the
one wich initiates the Query.

Best Regards
Nader

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Wed, 19 May 2004 18:41:14 +0200

Hi Nader

In normal operation, NodeB will not store the RII that was generated by
NodeA.
If NodeB needs to request a RESPONSE message, than this node will have to
initiate
another QUERY or RESERVE message and include another RII in an
REQUEST_RESPONSE object.

Please note that  RII is an identifier which must be (probabilistically)
unique
within the context of a SESSION_ID, and SHOULD be different
for each response request (generated by a node).
Thus an RII that is generated by NodeA will certainly be different than
an RII that is generated by NodeB.

Best Regards,
Georgios
PS. Please note that I will be out of office and that the next time that I
will read my e-mail
is next Monday!

----- Original Message ----- 
From: <[email-masked]>
To: "Georgios Karagiannis" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, May 19, 2004 5:30 PM
Subject: Re: [NSIS] qos-nslp: query and response request

|