Subject: RE: [NSIS] qos-nslp: session binding

From: [email-masked]
Date: Mon, 24 May 2004 11:14:51 +0200

Hi Cheng Hong,

Sorry for the delayed reply (holiday). Please see my response inline.

Cheers,
Sven

"Cheng Hong" <[email-masked]> on 20/05/2004 05:21:04

To:    <[email-masked]>
cc:    "'McDonald, Andrew'" <[email-masked]>, "'Georgios
       Karagiannis'" <[email-masked]>, Sven VAN DEN
       BOSCH/BE/ALCATEL@ALCATEL
Subject:    RE: [NSIS] qos-nslp: session binding

Hi all,

Regarding the section 4.2.6 session binding, I have a question about the
first example given. In the second to last paragraph on Page 33, it states:

"For this purpose, the end-to-end session contains a BOUND_SESSION_ID
carrying the SESSION_ID of the aggregate session",

It is further stated in the first paragraph on page 34,:

"By default, a session that is bound to another session with the
BOUND_SESSION_ID object shares fate with it. This means that if a bound
session is torn down, every binding session should be torn down as well".

Shouldn't this be the other way around? Obviously, the tearing down of the
aggregate session doesn't mean that every end-to-end session should be also
torn down. But if there is an end-to-end session torn down, the aggregated
session should be torn down as well.

Sven>> I think it is OK. See the definition of binding session and bound
session in the paragraph above. The binding session is the one with SID_A
(=the end-to-end one) in the example. The bound session (=the aggregate) is
the one with SID_B.  So it is only if the bound session is torn down that
all the binding sessions are torn down as well, just as you say.

cheers

Cheng Hong

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Cheng Hong" <[email-masked]>
Date: Mon, 24 May 2004 17:54:33 +0800

Hi Sven,

Thanks for the reply, regarding the issue:

> session in the paragraph above. The binding session is the 
> one with SID_A (=the end-to-end one) in the example. The 
> bound session (=the aggregate) is the one with SID_B.  So it 
> is only if the bound session is torn down that all the 
> binding sessions are torn down as well, just as you say.

That is my question. Should all the end-to-end (binding) be torn down when
the aggregate (bound) session is torn down? I think there would be cases
when one of the end-to-end (binding) session needs to be torn down, and thus
requires the aggregate (bound) session to be also torn down (since the
member has changed). But this does not mean all the other end-to-end
(binding) session should also be torn down.  

Also, there are cases where the network cannot afford to sustain the
aggregate session, and it has to be torn down, but some member of the
aggregation, e.g. some high priority end-to-end session, could be allowed to
remain. In this case, not all the end-to-end (binding) sessions have to be
torn down.

Or, the scenario you intent to deal with is different from the above?

cheers

Cheng Hong 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] 
> Sent: Monday, May 24, 2004 5:15 PM
> To: Cheng Hong
> Cc: [email-masked]; 'McDonald, Andrew'; 'Georgios Karagiannis'
> Regarding the section 4.2.6 session binding, I have a 
> question about the first example given. In the second to last 
> paragraph on Page 33, it states:
> 
> "For this purpose, the end-to-end session contains a 
> BOUND_SESSION_ID carrying the SESSION_ID of the aggregate session",
> 
> "By default, a session that is bound to another session with 
> the BOUND_SESSION_ID object shares fate with it. This means 
> that if a bound session is torn down, every binding session 
> should be torn down as well".
> 
> Shouldn't this be the other way around? Obviously, the 
> tearing down of the aggregate session doesn't mean that every 
> end-to-end session should be also torn down. But if there is 
> an end-to-end session torn down, the aggregated session 
> should be torn down as well.
> 
> session in the paragraph above. The binding session is the 
> one with SID_A (=the end-to-end one) in the example. The 
> bound session (=the aggregate) is the one with SID_B.  So it 
> is only if the bound session is torn down that all the 
> binding sessions are torn down as well, just as you say.
> 
> cheers
> 
> Cheng Hong
> 
> 
> 
> 
> 
> 
> 
> 
>