Subject: RE: [NSIS] qos-nslp: NR definition

From: "McDonald, Andrew" <[email-masked]>
Date: Thu, 20 May 2004 10:53:45 +0100

Cheng Hong wrote:
> In the terminology definition, the QNI is defined as
> "The first node in the sequence of QNEs that issues a reservation
> request for a session" ;
> the QNR is defind as "The last node in the sequence of QNEs that
> receives a reservation request for a session"
> 
> Also in section 5.4.1 RESERVE Message, paragraph 3 on page 49, it
> states "RESERVE messge MUST only be sent towards the NR"
> 
> But in the section 3.5.3 Basic Receiver Initiated Reservation, it is
> obvious that the RESERVE message is sent from the NR, as shown in
> figure 5. 
> 
> To have a consistant definition, maybe the QNI should be defined as
> the QNE that initiates the QoS NSLP message signaling (instead of
> referring to RESERVE message) and QNR should be the QNE that response
> to the QoS NSLP message from the QNI.

I think the error is in figure 5. A corrected version might look like:

      NR         NF         NF         NI
    sender                          receiver
      |          |          |          |
      | QUERY    |          |          |
      +--------->|          |          |
      |          | QUERY    |          |
      |          +--------->|          |
      |          |          | QUERY    |
      |          |          +--------->|
      |          |          |          |
      |          |          | RESERVE  |
      |          |          |<---------+
      |          | RESERVE  |          |
      |          |<---------+          |
      | RESERVE  |          |          |
      |<---------+          |          |
      |          |          |          |
      | RESPONSE |          |          |
      +--------->|          |          |
      |          | RESPONSE |          |
      |          +--------->|          |
      |          |          | RESPONSE |
      |          |          +--------->|
      |          |          |          |

In this case it is the receiver who initiates the _reservation_, by sending the first RESERVE message.

Does that solve the question?

regards,
Andrew

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Cheng Hong" <[email-masked]>
Date: Thu, 20 May 2004 18:29:29 +0800

Hi Andrew,

Yes. That could solve the problem, although it would make the NR initate the
signalling.

cheers

Cheng 

> -----Original Message-----
> From: McDonald, Andrew [mailto:[email-masked]] 
> Sent: Thursday, May 20, 2004 5:54 PM
> To: 'Cheng Hong'; [email-masked]
> Cc: 'Georgios Karagiannis'; [email-masked]
> Subject: RE: [NSIS] qos-nslp: NR definition
> 
> 
> Cheng Hong wrote:
> > request for a session" ; the QNR is defind as "The last node in the 
> > sequence of QNEs that receives a reservation request for a session"
> > 
> In this case it is the receiver who initiates the 
> _reservation_, by sending the first RESERVE message.
> 
> -- 
> Visit our website at www.roke.co.uk
> 
> Registered Office: Roke Manor Research Ltd, Siemens House, 
> Oldbury, Bracknell, Berkshire. RG12 8FZ
> 
> The information contained in this e-mail and any attachments 
> is confidential to Roke Manor Research Ltd and must not be 
> passed to any third party without permission. This 
> communication is for information only and shall not create or 
> change any contractual relationship.
> 
> 
>