Subject: RE: [NSIS] qos-nslp: query and response request

From: "Geib, Ruediger" <[email-masked]>
Date: Wed, 19 May 2004 16:22:53 +0200

Hi Georgios,

my comments in line. Note that I won't reply before 
Monday (holiday & vacations).

Regards, Rüdiger

|Georgios: Yes, you are right, but if the 
|RESPONSE message will not carry the
|RII, then this node (the node that 
|initiated the QUERY message) will not be 
|able to associate the sent (original)
|QUERY message with the received RESPONSE 
|message.
|Consider the following scenario:

Omitted, the figure had some line breaks. 

|Consider that:
|* NodeC is a last downstream node in the path 
| (Note that the definition of the last downstream
|  node is given in the QoS-NSLP draft).
|* Node A sends a QUERY that carries a 
|  REQUEST_RESPONSE object (with a RII inside).
|  At the same time this RII is stored by NodeA.

Would the downstream message carry A's origin IP 
address to C? 

|* NodeB receives, via NTLP, the QUERY message, 
|  but since this node is not the last downstream
|  node it will process it and via NTLP it will forarded 
|  further downstream.
|* NodeC is the last downstream node. Therefore, this message 
|  will check the RESPONSE_REQUEST object
|  and will generate a RESPONSE message that have to be sent 
|  back to NodeA.
|  Note however, that this RESPONSE message is sent using 
|  the Connection mode of NTLP. Thus this message will
|  be sent peer-to-peer upstream, using the NTLP reverse state. 
|  This message, however, has to be scoped up to NodeA. The 
|  only way of doing that is by using the  RII that
|  was carried by the RESPONSE_REQUEST object. In this way 
|  each (upstream) node that receives the RESPONSE message 
|  will have to check the RII in the RESPONSE message and
|  the stored (if there is any) RII.
|
|The matching of this two RII's (the one carried by the 
|RESPONSE message and the stored one) occurs only in NodeA. 
|Therefore, NodeA can deduce that the received RESPONSE
|message is associated to the QUERY message that was 
|initiatedd by NodeA.

If I got you right, C isn't aware of (or using) A's IP 
address (there's no IP adress carried at NSLP level in a 
response message, I see). Instead, it uses the session ID 
to identify the signaling relation and uses the RII to 
allow A to figure out that this is the reply to A's 
response request. Would this be the idea?

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Wed, 19 May 2004 16:36:29 +0200

Hi Rudiger

Please see inline:

----- Original Message ----- 
From: "Geib, Ruediger" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, May 19, 2004 4:22 PM
Subject: RE: [NSIS] qos-nslp: query and response request

> Omitted, the figure had some line breaks.
Georgios: Sorry about that, please see below:

NodeE----NodeA ---------NodeB ----------NodeC
                     QUERY
|                         |------------>|        QUERY   |
|                         |                    |--------------->|
|                         |                    |                         |
|                         |                    RESPONSE      |
|                         |                    | <-------------  |
|                         | RESPONSE
|                         |<----------- |

> Would the downstream message carry A's origin IP

Georgios: No, the downstream message does not carry NodeA's origin IP
address
to NodeC. That is why the RII has to be carried by the REQUEST_RESPONSE
object.

> response request. Would this be the idea?

Georgios: Yes, that is right.

Best regards,
Georgios