Subject: [NSIS] closing GIST issue 58 (S flag setting)

From: "Hancock, Robert" <[email-masked]>
Date: Thu, 1 Sep 2005 12:02:12 +0100

Dear all,

An issue was raised during the interoperability test about how to set
the GIST S flag in the common header when a message is originated from
the flow source. (The flag distinguishes the cases where the IP source
address is the flow source or the signalling source, and in this case
their is nothing to distinguish.)

See also
http://nsis.srmr.co.uk/cgi-bin/roundup.cgi/nsis-ntlp-issues/issue58

The conclusion at the time was that S should be set. The following text
is
proposed for section 5.2.1 (it is slightly more general):

   Source addressing mode: A flag set to indicate that the IP source
address
      of the message is the same as the signaling source address, in
      which case replies to this message can be sent safely to this
      address.  It is cleared if the IP source address was derived from 
      the message routing information in the payload and this is
different 
      from the signalling source address.

(also changed in C.2.1).

Cheers,

robert h.

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: [email-masked]
Date: Fri, 2 Sep 2005 22:02:52 +0300

Robert, 

This sounds reasonable.  However, do you define what a flag being
set means & what a flag being cleared means?  I know it should
be rather self-explanatory, but I suppose it wouldn't hurt to be
explicit.

John 

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On 
>Behalf Of ext Hancock, Robert
>Sent: 01 September, 2005 14:02
>To: [email-masked]
>Subject: [NSIS] closing GIST issue 58 (S flag setting)
>
>Dear all,
>
>An issue was raised during the interoperability test about how 
>to set the GIST S flag in the common header when a message is 
>originated from the flow source. (The flag distinguishes the 
>cases where the IP source address is the flow source or the 
>signalling source, and in this case their is nothing to distinguish.)
>
>See also
>The conclusion at the time was that S should be set. The 
>following text is proposed for section 5.2.1 (it is slightly 
>more general):
>
>   Source addressing mode: A flag set to indicate that the IP 
>source address
>      the message routing information in the payload and this 
>is different

---

From: "Hancock, Robert" <[email-masked]>
Date: Sun, 4 Sep 2005 19:55:44 +0100

john,

ok, i will look at including (S=1) and (S=0) statements
to make it clear. (Or do I mean (S=0) and (S=1)? you'll
have to wait and see...)

r.

> From: [email-masked] [mailto:[email-masked]] 
> Sent: 02 September 2005 20:03
> To: [email-masked]; [email-masked]
> Subject: RE: [NSIS] closing GIST issue 58 (S flag setting)
> 
> 
> Robert, 
>