Subject: [NSIS] new open GIST issue related to stateless handling

From: "Georgios Karagiannis" <[email-masked]>
Date: Mon, 5 Sep 2005 18:32:01 +0200

Hi Robert

During the NSIS interim meeting, in Munich, another issue has
been brought up by you that might affect the API between QoS-NSLP and
GIMPS, see Slide: 
"Transport II: Stateless Handling :

* API hook to allow node to process a message without creating routing state (Source-SII)

* Current API allows an NSLP to cause very strange message sequences, and
what happens to NSLP data in a Query is not defined
* Possible approach: GIMPS says "what should I do with this data for which
there is no routing state?", NSLP says .
A) Accept the routing state
B) Request routing state validation and here is a response
C) Drop out of the routing state and forward this payload"
(Stateless node cooses C) and statefull nodes choose either A) or B))

I am not sure if this issue has been discussed during the last IETF meeting.
If not, could you please include this issue as an open GIST issue in:
http://nsis.srmr.co.uk/cgi-bin/roundup.cgi/nsis-ntlp-issues/

Best Regards,
Georgios

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Hancock, Robert" <[email-masked]>
Date: Tue, 6 Sep 2005 14:41:54 +0100

hi Georgios,

could you be precise about which aspects you think need
to be made clearer? (The words don't line up exactly with
what was discussed at the interim, but the later formulation
is actually supposed to be more explicit.)

on your second point, we don't propose to define the values
of any of the API calls in the spec, since these are an
implementation issue. (that's true for practically everything
else in the API as well.)

cheers,

robert h.

> -----Original Message-----
> From: Georgios Karagiannis [mailto:[email-masked]] 
> Sent: 06 September 2005 14:22
> To: Hancock, Robert
> Cc: [email-masked]
> Subject: Re: [NSIS] RE: new open GIST issue related to 
> stateless handling
> 
> 
> Hi Robert
> 
> As you mentioned this is very roughly given :-)
> It will be good if some clarification on this point could be given!
> 
> Furthermore, regarding D.3 it mentions:
> "This primitive can return a value from the NSLP which 
> indicates whether the 
> NSLP wishes
> GIMPS to retain message routing state."
> 
> I am not sure if I missed it, but what is the value of this 
> primitive when
> NSLP does not wish to retain message routing state?
> 
> Best Regards,
> Georgios
> 
> ----- Original Message ----- 
> From: "Hancock, Robert" <[email-masked]>
> To: "Georgios Karagiannis" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Tuesday, September 06, 2005 12:42 PM
> Subject: RE: [NSIS] RE: new open GIST issue related to 
> stateless handling
> 
> 
> > georgios,
> >
> > from 4.3.2:
> >
> >   Even when a message relates to a local signaling application, an
> >   adjacency may or may not be required based on signaling 
> application
> >   policy, and the application of this policy may depend on the NSLP
> >   payload.  Therefore, when this decision has to be made, the NSLP
> >   payload is delivered and the signaling application has 
> two options:
> >
> >   o  to proceed setting up the adjacency.  The application 
> may provide
> >      an NSLP payload (which will be used in any GIMPS-Response).
> >
> >   o  to bypass the message and drop out of the signaling path.  The
> >      application may provide an NSLP payload (which will be 
> used in the
> >      message which is then forwarded in the same direction 
> by GIMPS).
> >
> > roughly, the first case is (A/B) [depending on exactly when 
> the state is
> > accepted] and the second case is (C).
> >
> > do you think more clarification is needed here?
> >
> > robert h.
> >
> > -----Original Message-----
> > From: Georgios Karagiannis [mailto:[email-masked]]
> > Sent: 06 September 2005 11:35
> > To: Hancock, Robert
> > Cc: [email-masked]
> > Subject: Re: [NSIS] RE: new open GIST issue related to stateless
> > handling
> >
> >
> > Hi Robert
> >
> > I have checked the given pointers, but I have not found the 
> description
> > of the following functionality:
> >
> >> GIMPS says "what should I do with this data for which
> >> (Stateless node cooses C) and statefull nodes choose 
> either A) or B))"
> >
> > Could you please clarify this?
> >
> > Best regards,
> > Georgios
> >
> > ----- Original Message ----- 
> > From: Hancock, Robert
> > To: Georgios Karagiannis
> > Cc: [email-masked]
> > Sent: Tuesday, September 06, 2005 11:57 AM
> > Subject: [NSIS] RE: new open GIST issue related to 
> stateless handling
> >
> >
> > hi georgios,
> >
> > there's been some movement on this since the interim.
> >
> > you might like to look at 4.3.2 and D.3 of the -07 version to see if
> > they
> > match what you are looking for (at the moment, there are no 
> outstanding
> > issues on these parts).
> >
> > robert h.
> > -----Original Message-----
> > From: Georgios Karagiannis [mailto:[email-masked]]
> > Sent: 05 September 2005 17:32
> > To: Hancock, Robert
> > Cc: [email-masked]
> > Subject: new open GIST issue related to stateless handling
> >
> >
> > Hi Robert
> >
> > * API hook to allow node to process a message without 
> creating routing
> > state (Source-SII)
> >
> > * Current API allows an NSLP to cause very strange message 
> sequences,
> > and