Subject: Re: [NSIS] A question on QoS NSLP RESERVE behavior

From: "Georgios Karagiannis" <[email-masked]>
Date: Sun, 4 Sep 2005 17:34:53 +0200 (MEST)

Hi Charles

You are right, we need to describe this functionality in a more precise
way.
The main point is that when the REPLACE flag is set to FALSE (= 0), it
indicates that the reservation on the old branch should be kept.
Furthermore, also note that:
"The default behaviour of a QNE that receives a RESERVE with a
   SESSION_ID for which it already has state installed but with a
   different flow ID is to replace the existing reservation (and tear
   down the reservation on the old branch if the RESERVE is received
   with a different SII)."

The descriptions emphasised by you below, are associated to the
situations were the REPLACE flag is FALSE (= 0).

>In the last paragraph on page 47 of qos-nslp-07.txt, it is said "A QNE that
>receives a RESERVE with the REPLACE flag set to zero but with the same SII
>will update the flow ID and indicate REPLACE=0 to the RMF".
>
>Could you please elaborate a bit what this "update the flow ID" means?
>Addition or replacement or ...? 

When REPLACE = 0 and the SII is the same, then the QoS-NSLP state (valid
only for QoS-NSLP statefull nodes) will be updated, e.g., new flow-ID
will be replaced, and the RMF is informed to deal with resource sharing.
 This may include, adding the reservations, or taking the maximum of the
two or more complex mathematical operations, specified by the QoS model.
Note that for QoS-NSLP stateless or QoS-NSLP reduced states, operating in
the above situation only the RMF is informed to deal with resource
sharing (since no QoS-NSLP state is maintained).

> Will the same update be performed if the SII
> is different and REPLACE=0 is set?

In the situation that SII is different, it means that it is a merge
point. In this case the same update, as described above will be
performed. Moreover, the QNE is notified that a tearing RESERVE SHOULD
NOT be sent on the old branch.
Note that if REPLACE was set (=1) and if the SII was different, then the
QNE
had to send a tearing RESERVE on the old branch.

Best Regards,
Georgios

On 8/29/2005, "Charles Shen" <[email-masked]> wrote:

>Hi
>
>In the last paragraph on page 47 of qos-nslp-07.txt, it is said "A QNE that
>receives a RESERVE with the REPLACE flag set to zero but with the same SII
>will update the flow ID and indicate REPLACE=0 to the RMF".
>
>Could you please elaborate a bit what this "update the flow ID" means?
>Addition or replacement or ...? Will the same update be performed if the SII
>is different and REPLACE=0 is set?
>
>Thanks.
>
>Best regards,
>
>Charles
>
>
>_______________________________________________
>nsis mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/nsis

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Jukka MJ Manner <[email-masked]>
Date: Tue, 6 Sep 2005 20:46:03 +0300 (EEST)

Hi Charles,

Georgios might be best to answer this, and he will surely correct me... As 
far as I can understand, "update" in this case would mean "add". And the 
same addition would be done if the SII is different, provided that replace 
is set to zero. Georgios, was I even close? :)

Cheers,
Jukka

---

From: Jukka MJ Manner <[email-masked]>
Date: Tue, 6 Sep 2005 20:53:49 +0300 (EEST)

Oh, boy, Georgios had answered days ago... sorry, all...:P

---

From: "Charles Shen" <[email-masked]>
Date: Wed, 7 Sep 2005 05:04:38 -0400

Oh, yes, Georgios indicated that the "update" means replacement while you
mentioned it as "add". So which one is the true intention ... ?

Thanks!

Charles 

> -----Original Message-----
> From: Jukka MJ Manner [mailto:[email-masked]] 
> Sent: Tuesday, September 06, 2005 1:54 PM
> To: Charles Shen
> Cc: McDonald, Andrew; Georgios Karagiannis; [email-masked]
> Subject: Re: [NSIS] Re: A question on QoS NSLP RESERVE behavior
> 
> 
> 
> > > In the last paragraph on page 47 of qos-nslp-07.txt, it 
> is said "A 
> > > QNE that receives a RESERVE with the REPLACE flag set to zero but 
> > > with the same SII will update the flow ID and indicate 
> REPLACE=0 to 
> > > the RMF".
> > > 
> > > Could you please elaborate a bit what this "update the flow ID" 
> > > means? Addition or replacement or ...? Will the same update be 
> > > performed if the SII is different and REPLACE=0 is set?
> > > 
> > > Thanks.
> > > 
> > > Best regards,
> > > 
> > > Charles
> > > 
> > > 
> >

---

From: Jukka MJ Manner <[email-masked]>
Date: Wed, 7 Sep 2005 12:07:35 +0300 (EEST)

Hi,

Listen to Georgios, he's the man. I got mixed up with the logic of replace 
(or not to replace). We (I) need to make this more understandable in the 
draft.

Jukka

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Wed, 7 Sep 2005 11:21:42 +0200

Hi Charles

Please note that both options, i.e., add or replace the flow ID,  are 
allowed!
See section 5.2.1 of the QoS-NSLP draft:
"Flow ID

      Copied from GIMPS.  Several entries are possible in case of
      mobility events."

Jukka is right, we have indeed to clarify this issue!

Best regards,
Georgios

----- Original Message ----- 
From: "Jukka MJ Manner" <[email-masked]>
To: "Charles Shen" <[email-masked]>
Cc: "'McDonald, Andrew'" <[email-masked]>; "'Georgios 
Karagiannis'" <[email-masked]>; <[email-masked]>
Sent: Wednesday, September 07, 2005 11:07 AM
Subject: RE: [NSIS] Re: A question on QoS NSLP RESERVE behavior

---

From: "Charles Shen" <[email-masked]>
Date: Wed, 7 Sep 2005 11:29:57 -0400

Yes, that's exactly what I originally had doubt with. It would be very
helpful to have that clarified. 

Thank you both!

Charles 

> From: Georgios Karagiannis [mailto:[email-masked]] 
> Sent: Wednesday, September 07, 2005 5:22 AM
> To: Jukka MJ Manner; Charles Shen
> Cc: 'McDonald, Andrew'; [email-masked]
> > Listen to Georgios, he's the man. I got mixed up with the logic of 
> > replace (or not to replace). We (I) need to make this more 
> > understandable in the draft.
> >
> > Jukka
> >
> >> Oh, yes, Georgios indicated that the "update" means 
> replacement while 
> >> you mentioned it as "add". So which one is the true intention ... ?
> >>
> >> Thanks!
> >>
> >> Charles
> >>
> >> > > Georgios might be best to answer this, and he will 
> surely correct 
> >> > > me... As far as I can understand, "update" in this case would 
> >> > > mean
> >> > "add". And the
> >> > > > QNE that receives a RESERVE with the REPLACE flag 
> set to zero 
> >> > > > but with the same SII will update the flow ID and indicate
> >> > REPLACE=0 to
> >> > > > the RMF".
> >> > > >
> >> > > [email-masked] https://www1.ietf.org/mailman/listinfo/nsis
> >> > >
> >> >
> >>
> >>
> > 
>