Subject: RE: [NSIS] SII-Handle

From: "Hancock, Robert" <[email-masked]>
Date: Thu, 8 Sep 2005 21:55:33 +0100

hi roland

inline:

> -----Original Message-----
> From: Roland Bless [mailto:[email-masked]] 
> Sent: 08 September 2005 21:43
> To: Hancock, Robert
> Cc: [email-masked]
> Subject: Re: [NSIS] SII-Handle
> 
> 
> Hi Robert,
> 
> Two additional questions:
> - Is it true that an SII-Handle references exactly
>   a particular next hop in one direction, either up- or downstream
>   (and not both peers at once)?

it always references exactly one hop. it's always associated 
with exactly one MRI, which references exactly one direction,
as you correctly point out below ;-)

> - sec 4.2.1 says:
>   The information for a given key consists of two items: the routing
>   state to reach the upstream and the downstream peer, with respect to
>   the MRI in each case.
> 
> I'm not sure whether the above statement is correct since the
> up/down flag is now contained in the MRI.
> I think that a key (MRI,SID,NSLPID) references
> routing state to exactly only one peer (either up or downstream,
> depending on the MRI D flag). If I'm right the above statement
> should be corrected since it says an entry consists of two items.

good catch. the point is now that there will (often) be a pair
of MRIs for any given flow. i'll fix this (also in appendix B).

thanks for the careful reading,

robert h.
> Regards,
>  Roland
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Roland Bless <[email-masked]>
Date: Fri, 09 Sep 2005 09:24:47 +0200

> as you correctly point out below ;-)

Sounds good :-)

> thanks for the careful reading,

That's what you're obliged to do if you're trying to
produce running code out of specs :-)

Regards,
 Roland