Subject: [NSIS] RE: new open GIST issue related to stateless handling

From: "Hancock, Robert" <[email-masked]>
Date: Tue, 6 Sep 2005 10:57:24 +0100

hi georgios,
 
there's been some movement on this since the interim. 
 
you might like to look at 4.3.2 and D.3 of the -07 version to see if
they
match what you are looking for (at the moment, there are no outstanding
issues on these parts).
 
robert h.

	-----Original Message-----
	From: Georgios Karagiannis [mailto:[email-masked]] 
	Sent: 05 September 2005 17:32
	To: Hancock, Robert
	Cc: [email-masked]
	Subject: new open GIST issue related to stateless handling

	Hi Robert
	 
	During the NSIS interim meeting, in Munich, another issue has
	been brought up by you that might affect the API between
QoS-NSLP and
	GIMPS, see Slide: 
	"Transport II: Stateless Handling :
	
	* API hook to allow node to process a message without creating
routing state (Source-SII)
	
	* Current API allows an NSLP to cause very strange message
sequences, and
	what happens to NSLP data in a Query is not defined
	* Possible approach: GIMPS says "what should I do with this data
for which
	there is no routing state?", NSLP says .
	A) Accept the routing state
	B) Request routing state validation and here is a response
	C) Drop out of the routing state and forward this payload"
	(Stateless node cooses C) and statefull nodes choose either A)
or B))

	I am not sure if this issue has been discussed during the last
IETF meeting.
	If not, could you please include this issue as an open GIST
issue in:
	http://nsis.srmr.co.uk/cgi-bin/roundup.cgi/nsis-ntlp-issues/
	 
	Best Regards,
	Georgios

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Tue, 6 Sep 2005 12:34:32 +0200

MessageHi Robert 

I have checked the given pointers, but I have not found the description of the following functionality:

> GIMPS says "what should I do with this data for which
> (Stateless node cooses C) and statefull nodes choose either A) or B))"

Could you please clarify this?

Best regards,
Georgios

  ----- Original Message ----- 
  From: Hancock, Robert 
  To: Georgios Karagiannis 
  Cc: [email-masked] 
  Sent: Tuesday, September 06, 2005 11:57 AM
  Subject: [NSIS] RE: new open GIST issue related to stateless handling

  hi georgios,

  you might like to look at 4.3.2 and D.3 of the -07 version to see if they
  match what you are looking for (at the moment, there are no outstanding
  issues on these parts).

  robert h.
    -----Original Message-----
    From: Georgios Karagiannis [mailto:[email-masked]] 
    Sent: 05 September 2005 17:32
    To: Hancock, Robert
    Cc: [email-masked]
    Subject: new open GIST issue related to stateless handling

    Hi Robert

    During the NSIS interim meeting, in Munich, another issue has
    been brought up by you that might affect the API between QoS-NSLP and
    GIMPS, see Slide: 
    "Transport II: Stateless Handling :

    * API hook to allow node to process a message without creating routing state (Source-SII)

    * Current API allows an NSLP to cause very strange message sequences, and
    what happens to NSLP data in a Query is not defined
    * Possible approach: GIMPS says "what should I do with this data for which
    there is no routing state?", NSLP says .
    A) Accept the routing state
    B) Request routing state validation and here is a response
    C) Drop out of the routing state and forward this payload"
    (Stateless node cooses C) and statefull nodes choose either A) or B))

    I am not sure if this issue has been discussed during the last IETF meeting.
    If not, could you please include this issue as an open GIST issue in:
    http://nsis.srmr.co.uk/cgi-bin/roundup.cgi/nsis-ntlp-issues/

    Best Regards,
    Georgios

------------------------------------------------------------------------------