Subject: RE: [NSIS] Loose-End MRM Direction

From: "Christian Dickmann" <[email-masked]>
Date: Thu, 10 Aug 2006 17:32:24 +0200

Hi,

> see also
> http://nsis.srmr.co.uk/cgi-bin/roundup.cgi/nsis-ntlp-issues/issue115

Sounds good to me.

Christian Dickmann

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Hancock, Robert" <[email-masked]>
Date: Wed, 30 Aug 2006 12:17:39 +0100

hi roland,

> -----Original Message-----
> From: Roland Bless [mailto:[email-masked]] 
> Sent: 21 August 2006 14:27
> To: Hancock, Robert
> Cc: [email-masked]
> Subject: Re: [NSIS] Loose-End MRM Direction
> 
> 
> Hi Robert,
> 
> [sorry for the delay, I was on a short vacation]
> 
> > there is no mystery here, it is just my screwup. Magnus'
> > review highlighted the earlier text as being unclear and
> > I tried to make it clearer; what I missed was that the
> > earlier text was wrong and I just made it clearly wrong.
> > The intent that *for Query encapsulated messages* only D=0
> > is allowed. I'll add that in the next version.
> > 
> > see also
> D flag:  The direction flag.  Note that for Q-mode messages, the only
>       valid value is D=0 (see Section 5.8.2).
> 
> This actually makes more sense. So it's ok to invert the
> flag in the RESPONSE.
> 
> On the other hand it's somehow still confusing:
> if one takes the original definition
> of upstream/downstream signaling into account, it would
> be *upstream* not downstream. At least if one follows
> the definitions and scenarios in the NAT/FW draft,
> because the GIST node that sends a query message containing
> the LE MRM is actually the data receiver. Thus, the signaling
> direction is upstream in this case?!

it may be that we should have abandoned the terms upstream
and downstream altogether. however, i think for the GIST
specification the usage is OK; GIST is not aware of the
semantics of the messages being carried over it, and one
could equally imagine other NSLPs wanting to discover the
edge of the local network for other reasons.

r.

> Regards,
>  Roland