Subject: RE: [NSIS] Loose-End MRM Direction

From: "Hancock, Robert" <[email-masked]>
Date: Thu, 10 Aug 2006 16:31:55 +0100

hi folks,

there is no mystery here, it is just my screwup. Magnus'
review highlighted the earlier text as being unclear and
I tried to make it clearer; what I missed was that the
earlier text was wrong and I just made it clearly wrong.
The intent that *for Query encapsulated messages* only D=0
is allowed. I'll add that in the next version.

see also
http://nsis.srmr.co.uk/cgi-bin/roundup.cgi/nsis-ntlp-issues/issue115

cheers,

robert h.

> -----Original Message-----
> From: Roland Bless [mailto:[email-masked]] 
> Sent: 09 August 2006 13:54
> To: Christian Dickmann; Hancock, Robert
> Cc: [email-masked]
> Subject: Re: [NSIS] Loose-End MRM Direction
> 
> 
> Hi Christian,
> 
> Christian Dickmann wrote:
> 
> > I just read the text about Loose-End MRM again and wondered
> > about the text "D flag: The direction flag. The only valid 
> > value is D=0 (see Section 5.8.2)."
> 
> Good point! We are indeed a little bit confused, too.
> The draft also says in sec. 5.8.2.1:
>                               Additional control information 
> defines the
>    direction of the message relative to this flow as in the 
> path-coupled
>    case.
> 
> What control information in which protocol? In GIST or in the NSLP?
> Or do you mean the D-flag (which is currently pretty useless)?
> 
> > The NATFW NSLP defines to use LEMRM for some cases of the REA
> > message. I wonder how the response can travel back to
> > the initiator if only downstream direction is allowed.
> 
> Actually that could be figured out by checking who actually
> sent the message, i.e. upstream or downstream peer. In either
> case you must forward it to the other peer. But that would break
> implementations that rely on evaluating the D-flag while routing
> messages and I think it will be an inconsequent use of the D-flag.
> Actually change history says:
> 23.  Clarified why only D=0 is valid for the loose-end MRM in
>         Appendix A.3.1.2 [AD review comment L23].
> but frankly I don't see any explanation for this.
> 
> > Even a GIST Query/Response would not work, as according to
> > Section 5.1 of the GIST draft the Response has inverted direction.
> > "Note that the direction of this MRI will be
> >  inverted compared to that in the Query, that is, an upstream MRI
> >  becomes downstream and vice versa (see Section 3.3)."
> > 
> > So I wondered if maybe using LEMRM implicitly means, that
> > there is no GIST routing-state installed, but the question
> > remains how to send the response to the REA back to initiator.
> 
> A possibility would be to forward a message to the
> upstream peer if it came from the downstream peer
> and vice versa. But I'm not sure that this will work
> in all cases.
> 
> > Can you please clarify this?
> 
> We are also looking forward to an answer.
> 
> Regards,
>  Roland
> 
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Roland Bless <[email-masked]>
Date: Mon, 21 Aug 2006 15:27:12 +0200

Hi Robert,

[sorry for the delay, I was on a short vacation]

> http://nsis.srmr.co.uk/cgi-bin/roundup.cgi/nsis-ntlp-issues/issue115

D flag:  The direction flag.  Note that for Q-mode messages, the only
      valid value is D=0 (see Section 5.8.2).

This actually makes more sense. So it's ok to invert the
flag in the RESPONSE.

On the other hand it's somehow still confusing:
if one takes the original definition
of upstream/downstream signaling into account, it would
be *upstream* not downstream. At least if one follows
the definitions and scenarios in the NAT/FW draft,
because the GIST node that sends a query message containing
the LE MRM is actually the data receiver. Thus, the signaling
direction is upstream in this case?!

Regards,
 Roland