Subject: [NSIS] I-D ACTION:draft-ietf-nsis-qos-nslp-14.txt

From: [email-masked]
Date: Mon, 11 Jun 2007 15:50:02 -0400

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.
This draft is a work item of the Next Steps in Signaling Working Group of the IETF.

	Title		: NSLP for Quality-of-Service Signaling
	Author(s)	: J. Manner, et al.
	Filename	: draft-ietf-nsis-qos-nslp-14.txt
	Pages		: 97
	Date		: 2007-6-11
	
This specification describes the NSIS Signaling Layer Protocol (NSLP)
   for signaling QoS reservations in the Internet.  It is in accordance
   with the framework and requirements developed in NSIS.  Together with
   GIST, it provides functionality similar to RSVP and extends it.  The
   QoS NSLP is independent of the underlying QoS specification or
   architecture and provides support for different reservation models.
   It is simplified by the elimination of support for multicast flows.
   This specification explains the overall protocol approach, design
   decisions made and provides examples.  It specifies object, message
   formats and processing rules.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-nsis-qos-nslp-14.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of 
the message. 
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the 
username "anonymous" and a password of your e-mail address. After 
logging in, type "cd internet-drafts" and then 
"get draft-ietf-nsis-qos-nslp-14.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-nsis-qos-nslp-14.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: <[email-masked]>
Date: Tue, 12 Jun 2007 16:27:48 -0500

Jukka has updated the draft.  We would like to start a 2 week
WGLC on the draft which will run through close of business on
June 25th.

Please review the draft, and comment if you feel that this draft
is ready to be sent to the IESG.  A simple mail saying that the
draft is ready for publication would be great.

Of course, if you read the draft and find open issues, then please
send a summary of your issue with the current draft.

thanks,
Martin and John 

>-----Original Message-----
>From: ext [email-masked] [mailto:[email-masked]] 
>Sent: 11 June, 2007 12:50
>To: [email-masked]
>Cc: [email-masked]
>Subject: [NSIS] I-D ACTION:draft-ietf-nsis-qos-nslp-14.txt 
>
>A New Internet-Draft is available from the on-line 
>Internet-Drafts directories.
>To remove yourself from the I-D Announcement list, send a 
>message to [email-masked] with the word 
>unsubscribe in the body of the message. 
>Internet-Drafts are also available by anonymous FTP. Login 
>with the username "anonymous" and a password of your e-mail 
>address. After logging in, type "cd internet-drafts" and then 
>http://www.ietf.org/shadow.html or 
>ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>Below is the data which will enable a MIME compliant mail 
>reader implementation to automatically retrieve the ASCII 
>version of the Internet-Draft.
>

---

From: Martin Stiemerling <[email-masked]>
Date: Mon, 18 Jun 2007 13:50:04 +0200

Dear all,

Just to remind you about the currently running WGLC for the QoS NSLP.
A simple mail saying that the draft is ready for publication would be  
great.

Thanks,

   Martin

Anfang der weitergeleiteten E-Mail:

> Von: <[email-masked]>
> Datum: 12. Juni 2007 23:27:48 MESZ
> An: <[email-masked]>
> Betreff: [NSIS] WGLC:draft-ietf-nsis-qos-nslp-14.txt
>

[email-masked]
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road,  
London W3 6BL | Registered in England 2832014

---

From: Bernd Schloer <[email-masked]>
Date: Sun, 24 Jun 2007 19:08:12 +0200

Hi,

I reviewed the draft and haven't found any open issues. I think
this draft is ready for publication.

Best regards,
Bernd

---

From: Hong Cheng <[email-masked]>
Date: Mon, 25 Jun 2007 23:37:00 +0800

Dear all,

I have reviewed the draft. It seems good. Below are some of my comments.

cheers

Cheng Hong

===============================
- Page 8 Figure 2: The figure needs to align with the decision made
about the API discussion, i.e. whether the Local Application is talking
to the QoS NSLP or to the RMF.

- Page 18, section 3.2.10.3, paragraph 2, line 6, "similar to section
3.2.10.3". This section is referring to itself? Shouldn't it be "3.2.10.2"?

- Page 31, section 4.4, paragraph 5, line 3 "Both directions of the
flows are bound by inserting the BOUND_SESSION_ID object at the QNI and
QNR". How does a QNR insert the BOUND_SESSION_ID? Maybe what it meant is
"Both directions of the flows are bound to the other direction by
inserting the BOUND_SESSION_ID object at the QNIs"? And, this would also
require the QNI (A) know about the Session ID to be used for RESERVE-2
(Flow-2) at B beforehand.

- Page 76, line 3, "If the RESERVE-INIT flag is included in an arrived
QUERY." This seems not a proper condition for "The QNE must create a new
RESERVE and send it to its next peer". Only the QNI, not any QNE, would
send a RESERVE when receiving such a QUERY. And, that RESERVE is sent
towards reverse direction of the QUERY, not the next peer. This was
clearly stated in paragraph 4 or section 5.4.2 (page 76).

- Page 78, second paragraph (section 5.4.3). There is another condition
in which the QNE must send a RESPONSE: received a RESERVE or QUERY with
the common header ACK-REQ-flag set. In this case, the RESPONSE message
does not contain any RII object, and should not be forwarded further by
the receiving QNE.

Martin Stiemerling wrote:
>> *Von: *<[email-masked] <mailto:[email-masked]>>
>> *Datum: *12. Juni 2007 23:27:48 MESZ
>> *An: *<[email-masked] <mailto:[email-masked]>>
>> *Betreff: **[NSIS] WGLC:draft-ietf-nsis-qos-nslp-14.txt *
>>
>>> To: [email-masked] <mailto:[email-masked]>
>>> Cc: [email-masked] <mailto:[email-masked]>
>>> message to [email-masked]
>>> <mailto:[email-masked]> with the word 
>>> [email-masked] <mailto:[email-masked]>.
>>> In the body type:
>> [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>
> ------------------------------------------------------------------------
>

---

From: Martin Stiemerling <[email-masked]>
Date: Tue, 26 Jun 2007 14:29:58 +0200

[writing chair's hat off]
Hi all,

I have read the draft and think it is ready to take the next steps.

   Martin

---

From: Roland Bless <[email-masked]>
Date: Tue, 26 Jun 2007 14:42:28 +0200

Hi,

> I have read the draft and think it is ready to take the next steps.

I'm still reading the draft completely and will provide comments
ASAP (scheduled for tomorrow). Sorry for not being able to make it
in the WGLC time frame...

Regards,
 Roland

---

From: <[email-masked]>
Date: Tue, 26 Jun 2007 08:25:56 -0500

That's OK.  

Anyone else who is still reading the draft?

John 

>From: ext Roland Bless [mailto:[email-masked]] 
>Sent: 26 June, 2007 05:42
>To: Martin Stiemerling
>Cc: nsis
>Subject: Re: [NSIS] WGLC:draft-ietf-nsis-qos-nslp-14.txt
>
>Hi,
>
>I'm still reading the draft completely and will provide 
>comments ASAP (scheduled for tomorrow). Sorry for not being 
>able to make it in the WGLC time frame...
>
>Regards,
> Roland
>
>

---

From: Luís Cordeiro <[email-masked]>
Date: Tue, 26 Jun 2007 14:57:20 +0100

I am reading it. I will try also to
give feedback tomorrow morning.

BR,

Luís Cordeiro

That's OK.

John

-----Original Message-----
From: ext Roland Bless [mailto:[email-masked]]
Sent: 26 June, 2007 05:42
To: Martin Stiemerling
Cc: nsis
Subject: Re: [NSIS] WGLC:draft-ietf-nsis-qos-nslp-14.txt

Hi,

Regards,
Roland

---

From: "Hancock, Robert" <[email-masked]>
Date: Tue, 26 Jun 2007 14:58:39 +0100

hi all,

i've read the draft. basically i think it is ready to ship.
we could all certainly think of things to add, but I think actually
as a core protocol it has the right balance between completeness
and conciseness; AFAICT anything i'd like to add can be done as
an extension (which is probably a good approach anyway).

cheers,

robert h. 

> From: [email-masked] [mailto:[email-masked]] 
> Sent: 26 June 2007 14:26
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: [NSIS] WGLC:draft-ietf-nsis-qos-nslp-14.txt
> 
> That's OK.  
> 
> comments ASAP 
> >(scheduled for tomorrow). Sorry for not being able to make it in the 
> >WGLC time frame...
> >
> >Regards,
> > Roland
> >
> >

---

From: Xiaoming Fu <[email-masked]>
Date: Thu, 28 Jun 2007 22:29:46 +0200

Hi all,

I have read the doc and think its reasonable to publish.
Xiaoming