Subject: Re: [NSIS] QoS NSLP final fixes for v.14

From: Jukka MJ Manner <[email-masked]>
Date: Sun, 10 Jun 2007 21:14:03 +0300 (EEST)

Dear all,

A new draft has been submitted. Before it is available from the 
repository, you can find it here, and a diff against v.13. The changes 
were given below, in addition a few API changes were done, and Georgios 
and Roland added a functionality to support intra-domain operation, maybe 
the boys could tell a bit more about it.

http://www.cs.helsinki.fi/u/jmanner/qos-nslp/

Regards,
Jukka

On Wed, 30 May 2007, Jukka MJ Manner wrote:

> 
> Dear all,
> 
> Here are the changes I have done to QoS NSLP spec. If I have missed some 
> comment, please forgive me, and send it again.
> 
> There is still the question of the abstract API. The current version is 
> (very) complex, and one proposal was to divide it into a simple API, and a 
> more powerful API (mainly for those inter-intra domain cases).
> 
> The changes:
> 
> 1.
> 
> Added Protocol Error:
> 
> 0x0f - Incompatible QSPEC
> (From Jerry & Andrew, Mar 14)
> 
> 2. 
> 
> Moved Break-flag from message-specific flags to Generic Flags in the
> Common Header.
> (Suggested by Roland, Mar 21)
> 
> 3. 
> 
> To support pre-emption mechanisms in QOSMs, we have added:
> 
> * RESERVE and QUERY should be able to carry an INFO_SPEC object
> 
> * BOUND_SESSION_ID that indicates the session that caused the
> pre-emption. Note that the value of this BOUND_SESSION_ID will have a
> new Binding Code value, which will have to be specified in the QOS-NSLP.
> 
> and the section below:
> 
> 4.2.12.  Pre-emption
> 
>    The QoS NSLP provides building blocks to implement pre-emption.  This
>    specification does not define how pre-emption should work, but only
>    provides signaling mechanisms that can be used by QoS Models.  For
>    example, an INFO_SPEC object can be added to messages to indicate
>    that the signaled session was pre-empted.  A BOUND_SESSION_ID object
>    can carry the Session ID of the flow that caused the pre-emption to
>    happen for the signaled session.  How these are used by QoS Models is
>    out of scope of the QoS NSLP specification.
> 
> 
> 
> When do we start WGLC?
> 
> 
> Regards,
> Jukka
> 
> ps. By far the biggest change was to move from good-old nroff to xml... 
> took a while. ;)
> 
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Roland Bless <[email-masked]>
Date: Mon, 11 Jun 2007 13:22:40 +0200

Hi all,

> the boys could tell a bit more about it.

Not exactly related to intra-domain operation only.
It's a feature that we call "message binding" and it allows
to reduce session setup time in case you are using reservation
aggregates. The basic idea is that you can start two signaling
exchanges simultaneously, that have a dependency among each other.
By using the message binding, you can let messages wait on
other messages if there is such a dependency.
So it would also be useful in inter-domain scenarios.

Regards,
 Roland