Subject: Re: AW: [NSIS] The QSPEC draft violates the QoS NSLP

From: Roland Bless <[email-masked]>
Date: Mon, 03 Sep 2007 17:48:38 +0200

Hello Cornelia and Hannes,

Kappler, Cornelia wrote:
> I agree, the QoS NSLP draft should be updated to specify that the QSPEC can appear several times as Hannes described below. 

Hmm, I probably don't understand to what exactly Hannes
is referring to.
I thought that there is always only one QSPEC object at most.
Thus, IMHO there is no need to change the QoS NSLP.

Regards,
 Roland

> Cornelia
> 
>> -----Ursprüngliche Nachricht-----
>> Von: ext Hannes Tschofenig [mailto:[email-masked]] 
>> Gesendet: Sonntag, 12. August 2007 20:57
>> An: [email-masked]
>> Betreff: [NSIS] The QSPEC draft violates the QoS NSLP
>>
>> Strictly speaking the QSPEC document with the currently defined QSPEC 
>> hiding procedure violates the QoS NSLP draft:
>>
>> The QoS NSLP draft defines the RESERVE and the RESPONSE as follows:
>>
>>       RESERVE = COMMON_HEADER
>>                 RSN [ RII ] [ REFRESH_PERIOD ] [ *BOUND_SESSION_ID ]
>>                 [ SESSION_ID_LIST [ RSN_LIST ] ]
>>                 [ MSG_ID / BOUND_MSG_ID ] [ INFO_SPEC ]
>>                 [ [ PACKET_CLASSIFIER ] QSPEC ]
>>
>>  RESPONSE = COMMON_HEADER
>>                  [ RII / RSN ] INFO_SPEC [SESSION_ID_LIST [ 
>> RSN_LIST ] ]
>>                  [ QSPEC ]
>>
>> I assume that the QSPEC hiding is applicable for the QUERY and the 
>> NOTIFY message as well.
>>
>> The QSPEC may appear 0 or 1 times.
>>
>> With the QSPEC hiding it would be correct to indicate for the RESERVE 
>> and the RESPONSE that the object may appear 0 to 2 times.
>>
>> Ciao
>> Hannes
>>
>>
>>
>> _______________________________________________
>> nsis mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/nsis
>>
> 
> 
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 

-- 
Dr. Roland Bless -- WWW: http://www.tm.uka.de/~bless
Institut für Telematik, Universität Karlsruhe (TH), Germany
Zirkel 2, D-76128 Karlsruhe -- Geb. 20.20, 3.OG, Raum 358
Tel.: +49 721 608-6413 Fax: +49 721 608-6789

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 03 Sep 2007 22:10:36 +0200

Hi Roland,

it seems that there is only one QoS NSLP QSPEC object in one message. 
However, 2 QSPECs object copied together.

The length of the QoS NSLP QSPEC object is therefore the full length of 
everything that is included. The QoS NSLP does not care about the content.

In short, there is only a minor terminology issue. Everything is called 
QSPEC.

Ciao
Hannes