Subject: Re: [NSIS] FW: I-D ACTION:draft-ietf-nsis-qspec-20.txt

From: Roland Bless <[email-masked]>
Date: Wed, 23 Jul 2008 12:59:21 +0200

Hi,

Martin Stiemerling wrote:

> Thanks to Jerry and the co-authors for updating the draft. 
> 
> Please review the draft and send your feedback.

Just a small first comment:

Page 43: (Sec. 7 - IANA considerations)
QSPEC Type: since this is only 4 bits, the given ranges
cannot be allocated and must be reassigned. I propose
0-7: specification required
8-12: local/experimental use
13-15: reserved

Regards,
 Roland
_______________________________________________
nsis mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nsis

---

From: Gerald Ash <[email-masked]>
Date: Thu, 24 Jul 2008 12:20:03 -0700 (PDT)

Hi Roland,
 
> cannot be allocated and must be reassigned.
 
Good catch.
 
> I propose
 
IMO we should allow more space for specified QOSMs.  7 seems like insufficient space for future growth (recall that 0 is assigned as the default QSPEC Type).
 
One alternative would be 
 
0 = default
1-12: specification required
12-15: local/experimental use

IMO a better alternative would be to expand the space for QSPEC Type, as follows:
 
In Section 5.1.1 reallocate 7 bits to QPSEC Type as follows:
 
 0                   1                   2                   3
 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|  Vers.|I|  QSPEC Type |  QSPEC Proc.  |      Length           |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
 
And reallocate QSPEC Type bits in Section 7 (IANA Considerations) as follows:
 
 QSPEC Type (7 bits):
   The following value is allocated by this specification:
   0: Default
   The allocation policies for further values are as follows:
   1-31: Specification Required
   32-63: Private/Experimental Use
   64-127: Reserved

Thanks,
Jerry

---

From: Roland Bless <[email-masked]>
Date: Tue, 29 Jul 2008 10:24:31 +0200

Hi Jerry,

Gerald Ash wrote:
> IMO we should allow more space for specified QOSMs.  7 seems like
> insufficient space for future growth (recall that 0 is assigned as the
> default QSPEC Type).

Sure, but I doubt that we need internal signaling with that many QoSMs.
Since this will only be used internally, it should be no problem to
re-use the same values in different domains.

> 12-15: local/experimental use

having at least one reserved value for future/special use
would probably be a good idea.

> In Section 5.1.1 reallocate 7 bits to QPSEC Type as follows:

Actually, what I don't like here is that there are no further flags
left for extensions. So I guess that it would be better to have at
least two more bits left as reserved flags (so QSPEC type could be
expanded by 1 bit if needed - however, I doubt that this is really
necessary).

Regards,
 Roland