Subject: [ntpwg] [NTP Protocol] strengthening NTP control packets for diagnostic purpose

From: "Anil Kumar S N (VRP Network BL)" <[email-masked]>
Date: Mon, 20 Apr 2015 04:49:22 +0000

Hi Folks,

                Please give your opinion on strengthening of NTP control packets for better diagnostic purpose.

Is Yang model and MIB is sufficient ? Will it help to get all the information ?
Ex: Authorization for management protocol such as MIB/Yang  is limited with respect to service provider, As NTP servers could be managed by other service providers.

I feel Mr. Mills was aware of this so he introduced control packets, but I feel it's out dated.

There are two options

1.       NTP dynamic runtime diagnostic tools can be implemented using NTP extensions using protocol packets

2.       Strengthen NTP control packets with new options to achieve the same. [Preferred]

Please give your opinion. We are working on this, Your opinion matters.

Thanks & Regards
Anil S N

"Be liberal in what you accept, and conservative in what you send" - Jon Postel

_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: Florian Weimer <[email-masked]>
Date: Tue, 21 Apr 2015 23:13:27 +0200

> 2.       Strengthen NTP control packets with new options to achieve the same. [Preferred]

I seriously suggest to consider moving diagnostics and other form of
management out of band (say SNMP, CIM or PCP, basically anything else
that does not run over port 123/UDP), so that these interfaces are not
constrained by the NTP technical framework regarding authentication,
authorization, confidentiality, and integrity protection.
_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: "Anil Kumar S N (VRP Network BL)" <[email-masked]>
Date: Wed, 22 Apr 2015 04:17:23 +0000

Hi Weimer,

	You are right, control packets are introduced with the same intention in the mind that only NTP core functionality should be with NTP packets.
	If I am not wrong, NTPq and NTPd process in Linux handle control packets and NTP packets respectively. 

	We just want to standardize and strengthen control packets to the current needs. 
	I want to trigger a discussion in the forum so that we can collect the opinions to come up with better solutions.

Thanks & Regards
Anil S N

-----Original Message-----
From: Florian Weimer [mailto:[email-masked]] 
Sent: 22 April 2015 02:43
To: Anil Kumar S N (VRP Network BL)
Cc: [email-masked]; Ankit Kumar Sinha (A); Karen O'Donoghue; Rajeshmv; kasturi chandradeep; Dhruv Dhody; Chirag shah; Kalyankumar Asangi
Subject: Re: [ntpwg] [NTP Protocol] strengthening NTP control packets for diagnostic purpose

> 2.       Strengthen NTP control packets with new options to achieve the same. [Preferred]

I seriously suggest to consider moving diagnostics and other form of management out of band (say SNMP, CIM or PCP, basically anything else that does not run over port 123/UDP), so that these interfaces are not constrained by the NTP technical framework regarding authentication, authorization, confidentiality, and integrity protection.
_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: "Ulrich Windl" <[email-masked]>
Date: Wed, 22 Apr 2015 08:46:59 +0200

>>> Florian Weimer <[email-masked]> schrieb am 21.04.2015 um 23:13 in Nachricht
> authorization, confidentiality, and integrity protection.

Well, SNMP, CIM and PCP (Performance Co-Pilot?) all may be more standard, but they all have some extra protocol (and library) overhead. And I think confidentiality and integrity are also issues when monitoring or controlling NTP. So I don't see why you want to have it out-band (unless you simply want to get rid of it).

Modeling NTP in SNMP may be an interesting exercise (consuming many hours), but may end up in a moster that only few people want to deal with. I don't like framework monsters feeding each other...

Regards,
Ulrich

---

From: "Anil Kumar S N (VRP Network BL)" <[email-masked]>
Date: Wed, 22 Apr 2015 09:43:45 +0000

Hi Windl,

	Please see my comments inline [Anil-1]

Thanks & Regards
Anil S N

-----Original Message-----
From: Ulrich Windl [mailto:[email-masked]] 
Sent: 22 April 2015 12:17
To: [email-masked]; Anil Kumar S N (VRP Network BL)
Cc: Chirag shah; Dhruv Dhody; Kalyankumar Asangi; kasturi chandradeep; Rajeshmv; [email-masked]; [email-masked]
Subject: Antw: Re: [ntpwg] [NTP Protocol] strengthening NTP control packets for diagnostic purpose

[Anil-1] : I think current IETF standards for managing NTP are NTP MIB (SNMP based) and Yang model. These are the protocols who's reach is confined to a service provider due to authentication issues. Many operators have defined their own private MIB to access information and configure NTP. Confidentiality is not required for NTP but integrity of the NTP content yes it is required, As of now its optional we can think of making it mandatory for control packets.  

Usually cases are like in service provider network they will have a NTP client connected to a different NTP server which belongs to different service provider; from which all other devices in that service provider network will get their time synchronized. If the server is faulty, diagnostic purpose we need to query behavior of the server at that particular time. Only with control packets we will be able to get the information of the NTP server which belongs to different service provider

NTP control packets exist for NTPv3, do you want to get rid of it :)  Think about it, there were very good reasons for introducing it.
I can see Linux exhaustively exploits NTP query functionality, One very good utility is People have written scripts to perform NTP trace. 
Let's take what's good in current design of control packets and address the shortcomings.

---

From: "Ulrich Windl" <[email-masked]>
Date: Wed, 22 Apr 2015 13:08:47 +0200

Hello!

I mostly agee except "(...)Confidentiality is not required for NTP(...)": Assume some configuration data is not publicly available. If someone who is allowed to access that configuration data over the net with proper authentication, these data will appear on the net (without confidentiality). You don't make them public, but you may disclose it these days...

That's what I thought.

Regards,
Ulrich

>>> "Anil Kumar S N (VRP Network BL)" <[email-masked]> schrieb am 22.04.2015 um
11:43 in Nachricht
<[email-masked]>:
> Cc: Chirag shah; Dhruv Dhody; Kalyankumar Asangi; kasturi chandradeep; 
> Rajeshmv; [email-masked]; [email-masked] 
> Well, SNMP, CIM and PCP (Performance Co-Pilot?) all may be more standard, but 
> they all have some extra protocol (and library) overhead. And I think 
> confidentiality and integrity are also issues when monitoring or controlling 
> NTP. So I don't see why you want to have it out-band (unless you simply want 
> to get rid of it).
> 
> Modeling NTP in SNMP may be an interesting exercise (consuming many hours), 
> but may end up in a moster that only few people want to deal with. I don't 
> like framework monsters feeding each other...
> Regards,
> Ulrich
> 
> 
> [Anil-1] : I think current IETF standards for managing NTP are NTP MIB (SNMP 
> based) and Yang model. These are the protocols who's reach is confined to a 
> service provider due to authentication issues. Many operators have defined 
> their own private MIB to access information and configure NTP. 
> Confidentiality is not required for NTP but integrity of the NTP content yes 
> it is required, As of now its optional we can think of making it mandatory 
> for control packets.  
> 
> Usually cases are like in service provider network they will have a NTP 
> client connected to a different NTP server which belongs to different service 
> provider; from which all other devices in that service provider network will 
> get their time synchronized. If the server is faulty, diagnostic purpose we 
> need to query behavior of the server at that particular time. Only with 
> control packets we will be able to get the information of the NTP server 
> which belongs to different service provider
> 
> NTP control packets exist for NTPv3, do you want to get rid of it :)  Think 
> about it, there were very good reasons for introducing it.
> I can see Linux exhaustively exploits NTP query functionality, One very good 
> utility is People have written scripts to perform NTP trace.

---

From: Florian Weimer <[email-masked]>
Date: Wed, 22 Apr 2015 13:57:36 +0200

* Ulrich Windl:

> I mostly agee except "(...)Confidentiality is not required for
> NTP(...)": Assume some configuration data is not publicly
> available. If someone who is allowed to access that configuration
> data over the net with proper authentication, these data will appear
> on the net (without confidentiality). You don't make them public,
> but you may disclose it these days...

It's also needed when the monitoring discloses information about
clients in some way (which would be pretty reasonable for load
monitoring, I assume).
_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: "Anil Kumar S N (VRP Network BL)" <[email-masked]>
Date: Wed, 22 Apr 2015 12:08:33 +0000

Hi,

	In NTP you are talking about Authentication key and password ?, Anyways that should not be in the scope of control packets.	
	What else you are expecting to be kept confidential ? Do you have anything specific in mind?

Thanks & Regards
Anil S N

-----Original Message-----
From: Ulrich Windl [mailto:[email-masked]] 
Sent: 22 April 2015 19:09
To: [email-masked]; Anil Kumar S N (VRP Network BL)
Cc: Chirag shah; Dhruv Dhody; Kalyankumar Asangi; kasturi chandradeep; Rajeshmv; [email-masked]; [email-masked]
Subject: RE: Antw: Re: [ntpwg] [NTP Protocol] strengthening NTP control packets for diagnostic purpose

Hello!

That's what I thought.

Regards,
Ulrich

11:43 in Nachricht
<[email-masked]>:
>> that does not run over port 123/UDP), so that these interfaces are 
>> not constrained by the NTP technical framework regarding 
>> authentication, authorization, confidentiality, and integrity protection.
> 
> Well, SNMP, CIM and PCP (Performance Co-Pilot?) all may be more 
> standard, but they all have some extra protocol (and library) 
> overhead. And I think confidentiality and integrity are also issues 
> when monitoring or controlling NTP. So I don't see why you want to 
> have it out-band (unless you simply want to get rid of it).
> 
> Modeling NTP in SNMP may be an interesting exercise (consuming many 
> hours), but may end up in a moster that only few people want to deal 
> with. I don't like framework monsters feeding each other...
> Regards,
> Ulrich
> 
> 
> based) and Yang model. These are the protocols who's reach is confined 
> to a service provider due to authentication issues. Many operators 
> have defined their own private MIB to access information and configure NTP.
> Confidentiality is not required for NTP but integrity of the NTP 
> content yes it is required, As of now its optional we can think of 
> making it mandatory for control packets.
> 
> Usually cases are like in service provider network they will have a 
> NTP client connected to a different NTP server which belongs to 
> different service provider; from which all other devices in that 
> service provider network will get their time synchronized. If the 
> server is faulty, diagnostic purpose we need to query behavior of the 
> server at that particular time. Only with control packets we will be 
> able to get the information of the NTP server which belongs to 
> different service provider
> 
> NTP control packets exist for NTPv3, do you want to get rid of it :)  
> Think about it, there were very good reasons for introducing it.
> I can see Linux exhaustively exploits NTP query functionality, One 
> very good utility is People have written scripts to perform NTP trace.

---

From: "Anil Kumar S N (VRP Network BL)" <[email-masked]>
Date: Wed, 22 Apr 2015 14:02:21 +0000

Hi Dowd,

                Do you expect White List in control packets, I feel anything confidential should not be part of NTP control packets.
                For Sensitive data such as Authentication Password and White/Black List  Configuration or access should be done using Management protocol which support confidentiality (Owned and controlled by service provider for their devices)

Thanks & Regards
Anil S N

From: Greg Dowd [mailto:[email-masked]]
Sent: 22 April 2015 19:28
To: Anil Kumar S N (VRP Network BL)
Cc: [email-masked]; Ulrich Windl; Kalyankumar Asangi; Dhruv Dhody; kasturi chandradeep; [email-masked]; Rajeshmv; Chirag shah; [email-masked]
Subject: Re: [ntpwg] Antw: Re: [NTP Protocol] strengthening NTP control packets for diagnostic purpose

I could see the white list restrict entries as confidential for example.
On Apr 22, 2015 5:10 AM, "Anil Kumar S N (VRP Network BL)" <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Thanks & Regards
Anil S N

-----Original Message-----
From: Ulrich Windl [mailto:[email-masked]]
Sent: 22 April 2015 19:09
To: [email-masked]<mailto:[email-masked]>; Anil Kumar S N (VRP Network BL)
Cc: Chirag shah; Dhruv Dhody; Kalyankumar Asangi; kasturi chandradeep; Rajeshmv; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: Antw: Re: [ntpwg] [NTP Protocol] strengthening NTP control packets for diagnostic purpose

Hello!

That's what I thought.

Regards,
Ulrich

>>> "Anil Kumar S N (VRP Network BL)" <[email-masked]<mailto:[email-masked]>> schrieb am
>>> 22.04.2015 um
11:43 in Nachricht
<[email-masked]<mailto:[email-masked]>>:
> To: [email-masked]<mailto:[email-masked]>; Anil Kumar S N (VRP Network BL)
> Rajeshmv; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
>>>> Florian Weimer <[email-masked]<mailto:[email-masked]>> schrieb am 21.04.2015 um 23:13 in
>>>> Nachricht
> <[email-masked]<mailto:[email-masked]>>:
>> * Anil Kumar S. N.:
>>
>>> There are two options
>>>
>> [email-masked]<mailto:[email-masked]>

_______________________________________________
ntpwg mailing list
[email-masked]<mailto:[email-masked]>
http://lists.ntp.org/listinfo/ntpwg
_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: Danny Mayer <[email-masked]>
Date: Thu, 23 Apr 2015 23:22:43 -0400

> packets for better diagnostic purpose.  

I am not sure I understand what you mean by that. Can you explain what
you want to accomplish first before we try to decide what you need?

> Is Yang model and MIB is sufficient ? Will it help to get all the

I have no idea what the Yang model is and what it does for you. Maybe
you can explain in a few words?

> Ex: Authorization for management protocol such as MIB/Yang  is limited
> with respect to service provider, As NTP servers could be managed by
> other service providers.
> 

This is even less clear. If you don't manage an NTP server you should
not be able to control it and sometimes not even know any details about
it. I'm not sure what this has to do with MIB/Yang.

> I feel Mr. Mills was aware of this so he introduced control packets, but
> I feel it’s out dated.
> 

You really should ask him if you want to know. We can't go by feelings.

> NTP extensions using protocol packets

What would these runtime diagnostiv tools do and why do you think you
should use NTP extension fields for this? There are other ways of
managing servers without using the NTP protocol. Have you considered that?

> 2.       Strengthen NTP control packets with new options to achieve the

What are you thinking of? What is meant by strengthen? What are these
new options and what would they accomplish?

> Please give your opinion. We are working on this, Your opinion matters.

What exactly are you working on? It's hard to make suggestions or give
advice without knowing the goals.

> Anil S N

I've been reading the responses to this thread and I'm no wiser as to
what you are trying to do. Can we get the ultimate goals detailed before
we discussed how to get there?

Danny

---

From: "Anil Kumar S N (VRP Network BL)" <[email-masked]>
Date: Mon, 27 Apr 2015 07:05:47 +0000

Hi Danny, 

	Was out of station, Will respond to this mail soon with details.

Thanks & Regards
Anil S N

-----Original Message-----
From: ntpwg [mailto:ntpwg-bounces+anilkumarsn=[email-masked]] On Behalf Of Danny Mayer
Sent: 24 April 2015 11:23
To: Anil Kumar S N (VRP Network BL); [email-masked]
Cc: Karen O'Donoghue; Rajeshmv; kasturi chandradeep; Dhruv Dhody; Chirag shah; Kalyankumar Asangi
Subject: Re: [ntpwg] [NTP Protocol] strengthening NTP control packets for diagnostic purpose

On 4/20/2015 12:49 AM, Anil Kumar S N (VRP Network BL) wrote:
> Hi Folks,
>                 Please give your opinion on strengthening of NTP 
> control packets for better diagnostic purpose.
>

> I feel it's out dated.

Danny