Subject: [Ntp] WGLC for draft-ietf-tictoc-1588v2-yang

From: Karen O'Donoghue <[email-masked]>
Date: Wed, 13 Sep 2017 19:16:02 +0000

Folks,

This message begins a 2 week working group last call (WGLC) for the following document: 

YANG Data Model for IEEE 1588v2
https://datatracker.ietf.org/doc/draft-ietf-tictoc-1588v2-yang/

Please review the referenced document and send any comments to the mailing list including your assessment of whether this document is mature enough to proceed to the IESG. Please note that these messages of support for progression to the mailing list are important and will be used to determine WG consensus to proceed. 

Please send all comments in by Thursday 28 September 2017.  

Thank you!
Karen

---

From: Tal Mizrahi <[email-masked]>
Date: Mon, 18 Sep 2017 09:58:44 +0300

Hi,

I believe this draft is almost ready to proceed to the IESG.

Other than the YANG format issues that have already mentioned on the list,
I believe the Security Considerations section should be slightly extended.
- "Some data nodes defined in this YANG module are writable, and any
changes to them may adversely impact a synchronization network."
  Please elaborate about the consequences, i.e., what is the impact on the
network (Clock inaccuracy? Loss of synchronization? Other consequences?).
- The section should probably mention that the security considerations of
time protocols in general are discussed in [RFC 7384].

Cheers,
Tal.

On Wed, Sep 13, 2017 at 10:16 PM, Karen O'Donoghue <[email-masked]>
wrote:

> Please review the referenced document and send any comments to the mailing
> list including your assessment of whether this document is mature enough to
> proceed to the IESG. Please note that these messages of support for
> progression to the mailing list are important and will be used to determine
> WG consensus to proceed.
>
> _______________________________________________
> TICTOC mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tictoc
>

---

From: Jiangyuanlong <[email-masked]>
Date: Tue, 19 Sep 2017 01:23:41 +0000

Tal,

   Good suggestions! Based on your comments, I would propose the following texts for the Security considerations:
   “YANG modules are designed to be accessed via the NETCONF protocol
   [RFC6241], thus security considerations in [RFC6241] apply here.
   Security measures such as using the NETCONF over SSH [RFC6242] and
   restricting its use with access control [RFC6536] can further
   improve its security, avoid injection attacks and misuse of the
   protocol. Furthermore, general security considerations of time
   protocols are discussed in [RFC7384].

   Some data nodes defined in this YANG module are writable, and an
   inappropriate use of them may adversely impact a synchronization network,
   for example, loss of synchronization on a clock, accuracy degradation
   on a set of clocks, or even break down of a whole synchronization network.”

  Are you OK with the above texts?

Thanks a lot,
Yuanlong

From: ntp [mailto:[email-masked]] On Behalf Of Tal Mizrahi
Sent: Monday, September 18, 2017 2:59 PM
To: Karen O'Donoghue
Cc: [email-masked]; [email-masked]
Subject: Re: [Ntp] [TICTOC] WGLC for draft-ietf-tictoc-1588v2-yang

Hi,

Other than the YANG format issues that have already mentioned on the list, I believe the Security Considerations section should be slightly extended.
- "Some data nodes defined in this YANG module are writable, and any changes to them may adversely impact a synchronization network."
  Please elaborate about the consequences, i.e., what is the impact on the network (Clock inaccuracy? Loss of synchronization? Other consequences?).
- The section should probably mention that the security considerations of time protocols in general are discussed in [RFC 7384].

Cheers,
Tal.

On Wed, Sep 13, 2017 at 10:16 PM, Karen O'Donoghue <[email-masked]<mailto:[email-masked]>> wrote:
Folks,

Thank you!
Karen
_______________________________________________
TICTOC mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tictoc