Subject: Re: [Ntp] WG Call for Adoption: draft-stenn-ntp-extension-fields

From: Hal Murray <[email-masked]>
Date: Thu, 26 Jul 2018 13:51:32 -0700

[email-masked] said:
> It’s worth doing, but not “quickly”.  If we’re going to “big bang” things,
> let’s make sure that all current issues are adequately addressed and all new
> issues are properly reviewed. 

I guess I wasn't clear enough.  The idea was to avoid a big bang.  The only 
change is "no legacy MACs" so we can stop wasting time on how to make 
extension fields coexist with old code.

-- 
These are my opinions.  I hate spam.

---

From: Daniel Franke <[email-masked]>
Date: Thu, 26 Jul 2018 16:55:02 -0400

I think this is a bad idea if for no other reason that we only get
versions 5, 6, and 7 before we run out of bits in the version field,
and it's not worth wasting one of our last three bullets on this
problem.
On Thu, Jul 26, 2018 at 4:51 PM Hal Murray <[email-masked]> wrote:
> _______________________________________________
> ntp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ntp

---

From: Alex Campbell <[email-masked]>
Date: Thu, 26 Jul 2018 22:12:22 +0000

I'll point out that it's entirely possible for a new version to add a secondary version field, such that future versions would be represented as 5.6, 5.7, 5.8, etc...
________________________________________
From: ntp <[email-masked]> on behalf of Daniel Franke <[email-masked]>
Sent: Friday, 27 July 2018 8:55 a.m.
To: Hal Murray
Cc: [email-masked]; [email-masked]
Subject: Re: [Ntp] WG Call for Adoption: draft-stenn-ntp-extension-fields

---

From: Philip Prindeville <[email-masked]>
Date: Thu, 26 Jul 2018 16:54:02 -0600

What would that look like?

> On Jul 26, 2018, at 4:12 PM, Alex Campbell <[email-masked]> wrote:
>

---

From: "Ulrich Windl" <[email-masked]>
Date: Mon, 30 Jul 2018 08:12:02 +0200

>>> Alex Campbell <[email-masked]> schrieb am 27.07.2018 um 00:12
in
Nachricht <[email-masked]>:
> I'll point out that it's entirely possible for a new version to add a 
> secondary version field, such that future versions would be represented as 
> 5.6, 5.7, 5.8, etc...

Or even better: State that with the legavy-version field being set to 5 means
that the actual NTP version is found in an extension field (that is still to be
specified). Maybe sub-versions actually do make sense (semantics to be
specified in detail)...

Regards,
Ulrich

> From: ntp <ntp‑[email-masked]> on behalf of Daniel Franke 
> <[email-masked]>
> Cc: [email-masked]; philipp@redfish‑solutions.com 
> Subject: Re: [Ntp] WG Call for Adoption: draft‑stenn‑ntp‑extension‑fields
> 
>> philipp@redfish‑solutions.com said:
>> > let’s make sure that all current issues are adequately addressed and all

> new
>> ‑‑