Subject: [Ntp] Summary notes from IETF 102

From: Karen O'Donoghue <[email-masked]>
Date: Wed, 15 Aug 2018 19:58:48 +0000

Folks,

Below is my summary of the next steps for each document from our IETF 102 meeting...
I produced it for my own sanity, but I thought it might be helpful to some of you…

Also, please remember that the minutes (thank you Tal and Dieter!) have been posted by Dieter.
https://datatracker.ietf.org/meeting/102/materials/minutes-102-ntp-01
Please get any final corrections to us by 30 Sept.

Regards,
Karen

*********************
IETF 102 Summary…

TICTOC
------

1588v2 YANG module
https://datatracker.ietf.org/doc/html/draft-ietf-tictoc-1588v2-yang
Status:  Submitted to IESG for Publication -
Next Steps:  Chairs to followup with AD and authors to ensure progression

Enterprise Profile for the PTP With Mixed Multicast and Unicast Messages
https://tools.ietf.org/html/draft-ietf-tictoc-ptp-enterprise-profile
Status:  WGLC closed successfully with some minor edits required.
Next Steps: Document update expected within two weeks. Once the update is completed, the document will be ready for the IESG.

Synchronizing Internet Clocks
https://datatracker.ietf.org/doc/html/draft-alavarez-hamelin-tictoc-sic
Status:  No consensus to adopt document at this time. Author needs to work to identify a broader community or set of collaborators interested in this work.

NTP
---

NTP MAC
https://datatracker.ietf.org/doc/html/draft-ietf-ntp-mac
Status:  Submitted to IESG for Publication
Next Steps:  Chairs to follow up with AD on status of IESG review

NTP Data Minimization
https://datatracker.ietf.org/doc/html/draft-ietf-ntp-data-minimization
Status: Document has been updated.
Next Steps: Issue WGLC

Guidelines for Defining Packet Timestamps
https://datatracker.ietf.org/doc/html/draft-ietf-ntp-packet-timestamps
Status: Document updated
Next Steps: Ask mailing list about addition of another recommended timestamp format. Pending resolution of that issue, document is ready for WGLC.

Network Time Protocol Best Current Practices
https://datatracker.ietf.org/doc/html/draft-ietf-ntp-bcp
Status: Submitted to IESG for publication.
Next Steps: Authors to update based on INTDIR review. Chairs to followup with AD.

Control Messages Protocol for Use with NTPv4
https://datatracker.ietf.org/doc/html/draft-ietf-ntp-mode-6-cmds
Status: Document updated based on WGLC
Next Steps: Measure consensus on publishing as informational versus historic. Answer the question: what implementations beyond the reference implementation implement this?

A YANG Data Model for NTP
https://datatracker.ietf.org/doc/html/draft-ietf-ntp-yang-data-model
Status: Document is updated and ready.
Next Steps: Chairs ask for a YANG expert review.

Interleaved Modes
https://datatracker.ietf.org/doc/html/draft-ietf-ntp-interleaved-modes
Status: Document has been updated.
Next Steps: Further review/discussion. When will it be ready for a WGLC?

NTS for NTP
https://datatracker.ietf.org/doc/html/draft-ietf-ntp-using-nts-for-ntp
https://datatracker.ietf.org/doc/html/draft-dansarie-nts-00
Status: Base document updated from hackathon lessons. dansarie document provides some updates.
Next Steps: Marcus to do pull requests for changes suggested by his team. Possible WGLC after those pull requests are implemented.

A Secure Selection and Filtering Mechanism for the NTPv4
https://datatracker.ietf.org/doc/html/draft-schiff-ntp-chronos
Status: Individual submission
Next Steps: Further development by author and any interested parties.

REFID Updates
https://datatracker.ietf.org/doc/html/draft-ietf-ntp-refid-updates
Status: Been around for awhile and not changing much. General support/understanding for Not You and IPv6 IDs. Concerns with leap smear ID.
Next Steps: Suggestion to split the document into two. Take question to the mailing list.

NTP Correction Field
https://datatracker.ietf.org/doc/html/draft-mlichvar-ntp-correction-field
Status: Document updated
Next Steps: Further review/discussion by working group.

7822bis (Network Time Protocol Version 4 Extension Fields0
https://datatracker.ietf.org/doc/html/draft-ietf-ntp-extension-fields
Status: Document updated.
Next Steps: Chairs to issue a WG Call for Adoption

Additional Extension Field Proposals
https://datatracker.ietf.org/doc/draft-stenn-ntp-extended-information/
https://datatracker.ietf.org/doc/draft-stenn-ntp-i-do/
https://datatracker.ietf.org/doc/draft-stenn-ntp-mac-last-ef/
https://datatracker.ietf.org/doc/draft-stenn-ntp-suggest-refid/
Status: Documents exist
Next Steps: Harlan to update to ensure compliance with RFC 7822. Any that can be published under the current extension field construct can be considered for WG adoption. Those that cannot will need to be deferred until there is consensus on any update to extension fields.

---

From: Denis Reilly <[email-masked]>
Date: Thu, 16 Aug 2018 19:40:37 +0000

Hello, Karen! Thanks for keeping track of all this.

In regards to the NTP BCP, I finally did submit the updates we made in response to the INTDIR review to datatracker, on 31 July.
So, we consider that done, and we can start working with Suresh on the next steps.

Best Regards,

- Denis

--
Denis Reilly  |  Lead Engineer  |  [email-masked]<mailto:[email-masked]>  (585)321-5837<tel:(585)%20321-5837>

From: ntp <[email-masked]> On Behalf Of Karen O'Donoghue
Sent: Wednesday, August 15, 2018 3:59 PM
To: [email-masked]; [email-masked]
Subject: [Ntp] Summary notes from IETF 102

Folks,

Regards,
Karen

*********************
IETF 102 Summary…

TICTOC
------

1588v2 YANG module

NTP
---

NTP MAC

NTP Data Minimization

Interleaved Modes

NTS for NTP

REFID Updates

NTP Correction Field