Subject: Re: [Ntp] WGLC: draft-ietf-ntp-data-minimization

From: "Salz, Rich" <[email-masked]>
Date: Thu, 30 Aug 2018 18:16:37 +0000

https://datatracker.ietf.org/doc/draft-ietf-ntp-data-minimization/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dntp-2Ddata-2Dminimization_&d=DwMFAg&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=5iYWQiWDVhN9rLrLpPsCRkhzxWZHskY76f-iQSnFawM&s=3uRvu0XyYQHKGWgEdarsyNcbdSh8thv5eoui4VLyuA8&e=>

Sorry, a bit late but a couple of minor editorial suggestions.

  *   The Poll field MAY be set to the actual polling interval as
  *         specified by RFC 5905, or else MAY be set to zero.

I think this editorial is better, fits with the other text in that section
                The Poll field SHOULD be set to either the actual polling intercal as specified by RFC 5905 or zero.

  *   This requirement shall not be construed so as to prohibit servers from rejecting …

Maybe
                Servers may reject …
Is simpler and has the same meaning?  Not a big deal.  But a bigger issue is that this DOES impose requirements on servers. So I would change

  *   will remain fully interoperable with existing servers
to “should remain …”

---

From: Loganaden Velvindron <[email-masked]>
Date: Thu, 30 Aug 2018 23:08:41 +0400

Sorry for the late feedback as well. During an IETF Hackathon, there
were issues with this part of the draft:

"4.2.  Transmit Timestamp Randomization

   While this memo calls for most fields in client packets to be set to
   zero, the transmit timestamp is randomized."

Quite a few people mis-interpreted this part as transmit timestamp
needs to be 0.

I think it would be clearer to write this part as :

"While this memo calls for most fields in client packets to be set to
0, the transmit timestamp SHOULD be randomized."