Subject: Re: [Ntp] Finding leap-seconds.list

From: "[email-masked]" <[email-masked]>
Date: Thu, 08 Nov 2018 06:58:06 +0300

So formally complain to the NIST calibration desk or the ITS program offices from this working group.

They (NIST) under 15usc272 are the ones obligated to provide this. Both providing it securely meanibg digitally signed, and in an ongoing manner. 

//tsg

Sent from my HTC, so please excuse any typos this keyboard sucks!

----- Reply message -----
From: "Warner Losh" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>, <[email-masked]>
Subject: [Ntp] Finding leap-seconds.list
Date: Thu, Nov 8, 2018 06:25

_______________________________________________
ntp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ntp

---

From: Hal Murray <[email-masked]>
Date: Fri, 09 Nov 2018 12:49:31 -0800

[email-masked] said:
> There's at least 5 other formats this data exists in on the internet, but ntp
> doesn't use them, nor do people grab that data and convert to the ntp
> leap-second.txt format unless they happen to need it for other purposes and
> get a 'twofer' by doing so. 

Are any of them well supported/distributed?

Would it clean things up if we switched ntpd to use one of them?

That could be done by writing a program to translate one of the other formats to what ntpd currently reads, or teaching ntpd to use a new format.

-- 
These are my opinions.  I hate spam.