Subject: Re: [Ntp] Antw: Re: Finding leap-seconds.list

From: Hal Murray <[email-masked]>
Date: Mon, 12 Nov 2018 12:41:09 -0800

[email-masked] said:
> The deadline for #6 is leap-second day, correct? ntpd only announces an
> impending leap second in the last 24 hours before the leap second. Or is that
> just a reference implementation detail. When there's no leap second the
> deadline is a few days before since that's the expiration of the previous
> file. 

The ntpd-kernel API is "leap tonight".
The ntpd-ntpd API is "leap at the end of this month".

A valid local leap-seconds file overrides the results from upstream servers.

I'm not sure what happens if ntpd has a valid leap-seconds file after it 
expires.

The early announcement on the wire gives humans a chance to verify that the servers are announcing as expected and/or maybe time to correct things if something is not right.

>>   3 TZDB releases updated copy from NIST
>>   4  distro releases update to TZDB
>>   5  end system picks up new TZDB from distro
> Also, to be clear, as far as ntpd is concerned, steps 3, 4, 5 are all
> *optional* if there's another mechanism to pull in a new leap-second.txt file
> from elsewhere. #5 implies an upgrade of at least some of the packages on the
> system. While that's *A* way to do it, there are other equally valid ways. We
> should allow for the extra time, of course, for this to happen. 

Correct.

I think the timing on alternatives will be similar so I haven't explored them.  In many cases, step 3 goes away.

> P.S. Sorry if I'm being too nit-picky here, but traditionally there's been a
> wide diversity of methods for obtaining leap-seconds.txt, and it would be
> premature to standardize on the above list. 

Doesn't look nit-picky to me.  Not even mildly so, much less "too".  Thanks for pointing it out so it gets archived.

My main goal is to avoid having every end-user workstation running a cron job pointed at some server that can't do anything about it if some distro ships a buggy version that turns into a DoS.

If your users get it from your servers, I'll be happy.

-- 
These are my opinions.  I hate spam.

---

From: Harlan Stenn <[email-masked]>
Date: Mon, 12 Nov 2018 15:26:47 -0800

> I'm not sure what happens if ntpd has a valid leap-seconds file after it 

If the file was valid but has expired, it's no longer valid.

H
--

-- 
Harlan Stenn <[email-masked]>
http://networktimefoundation.org - be a member!

---

From: Martin Burnicki <[email-masked]>
Date: Tue, 13 Nov 2018 09:27:08 +0100

> On 11/12/18 12:41 PM, Hal Murray wrote:
[...]
> If the file was valid but has expired, it's no longer valid.

Just for completeness please note:

Only starting with v4.2.8, ntpd ignores a leap second file that has
expired, which is good behavior.

Up to v4.2.6 an expired file was anyway considered valid, and was accepted.

This could lead an ugly error if a valid leap second announcement was
received from upstream time sources but was ignored just because an
expired leap second file was available.

Martin
-- 
Martin Burnicki

Senior Software Engineer

MEINBERG Funkuhren GmbH & Co. KG
Email: [email-masked]
Phone: +49 5281 9309-414
Linkedin: https://www.linkedin.com/in/martinburnicki/

Lange Wand 9, 31812 Bad Pyrmont, Germany
Amtsgericht Hannover 17HRA 100322
Geschäftsführer/Managing Directors: Günter Meinberg, Werner Meinberg,
Andre Hartmann, Heiko Gerstung
Websites: https://www.meinberg.de  https://www.meinbergglobal.com
Training: https://www.meinberg.academy

---

From: Harlan Stenn <[email-masked]>
Date: Tue, 13 Nov 2018 03:23:13 -0800

Thanks, Martin!

As per long-standing policy, we EOL'd 4.2.6 in December of 2014, for
good reason, when we released ntp-4.2.8.  4.2.8 fixed over 1100 bugs in
4.2.6.  We still offer support contracts for 4.2.6.

Just to document it:

 http://support.ntp.org/bin/view/Dev/ReleaseTimeline

Since the initial release of ntp-4.2.8 in December of 2014, we have had
12 patch releases of ntp-4.2.8.

H