Subject: [Ntp] Comments on draft-ietf-ntp-packet-timestamps-04

From: Watson Ladd <[email-masked]>
Date: Tue, 18 Dec 2018 10:17:30 -0800

Dear all,

I read the draft and have some comments. In NTP it is stated that NTP
time is the number of seconds minus the number of leap seconds. While
it is true there has never been a leap forward, such a possibility may
happen.

Secondly there should be discussion of leap smearing. We've had a
major operational outage related to leap seconds (discussed publicly
at https://blog.cloudflare.com/how-and-why-the-leap-second-affected-cloudflare-dns/)
and this has motivated some companies to adopt leap smearing. This can
result in timestamps made by services on smearing machines not quite
matching up to what other people think they should.

These aren't objections, just comments. I think the draft should go
forward and I like the example taken from another RFC of doing things
right.

Sincerely,
Watson Ladd

---

From: Tal Mizrahi <[email-masked]>
Date: Wed, 19 Dec 2018 16:33:10 +0200

Hi Watson,

Many thanks for reviewing the draft.
Please note that the current version of the draft is 05, and I believe that
both your comments were already noted with respect to draft 04, and I
believe we have addressed them in draft 05:

https://tools.ietf.org/html/draft-ietf-ntp-packet-timestamps-05

Regarding the first issue you raised (leap second being either forward or
backward), draft 05 includes the following text regarding this issue:

   A leap second may be either positive or
   negative, i.e., the clock may either be shifted one second forwards
   or backwards.  All leap seconds that have occurred up to the
   publication of this document have been in the backwards direction,

   and although forward leap seconds are theoretically possible, the

   text throughout this document focuses on the common case, which is
   the backward leap second.

Regarding the second issue of leap smearing, the following text has been
added to draft 05 as one of the possible ways of implementing a leap second:

      The clock is slowed down during the leap second and adjacent time
      intervals until the new time value catches up.  The interval for
      this process, commonly referred to as leap smear, can range from
      several seconds to several hours before, during, and/or after the
      occurrence of the leap second.

I hope these changes resolve your comments. Please let me know if they do
not.

Thanks,
Tal.

On Tue, Dec 18, 2018 at 8:17 PM Watson Ladd <watson=
[email-masked]> wrote:

> at
> https://blog.cloudflare.com/how-and-why-the-leap-second-affected-cloudflare-dns/
> )
> _______________________________________________
> ntp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ntp
>

---

From: Watson Ladd <[email-masked]>
Date: Wed, 19 Dec 2018 07:21:21 -0800

On Wed, Dec 19, 2018 at 6:33 AM Tal Mizrahi <[email-masked]> wrote:
> Please note that the current version of the draft is 05, and I believe that both your comments were already noted with respect to draft 04, and I believe we have addressed them in draft 05:
>
> Regarding the first issue you raised (leap second being either forward or backward), draft 05 includes the following text regarding this issue:
>
> Regarding the second issue of leap smearing, the following text has been added to draft 05 as one of the possible ways of implementing a leap second:
>
> I hope these changes resolve your comments. Please let me know if they do not.

They do. Next time I'll increment the number in the URL and make sure
that doesn't work before sending an email.

>
> Thanks,
> Tal.
>
>
>
>
> On Tue, Dec 18, 2018 at 8:17 PM Watson Ladd <watson=[email-masked]> wrote:
>>
>> Dear all,
>>

-- 
"Man is born free, but everywhere he is in chains".
--Rousseau.