Subject: Re: [Ntp] NTS4UPTP Rev 03 - Formal request for WG adoption

From: "Steve Guendert" <[email-masked]>
Date: Tue, 1 Jun 2021 16:33:36 -0400

Hello,

I am the IBM Z (IBM mainframe servers) time synchronization architect and
engineering lead. I have been following the thread with great interest
because our mainframe customers are quite interested in the subject.  95 of
the 100 largest banks in the world run their mission critical applications
on IBM mainframes leading many to say the world's economy runs on IBM
mainframes.  They are the largest data center environments in the world.
Time synchronization accuracy, resiliency, and security are top of mind for
their CIOs and CTOs.  I am usually quiet on these threads.  However,  since
you are debating something that is of critical urgency to my customers, on
their behalf I am "chiming in".

Many of you whom also work for "vendors" have these very same customers as
your own customers for your products.

These IBM mainframe customers  are/will be implementing unicast PTP for
their mainframe environments.   What to do for time synch security (PTP and
NTP)  is the big question.   While the core business applications run on
mainframes, these same customers have extensive open systems environments
as well, much of which could be running NTP.

I talked with the largest American multinational bank about this topic
early last week , and earlier in May with our 40 largest mainframe
customers across all industries and geographies.  The proposal off NTS4UPTP
and its ideas is very important to our customers because they see 1) PTP as
a vital part of their future, 2) the  idea provides a PTP security solution
and 3) as I said earlier, they will still use NTP for some things and the
proposal would essentially allow them to use a common security mechanism
for both NTP and PTP.  A solution that secures only NTP and leaves out PTP
is not acceptable to them.  It would leave the mainframe time synch
environment unprotected.
Now, you may be thinking, well those mainframe environments will just go
back to/stay with NTP.  Guess again.  What will happen is we will be forced
to develop something on our own for PTP that meets their needs.  Standards
based is much preferable to proprietary, but you do what the customer
demands.

Too many times, standards bodies seem to focus on "politics" or protecting
things/ideas  we may have worked on in the past or personalities.  Most of
you don't know me and I don't know you.  I'm just here as someone with
intimate first hand knowledge of what a lot of big end users of time
synchronization want   to tell you that there are a lot of very large end
user companies who would benefit greatly from adopting the proposal under
discussion.

Therefore, on behalf of IBM's mainframe customers I would like to ask for
support of the adoption of NTS4UPTP Rev 3

Regards,

Steve

Steve Guendert, Ph.D.
Time Synchronization / STP Team Leader
IBM Z Engineering and Development
Member IBM Academy of Technology Leadership Team/TC

[email-masked]
(845) 433-3664
Twitter: Steve Guendert
Linked In: Steve Guendert
My  IBM Research Homepage

"When it comes your time to die, be not like those whose hearts are filled
with the fear of death, so that when their time comes they weep and pray
for a little more time to live their lives over again in a different way.
Sing your death song and die like a hero going home."  -Chief Tecumseh
1768-1813

                                                                                      

                                                                                      

From:	[email-masked]
To:	[email-masked]
Date:	06/01/2021 02:03 PM
Subject:	[EXTERNAL] ntp Digest, Vol 47, Issue 6
Sent by:	"ntp" <[email-masked]>

Send ntp mailing list submissions to
		 [email-masked]

To subscribe or unsubscribe via the World Wide Web, visit

https://www.ietf.org/mailman/listinfo/ntp

or, via email, send a message with subject or body 'help' to
		 [email-masked]

You can reach the person managing the list at
		 [email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of ntp digest..."
Today's Topics:

   1. Re: NTS4UPTP Rev 03 - Formal request for WG adoption (Danny Mayer)
   2. Re: NTS4UPTP Rev 03 - Formal request for WG adoption
      (Daniel Franke)
   3. Re: NTS4UPTP Rev 03 - Formal request for WG adoption
      (Daniel Franke)
   4. Re: NTS4UPTP Rev 03 - Formal request for WG adoption (Danny Mayer)
   5. Re: NTS4UPTP Rev 03 - Formal request for WG adoption
      (Daniel Franke)

----- Message from Danny Mayer <[email-masked]> on Tue, 1 Jun 2021
13:24:24 -0400 -----
                                                                                              
      To: Miroslav Lichvar <[email-masked]>, Heiko Gerstung                              
          <heiko.gerstung=[email-masked]>                                       
                                                                                              
      cc: "[email-masked]" <[email-masked]>                                                       
                                                                                              
 Subject: Re: [Ntp] NTS4UPTP Rev 03 - Formal request for WG adoption                          

On 6/1/21 11:42 AM, Miroslav Lichvar wrote:
>
> I'm not sure I follow here. You can send NTP requests at any rate you
> like. That doesn't require a new protocol. The poll field is a signed
> 8-bit integer if you had a server that actually looked in the content
> of the field.

I hope not. How would you implement a negative poll interval? :)

It really should be unsigned. If not, then that's really an error.

Danny

----- Message from Daniel Franke <[email-masked]> on Tue, 1 Jun 2021
13:28:57 -0400 -----
                                                                                                                   
      To: Danny Mayer <[email-masked]>                                                                    
                                                                                                                   
      cc: Miroslav Lichvar <[email-masked]>, Heiko Gerstung <heiko.gerstung=[email-masked]>,    
          NTP WG <[email-masked]>                                                                                    
                                                                                                                   
 Subject: Re: [Ntp] NTS4UPTP Rev 03 - Formal request for WG adoption                                               

It's in units of log2(seconds) so a negative value makes fine sense. E.g.
-1 means half a second.

On Tue, Jun 1, 2021, 13:24 Danny Mayer <[email-masked]> wrote:

  On 6/1/21 11:42 AM, Miroslav Lichvar wrote:
  >
  > I'm not sure I follow here. You can send NTP requests at any rate you
  > like. That doesn't require a new protocol. The poll field is a signed
  > 8-bit integer if you had a server that actually looked in the content
  > of the field.

  I hope not. How would you implement a negative poll interval? :)

  It really should be unsigned. If not, then that's really an error.

  Danny

  _______________________________________________
  ntp mailing list
  [email-masked]
  https://www.ietf.org/mailman/listinfo/ntp
  ----- Message from Daniel Franke <[email-masked]> on Tue, 1 Jun
  2021 13:37:21 -0400 -----
                                                                                                                   
      To: Danny Mayer <[email-masked]>                                                                    
                                                                                                                   
      cc: Miroslav Lichvar <[email-masked]>, Heiko Gerstung <heiko.gerstung=[email-masked]>,    
          NTP WG <[email-masked]>                                                                                    
                                                                                                                   
 Subject: Re: [Ntp] NTS4UPTP Rev 03 - Formal request for WG adoption                                               

Anyway, I believe I explained early last April how a negative polling
interval might be implemented :-P

On Tue, Jun 1, 2021, 13:28 Daniel Franke <[email-masked]> wrote:
  It's in units of log2(seconds) so a negative value makes fine sense. E.g.
  -1 means half a second.

  On Tue, Jun 1, 2021, 13:24 Danny Mayer <[email-masked]> wrote:

   On 6/1/21 11:42 AM, Miroslav Lichvar wrote:
   >
   > I'm not sure I follow here. You can send NTP requests at any rate you
   > like. That doesn't require a new protocol. The poll field is a signed
   > 8-bit integer if you had a server that actually looked in the content
   > of the field.

   I hope not. How would you implement a negative poll interval? :)

   It really should be unsigned. If not, then that's really an error.

   Danny

   _______________________________________________
   ntp mailing list
   [email-masked]
   https://www.ietf.org/mailman/listinfo/ntp
   ----- Message from Danny Mayer <[email-masked]> on Tue, 1 Jun
   2021 13:54:24 -0400 -----
                                                                                                                   
      To: Daniel Franke <[email-masked]>                                                                     
                                                                                                                   
      cc: Heiko Gerstung <heiko.gerstung=[email-masked]>, Miroslav Lichvar <[email-masked]>,    
          NTP WG <[email-masked]>                                                                                    
                                                                                                                   
 Subject: Re: [Ntp] NTS4UPTP Rev 03 - Formal request for WG adoption                                               

Noone should be using a polling interval that small. Oversampling is as bad
as undersampling.

Danny

On 6/1/21 1:28 PM, Daniel Franke wrote:
      It's in units of log2(seconds) so a negative value makes fine sense.
      E.g. -1 means half a second.

      On Tue, Jun 1, 2021, 13:24 Danny Mayer <[email-masked]>
      wrote:

        On 6/1/21 11:42 AM, Miroslav Lichvar wrote:
        >
        > I'm not sure I follow here. You can send NTP requests at any rate
        you
        > like. That doesn't require a new protocol. The poll field is a
        signed
        > 8-bit integer if you had a server that actually looked in the
        content
        > of the field.

        I hope not. How would you implement a negative poll interval? :)

        It really should be unsigned. If not, then that's really an error.

        Danny

        _______________________________________________
        ntp mailing list
        [email-masked]
        https://www.ietf.org/mailman/listinfo/ntp

      _______________________________________________
      ntp mailing list
      [email-masked]
      https://www.ietf.org/mailman/listinfo/ntp

      ----- Message from Daniel Franke <[email-masked]> on Tue, 1 Jun
      2021 14:03:06 -0400 -----
                                                                                                                   
      To: Danny Mayer <[email-masked]>                                                                    
                                                                                                                   
      cc: Heiko Gerstung <heiko.gerstung=[email-masked]>, Miroslav Lichvar <[email-masked]>,    
          NTP WG <[email-masked]>                                                                                    
                                                                                                                   
 Subject: Re: [Ntp] NTS4UPTP Rev 03 - Formal request for WG adoption                                               

Depends on your clock discipline algorithm. Yes, if you feed an excessive
number of samples into a underdamped PLL then your clock is just going to
bounce around a lot without ever getting more accurate. But e.g. a Kalman
filter should happily slurp up as many samples as you throw at it. Having
more information can't be bad unless you use it badly.

On Tue, Jun 1, 2021, 13:54 Danny Mayer <[email-masked]> wrote:
  Noone should be using a polling interval that small. Oversampling is as
  bad as undersampling.

  Danny

  On 6/1/21 1:28 PM, Daniel Franke wrote:
        It's in units of log2(seconds) so a negative value makes fine
        sense. E.g. -1 means half a second.

        On Tue, Jun 1, 2021, 13:24 Danny Mayer <[email-masked]>
        wrote:

         On 6/1/21 11:42 AM, Miroslav Lichvar wrote:
         >
         > I'm not sure I follow here. You can send NTP requests at any
         rate you
         > like. That doesn't require a new protocol. The poll field is a
         signed
         > 8-bit integer if you had a server that actually looked in the
         content
         > of the field.

         I hope not. How would you implement a negative poll interval? :)

         It really should be unsigned. If not, then that's really an error.

         Danny

         _______________________________________________
         ntp mailing list
         [email-masked]
         https://www.ietf.org/mailman/listinfo/ntp

        _______________________________________________
        ntp mailing list
        [email-masked]
        https://www.ietf.org/mailman/listinfo/ntp
        _______________________________________________
        ntp mailing list
        [email-masked]
        https://www.ietf.org/mailman/listinfo/ntp

---

From: Daniel Franke <[email-masked]>
Date: Tue, 1 Jun 2021 16:49:52 -0400

On Tue, Jun 1, 2021 at 4:34 PM Steve Guendert <[email-masked]>
wrote:

> These IBM mainframe customers  are/will be implementing *unicast* PTP for
> for both NTP and PTP.  *A solution that secures only NTP and leaves out
> PTP is not acceptable to them. * *It would leave the mainframe time synch
> environment unprotected.  *
What are the desiderata of "secure PTP" in your view and that of your
customers? What must it guarantee, and what adversaries must it guarantee
them against?

---

From: "Langer, Martin" <[email-masked]>
Date: Tue, 1 Jun 2021 23:28:14 +0000

Hello all,

I would like to express my point of view here, even though I am very busy at
the moment and can therefore only follow the discussion to a limited extent.
I am supporting the NTS4UPTP draft, because I also think we need a solution
for PTP. Using a pure NTS secured NTP as watchdog is not sufficient in my opinion.

This discussion applies to my proposal (NTS4PTP) as well. I deliberately haven't
pushed it yet, as it's still under revision. I hope to be able to read all the comments
on this topic next week and be a bit more precise about my point of view.

best regards,

Martin

-------------------
Martin Langer, M.Eng.
Ostfalia Hochschule für angewandte Wissenschaften
- Hochschule Braunschweig/Wolfenbüttel
University of Applied Sciences

Labor Datentechnik, Labor Design Digitaler Systeme
Fakultät Elektrotechnik
Salzdahlumer Straße 46/48
38302 Wolfenbüttel
Germany

Tel.: +49 5331 939 43370
Web: https://www.ostfalia.de/cms/de/pws/bermbach/mitarbeiter/martin-langer

________________________________
Von: ntp <[email-masked]> im Auftrag von Daniel Franke <[email-masked]>
Gesendet: Dienstag, 1. Juni 2021 22:49:52
An: Steve Guendert
Cc: NTP WG
Betreff: Re: [Ntp] NTS4UPTP Rev 03 - Formal request for WG adoption

On Tue, Jun 1, 2021 at 4:34 PM Steve Guendert <[email-masked]<mailto:[email-masked]>> wrote:

Hello,

I am the IBM Z (IBM mainframe servers) time synchronization architect and engineering lead. I have been following the thread with great interest because our mainframe customers are quite interested in the subject.  95 of the 100 largest banks in the world run their mission critical applications on IBM mainframes leading many to say the world's economy runs on IBM mainframes.  They are the largest data center environments in the world. Time synchronization accuracy, resiliency, and security are top of mind for their CIOs and CTOs.  I am usually quiet on these threads.  However,  since you are debating something that is of critical urgency to my customers, on their behalf I am "chiming in".

Many of you whom also work for "vendors" have these very same customers as your own customers for your products.

These IBM mainframe customers  are/will be implementing unicast PTP for their mainframe environments.   What to do for time synch security (PTP and NTP)  is the big question.   While the core business applications run on mainframes, these same customers have extensive open systems environments as well, much of which could be running NTP.

I talked with the largest American multinational bank about this topic early last week , and earlier in May with our 40 largest mainframe customers across all industries and geographies.  The proposal off NTS4UPTP and its ideas is very important to our customers because they see 1) PTP as a vital part of their future, 2) the  idea provides a PTP security solution and 3) as I said earlier, they will still use NTP for some things and the proposal would essentially allow them to use a common security mechanism for both NTP and PTP.  A solution that secures only NTP and leaves out PTP is not acceptable to them.  It would leave the mainframe time synch environment unprotected.
Now, you may be thinking, well those mainframe environments will just go back to/stay with NTP.  Guess again.  What will happen is we will be forced to develop something on our own for PTP that meets their needs.  Standards based is much preferable to proprietary, but you do what the customer demands.

Too many times, standards bodies seem to focus on "politics" or protecting things/ideas  we may have worked on in the past or personalities.  Most of you don't know me and I don't know you.  I'm just here as someone with intimate first hand knowledge of what a lot of big end users of time synchronization want   to tell you that there are a lot of very large end user companies who would benefit greatly from adopting the proposal under discussion.

Therefore, on behalf of IBM's mainframe customers I would like to ask for support of the adoption of NTS4UPTP Rev 3

What are the desiderata of "secure PTP" in your view and that of your customers? What must it guarantee, and what adversaries must it guarantee them against?