Subject: [Ntp] Francesca Palombini's Discuss on draft-ietf-ntp-yang-data-model-15: (with DISCUSS and COMMENT)

From: Francesca Palombini via Datatracker <[email-masked]>
Date: Wed, 30 Jun 2021 09:15:55 -0700

Francesca Palombini has entered the following ballot position for
draft-ietf-ntp-yang-data-model-15: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ntp-yang-data-model/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Thank you for the work on this document.

I have a simple-to-solve DISCUSS point, and some non blocking comments.

Francesca

1. -----

        leaf clock-precision {
          type int8;
          units "Hz";

FP: I believe the units should be seconds here.

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

2. -----

  typedef ntp-date-and-time {
    type union {
      type yang:date-and-time;
      type uint8;
    }
    description
      "Follows the normal date-and-time format when valid value
       exist, otherwise allows for setting special value such as
       zero.";

FP: I'd rather the document avoided the term "normal", which could be just
removed. Also, could a 'reference' be added, pointing to RFC 6991?

3. -----

        "The association was configured or dynamic
         which result in clock synchronization.";

FP: This sentence doesn't parse correctly for me. Is there any text missing? Or
maybe a wrong copy paste?

4. -----

      description
        "Configuration to control access to NTP service
         by using NTP access-group feature.
         The access-mode identifies how the acl is
         applied with NTP.";

FP: (here and other places) please make sure the capitalization of ACL is
consistent in the descriptions and in the text of the doc.

---

From: "Ulrich Windl" <[email-masked]>
Date: Thu, 01 Jul 2021 08:26:33 +0200

I fully agree to the discussion items, i.e.: the items need discussion.

>>> Francesca Palombini via Datatracker <[email-masked]> schrieb am
30.06.2021 um
18:15 in Nachricht <[email-masked]>:
> draft‑ietf‑ntp‑yang‑data‑model‑15: Discuss
> 
> Please refer to https://www.ietf.org/iesg/statement/discuss‑criteria.html 
> https://datatracker.ietf.org/doc/draft‑ietf‑ntp‑yang‑data‑model/ 
> 
> 
> 
> ‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑
> DISCUSS:
> ‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑
> 
> I have a simple‑to‑solve DISCUSS point, and some non blocking comments.
> 
> Francesca
> 
> 
> 1. ‑‑‑‑‑
> 
>         leaf clock‑precision {
>           type int8;
>           units "Hz";
> 
> ‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑
> COMMENT:
> ‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑‑
> 
> 2. ‑‑‑‑‑
> 
>   typedef ntp‑date‑and‑time {
>     type union {
>       type yang:date‑and‑time;
>       type uint8;
>     }
>     description
>       "Follows the normal date‑and‑time format when valid value
> 3. ‑‑‑‑‑
> FP: This sentence doesn't parse correctly for me. Is there any text missing?

> Or
> 4. ‑‑‑‑‑
>          by using NTP access‑group feature.
>          The access‑mode identifies how the acl is
>          applied with NTP.";
> 
> _______________________________________________
> ntp mailing list
> [email-masked] 
> https://www.ietf.org/mailman/listinfo/ntp