Subject: [nvo3] NVo3 Framework draft

From: Lucy yong <[email-masked]>
Date: Wed, 23 May 2012 21:18:11 +0000

To the draft authors:

Here are some comments about the NVo3 framework draft, draft-lasserre-nvo3-framework-01.txt

1.
Section 2.2 state: The NVE functionality could reside solely on the End Devices, on the
   ToRs or on both the End Devices and the ToRs.

Section 4.2.5 state: In the case of ELAN service, it can be switched by a local VM switch or ToR switch and then by a DC gateway. The NVE function can be embedded within any of these elements.

Question: Should NVE function reside on DC gateway or not?

2. It seems that some DC applications may also require VNI connecting external switch without overlay module. For example, One NVo3 instance connects many Tenant End Systems and also need to connect to Internet. Should the architecture reference model capture this as well?

3. Some DC applications also require a L2 Tenant instance and L3 Tenant instance interconnection on a NVE. Should the document describe this too?

4. Section 2.3 NVE Service Type. Comment: The service Type associates with Tenant Instance as described in the dp-reqs draft associates, not NVE.

5. Figure 5 should be Figure 4 and include multiple Tenant Instances. Figure 6 should be Figure 5. (no draw as Figure 4)

6. Section 3.2 Service Overlay Topologies. Suggest not use of "a tunnel mesh". IP tunnel provides one hop nature between NVEs but is an aggregated tunnel.

6. It would be nice to align the terms in the framework draft and data plane req. draft since authors are the same.

Cheers,
Lucy

---

From: "LASSERRE, MARC (MARC)" <[email-masked]>
Date: Thu, 24 May 2012 11:32:39 +0200

Lucy,

Thanks for your comments.
See my answers inline.

Marc

________________________________
From: Lucy yong [mailto:[email-masked]]
Sent: Wednesday, May 23, 2012 11:18 PM
To: [email-masked]; LASSERRE, MARC (MARC); Balus, Florin Stelian (Florin)
Subject: NVo3 Framework draft

To the draft authors:

1.

[ml] It may but it can also be part of a VM switch or ToR.

[ml] Sure. We'll try to capture this in the next revision.

[ml]  It does not preclude it... Can you be more specific as to what you would like described?

[ml] An NVE provides L2 and/or L3 services. The corresponding VNI (which is specific per tenant) is either an L2 or an L3 "context"

[ml] Thanks. We'll fix it.

[ml] ok

[ml] It is planned.

Cheers,
Lucy

---

From: Lucy yong <[email-masked]>
Date: Thu, 24 May 2012 17:02:23 +0000

Marc,

Pasted:

-end

[LY] In the dp-req draft, it states "integrated routing and bridging per
   tenant must be supported on an NVE. An instantiation of such service
   may be realized by interconnecting an L2 VNI as access to an L3 VNI
   on the NVE."

The framework document should describe the ability in supporting this. The interface is needed for L2 VNI and L3 VNI interconnection on an NVE and this interface is not VAP because configuration and management of this interface is very different from VAP.

I can provide some text if you agree on the addition.

BR,
Lucy

From: LASSERRE, MARC (MARC) [mailto:[email-masked]]
Sent: Thursday, May 24, 2012 4:33 AM
To: Lucy yong; [email-masked]; Balus, Florin Stelian (Florin)
Subject: RE: NVo3 Framework draft

Lucy,

Marc

To the draft authors:

1.

[ml] ok

[ml] It is planned.

Cheers,
Lucy

---

From: "LASSERRE, MARC (MARC)" <[email-masked]>
Date: Thu, 24 May 2012 19:38:16 +0200

Hi Lucy,

Thanks for suggesting some text for us to look at.

Marc

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lucy yong
Sent: Thursday, May 24, 2012 7:02 PM
To: LASSERRE, MARC (MARC); [email-masked]; Balus, Florin Stelian (Florin)
Subject: Re: [nvo3] NVo3 Framework draft

Marc,

Pasted:

-end

BR,
Lucy

Lucy,

Marc

To the draft authors:

1.

[ml] ok

[ml] It is planned.

Cheers,
Lucy