Subject: [nvo3] Virtual Network - what's an instance?

From: "Black, David" <[email-masked]>
Date: Tue, 18 Jun 2013 19:24:19 -0400

In working on some control plane draft material, I've run across an
inconsistency in the use of the concept of a "virtual network instance"
(or VNI) between the problem statement and framework drafts.

The problem statement draft does not define "virtual network instance"
and uses that term more or less interchangeably with "virtual network"
to refer to a specific virtual network.  Here's an example with both
terms used in the same sentence near the top of p.5:

   A key requirement is that each
   individual virtual network instance be isolated from other virtual
   network instances, with traffic crossing from one virtual network to
   another only when allowed by policy.

The framework draft defines Virtual Network Instance (VNI) as effectively
being the portion of a virtual network that is instantiated in an NVE:

       VNI: Virtual Network Instance. This is one instance of a virtual 
       overlay network. It refers to the state maintained for a given VN on 
       a given NVE. Two Virtual Networks are isolated from one another and 
       may use overlapping addresses.

Something's wrong here.  Back in February, Thomas Narten proposed that
we use the problem statement terminology consistently in the framework
draft, but there hasn't been any further discussion.

Speaking for myself, the problem statement draft's usage seems more
intuitive (an "instance" of a virtual network is a virtual network, not
part of one, as is the case in the framework draft), but we've had the
VNI acronym around in the framework draft for a good long time now.

If it were ok to change the framework draft, I would prefer:

       VNLI: Virtual Network Local Instance.  This is an instance of a
	 virtual overlay network on a specific NVE. The VNLI refers to the
       local state and associated processing for a given VN on a given
       NVE.  Within an NVE, VNLIs are isolated from one another and
       may use overlapping network addresses.

But that's just my 0.02 - what should be done about this?

Thanks,
--David
----------------------------------------------------
David L. Black, Distinguished Engineer
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

---

From: "LASSERRE, MARC (MARC)" <[email-masked]>
Date: Wed, 19 Jun 2013 07:53:38 +0000

Hi David,

In the soon-to-be-published revision of the framework draft, the VN & VNI definitions stand as:

Virtual Network (VN): A VN is a logical abstraction of a physical network that provides L2 or L3 network services to a set of Tenant Systems. A VN is also known as a Closed User Group (CUG).

Virtual Network Instance (VNI): A specific instance of a VN.

I think that this addresses your concern.

Marc

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Black, David
> Sent: Wednesday, June 19, 2013 1:24 AM
> To: [email-masked]
> Subject: [nvo3] Virtual Network - what's an instance?
> 
> In working on some control plane draft material, I've run 
> across an inconsistency in the use of the concept of a 
> "virtual network instance"
> to refer to a specific virtual network.  Here's an example 
> with both terms used in the same sentence near the top of p.5:
> 
> The framework draft defines Virtual Network Instance (VNI) as 
> effectively being the portion of a virtual network that is 
> instantiated in an NVE:
> 
> Something's wrong here.  Back in February, Thomas Narten 
> proposed that we use the problem statement terminology 
> consistently in the framework draft, but there hasn't been 
> any further discussion.
> 
> Speaking for myself, the problem statement draft's usage 
> seems more intuitive (an "instance" of a virtual network is a 
> virtual network, not part of one, as is the case in the 
> framework draft), but we've had the VNI acronym around in the 
> framework draft for a good long time now.
> 
> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3
>

---

From: "Florian Mahr" <[email-masked]>
Date: Wed, 19 Jun 2013 16:06:33 +0200

Hi David,

I totally share your concerns with regard to the use of the VN/VNI concepts.

For me the terms "Virtual Network Instance" and "Virtual Network" mean the same thing,

and I think, both terms can be used interchangeably to refer to a specific virtual network.

Instead of "Virtual Network Local Instance" or "VNLI" as you suggest, I can also imagine

the term "Virtual Network Forwarding Instance" or "VNFI". By using this definition, a VN

is actually a set of one or more VNFIs interconnected by a set of L3 tunnels.

Please note that the term VNFI is independent of the service it provides (L2 or L3) as

"forwarding" can happen at both Layer 2 or Layer 3.

What do you think?

Thanks,

Florian

>>> "Black, David" <[email-masked]> 19.06.13 1.25 Uhr >>> 

Thanks, 
--David

---

From: "Black, David" <[email-masked]>
Date: Wed, 19 Jun 2013 10:47:36 -0400

Marc,

Good - that'll work well, and I'm assuming that you'll bring the rest
of the draft into line, as there is usage of the VNI acronym to refer
to the NVE-local portion of a VN (what I refer to as VNLI below).

Thanks,
--David

> From: LASSERRE, MARC (MARC) [mailto:[email-masked]]
> Sent: Wednesday, June 19, 2013 3:54 AM
> To: Black, David
> Cc: [email-masked]
> Subject: RE: Virtual Network - what's an instance?
> 
> Hi David,
> 
> Virtual Network (VN): A VN is a logical abstraction of a physical network that
> provides L2 or L3 network services to a set of Tenant Systems. A VN is also
> known as a Closed User Group (CUG).
>

---

From: Eric Gray <[email-masked]>
Date: Wed, 19 Jun 2013 14:53:02 +0000

Marc,

	It is worth noting that - while some folks do use the terms "CUG" and "VN" interchangeably,
they are not precisely synonymous.

	A VN includes the (portion of) physical network infrastructure used to connect a CUG, while 
a CUG includes only the devices thus connected.

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Black, David
Sent: Wednesday, June 19, 2013 10:48 AM
To: LASSERRE, MARC (MARC)
Cc: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Marc,

Good - that'll work well, and I'm assuming that you'll bring the rest of the draft into line, as there is usage of the VNI acronym to refer to the NVE-local portion of a VN (what I refer to as VNLI below).

Thanks,
--David

> Virtual Network (VN): A VN is a logical abstraction of a physical 
> network that provides L2 or L3 network services to a set of Tenant 
> Systems. A VN is also known as a Closed User Group (CUG).
> 
> > From: [email-masked] [mailto:[email-masked]] On Behalf 
> > Of Black, David
> > Something's wrong here.  Back in February, Thomas Narten proposed 
> > that we use the problem statement terminology consistently in the 
> > framework draft, but there hasn't been any further discussion.
> >
> > intuitive (an "instance" of a virtual network is a virtual network, 
> > not part of one, as is the case in the framework draft), but we've 
> > had the VNI acronym around in the framework draft for a good long 
> > time now.
> >
> > David L. Black, Distinguished Engineer EMC Corporation, 176 South 
> > St., Hopkinton, MA  01748

---

From: "Reith, Lothar" <[email-masked]>
Date: Wed, 19 Jun 2013 17:18:15 +0000

Eric,

I share your concern.

My view is also, that a CUG is a group, which has members, and these members being endpoints - independent of the network implementation, e.g. L2 or L3.

And with regard to the discussion on the concept  "VNLI": isn't that an endpoint (and therefore the same as a CUG member, independent of whether the network connecting the endpoints is L2 or L3?

Lothar

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Eric Gray
Gesendet: Mittwoch, 19. Juni 2013 16:53
An: LASSERRE, MARC (MARC)
Cc: Black, David; [email-masked]
Betreff: Re: [nvo3] Virtual Network - what's an instance?

Marc,

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Black, David
Sent: Wednesday, June 19, 2013 10:48 AM
To: LASSERRE, MARC (MARC)
Cc: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Marc,

Thanks,
--David

---

From: "Joe Pelissier (jopeliss)" <[email-masked]>
Date: Wed, 19 Jun 2013 22:29:19 +0000

Maybe it's just me, but the definition of VNI does not seem useful:

"Virtual Network Instance (VNI): A specific instance of a VN."
If someone did not understand what a Virtual Network Instance is, then simply adding the word "specific" does not help much.  Essentially, a VNI is a VN - the terms appear synonymous, so it would be best to simply eliminate the VNI term.

My $0.02 worth...
Joe Pelissier

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Black, David
Sent: Wednesday, June 19, 2013 7:48 AM
To: LASSERRE, MARC (MARC)
Cc: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Marc,

Thanks,
--David

---

From: Dave Hood <[email-masked]>
Date: Wed, 19 Jun 2013 23:03:01 +0000

IMO, a virtual network is the set of [network] resources exposed by a server to a client. From the client's point of view, there is only one VN. From the server's point of view, there are as many VNIs as there are clients.

Would that be a useful way to describe the difference?

Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Pelissier (jopeliss)
Sent: Wednesday, June 19, 2013 3:29 PM
To: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

My $0.02 worth...
Joe Pelissier

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Black, David
Sent: Wednesday, June 19, 2013 7:48 AM
To: LASSERRE, MARC (MARC)
Cc: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Marc,

Thanks,
--David

---

From: "Joe Pelissier (jopeliss)" <[email-masked]>
Date: Thu, 20 Jun 2013 02:55:08 +0000

Hi Dave,
Maybe I could rephrase your last sentence:
"....From the server's point of view, there are as many VNs as there are clients."
This appears to have the same meaning as your sentence, which seems to indicate the terms are synonymous.  

Cheers,
Joe

-----Original Message-----
From: Dave Hood [mailto:[email-masked]] 
Sent: Wednesday, June 19, 2013 4:03 PM
To: Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?

Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Pelissier (jopeliss)
Sent: Wednesday, June 19, 2013 3:29 PM
To: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

My $0.02 worth...
Joe Pelissier

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Black, David
Sent: Wednesday, June 19, 2013 7:48 AM
To: LASSERRE, MARC (MARC)
Cc: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Marc,

Thanks,
--David

---

From: Dave Hood <[email-masked]>
Date: Thu, 20 Jun 2013 13:00:06 +0000

Right. 

The point is that, to the client, the idea of instance is irrelevant because there is only one.

On the other hand, the server instantiates a separate VN for each client, a total of zero or more, depending on the number of clients, so VN instances are an essential concept to the server.

Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Pelissier (jopeliss)
Sent: Wednesday, June 19, 2013 7:55 PM
To: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Hi Dave,

Cheers,
Joe

-----Original Message-----
From: Dave Hood [mailto:[email-masked]]
Sent: Wednesday, June 19, 2013 4:03 PM
To: Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?

Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Pelissier (jopeliss)
Sent: Wednesday, June 19, 2013 3:29 PM
To: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

My $0.02 worth...
Joe Pelissier

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Black, David
Sent: Wednesday, June 19, 2013 7:48 AM
To: LASSERRE, MARC (MARC)
Cc: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Marc,

Thanks,
--David

---

From: "Joe Pelissier (jopeliss)" <[email-masked]>
Date: Thu, 20 Jun 2013 17:59:30 +0000

Ok, that seems to make sense, but in this case, VN Instance does not need to be a defined term.  I.e., VN is defined, and "instance" has its normal English meaning.  So maybe keep the definition of "Virtual Network", delete the definition for "Virtual Network Instance", and in the text use "Virtual Network instance" instead of "Virtual Network Instance".

Still, I doubt that there is any place that the term "Virtual Network Instance" is used that could not be replaced with "Virtual Network" since the singular form of VN is, by definition, an instance. Adding the extra word "instance" may make the intent more clear in some cases; after all, we are network engineers, so we are always promoting redundancy :-).

Cheers,
Joe Pelissier

-----Original Message-----
From: Dave Hood [mailto:[email-masked]] 
Sent: Thursday, June 20, 2013 6:00 AM
To: Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?

Right. 

Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Pelissier (jopeliss)
Sent: Wednesday, June 19, 2013 7:55 PM
To: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Hi Dave,

Cheers,
Joe

-----Original Message-----
From: Dave Hood [mailto:[email-masked]]
Sent: Wednesday, June 19, 2013 4:03 PM
To: Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?

Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Pelissier (jopeliss)
Sent: Wednesday, June 19, 2013 3:29 PM
To: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

My $0.02 worth...
Joe Pelissier

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Black, David
Sent: Wednesday, June 19, 2013 7:48 AM
To: LASSERRE, MARC (MARC)
Cc: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Marc,

Thanks,
--David

---

From: "Reith, Lothar" <[email-masked]>
Date: Fri, 21 Jun 2013 12:38:40 +0000

My 2 cents:

For a network centric engineer, there may not be a difference between a virtual network and a virtual network instance.

For a compute centric engineer (such as those creating the virtual networks via a Quantum API in OpenStack), there may very well be a fundamental difference as he may associate with " virtual network" a class, and with "virtual network instance" an object.

One key problem in IETF is, that key terms often may be loosely defined. I am afraid, that this may be just happening again (similar and related also with the term CUG).

Can someone please come up with a UML cardinality diagram, which explains the relation between VN, VNI, and CUG? 

Or tell us their view regarding which of the following statements are true:

1. There is always a one to one relation between VN and VNI (therefore the terms are actually synonymous and can be harmonized to VN)
2. There is always a 1 to n relation between VN and VNI (like between Class and object)
3. There is always a one to one relation between a VN and a CUG
4. There may be a 1:n relation between CUG and VN, i.e. the members of one CUG may be network endpoints (devices/stations/station interfaces/NICs/vNICs) in multiple VNs (or VNIs?)
5. There may be a 1:n relation between VN and CUG, i.e. a VN may have network endpoints which  are members of multiple CUGs
6. There may be an n:m relation between CUG and VN, because both 4 and 5 are true statements.

Lothar

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Joe Pelissier (jopeliss)
Gesendet: Donnerstag, 20. Juni 2013 20:00
An: [email-masked]
Betreff: Re: [nvo3] Virtual Network - what's an instance?

Cheers,
Joe Pelissier

-----Original Message-----
From: Dave Hood [mailto:[email-masked]] 
Sent: Thursday, June 20, 2013 6:00 AM
To: Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?

Right. 

Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Pelissier (jopeliss)
Sent: Wednesday, June 19, 2013 7:55 PM
To: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Hi Dave,

Cheers,
Joe

-----Original Message-----
From: Dave Hood [mailto:[email-masked]]
Sent: Wednesday, June 19, 2013 4:03 PM
To: Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?

Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Pelissier (jopeliss)
Sent: Wednesday, June 19, 2013 3:29 PM
To: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

My $0.02 worth...
Joe Pelissier

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Black, David
Sent: Wednesday, June 19, 2013 7:48 AM
To: LASSERRE, MARC (MARC)
Cc: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Marc,

Thanks,
--David

---

From: Lucy yong <[email-masked]>
Date: Fri, 21 Jun 2013 17:25:55 +0000

Here is my thought.

Use "a virtual network (VN)" to describe the virtual network function and behavior. For example, create one VN or two VNs.

Use "VNI, i.e. virtual network instance" to model that one NVE is the member in multiple virtual networks. Thus, VN and VNI has one-on-one relationship.

It is important to model NVE with following characteristics:

TSs attached to the same NVE may belong to the same or different virtual networks.
A TS attached to an NVE may participate one or more virtual networks.
An NVE has the corresponding VNIs for the virtual networks that attached TSs belong to.  

It is also important to differentiate the virtual network and tenant network.
One tenant network may contain one or more virtual networks.

Lucy

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Reith, Lothar
> Sent: Friday, June 21, 2013 7:39 AM
> For a network centric engineer, there may not be a difference between a
> virtual network and a virtual network instance.
> 
> For a compute centric engineer (such as those creating the virtual
> networks via a Quantum API in OpenStack), there may very well be a
> fundamental difference as he may associate with " virtual network" a
> class, and with "virtual network instance" an object.
> 
> One key problem in IETF is, that key terms often may be loosely defined.
> I am afraid, that this may be just happening again (similar and related
> also with the term CUG).
> 
> Can someone please come up with a UML cardinality diagram, which
> explains the relation between VN, VNI, and CUG?
> 
> 1. There is always a one to one relation between VN and VNI (therefore
> the terms are actually synonymous and can be harmonized to VN)
> 4. There may be a 1:n relation between CUG and VN, i.e. the members of
> one CUG may be network endpoints (devices/stations/station
> interfaces/NICs/vNICs) in multiple VNs (or VNIs?)
> 5. There may be a 1:n relation between VN and CUG, i.e. a VN may have
> network endpoints which  are members of multiple CUGs
> Ok, that seems to make sense, but in this case, VN Instance does not
> need to be a defined term.  I.e., VN is defined, and "instance" has its
> normal English meaning.  So maybe keep the definition of "Virtual
> Network", delete the definition for "Virtual Network Instance", and in
> the text use "Virtual Network instance" instead of "Virtual Network
> Instance".
> 
> Still, I doubt that there is any place that the term "Virtual Network
> Instance" is used that could not be replaced with "Virtual Network"
> since the singular form of VN is, by definition, an instance. Adding
> the extra word "instance" may make the intent more clear in some cases;
> after all, we are network engineers, so we are always promoting
> redundancy :-).
> 
> Cheers,
> Joe Pelissier
> 
> 
> On the other hand, the server instantiates a separate VN for each
> client, a total of zero or more, depending on the number of clients, so
> VN instances are an essential concept to the server.
> 
> Dave
> 
> IMO, a virtual network is the set of [network] resources exposed by a
> server to a client. From the client's point of view, there is only one
> VN. From the server's point of view, there are as many VNIs as there
> are clients.
> 
> If someone did not understand what a Virtual Network Instance is, then
> simply adding the word "specific" does not help much.  Essentially, a
> VNI is a VN - the terms appear synonymous, so it would be best to
> simply eliminate the VNI term.
> 
> My $0.02 worth...
> Joe Pelissier
> 
> Behalf
> > >    network instances, with traffic crossing from one virtual
> network
> > > to

---

From: Linda Dunbar <[email-masked]>
Date: Sat, 22 Jun 2013 02:15:35 +0000

My 2 cents:

One virtual network may have multiple IDs. 

Linda

> Joe Pelissier (jopeliss)
> Joe Pelissier (jopeliss)
> Black, David

---

From: "Black, David" <[email-masked]>
Date: Sat, 22 Jun 2013 15:27:40 -0400

> > explains the relation between VN, VNI, and CUG?

Please don't :-).  Here's my 0.02 ... :

a) VN and VNI (spelled out) are used interchangeably in the problem
statement draft.  I think it's a bad idea to split hairs to try to
distinguish those terms, and I definitely don't want to rewrite the
problem statement draft to make that distinction.

b) CUG appears to be a term from BGP/MPLS L3VPN space that should be
used only with such L3VPNs, not more generally.  NVO3 has settled on
VN as the basic solution-independent concept, and I think CUG only
adds confusion (e.g., as demonstrated by Lothar's message).  Let's
stick with VN.

c) The Framework draft needs a new term to identify the portion of
a VN that exists in an NVE, as VNI should not be used for that purpose -
see a) above.  That new term is not VAP, because VAP is a port abstraction,
not a network abstraction, and we need a port abstraction to identify
the entity to which TS's are connected (i.e., a TS is connected to a VAP,
possibly multiple VAPs).

In private email, I've suggested VNLI (Virtual Network Local Instance)
for c) - while I'm not strongly attached to the term, I like the use
of the word "local" to make it clear that this term designates a subset
of a VN, and is specific to an NVE.

Thanks,
--David

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Linda
> Dunbar
> Sent: Friday, June 21, 2013 10:16 PM
> To: Reith, Lothar; Joe Pelissier (jopeliss); [email-masked]

---

From: Eric Gray <[email-masked]>
Date: Thu, 27 Jun 2013 19:50:43 +0000

Joe,

	At the end of the day, every definition is either a tautology, or it is 
wrong.

	As one of my colleagues has put it, a VN is a concept and a VNI is a
realization of the concept.

	VLAN 41 may be an instance of the VLAN concept.  

	The subnet associated with a router interface IP address and its 
associated net-mask is an instance of the IP subnet concept.

	A VN is intended to be a generic concept that includes multiple
virtual-network types.  A VNI is an instance (or realization?) of a VN.

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Pelissier (jopeliss)
Sent: Wednesday, June 19, 2013 6:29 PM
To: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

My $0.02 worth...
Joe Pelissier

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Black, David
Sent: Wednesday, June 19, 2013 7:48 AM
To: LASSERRE, MARC (MARC)
Cc: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Marc,

Thanks,
--David

---

From: Eric Gray <[email-masked]>
Date: Thu, 27 Jun 2013 19:57:52 +0000

Joe,

	Not quite.  A VLAN is a VN.  So is an IPv4 or IPv6 subnet.

	A VNI is a specific VN.

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Pelissier (jopeliss)
Sent: Thursday, June 20, 2013 2:00 PM
To: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Cheers,
Joe Pelissier

-----Original Message-----
From: Dave Hood [mailto:[email-masked]]
Sent: Thursday, June 20, 2013 6:00 AM
To: Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?

Right. 

Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Pelissier (jopeliss)
Sent: Wednesday, June 19, 2013 7:55 PM
To: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Hi Dave,

Cheers,
Joe

-----Original Message-----
From: Dave Hood [mailto:[email-masked]]
Sent: Wednesday, June 19, 2013 4:03 PM
To: Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?

Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Pelissier (jopeliss)
Sent: Wednesday, June 19, 2013 3:29 PM
To: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

My $0.02 worth...
Joe Pelissier

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Black, David
Sent: Wednesday, June 19, 2013 7:48 AM
To: LASSERRE, MARC (MARC)
Cc: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Marc,

Thanks,
--David

---

From: "smith, erik" <[email-masked]>
Date: Thu, 27 Jun 2013 16:11:11 -0400

Eric, if VNI is required to describe an instance of a VN, why isn't VLANI required to describe an instance of a VLAN?

Regards, Erik  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Eric Gray
Sent: Thursday, June 27, 2013 3:51 PM
To: Joe Pelissier (jopeliss); [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Joe,

	At the end of the day, every definition is either a tautology, or it is wrong.

	As one of my colleagues has put it, a VN is a concept and a VNI is a realization of the concept.

	The subnet associated with a router interface IP address and its associated net-mask is an instance of the IP subnet concept.

	A VN is intended to be a generic concept that includes multiple virtual-network types.  A VNI is an instance (or realization?) of a VN.

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Pelissier (jopeliss)
Sent: Wednesday, June 19, 2013 6:29 PM
To: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

My $0.02 worth...
Joe Pelissier

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Black, David
Sent: Wednesday, June 19, 2013 7:48 AM
To: LASSERRE, MARC (MARC)
Cc: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Marc,

Thanks,
--David

---

From: Eric Gray <[email-masked]>
Date: Thu, 27 Jun 2013 20:18:36 +0000

David,

	The problem statement draft does not use the term VNI, at all.

	I was surprised to hear you say this, so I checked.  :-)

	The PS draft does use the phrase "virtual network instance" (a lot) - 
but it uses the term in the sense of distinguishing the concept of a "virtual 
network" from a specific virtual network (in fact, the words "each", "specific", 
"particular", "different" and/or "individual" are frequently - if not consistently 
- used with the phrase).

	There are some cases where the phrase "virtual network instance"
could arguably have been replaced with "virtual network" - but that would
very likely have provoked argument in return.

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Black, David
Sent: Saturday, June 22, 2013 3:28 PM
To: Reith, Lothar; [email-masked]
Cc: Black, David
Subject: Re: [nvo3] Virtual Network - what's an instance?

a) VN and VNI (spelled out) are used interchangeably in the problem statement draft.  I think it's a bad idea to split hairs to try to distinguish those terms, and I definitely don't want to rewrite the problem statement draft to make that distinction.

b) CUG appears to be a term from BGP/MPLS L3VPN space that should be used only with such L3VPNs, not more generally.  NVO3 has settled on VN as the basic solution-independent concept, and I think CUG only adds confusion (e.g., as demonstrated by Lothar's message).  Let's stick with VN.

c) The Framework draft needs a new term to identify the portion of a VN that exists in an NVE, as VNI should not be used for that purpose - see a) above.  That new term is not VAP, because VAP is a port abstraction, not a network abstraction, and we need a port abstraction to identify the entity to which TS's are connected (i.e., a TS is connected to a VAP, possibly multiple VAPs).

In private email, I've suggested VNLI (Virtual Network Local Instance) for c) - while I'm not strongly attached to the term, I like the use of the word "local" to make it clear that this term designates a subset of a VN, and is specific to an NVE.

Thanks,
--David

> Of Linda Dunbar
> > Of Reith, Lothar
> > For a network centric engineer, there may not be a difference 
> > between a virtual network and a virtual network instance.
> >
> > I am afraid, that this may be just happening again (similar and 
> > related also with the term CUG).
> >
> > Or tell us their view regarding which of the following statements 
> > are
> > true:
> >
> > 1. There is always a one to one relation between VN and VNI 
> > (therefore the terms are actually synonymous and can be harmonized 
> > to VN) 2. There is always a 1 to n relation between VN and VNI (like 
> > between Class and object) 3. There is always a one to one relation 
> > between a VN and a CUG 4. There may be a 1:n relation between CUG 
> > and VN, i.e. the members of one CUG may be network endpoints 
> > (devices/stations/station
> > interfaces/NICs/vNICs) in multiple VNs (or VNIs?) 5. There may be a 
> > 1:n relation between VN and CUG, i.e. a VN may have network 
> > endpoints which  are members of multiple CUGs 6. There may be an n:m 
> > relation between CUG and VN, because both 4 and
> > 5 are true statements.
> >
> > Lothar
> >
> >
> >
> >
> > need to be a defined term.  I.e., VN is defined, and "instance" has 
> > its normal English meaning.  So maybe keep the definition of 
> > "Virtual Network", delete the definition for "Virtual Network 
> > Instance", and in the text use "Virtual Network instance" instead of 
> > "Virtual Network Instance".
> >
> > Still, I doubt that there is any place that the term "Virtual 
> > Network Instance" is used that could not be replaced with "Virtual Network"
> > the extra word "instance" may make the intent more clear in some 
> > cases; after all, we are network engineers, so we are always 
> > promoting redundancy :-).
> >
> > Cheers,
> > Joe Pelissier
> >
> >
> > client, a total of zero or more, depending on the number of clients, 
> > so VN instances are an essential concept to the server.
> >
> > Dave
> >
> > Of Joe Pelissier (jopeliss)
> > IMO, a virtual network is the set of [network] resources exposed by 
> > a server to a client. From the client's point of view, there is only 
> > one VN. From the server's point of view, there are as many VNIs as 
> > there are clients.
> >
> > Of Joe Pelissier (jopeliss)
> > If someone did not understand what a Virtual Network Instance is, 
> > then simply adding the word "specific" does not help much.  
> > Essentially, a VNI is a VN - the terms appear synonymous, so it 
> > would be best to simply eliminate the VNI term.
> >
> > My $0.02 worth...
> > Joe Pelissier
> >
> > Good - that'll work well, and I'm assuming that you'll bring the 
> > rest of the draft into line, as there is usage of the VNI acronym to 
> > refer to the NVE-local portion of a VN (what I refer to as VNLI below).
> >
> > Thanks,
> > --David
> >
> > > From: LASSERRE, MARC (MARC) 
> > > [mailto:[email-masked]]
> > > > In working on some control plane draft material, I've run across 
> > > > an inconsistency in the use of the concept of a "virtual network 
> > > > instance"
> > > > consistently in the framework draft, but there hasn't been any further discussion.
> > > >
> > > > Speaking for myself, the problem statement draft's usage seems 
> > > > more intuitive (an "instance" of a virtual network is a virtual 
> > > > network, not part of one, as is the case in the framework 
> > > > draft), but we've had the VNI acronym around in the framework 
> > > > draft for a good long time now.
> > > >
> > > >        VNLI: Virtual Network Local Instance.  This is an 
> > > > instance
> > of a
> > > > David L. Black, Distinguished Engineer EMC Corporation, 176 
> > > > South St., Hopkinton, MA  01748

---

From: Eric Gray <[email-masked]>
Date: Thu, 27 Jun 2013 20:28:03 +0000

Erik,

	Weird talking to someone whose name is "correctly spelled" according
to most of my Ericsson colleagues - which is already strange enough.  :-)

	Specific VLANs (i.e. - VLAN instances) are identified by a VID (VLAN ID).
Specific IP subnets (i.e. - IP Subnet instances) are identified in a somewhat more 
complicated way.

	If we need to talk about generic concepts, we need to differentiate the
generic concept of a virtual network from the equally generic concept of a specific
instance of a virtual network.

--
Eric

-----Original Message-----
From: smith, erik [mailto:[email-masked]] 
Sent: Thursday, June 27, 2013 4:11 PM
To: Eric Gray; Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?
Importance: High

Regards, Erik  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Eric Gray
Sent: Thursday, June 27, 2013 3:51 PM
To: Joe Pelissier (jopeliss); [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Joe,

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Pelissier (jopeliss)
Sent: Wednesday, June 19, 2013 6:29 PM
To: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

My $0.02 worth...
Joe Pelissier

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Black, David
Sent: Wednesday, June 19, 2013 7:48 AM
To: LASSERRE, MARC (MARC)
Cc: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Marc,

Thanks,
--David

---

From: "smith, erik" <[email-masked]>
Date: Thu, 27 Jun 2013 18:49:17 -0400

Ha..that's funny...  I was going to complement you on your correct spelling (because it's the way the everyone spells my name by default)! :-)  

To borrow your format:

Specific VNs (i.e. - VN instances) are identified by a VNID (Virtual Network ID)

My point is, if the statement "VLAN 41 may be an instance of the VLAN concept" is technically correct (and I believe it is), then why wouldn't "VN 41 may be an instance of the VN concept", "the tenant's VN" or "there's a problem with VN 41"  also be acceptable?  Why should we have to append "I" to "VN" in each case?  If the answer is "we don't", then can anyone provide a specific scenario where VNI must be used?

Regards, Erik    

-----Original Message-----
From: Eric Gray [mailto:[email-masked]] 
Sent: Thursday, June 27, 2013 4:28 PM
To: smith, erik; Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?

Erik,

	Weird talking to someone whose name is "correctly spelled" according to most of my Ericsson colleagues - which is already strange enough.  :-)

	Specific VLANs (i.e. - VLAN instances) are identified by a VID (VLAN ID).
Specific IP subnets (i.e. - IP Subnet instances) are identified in a somewhat more complicated way.

	If we need to talk about generic concepts, we need to differentiate the generic concept of a virtual network from the equally generic concept of a specific instance of a virtual network.

--
Eric

-----Original Message-----
From: smith, erik [mailto:[email-masked]]
Sent: Thursday, June 27, 2013 4:11 PM
To: Eric Gray; Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?
Importance: High

Regards, Erik  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Eric Gray
Sent: Thursday, June 27, 2013 3:51 PM
To: Joe Pelissier (jopeliss); [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Joe,

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Pelissier (jopeliss)
Sent: Wednesday, June 19, 2013 6:29 PM
To: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

My $0.02 worth...
Joe Pelissier

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Black, David
Sent: Wednesday, June 19, 2013 7:48 AM
To: LASSERRE, MARC (MARC)
Cc: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Marc,

Thanks,
--David

---

From: "Joe Pelissier (jopeliss)" <[email-masked]>
Date: Thu, 27 Jun 2013 23:49:46 +0000

Still trying to find an example of a case in which the term Virtual Network could not be used instead of Virtual Network Instance.  And more importantly, given that Virtual Network is a defined term, why does Virtual Network Instance need a definition given that "Instance" in this case has the normal English meaning of "instance".   And most importantly, let's not define a Virtual Network Instance as "a specific instance of a virtual network".  Reminds of the Star Trek Movie:

SPOCK: And who is the Creator? 
 ILIA PROBE: The Creator is that which created V'Ger. 
 KIRK: Who is V'Ger? 
 ILIA PROBE: V'Ger is that which seeks the Creator.

Joe Pelissier

-----Original Message-----
From: smith, erik [mailto:[email-masked]] 
Sent: Thursday, June 27, 2013 3:49 PM
To: Eric Gray; Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?

To borrow your format:

Regards, Erik    

-----Original Message-----
From: Eric Gray [mailto:[email-masked]]
Sent: Thursday, June 27, 2013 4:28 PM
To: smith, erik; Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?

Erik,

--
Eric

-----Original Message-----
From: smith, erik [mailto:[email-masked]]
Sent: Thursday, June 27, 2013 4:11 PM
To: Eric Gray; Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?
Importance: High

Regards, Erik  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Eric Gray
Sent: Thursday, June 27, 2013 3:51 PM
To: Joe Pelissier (jopeliss); [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Joe,

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Pelissier (jopeliss)
Sent: Wednesday, June 19, 2013 6:29 PM
To: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

My $0.02 worth...
Joe Pelissier

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Black, David
Sent: Wednesday, June 19, 2013 7:48 AM
To: LASSERRE, MARC (MARC)
Cc: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Marc,

Thanks,
--David

---

From: "Black, David" <[email-masked]>
Date: Thu, 27 Jun 2013 20:43:01 -0400

Eric,

>       The PS draft does use the phrase "virtual network instance" (a lot) -

Well, the framework draft's definition of VNI starts with:

       VNI: Virtual Network Instance.

and continues with a definition that does not match the problem statement
draft's usage of "virtual network instance" that is described in your
message.

I would think that "Virtual Network Instance" (framework draft) and
"virtual network instance" (problem statement draft) ought to be the
same term - do you disagree?

Thanks,
--David

> Sent: Thursday, June 27, 2013 4:19 PM
> To: Black, David; Reith, Lothar; [email-masked]
> a) VN and VNI (spelled out) are used interchangeably in the problem statement
> draft.  I think it's a bad idea to split hairs to try to distinguish those
> terms, and I definitely don't want to rewrite the problem statement draft to
> make that distinction.
>
> b) CUG appears to be a term from BGP/MPLS L3VPN space that should be used only
> with such L3VPNs, not more generally.  NVO3 has settled on VN as the basic
> solution-independent concept, and I think CUG only adds confusion (e.g., as
> demonstrated by Lothar's message).  Let's stick with VN.
>
> c) The Framework draft needs a new term to identify the portion of a VN that
> exists in an NVE, as VNI should not be used for that purpose - see a) above.
> That new term is not VAP, because VAP is a port abstraction, not a network
> abstraction, and we need a port abstraction to identify the entity to which
> TS's are connected (i.e., a TS is connected to a VAP, possibly multiple VAPs).
>
> In private email, I've suggested VNLI (Virtual Network Local Instance) for c)
> - while I'm not strongly attached to the term, I like the use of the word
> "local" to make it clear that this term designates a subset of a VN, and is
> specific to an NVE.
>
> Thanks,
> --David
>

---

From: Eric Gray <[email-masked]>
Date: Fri, 28 Jun 2013 11:50:36 +0000

Erik,

Well, one issue is that we would minimally need to include "VNI" in an 
acronym expansion.  I believe we can all agree that the English language
interpretation of "instance" fits the way we are using it.  But this may 
not be important enough to worry about, given how late in the cycle we
are in discussing this WRT to framework draft, and - if the English usage
is correct - then the "definition" is also correct.

In fact, it would have been nice if we could have used the acronym VNI
instead of spelling it out in the problem statement draft.  It might have
been a whole page shorter.

For many of us, there is a reason to distinguish a VN from a VNI.

For instance, in talking about the various approaches that might be used
to implement virtual network overlays, one might use the phrase "specific
VN" to mean a VN of a specific type, but not necessarily a specific VNI.

A specific VN might - for instance - be a VLAN, or an IP subnet, without 
being a specific instance of either.  Therefore, it is possible to distinguish
a "specific VN" from a "specific VNI."

Either a VN, or a VNI may be implemented using BGP/MPLS VPNs, VPLS, 
NVGRE, etc.  In the VN case, we may talk about the technology/approach
used while in the VNI case, were talking about a specific VN instance.

Your reference to "VNID" below doesn't help and may be an illustrative
example of why the distinction is needed.  For some approaches that may
be used, the technology provides its own "VNID" while for others, either
the way that the VN would otherwise be identified is more complicated
than desired (hence a numerical identifier that maps to a more complex
real identification may be useful), or there isn't a way to identify a VN of
that type at present (so we invent one).

A VN of a certain type may be identified by a VNID of a certain type.  A VNI
is identified by a specific VNID for its associated type.

--
Eric

-----Original Message-----
From: smith, erik [mailto:[email-masked]] 
Sent: Thursday, June 27, 2013 6:49 PM
To: Eric Gray; Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?
Importance: High

To borrow your format:

Regards, Erik    

-----Original Message-----
From: Eric Gray [mailto:[email-masked]]
Sent: Thursday, June 27, 2013 4:28 PM
To: smith, erik; Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?

Erik,

--
Eric

-----Original Message-----
From: smith, erik [mailto:[email-masked]]
Sent: Thursday, June 27, 2013 4:11 PM
To: Eric Gray; Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?
Importance: High

Regards, Erik  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Eric Gray
Sent: Thursday, June 27, 2013 3:51 PM
To: Joe Pelissier (jopeliss); [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Joe,

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Pelissier (jopeliss)
Sent: Wednesday, June 19, 2013 6:29 PM
To: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

My $0.02 worth...
Joe Pelissier

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Black, David
Sent: Wednesday, June 19, 2013 7:48 AM
To: LASSERRE, MARC (MARC)
Cc: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Marc,

Thanks,
--David

---

From: "Reith, Lothar" <[email-masked]>
Date: Fri, 28 Jun 2013 13:52:23 +0000

Assuming that an NVI would make sense, what would be a sensible namespace for the NVI. For simple VLANs, the namespace is just integer from 1 to 4094.

For other layer 2 VNs, the namespace maybe larger, such as the VXLAN defined namespace for VNs allowing roundabout 16 million VXLAN VNs per domain - assuming that  a VXLAN section-ID is a valid VNI of a VN of type layer 2 VN.

And what about Layer3 VN, could someone please provide an example of a Layer 3 VN VNI.  Is a CIDR a valid VNI? Is an autonomous system number a valid VNI? 

In that context I like to raise the question: 

Do we need a VN-type to differentiate a VXLAN based VN with the ID "41" (VNI41) from a VLAN with VID 41 (VLAN41), and from a VNI identifying a specific instance of a VN that is a layer3 VN?

In summary, I share the view of those that question the necessity of VNI. Of course it would be a different story, if the draft specifies a VNI namespace.

In closing, I would also appreciate if someone could point me to an authoritative IETF definition of the term network.

Lothar 

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Joe Pelissier (jopeliss)
Gesendet: Freitag, 28. Juni 2013 01:50
An: [email-masked]
Betreff: Re: [nvo3] Virtual Network - what's an instance?

Joe Pelissier

-----Original Message-----
From: smith, erik [mailto:[email-masked]] 
Sent: Thursday, June 27, 2013 3:49 PM
To: Eric Gray; Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?

To borrow your format:

Regards, Erik    

-----Original Message-----
From: Eric Gray [mailto:[email-masked]]
Sent: Thursday, June 27, 2013 4:28 PM
To: smith, erik; Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?

Erik,

--
Eric

-----Original Message-----
From: smith, erik [mailto:[email-masked]]
Sent: Thursday, June 27, 2013 4:11 PM
To: Eric Gray; Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?
Importance: High

Regards, Erik  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Eric Gray
Sent: Thursday, June 27, 2013 3:51 PM
To: Joe Pelissier (jopeliss); [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Joe,

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Pelissier (jopeliss)
Sent: Wednesday, June 19, 2013 6:29 PM
To: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

My $0.02 worth...
Joe Pelissier

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Black, David
Sent: Wednesday, June 19, 2013 7:48 AM
To: LASSERRE, MARC (MARC)
Cc: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Marc,

Thanks,
--David

---

From: Eric Gray <[email-masked]>
Date: Fri, 28 Jun 2013 14:05:29 +0000

Lothar,

	You must be joking, of course.

	The IETF does not have a consensus definition for the term "Authoritative."

	If we can't agree on what it means to be "authoritative" how can we agree
on an "authoritative definition" for anything?

	Thus we introduce the self-referential observation:

	"This statement is not authoritative" - causing V'Ger to crash...

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Reith, Lothar
Sent: Friday, June 28, 2013 9:52 AM
To: Joe Pelissier (jopeliss); [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Lothar 

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Joe Pelissier (jopeliss)
Gesendet: Freitag, 28. Juni 2013 01:50
An: [email-masked]
Betreff: Re: [nvo3] Virtual Network - what's an instance?

Joe Pelissier

-----Original Message-----
From: smith, erik [mailto:[email-masked]]
Sent: Thursday, June 27, 2013 3:49 PM
To: Eric Gray; Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?

To borrow your format:

Regards, Erik    

-----Original Message-----
From: Eric Gray [mailto:[email-masked]]
Sent: Thursday, June 27, 2013 4:28 PM
To: smith, erik; Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?

Erik,

--
Eric

-----Original Message-----
From: smith, erik [mailto:[email-masked]]
Sent: Thursday, June 27, 2013 4:11 PM
To: Eric Gray; Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?
Importance: High

Regards, Erik  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Eric Gray
Sent: Thursday, June 27, 2013 3:51 PM
To: Joe Pelissier (jopeliss); [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Joe,

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Pelissier (jopeliss)
Sent: Wednesday, June 19, 2013 6:29 PM
To: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

My $0.02 worth...
Joe Pelissier

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Black, David
Sent: Wednesday, June 19, 2013 7:48 AM
To: LASSERRE, MARC (MARC)
Cc: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Marc,

Thanks,
--David

---

From: Lucy yong <[email-masked]>
Date: Fri, 28 Jun 2013 14:44:14 +0000

Here is my 2cent.

Why do we now run into the language and term conflict issue in nvo3?

We used similar terms such as VSI, VFI, VRI etc in L2VPN and L3VPN before to present multiple xx instances on a device. There are many documents developed in L2VPN and L3VPN WGs. We did not have problem there. 

Regards,
Lucy

> Eric Gray
> Sent: Friday, June 28, 2013 6:51 AM
> Ha..that's funny...  I was going to complement you on your correct
> spelling (because it's the way the everyone spells my name by
> default)! :-)
> 
> To borrow your format:
> 
> My point is, if the statement "VLAN 41 may be an instance of the VLAN
> concept" is technically correct (and I believe it is), then why
> wouldn't "VN 41 may be an instance of the VN concept", "the tenant's
> VN" or "there's a problem with VN 41"  also be acceptable?  Why should
> we have to append "I" to "VN" in each case?  If the answer is "we
> don't", then can anyone provide a specific scenario where VNI must be
> used?
> 
> Regards, Erik
> 
> 
> 	Weird talking to someone whose name is "correctly spelled"
> according to most of my Ericsson colleagues - which is already strange
> enough.  :-)
> 
> 	If we need to talk about generic concepts, we need to
> differentiate the generic concept of a virtual network from the equally
> generic concept of a specific instance of a virtual network.
> 
> --
> Eric
> 
> Eric, if VNI is required to describe an instance of a VN, why isn't
> VLANI required to describe an instance of a VLAN?
> 
> Regards, Erik
> 
> Eric Gray

---

From: "Black, David" <[email-masked]>
Date: Fri, 28 Jun 2013 11:38:40 -0400

HI Lucy,

Short answer: the problem statement draft's use of "virtual network instance"
and much of the discussion here (including Eric's note below) does not limit
the scope of "virtual network instance" (VNI) to "on a device".

The framework draft needs a term for that concept (portion of a specific
virtual network that is on a specific device") and as of now, "virtual
network instance" has been taken by the problem statement draft with a
broader meaning, making VNI problematic for that purpose.

IMHO, We need to decide whether a "virtual network instance" is limited to
"on a device" or not and modify the problem statement or framework draft
accordingly.

Thanks,
--David

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Lucy
> yong
> Sent: Friday, June 28, 2013 10:44 AM
> To: Eric Gray; smith, erik; Joe Pelissier (jopeliss); [email-masked]
> We used similar terms such as VSI, VFI, VRI etc in L2VPN and L3VPN before to
> present multiple xx instances on a device. There are many documents developed
> in L2VPN and L3VPN WGs. We did not have problem there.
> 
> Regards,
> Lucy
> 
> 
> 
>

---

From: Eric Gray <[email-masked]>
Date: Fri, 28 Jun 2013 15:44:58 +0000

David,

	I do not disagree.  My earlier comments were based on Marc's 
"extracted" definition for VNI - which is what everyone else was also
responding to.

	The full definition in the current posted Framework draft is:

"VNI: Virtual Network Instance. This is one instance of a virtual
   overlay network. It refers to the state maintained for a given VN on
   a given NVE. Two Virtual Networks are isolated from one another and
   may use overlapping addresses."

	You mentioned this earlier in this thread (though that part of
the thread is now pretty hard to read).

	I strongly suspect that the extra detail in the full definition may
have assuaged some concerns raised in the discussion about the way
we defined it - since it clearly says more than Marc's extracted version
below.

	However, I'm unsure how the detailed version is inconsistent
with the way we used the phrase in the problem statement draft.  It
is perhaps somewhat more specific to a host operating system (in the
reference to VN state maintained in an NVE) - but the meaning seems 
to be the same.

	It is simply a more detailed way of saying what Marc said below
- i.e. - it is "[a] specific instance of a VN ."

	Also, from what Marc said, I assume that the definition that is
present in the "soon to be published version" is significantly briefer
than the definition in the currently posted version.

	This seems to indicate that the definition is no longer the one
that you referred to earlier and seem to be referring to now.

	Perhaps we are confusing things by referring to the posted 
version, after having been told that the current up-to-date draft has
a different definition?

	That being the case, it seems that the definition in the "soon
to be published version" is in alignment with the way that we use the
phrase in the problem statement draft.

--
Eric	

-----Original Message-----
From: Black, David [mailto:[email-masked]] 
Sent: Thursday, June 27, 2013 8:43 PM
To: Eric Gray; [email-masked]
Subject: RE: Virtual Network - what's an instance?
Importance: High

Eric,

and continues with a definition that does not match the problem statement draft's usage of "virtual network instance" that is described in your message.

I would think that "Virtual Network Instance" (framework draft) and "virtual network instance" (problem statement draft) ought to be the same term - do you disagree?

Thanks,
--David

>       The PS draft does use the phrase "virtual network instance" (a 
> lot) - but it uses the term in the sense of distinguishing the concept 
> of a "virtual network" from a specific virtual network (in fact, the 
> words "each", "specific", "particular", "different" and/or 
> "individual" are frequently - if not consistently
> - used with the phrase).
>
> could arguably have been replaced with "virtual network" - but that 
> would very likely have provoked argument in return.
>
> --
> Eric
>
> adds confusion (e.g., as demonstrated by Lothar's message).  Let's stick with VN.
>
> c) The Framework draft needs a new term to identify the portion of a 
> VN that exists in an NVE, as VNI should not be used for that purpose - see a) above.
> That new term is not VAP, because VAP is a port abstraction, not a 
> network abstraction, and we need a port abstraction to identify the 
> entity to which TS's are connected (i.e., a TS is connected to a VAP, possibly multiple VAPs).
>
> for c)
> - while I'm not strongly attached to the term, I like the use of the 
> word "local" to make it clear that this term designates a subset of a 
> VN, and is specific to an NVE.
>
> Thanks,
> --David
>
> > > Behalf Of Reith, Lothar
> > > fundamental difference as he may associate with " virtual network" 
> > > a class, and with "virtual network instance" an object.
> > >
> > > to VN) 2. There is always a 1 to n relation between VN and VNI 
> > > (like between Class and object) 3. There is always a one to one 
> > > relation between a VN and a CUG 4. There may be a 1:n relation 
> > > between CUG and VN, i.e. the members of one CUG may be network 
> > > endpoints (devices/stations/station
> > > interfaces/NICs/vNICs) in multiple VNs (or VNIs?) 5. There may be 
> > > a 1:n relation between VN and CUG, i.e. a VN may have network 
> > > endpoints which  are members of multiple CUGs 6. There may be an 
> > > n:m relation between CUG and VN, because both 4 and
> > > 5 are true statements.
> > >
> > > Lothar
> > >
> > >
> > >
> > >
> > > Ok, that seems to make sense, but in this case, VN Instance does 
> > > not need to be a defined term.  I.e., VN is defined, and 
> > > "instance" has its normal English meaning.  So maybe keep the 
> > > definition of "Virtual Network", delete the definition for 
> > > "Virtual Network Instance", and in the text use "Virtual Network 
> > > instance" instead of "Virtual Network Instance".
> > >
> > > since the singular form of VN is, by definition, an instance. 
> > > Adding the extra word "instance" may make the intent more clear in 
> > > some cases; after all, we are network engineers, so we are always 
> > > client, a total of zero or more, depending on the number of 
> > > clients, so VN instances are an essential concept to the server.
> > >
> > > Dave
> > >
> > > Behalf Of Joe Pelissier (jopeliss)
> > > This appears to have the same meaning as your sentence, which 
> > > seems to indicate the terms are synonymous.
> > >
> > > Cheers,
> > > Joe
> > >
> > > IMO, a virtual network is the set of [network] resources exposed 
> > > by a server to a client. From the client's point of view, there is 
> > > only one VN. From the server's point of view, there are as many 
> > > VNIs as there are clients.
> > >
> > > Behalf Of Joe Pelissier (jopeliss)
> > > rest of the draft into line, as there is usage of the VNI acronym 
> > > to refer to the NVE-local portion of a VN (what I refer to as VNLI below).
> > >
> > > Thanks,
> > > --David
> > >
> > > > Virtual Network (VN): A VN is a logical abstraction of a 
> > > > physical network that provides L2 or L3 network services to a 
> > > > set of Tenant Systems. A VN is also known as a Closed User Group (CUG).
> > > >
> > > > > with
> > > both
> > > > > consistently in the framework draft, but there hasn't been any 
> > > > > further
> discussion.
> > > > >
> > > > > more intuitive (an "instance" of a virtual network is a 
> > > > >        virtual overlay network on a specific NVE. The VNLI 
> > > > > refers to
> > > the
> > > > >        local state and associated processing for a given VN on 
> > > > > a
> > > given

---

From: Lucy yong <[email-masked]>
Date: Fri, 28 Jun 2013 15:49:24 +0000

So this is because that the problem statement already uses it for different meaning. 

Should the framework draft support the consistency to L2VPN/L3VPN or the nvo3 problem statement? 
L2/L3VPN documents were generated much early without the description issues.

Regards,
Lucy

> Sent: Friday, June 28, 2013 10:39 AM
> To: Lucy yong; [email-masked]
> Cc: Black, David
> Of Lucy
> Behalf Of
> > > interpretation of "instance" fits the way we are using it.  But
> this
> > > may
> > > instead of spelling it out in the problem statement draft.  It
> might
> > > have
> > > real identification may be useful), or there isn't a way to
> identify a
> > > VN of
> > > A VN of a certain type may be identified by a VNID of a certain
> type.
> > > A VNI
> > > Specific VNs (i.e. - VN instances) are identified by a VNID
> (Virtual
> > > Network ID)
> > >
> > > Specific IP subnets (i.e. - IP Subnet instances) are identified in
> a
> > > somewhat more complicated way.
> > >
> Behalf Of
> then
> Behalf Of
> rest
> > > > In the soon-to-be-published revision of the framework draft, the
> VN &
> > > > VNI definitions stand as:
> > > >
> across an
> proposed
> more
> > > > > 	 virtual overlay network on a specific NVE. The VNLI refers
> to
> > > the

---

From: Eric Gray <[email-masked]>
Date: Fri, 28 Jun 2013 16:24:57 +0000

Folks need to back up a bit.  From the discussion, it certainly looks like the
definition in the framework draft has changed.  In my opinion, the changed
version is in alignment with the usage in the problem statement draft.

That seems to be a good thing.

Folks in this thread are talking about several things:
o	What the definition was in the previous (currently posted) version
	of the framework draft.
o	What the definition seems to be in the most up-to-date version of
	the framework draft (soon to be posted/published?).
o	What the definition should be - according to a number of different
	perspectives.

There are a few too many variants of a definition for VNI being discussed for
anyone to make much sense in the discussion to anyone else.  Let's wait to 
see what the definition actually is, before we spin things out of control.

By the way, IMHO, we don't really need definitions for state maintained by
a host in this respect.  For one thing, the OS vendors may want to take an
exception to our telling them how to do what they do.  So it is unclear to me
why we need a term to talk about this.

Assuming we actually do need to do this (certainly possible), I don't see why
we cannot simply use the phrase "Host per-VNI state information."  We could
even allow that - from a host perspective - this may be equivalent to the term
"VNI."

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lucy yong
Sent: Friday, June 28, 2013 11:49 AM
To: Black, David; [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Regards,
Lucy

> and much of the discussion here (including Eric's note below) does not 
> limit the scope of "virtual network instance" (VNI) to "on a device".
> 
> The framework draft needs a term for that concept (portion of a 
> specific virtual network that is on a specific device") and as of now, 
> "virtual network instance" has been taken by the problem statement 
> draft with a broader meaning, making VNI problematic for that purpose.
> 
> IMHO, We need to decide whether a "virtual network instance" is 
> limited to "on a device" or not and modify the problem statement or 
> framework draft accordingly.
> 
> Thanks,
> --David
> 
> > > Well, one issue is that we would minimally need to include "VNI" 
> > > in
> an
> > > acronym expansion.  I believe we can all agree that the English 
> > > language interpretation of "instance" fits the way we are using 
> > > it.  But
> this
> > > may
> > > not be important enough to worry about, given how late in the 
> > > cycle
> we
> > > are in discussing this WRT to framework draft, and - if the 
> > > English usage is correct - then the "definition" is also correct.
> > >
> > > For instance, in talking about the various approaches that might 
> > > be used to implement virtual network overlays, one might use the 
> > > phrase "specific VN" to mean a VN of a specific type, but not 
> > > necessarily a specific
> VNI.
> > >
> > > A specific VN might - for instance - be a VLAN, or an IP subnet, 
> > > without being a specific instance of either.  Therefore, it is 
> > > possible to distinguish a "specific VN" from a "specific VNI."
> > >
> > > Either a VN, or a VNI may be implemented using BGP/MPLS VPNs, 
> > > VPLS, NVGRE, etc.  In the VN case, we may talk about the
> technology/approach
> > > example of why the distinction is needed.  For some approaches 
> > > that
> may
> > > be used, the technology provides its own "VNID" while for others, 
> > > either the way that the VN would otherwise be identified is more
> complicated
> > > Eric, if VNI is required to describe an instance of a VN, why 
> > > isn't VLANI required to describe an instance of a VLAN?
> > >
> > > Regards, Erik
> > >
> > > virtual-network types.  A VNI is an instance (or realization?) of 
> > > a
> VN.
> > >
> > > --
> > > Eric
> > >
> > > simply adding the word "specific" does not help much.  
> > > Essentially,
> a
> > > > set of
> Tenant
> > > > >        NVE.  Within an NVE, VNLIs are isolated from one 
> > > > > another
> and

---

From: "Reith, Lothar" <[email-masked]>
Date: Fri, 28 Jun 2013 17:18:02 +0000

Hi Eric,

well, I may have been a little bit unprecise and intentionally provoking, which may have lead to your impression, that I was joking.

I was only partly joking, and I try to be a bit more precise now - without joking.

I was trying to begin a mathematical proof, that the idea of VNI is wrong.

In mathematics, there is this method of indirect proof. You start with the assumption, that VNI makes sense, and lead it through logical conclusions to some conclusion, that is absurd. As a result, you have mathematically proven, that the assumption was wrong.

Let us try with the assumption, that the terms VN and VNI are not synonymous. This means that there must exist a VNI, which is not the same as a VN.

Since the difference lies in the word instance, the difference must come from this word. There must exist a virtual network, which is not an instance of a virtual network.

If someone comes up with an example of such a virtual network which is not an instance of a virtual network, I would tend to agree with those wanting to keep the term VNI.

With respect to the namespace, this is another argument against VNI. 

What must happens at the time of the creation of the virtual network instance? Of course the instance must be named, otherwise you cannot refer to it, and you cannot prove that it exists, nor can you distinguish it from another VN instance. 

Therefore, the more precise question I should have asked is, from how many different namespaces do we anticipate that the name of newly a created VN instance will be taken? 

And what distinguishes these namespaces? 

Will we have different namespaces for:
Simple L2 VNs: string type: e.g. VLAN1-VLAN4094 or integer type: 1-4094
IETF defined L2 VNs: e.g. 24 bit unsigned integer (VXLAN Section ID)
IEEE defined L2 VNs: e.g. 24 bit unsigned integer  (I-SID)
IETF defined L3 VN: e.g. route distinguisher or something else?

If really multiple different namespaces  must be used, then there may be a requirement for the definition of a VN type, and an explanation how these types differ, which is missing currently, and which may be a cause of confusion as I have the impression, that some people may confuse such VN type with that thing, which is a VN but not a VN instance.

Or will a future IETF draft specify a single unified VNI namespace: for example: the name that identifies a VNI is of type String, and you have to parse the string to find out if it is a L2 VN or a L3 VN?

And regarding my other joke (using the word authoritative): okay, I would already be happy if someone points me to any IETF definition of the term "network", because I want to check if the IETF definition(s) of the term "network" and the IETF definition(s) of the term "virtual network" are aligned, before we discuss if the IETF definitions of the terms "virtual network" and "virtual network instance" are aligned.

Lothar 
Ceterum censeo terminem "VNI" esse delendam 

-----Ursprüngliche Nachricht-----
Von: Eric Gray [mailto:[email-masked]] 
Gesendet: Freitag, 28. Juni 2013 16:05
An: Reith, Lothar; Joe Pelissier (jopeliss)
Cc: [email-masked]
Betreff: RE: Virtual Network - what's an instance?

Lothar,

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Reith, Lothar
Sent: Friday, June 28, 2013 9:52 AM
To: Joe Pelissier (jopeliss); [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Lothar 

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Joe Pelissier (jopeliss)
Gesendet: Freitag, 28. Juni 2013 01:50
An: [email-masked]
Betreff: Re: [nvo3] Virtual Network - what's an instance?

Joe Pelissier

-----Original Message-----
From: smith, erik [mailto:[email-masked]]
Sent: Thursday, June 27, 2013 3:49 PM
To: Eric Gray; Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?

To borrow your format:

Regards, Erik    

-----Original Message-----
From: Eric Gray [mailto:[email-masked]]
Sent: Thursday, June 27, 2013 4:28 PM
To: smith, erik; Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?

Erik,

--
Eric

-----Original Message-----
From: smith, erik [mailto:[email-masked]]
Sent: Thursday, June 27, 2013 4:11 PM
To: Eric Gray; Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?
Importance: High

Regards, Erik  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Eric Gray
Sent: Thursday, June 27, 2013 3:51 PM
To: Joe Pelissier (jopeliss); [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Joe,

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Pelissier (jopeliss)
Sent: Wednesday, June 19, 2013 6:29 PM
To: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

My $0.02 worth...
Joe Pelissier

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Black, David
Sent: Wednesday, June 19, 2013 7:48 AM
To: LASSERRE, MARC (MARC)
Cc: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Marc,

Thanks,
--David

---

From: Eric Gray <[email-masked]>
Date: Sat, 29 Jun 2013 02:29:15 +0000

Lothar,

	So, we've wandered into the weeds.  The logical argument style you refer
to is usually referred to as "reductio ad absurdum" (or "argumentum ad absurdum")
which might be a clue about where we are headed with this.

	Logic allows us to err with confidence.  We need to be careful about that.

	As has already come up, the inclusion of "self-reference" is one easy way 
to make any logical argument arrive at any conclusion you might like to arrive at.

	Another is to assert, as an Axiom, something that depends on the desired
conclusion - possibly in some subtle way.

	In this case, you assert that - because the difference between VN and VNI
is the word "instance" - the difference has to be about the word "instance."

	Sounds reasonable?  No.

	This argument could be applied to the difference between Egg and Egg Shell.
It could also be applied to any number of similar analogies.  And here we have the
absurdity: the difference between an Egg and Egg Shell is not that one has a shell
and the other does not.

	Further, the argument style does not require counter examples.  If you want
to prove that the hypothesis "a VN is not necessarily the same as a VNI" leads to an
absurdity, you have to show the constructive steps that take you there - not make a
statement that it does and then challenge somebody to show you an example that 
proves you are wrong.

	As it happens, however, examples have already been provided.  

	Lucy Yong pointed out that the term is consistent with similar usage in other 
contexts - where people have felt it necessary to distinguish a logical concept from a 
specific instantiation of that logical concept.  

	David Black pointed out that the definition in the currently posted version of
the framework draft includes "additional stuff" (specifically, it includes a reference
to state information in an NVE about a specific VN).  This also is consistent with the
usages that Lucy referred to.

	I've pointed out that the term VN may refer to an IP subnet without referring
to a specific IP subnet, but that a VNI (that happens to also be an IP subnet) must be
a specific IP subnet.

	I would also argue that the definition that includes a reference to VN state
information on specific devices can be made more general by saying that a VNI is the
state information maintained in all devices associated with a specific VN instance.
And this can be simplified to "a VNI is an instance of a VN that is identifiable to all 
(virtual) devices that are part of a specific VN" or - even simpler - "a VNI is an instance
of a specific VN."

--
Eric

-----Original Message-----
From: Reith, Lothar [mailto:[email-masked]] 
Sent: Friday, June 28, 2013 1:18 PM
To: Eric Gray; Joe Pelissier (jopeliss)
Cc: [email-masked]
Subject: AW: Virtual Network - what's an instance?
Importance: High

Hi Eric,

Will we have different namespaces for:
Simple L2 VNs: string type: e.g. VLAN1-VLAN4094 or integer type: 1-4094 IETF defined L2 VNs: e.g. 24 bit unsigned integer (VXLAN Section ID) IEEE defined L2 VNs: e.g. 24 bit unsigned integer  (I-SID) IETF defined L3 VN: e.g. route distinguisher or something else?

Lothar

-----Ursprüngliche Nachricht-----
Von: Eric Gray [mailto:[email-masked]] 
Gesendet: Freitag, 28. Juni 2013 16:05
An: Reith, Lothar; Joe Pelissier (jopeliss)
Cc: [email-masked]
Betreff: RE: Virtual Network - what's an instance?

Lothar,

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Reith, Lothar
Sent: Friday, June 28, 2013 9:52 AM
To: Joe Pelissier (jopeliss); [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Lothar 

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Joe Pelissier (jopeliss)
Gesendet: Freitag, 28. Juni 2013 01:50
An: [email-masked]
Betreff: Re: [nvo3] Virtual Network - what's an instance?

Joe Pelissier

-----Original Message-----
From: smith, erik [mailto:[email-masked]]
Sent: Thursday, June 27, 2013 3:49 PM
To: Eric Gray; Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?

To borrow your format:

Regards, Erik    

-----Original Message-----
From: Eric Gray [mailto:[email-masked]]
Sent: Thursday, June 27, 2013 4:28 PM
To: smith, erik; Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?

Erik,

--
Eric

-----Original Message-----
From: smith, erik [mailto:[email-masked]]
Sent: Thursday, June 27, 2013 4:11 PM
To: Eric Gray; Joe Pelissier (jopeliss); [email-masked]
Subject: RE: Virtual Network - what's an instance?
Importance: High

Regards, Erik  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Eric Gray
Sent: Thursday, June 27, 2013 3:51 PM
To: Joe Pelissier (jopeliss); [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Joe,

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Pelissier (jopeliss)
Sent: Wednesday, June 19, 2013 6:29 PM
To: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

My $0.02 worth...
Joe Pelissier

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Black, David
Sent: Wednesday, June 19, 2013 7:48 AM
To: LASSERRE, MARC (MARC)
Cc: [email-masked]
Subject: Re: [nvo3] Virtual Network - what's an instance?

Marc,

Thanks,
--David

---

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Mon, 1 Jul 2013 03:21:41 +0000

OK, I'll weigh in on this.

The problem statement uses the non-capitalized phrase "virtual network
instance" to mean one specific virtual network.  It could just as well be
replace with "a specific virtual network".

One way to fix to this is to change the problem statement to either remove
the word "instance" when it falls directly after "virtual network", or
replace the term "virtual network instance" with "specific virtual
network", or "instance of a virtual network".

The framework is more precise in its definition of VNI.  Regardless of
what the old or new definition is, let me quote how the term is being used
in the framework in a few places:

"One or more VNIs can be instantiated on an NVE. Tenant Systems
interface with a corresponding VNI via a Virtual Access Point (VAP)."

"The VNI represents a set of configuration attributes defining access
and tunnel policies and (L2 and/or L3) forwarding functions."

"In a multi-tenant context, the tunnel aggregates frames from/to
       different VNIs. Tenant identification and traffic demultiplexing are
based on the VN Context identifier (e.g., VNID)."

This context seems consistent with the currently published definition of
term, regardless of what the new definition will be.

Now regarding identifiers for a specific virtual network, the framework
has defined two related terms, VN Context and VNID, defined as follows:

"Virtual Network Context or VN Context: Field that is part of the
       overlay encapsulation header which allows the encapsulated frame to
       be delivered to the appropriate virtual network endpoint by the
       egress NVE. The egress NVE uses this field to determine the
       appropriate virtual network context in which to process the packet.
       This field MAY be an explicit, unique (to the administrative domain)
       virtual network identifier (VNID) or MAY express the necessary
       context information in other ways (e.g., a locally significant
identifier)."

"VNID:  Virtual Network Identifier. In the case where the VN context
       identifier has global significance, this is the ID value that is
       carried in each data packet in the overlay encapsulation that
identifies the Virtual Network the packet belongs to."

So, it is the VN Context that maps within the NVE to a VNI (A VNI is not
the same as a VLAN ID, a VNID would be) and it seems like it is up to the
implementation of the NVE whether it will allow different technologies to
use the same context values.

Also note that in draft-kreeger-nvo3-overlay-cp-04, the following
additional related terms are defined that may help answer some of the
questions I have seen raised in this thread.

"VN Alias:  A string name for a VN as used by administrators and
      customers to name a specific VN.  A VN Alias is a human-usable
      string that can be listed in contracts, customer forms, email,
      configuration files, etc. and that can be communicated easily
      vocally (e.g., over the phone).  A VN Alias is independent of the
      underlying technology used to implement a VN and will generally
      not be carried in protocol fields of control protocols used in
      virtual networks.  Rather, a VN Alias will be mapped into a VN
      Name where precision is required.

"VN Name:  A globally unique identifier for a VN suitable for use
      within network protocols.  A VN Name will usually be paired with a
      VN Alias, with the VN Alias used by humans as a shorthand way to
      name and identify a specific VN.  A VN Name should have a compact
      representation to minimize protocol overhead where a VN Name is
      carried in a protocol field.  Using a Universally Unique
      Identifier (UUID) as discussed in RFC 4122
<http://tools.ietf.org/html/rfc4122>, may work well because
      it is both compact and a fixed size and can be generated locally
      with a very high likelihood of global uniqueness."

 - Larry

On 6/28/13 9:24 AM, "Eric Gray" <[email-masked]> wrote:

>Lucy yong