Subject: Re: [nvo3] comments to draft-ietf-nvo3-dataplane-requirements-00

From: "LASSERRE, MARC (MARC)" <[email-masked]>
Date: Sun, 2 Jun 2013 12:08:50 +0000

Hi Linda,

See my answers inline.

Thanks,
Marc

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Friday, May 31, 2013 11:33 PM
To: [email-masked]
Subject: [nvo3] FW: comments to draft-ietf-nvo3-dataplane-requirements-00

Nabil, et al:

Here are some comments and questions to your draft:

-        3.2.1: L2 VNI:

"..standard MAC learning procedures are used: The source MAC address is learned against the VAP or the NVO3 tunnel on which the frame arrived.."

Standard MAC learning is actually: Inner MAC Source address is learned to be mapped to the outer (IP) Source address.
No, this is an L2 service. MACs are learned against ports or tunnels and not IP addresses.

"..the NVE MUST either support ingress replication or multicast. In this latter case, the NVE MUST be able to build at least a default flooding tree per VNI. In such cases, multiple VNIs MAY share the same default flooding tree."

One sentence says "at least a default flooding tree per VNI". The next sentence says "multiple VNIs may share the same default flooding tree". It is inconsistent.
No, it is consistent. When flooding tree(s) are used, it is possible for to use shared multicast trees.

I don't think it is necessary to require that "NVE MUST be able to build one flooding tree per VNI". Besides, it is  not the NVE who builds the multicast tree.
Again, the beginning of  the sentence says that either ingress replication or flooding trees have to be supported and that flooding trees can be shared.
It is the NVE's responsibility to build such trees.

-        3.2.2: L3 VNI:
"L3 VNIs MUST support per-tenant forwarding instance with IP address isolation..."

Is it same as L3VPN requirement?
Yes.

"the inner TTL field MUST be decremented by (at least) 1 as if the NVO3 egress NVE was one (or more) hop(s) Away"

Is it referring to the Ingress  NVE decrementing the TTL by 1?
Yes
 Does Egress NVE also decrement the TTL by 1?
No
Why "Away" has to be capitalized?
It is a typo.

-        4.1.1. VPN and internet GWs:
"..The translation function SHOULD NOT require provisioning touches.."

GW will need external input to match the VPN ID to the NV03 VNID. It is the "provisioning".
Why you say "Should not"?
 Agree that this is ambiguous. It will be fixed in the next revision.

Linda Dunbar

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 3 Jun 2013 15:45:35 +0000

Nabil,

"tenant system source MAC address is learned against the VAP or the NVO3 tunneling encapsulation source address on which the frame arrived.

[Linda] That is much more clear. I like your new sentence.

Does that address your comment?

<NB>

<NB> I think your comment is the "per" meaning a dedicated default tree for each VNI that is not shared by others. I think it is better to say, "In this latter case, the NVE MUST have one or more multicast trees that can be used by local VNIs for flooding to NVEs with instances of the same VNI. For each VNI, there is one flooding tree, and a  multicast tree may be dedicated per VNI or shared  across VNIs. " Thoughts?

[Linda] The "multicast trees" are built over the underlay network, isn't it? It is not really each NVE building a multicast tree. It is more like each NVE is associated with a multicast tree.

I like your statement "... multicast trees that can be used by local VNIs for flooding..."

Linda Dunbar