Subject: Re: [nvo3] Is there any difference between "Network Virtualization Overlay" and "Network Overlay"?

From: Eric Gray <[email-masked]>
Date: Mon, 3 Jun 2013 22:39:24 +0000

Agree with Larry.

Using "Network Virtualization Overlay" is just being more specific than using either overlay, or virtual
network.  The meaning of the phrase is clear.

In addition, I am unsure why we necessarily want to distinguish IP overlays from MPLS overlays, as
use of MPLS as a general IP transport mechanism means it is likely that the two may functionally overlap.

--
Eric

From: [email-masked] [mailto:[email-masked]] On Behalf Of Larry Kreeger (kreeger)
Sent: Friday, May 31, 2013 7:52 PM
To: Linda Dunbar; Thomas Narten; [email-masked]; Black, David; Murari Sridharan; [email-masked]
Subject: Re: [nvo3] Is there any difference between "Network Virtualization Overlay" and "Network Overlay"?

Hi Linda,

See my responses below, marked with LK>.

Thanks, Larry

From: Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Date: Friday, May 31, 2013 2:49 PM
To: Larry Kreeger <[email-masked]<mailto:[email-masked]>>, Thomas Narten <[email-masked]<mailto:[email-masked]>>, Dinesh Dutt <[email-masked]<mailto:[email-masked]>>, David Black <[email-masked]<mailto:[email-masked]>>, Murari Sridharan <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Is there any difference between "Network Virtualization Overlay" and "Network Overlay"?

Larry, et al:

In NV03 problem statement draft, "Network Overlay" is used. It is used in a context to indicate that virtualized network is achieved by IP overlay (instead of MPLS overlay, Ethernet Overlay, or TRILL overlay, etc).

LK> The problem statement also uses the terms "Network Virtualization" and "Network Overlay" and discusses "Using Network Overlay to provide Virtual Networks".  The document title is "Problem Statement: Overlays for Network Virtualization".

In draft-kreeger-nvo3-overlay-cp-03, "Network Virtualization Overlay" is used.

Is there any difference between "Network Virtualization Overlay" and "Network Overlay"?

LK> Network Virtualization can be achieved without using an overlay.   Network Overlays can be used for purposes other than virtualization of the network.  So, a Network Virtualization Overlay describes the more specific use case of using a Network Overlay for creating a Virtual Network.

If yes, I suggest to define them properly. If no, let's keep the terminology consistent in NVO3 WG.

LK> I don't see a formal definition in the framework document for "Network Overlay" or "Network Virtualization" either (only "Virtual Network").

NVO3 WG's charter doesn't include tackling control plane issues for all overlay models.
Therefore, it is really out of the scope to have a draft on control plane for all overlay models.

LK> Well, if you want to discuss terminology, the NVO3 WG charter discusses Data Center VPNs, a term which have not really been using much.  The charter doesn't even have the word "Overlay" in it!  I'm not sure where you are getting the impression that the control plane requirements is trying to address all overlay models based on the term "Network Virtualization Overlay". Do you have some terminology definitions you would like to see added to the Framework?  Once they are there, I will be happy to see them used consistently in all our documents.

Linda

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 4 Jun 2013 14:46:14 +0000

[Linda]When MPLS is used for IP transport, another layer of MPLS header is added to the data frame.

I would think that the reason to distinguish IP overlays from MPLS overlays is distinguish the scope of NV03 WG from L2VPN WG and L3VPN WG.

Linda
--

---

From: Lucy yong <[email-masked]>
Date: Tue, 4 Jun 2013 18:02:36 +0000

Snip...

[Lucy]  I disagree this assessment. L2VPN and L3VPN are virtualization and overlay technologies. Although they are often deployed on IP/MPLS networks now, it is not necessary. When MPLS is not available, using mpls in GRE encapsulation, L2VPN/L3VPN can be over an IP network, which fits in the NVO3 scope.

Lucy

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 4 Jun 2013 20:10:01 +0000

Snip...

. When MPLS is not available, using mpls in GRE encapsulation, L2VPN/L3VPN can be over an IP network, which fits in the NVO3 scope.

[Linda] That is exactly what I want to say: i.e. L2VPN/L3VPN achieved via IP encapsulation (GRE, VxLAN, etc) is in the scope of NVO3. The L2VPN/L3VPN achieved via MPLS encapsulation fits in the scope of L2VPN WG and L3VPN WG respectively.

Linda

---

From: Eric Gray <[email-masked]>
Date: Tue, 4 Jun 2013 20:53:09 +0000

Linda,

I could be wrong, but I think we're confusing the "scope" of the NVO3 working group with
the work that might actually get done in NVO3.

First, we need to remember that NVO3 is not currently chartered to define any solution.

It is chartered to "consider approaches to multi-tenancy that reside at the network layer"
- which certainly includes L3VPN and likely includes aspects of L2VPN that have to do with
network virtualization "at the network layer" (i.e. - over layer 3, which is how we do it).

This latter point was discussed months ago.  Because we defined L2VPN, Pseudowires,
etc. here (in the IETF), if we now discover that there are compatibility (or other) issues
with using these approaches as a network virtualization technique, we have to fix those
issues here.

It is certainly within the scope of the charter for NVO3 to evaluate this.

That does not mean that the NVO3 working group would take a direct active role in fixing
issues we find with either L2VPN or L3 VPN.  As I said, fixing issues isn't in  NVO3's charter
in any case and fixing anything that belongs to another IETF working group is an activity
that is either unlikely in NVO3, or would be explicitly delegated to NVO3 at some future
time - as part of a re-chartering evolution.

It is very odd to try to talk now about the "scope" of a potentially re-chartered NVO3 WG
at some future date.

As for MPLS, I believe that the IETF once had a broad discussion about whether or not it
is a Network Layer thing.  I believe the conclusion was that MPLS is closely tied to the
network layer (and IP in particular).

In addition to L2VPN and L3VPN as applications of MPLS, there is also Traffic Engineering.
I don't believe we have yet eliminated the potential need for traffic engineered paths in
virtual networks used for data-centers.  And I doubt anyone is willing to consider using
IP explicit routing to accomplish this, in the even that it is needed.

If we limit the scope of what NVO3 needs to consider to strictly IP encapsulation we may
be dodging many the problems we've talked about in NVO3.  In many cases, that might
be okay, but we don't know that at the moment...

--
Eric

From: [email-masked] [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Tuesday, June 04, 2013 4:10 PM
To: Lucy yong; Eric Gray; Larry Kreeger (kreeger); Thomas Narten; [email-masked]; Black, David; Murari Sridharan; [email-masked]
Subject: Re: [nvo3] Is there any difference between "Network Virtualization Overlay" and "Network Overlay"?
Importance: High

Snip...

Linda

---

From: Lucy yong <[email-masked]>
Date: Tue, 4 Jun 2013 22:26:59 +0000

IMO:  "over the network layer" is another important aspect for NVO3. We want to decouple application networking from the infrastructure network.
Thus, Virtualization and Overlay are the key.

Lucy

From: Eric Gray [mailto:[email-masked]]
Sent: Tuesday, June 04, 2013 3:53 PM
To: Linda Dunbar; [email-masked]
Cc: Lucy yong
Subject: RE: [nvo3] Is there any difference between "Network Virtualization Overlay" and "Network Overlay"?

Linda,

--
Eric

Snip...

Linda

---

From: Jon Hudson <[email-masked]>
Date: Tue, 4 Jun 2013 22:48:14 -0700

+1 well said!

On Jun 3, 2013, at 3:39 PM, Eric Gray <[email-masked]> wrote:

> From: Linda Dunbar <[email-masked]>
> To: Larry Kreeger <[email-masked]>, Thomas Narten <[email-masked]>, Dinesh Dutt <[email-masked]>, David Black <[email-masked]>, Murari Sridharan <[email-masked]>, "[email-masked]" <[email-masked]>
> In NV03 problem statement draft, “Network Overlay” is used. It is used in a context to indicate that virtualized network is achieved by IP overlay (instead of MPLS overlay, Ethernet Overlay, or TRILL overlay, etc).    
>  
> In draft-kreeger-nvo3-overlay-cp-03, “Network Virtualization Overlay” is used.
>  
> If yes, I suggest to define them properly. If no, let’s keep the terminology consistent in NVO3 WG.
>  
> NVO3 WG’s charter doesn’t include tackling control plane issues for all overlay models.
> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3

---

From: Jon Mitchell <[email-masked]>
Date: Thu, 6 Jun 2013 20:48:46 -0400

> IP explicit routing to accomplish this, in the even that it is needed.

Generally agree with your overall sentiment but just a nit - some are
willing to consider using IP explicit (not static) routing methods
(including just weighting by multiple path introduction) to acheive
non-MPLS based TE in DC's.

Jon

---

From: Eric Gray <[email-masked]>
Date: Mon, 10 Jun 2013 15:02:12 +0000

Jon,

	I likely introduced some confusion into this by misnaming the IP option I meant to refer to
when I said "IP explicit routing" - I meant "IP Source Routing" which provides a list of IP routers to be
used in forwarding an IP packet.

	In the past, this has been regarded by most as anathema because it involves manipulating
IP header information in ways that few (if any) routers are able to handle in the dataplane.

	Not sure what you mean by "IP explicit (not static) routing methods."

	Weighting of ECMP paths is a different thing entirely.

	Sorry about the confusion...

--
Eric

-----Original Message-----
From: Jon Mitchell [mailto:[email-masked]] 
Sent: Thursday, June 06, 2013 8:49 PM
To: Eric Gray
Cc: Linda Dunbar; [email-masked]; Lucy yong
Subject: Re: [nvo3] Is there any difference between "Network Virtualization Overlay" and "Network Overlay"?
Importance: High

On 04/06/13 20:53 +0000, Eric Gray wrote:
> I don't believe we have yet eliminated the potential need for traffic 
> engineered paths in virtual networks used for data-centers.  And I 
> doubt anyone is willing to consider using IP explicit routing to accomplish this, in the even that it is needed.

Generally agree with your overall sentiment but just a nit - some are willing to consider using IP explicit (not static) routing methods (including just weighting by multiple path introduction) to acheive non-MPLS based TE in DC's.

Jon

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 10 Jun 2013 15:06:21 +0000

Hi,

You might want to take a look at segment routing.

Regards,
Jeff