Subject: [nvo3] Poll for WG adoption of draft-ashwood-nvo3-operational-requirement-03

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Fri, 23 Aug 2013 15:19:15 +0000

This email begins a two week poll to help the chairs determine if there is consensus to adopt draft-ashwood-nvo3-operational-requirement-03.txt as an NVO3 working group draft.

The draft can be found here:
http://tools.ietf.org/id/draft-ashwood-nvo3-operational-requirement-03.txt

Please read the draft and indicate to the list if you support adoption, or if you do not support adoption (giving reasons).

Please note that this is only a call for adoption. There needs to be consensus that this draft is a good basis for the work, but it does not need to be perfect at this stage.

The poll for adoption will close in two weeks time, on Friday 6th September.

Best regards,

Matthew and Benson

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 25 Aug 2013 08:03:36 +0000

Hi,

I am confused. The charter of the NVO3 WG speaks about writing an Informational document that describes Operational Requirements. The I-D draft-ashwood-nvo3-operational-requirement-03.txt is not such a document, excepting its title. It takes as a model RFC 6136 which is an OAM requirements document. There is a clear difference between Operational Requirements and OAM Requirements. When we talk about Operational Requirements I for a new protocol or for protocol extensions I would expect to find information and derived requirements about operational environments, installation and set-up, migration path from current deployed networks, relation, coexistence and interaction with already deployed protocol, and impact on network operations. Yes, as a result of the operational requirements there may be a need to deploy OAM, and OAM requirements may be part of the solution and be described in the same document or in different documents, but Operations means more than just OAM.

I do not believe that in its current form this draft is a good enough basis for the chartered document on operational requirements.

Regards,

Dan

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Friday, August 23, 2013 6:19 PM
To: [email-masked]
Subject: [nvo3] Poll for WG adoption of draft-ashwood-nvo3-operational-requirement-03

Best regards,

Matthew and Benson

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 25 Aug 2013 08:05:57 +0000

See also RFC 5706 for more information about what would be expected in a more complete view of the operational requirements for new protocols and protocols extensions.

Regards,

Dan

From: [email-masked] [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Sunday, August 25, 2013 11:04 AM
To: Bocci, Matthew (Matthew); [email-masked]
Subject: Re: [nvo3] Poll for WG adoption of draft-ashwood-nvo3-operational-requirement-03

Hi,

Regards,

Dan

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Friday, August 23, 2013 6:19 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [nvo3] Poll for WG adoption of draft-ashwood-nvo3-operational-requirement-03

Best regards,

Matthew and Benson

---

From: Eric Gray <[email-masked]>
Date: Tue, 27 Aug 2013 21:26:23 +0000

Support.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Matthew)
Sent: Friday, August 23, 2013 11:19 AM
To: [email-masked]
Subject: [nvo3] Poll for WG adoption of draft-ashwood-nvo3-operational-requirement-03

Best regards,

Matthew and Benson

---

From: Eric Gray <[email-masked]>
Date: Tue, 27 Aug 2013 21:47:26 +0000

:-}

Wish I had seen this a minute or so earlier.

Dan (of course) has an excellent point.  However, there is (as Dan points out) a
few good reference points for what should be in this draft before it is done, and
I would rather avoid having a few "competing" drafts crop up in the meantime.

So, my support for adoption of this draft depends on the authors willingness to
make the modifications necessary for the draft to fulfill its role as intended in
the WG charter.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Sunday, August 25, 2013 4:04 AM
To: Bocci, Matthew (Matthew); [email-masked]
Subject: Re: [nvo3] Poll for WG adoption of draft-ashwood-nvo3-operational-requirement-03

Hi,

Regards,

Dan

Best regards,

Matthew and Benson

---

From: Tina TSOU <[email-masked]>
Date: Tue, 27 Aug 2013 21:53:24 +0000

Dear Eric et al,
Yes, we are willing to make necessary changes.

Thank you,
Tina

On Aug 27, 2013, at 2:48 PM, "Eric Gray" <[email-masked]<mailto:[email-masked]>> wrote:

:-}

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Sunday, August 25, 2013 4:04 AM
To: Bocci, Matthew (Matthew); [email-masked]<mailto:[email-masked]>
Subject: Re: [nvo3] Poll for WG adoption of draft-ashwood-nvo3-operational-requirement-03

Hi,

Regards,

Dan

Best regards,

Matthew and Benson

---

From: Melinda Shore <[email-masked]>
Date: Tue, 27 Aug 2013 16:20:25 -0800

On 8/27/13 1:47 PM, Eric Gray wrote:
> So, my support for adoption of this draft depends on the authors 
> willingness to make the modifications necessary for the draft to
> fulfill its role as intended in the WG charter.

I don't expect -00 working group drafts to be particularly
good, and I don't feel that adoption should be contingent on
how close a document is to being publication-ready.  However,
this one is so far off the mark that I think that it might
be a good idea if the authors revised it prior to the
issuance of another adoption call.  The basic issue here is
whether or not the authors understand the issues that Dan
raised.  They've indicated that they're willing to revise
the draft according to his suggestions but frankly the
charter text really is very clear.  I'm not opposed to
adopting a draft by these authors but I'm opposed to adopting
*this* draft.

Melinda

---

From: Melinda Shore <[email-masked]>
Date: Tue, 27 Aug 2013 16:30:29 -0800

Melinda

---

From: John E Drake <[email-masked]>
Date: Wed, 28 Aug 2013 00:42:47 +0000

Excellent, I agree completely.

Sent from my iPhone

On Aug 27, 2013, at 8:30 PM, "Melinda Shore" <[email-masked]> wrote:

> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3
> 
>

---

From: Tina TSOU <[email-masked]>
Date: Wed, 28 Aug 2013 05:49:57 +0000

Dear Dan,
Thank you for raising your concern.

You said "Operations means more than just OAM."
However, O of OAM stands for Operations literally.

I understand RFC5706, and quote it very often.

Thank you,
Tina

On Aug 25, 2013, at 1:04 AM, "Romascanu, Dan (Dan)" <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Regards,

Dan

Best regards,

Matthew and Benson

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 28 Aug 2013 10:53:03 +0000

Hi Tina,

Yes, the O in OAM stands for Operations. This does not mean however that all operational requirements are being met by defining and deploying OAM protocols.

Regards,

Dan

From: [email-masked] [mailto:[email-masked]] On Behalf Of Tina TSOU
Sent: Wednesday, August 28, 2013 8:50 AM
To: Romascanu, Dan (Dan)
Cc: Bocci, Matthew (Matthew); [email-masked]
Subject: Re: [nvo3] Poll for WG adoption of draft-ashwood-nvo3-operational-requirement-03

Dear Dan,

Thank you,
Tina

Regards,

Dan

Best regards,

Matthew and Benson

---

From: Eric Gray <[email-masked]>
Date: Wed, 28 Aug 2013 15:23:36 +0000

Makes sense.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Melinda Shore
Sent: Tuesday, August 27, 2013 8:20 PM
To: Eric Gray
Cc: Bocci, Matthew (Matthew); [email-masked]; Romascanu, Dan (Dan)
Subject: Re: [nvo3] Poll for WG adoption of draft-ashwood-nvo3-operational-requirement-03
Importance: High

> fulfill its role as intended in the WG charter.

I don't expect -00 working group drafts to be particularly good, and I don't feel that adoption should be contingent on how close a document is to being publication-ready.  However, this one is so far off the mark that I think that it might be a good idea if the authors revised it prior to the issuance of another adoption call.  The basic issue here is whether or not the authors understand the issues that Dan raised.  They've indicated that they're willing to revise the draft according to his suggestions but frankly the charter text really is very clear.  I'm not opposed to adopting a draft by these authors but I'm opposed to adopting
*this* draft.

Melinda

---

From: AshwoodsmithPeter <[email-masked]>
Date: Wed, 28 Aug 2013 19:45:58 +0000

Hey all, thanks for the feedback,

I see no problem with addressing these concrete concerns before adoption, it really does not make much difference to me, the main thing is that the document and its contents are useful to the group at large. 

What I would suggest is that we could restructure to use RFC 5706 as a template. I took a look at 5706 and listed out the table of contents and then put ** besides things that I think are already covered in the existing draft (see  below). 

The non asterisked items are the missing pieces that people feel need to be addressed.

If there is agreement with this approach then we are happy to try to do this and of course solicit input from the group on those missing pieces.

As to if it gets adopted before or after changes I leave that purely to the discretion of the group/chairs. I don't mind either way.
 
Peter
 
   2. Operational Considerations - How Will the New Protocol
      Fit into the Current Environment? ...............................8
      2.1. Operations .................................................9
      2.2. Installation and Initial Setup .............................9
      2.3. Migration Path ............................................10
      2.4. Requirements on Other Protocols and Functional
           Components ................................................11
      2.5. Impact on Network Operation ...............................11
      2.6. Verifying Correct Operation ...............................12 **
   3. Management Considerations - How Will the Protocol Be Managed? ..12
      3.1. Interoperability ..........................................14
      3.2. Management Information ....................................17
           3.2.1. Information Model Design ...........................18
      3.3. Fault Management ..........................................18 **
           3.3.1. Liveness Detection and Monitoring ..................19 **
           3.3.2. Fault Determination ................................19 **
           3.3.3. Root Cause Analysis ................................20 (some)
           3.3.4. Fault Isolation ....................................20 **
      3.4. Configuration Management ..................................20
           3.4.1. Verifying Correct Operation ........................22 **
      3.5. Accounting Management .....................................22
      3.6. Performance Management ....................................22 **
           3.6.1. Monitoring the Protocol ............................23 **
           3.6.2. Monitoring the Device ..............................24 **
           3.6.3. Monitoring the Network .............................24 **
           3.6.4. Monitoring the Service .............................25 **
      3.7. Security Management .......................................25

Peter

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Eric Gray
Sent: Wednesday, August 28, 2013 11:24 AM
To: Melinda Shore
Cc: Bocci, Matthew (Matthew); [email-masked]; Romascanu, Dan (Dan)
Subject: Re: [nvo3] Poll for WG adoption of draft-ashwood-nvo3-operational-requirement-03

Makes sense.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Melinda Shore
Sent: Tuesday, August 27, 2013 8:20 PM
To: Eric Gray
Cc: Bocci, Matthew (Matthew); [email-masked]; Romascanu, Dan (Dan)
Subject: Re: [nvo3] Poll for WG adoption of draft-ashwood-nvo3-operational-requirement-03
Importance: High

Melinda