Subject: [nvo3] One question about draft draft-tissa-nvo3-oam-fm-00

From: Haoweiguo <[email-masked]>
Date: Fri, 13 Jun 2014 09:07:01 +0000

Hi Tissa,

In section 10.1 in your draft of draft-tissa-nvo3-oam-fm-00, theory of operation is discribed, you say that originator device should specify the TTL of the transport header as 1 for the first request. Because transit devices in underlying network normally don't support the OAM function, if you specify TTL as 1, the first transit device will drop it, remote MEP or MIP won't receive the message if two or more hops exists between ingress and egress MEPs, so the response timer will expire on originator device.
How can you ensure the OAM state machine on originator runs correctly in this scenario?

Thanks

weiguo

---

From: "Tissa Senevirathne (tsenevir)" <[email-masked]>
Date: Fri, 13 Jun 2014 14:12:34 +0000

Hi Weiguo

This is a good question.

If the intermediate device is not aware of the nvo3 OAM few thing will happen

1.      When TTL expiry happens the device is supposed to generate ICMP message TTL expiery, the originator can interpret

2.      Assume #1 did not happen

a.      In that case originator device , upon retransmission expiry would increment the TTL and re-transmit.

b.      In the display you would see a * - indicating device timedout or unknown

c.      Output will look like something below

                                                    i.     [ip address of TTL=1]

                                                   ii.     *  [non compatible device]

                                                  iii.     [ip address of TTL=2]

                                                  iv.     And so on.

3.      It is possible the path is broken at (ii). So the drawback is originator has to try max-TTL to figure out path is indeed broken at (ii). Which is a slightly a longer time and a price to pay for mixed network. BTW: this is the exact same result today with IP traceroute and one of the devices disable ICMP response due to security or other reasons.

I will update the draft with backwards compatibility section to include this and other caveats in a mixed mode networks.

From: nvo3 [mailto:[email-masked]] On Behalf Of Haoweiguo
Sent: Friday, June 13, 2014 2:07 AM
To: Tissa Senevirathne (tsenevir)
Cc: [email-masked]
Subject: [nvo3] One question about draft draft-tissa-nvo3-oam-fm-00

Hi Tissa,

Thanks

weiguo

---

From: Haoweiguo <[email-masked]>
Date: Mon, 16 Jun 2014 02:56:25 +0000

Hi Tissa,

Thanks for your reply.

Based on your original method of specifying TTL=1 in your first OAM request message, if the transit devices can't generate ICMP TTL expirary message to originator when receiving TTL=0 IP packet, the transit device's behavior is always equal to the underlay network device or link failure for the originator.

So I think the correct procedures should as follows:

1. Specify TTL=254 in the OAM first request message.

2. In normal case, the OAM response message will be received on the originator.

3. If underlay network occurs node or link failure , the OAM response timer on the originator will expire. Then it will trigger the originator to detect underlay network failure through IP trace procedures.

Firstly the originator construct IP trace message with TTL=1 and wait ICMP TTL expirary message, if no response is received, link or node failure to the first hop device should occur. If the response is received, then it will increase TTL and repeat the procedures until finally node and failure of underlay network is detected.

Thanks

weiguo

________________________________

发件人: Tissa Senevirathne (tsenevir) [[email-masked]]
发送时间: 2014年6月13日 22:12
收件人: Haoweiguo
抄送: [email-masked]
主题: RE: One question about draft draft-tissa-nvo3-oam-fm-00

Hi Weiguo

This is a good question.

                                                    i.     [ip address of TTL=1]

                                                  iv.     And so on.

Hi Tissa,

Thanks

weiguo