Subject: [nvo3] Secdir review of draft-ietf-nvo3-arch-06

From: "Takeshi Takahashi" <[email-masked]>
Date: Sat, 13 Aug 2016 00:11:04 +0900

I have reviewed this document as part of the security directorate's ongoing
effort to review all IETF documents being processed by the IESG.

These comments were written primarily for the benefit of the security area
directors.

Document editors and WG chairs should treat these comments just like any
other last call comments.

[General summary]

This document is ready.

[Topic of this draft]

This informational document describes a high-level overview architecture for
building data center network viatualization overlay (NVO3) networks.

It breaks down the architecture and defines several components needed for
realizing the architecture, such as Network Virtualization Edge (NVE) and
Network Virtualization Authority (NVA).

[Minor Comment]

In Section 16 "Security Considerations", you could consider addressing the
policy enforcement issue you've discussed in Section 5.4.

The sentence starting with "Leakage of sensitive information" could be, for
instance, changed from "...by using encryption" to "...by using encryption
and ensuring policy enforcement".

[Editorial Comment]

In Page 9, there is a sentence "NVAs provide a service, and NVEs access that
service via an NVE-to-NVA protocol as discussed in Section 4.3."

This current sentence is fine, but referring Section 8 "NVE-to-NVA Protocol"
(instead of Section 4.3 "NVE State") could be better.

In Section 2, definition of "VLAN": "are used in this document denote a
C-VLAN", could be "are used in this document to denote a C-VLAN".

I enjoyed reading the draft.

Thank you.

Take

---

From: "Black, David" <[email-masked]>
Date: Fri, 12 Aug 2016 15:51:00 +0000

Take-san,

Thank you for the review.   I've made changes to address all of your comments in my working copy of this draft that will be posted as the -07 version next week.

The minor comment on information leakage affects both the data plane and control plane and hence I've made changes to address it in two paragraphs in the Security Considerations section.  Here are the revised versions of both paragraphs:

For the data plane, tunneled application traffic may need protection against being misdelivered, modified, or having its content exposed to an inappropriate third party. In all cases, encryption between authenticated tunnel endpoints and enforcing policies that control which endpoints and VNs are permitted to exchange traffic can be used to mitigate risks.

[...]

Leakage of sensitive information about users or other entities associated with VMs whose traffic is virtualized can also be covered by using encryption for the control plane protocols and enforcing policies that control which NVO3 components are permitted to exchange control plane traffic.

Thanks, --David

From: Takeshi Takahashi [mailto:[email-masked]]
Sent: Friday, August 12, 2016 11:11 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Secdir review of draft-ietf-nvo3-arch-06

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.
These comments were written primarily for the benefit of the security area directors.
Document editors and WG chairs should treat these comments just like any other last call comments.

[General summary]
This document is ready.

[Topic of this draft]
This informational document describes a high-level overview architecture for building data center network viatualization overlay (NVO3) networks.
It breaks down the architecture and defines several components needed for realizing the architecture, such as Network Virtualization Edge (NVE) and Network Virtualization Authority (NVA).

[Minor Comment]
In Section 16 "Security Considerations", you could consider addressing the policy enforcement issue you've discussed in Section 5.4.
The sentence starting with "Leakage of sensitive information" could be, for instance, changed from "...by using encryption" to "...by using encryption and ensuring policy enforcement".

[Editorial Comment]
In Page 9, there is a sentence "NVAs provide a service, and NVEs access that service via an NVE-to-NVA protocol as discussed in Section 4.3."
This current sentence is fine, but referring Section 8 "NVE-to-NVA Protocol" (instead of Section 4.3 "NVE State") could be better.

In Section 2, definition of "VLAN": "are used in this document denote a C-VLAN", could be "are used in this document to denote a C-VLAN".

Thank you.
Take

---

From: "Takeshi Takahashi" <[email-masked]>
Date: Sat, 13 Aug 2016 09:10:17 +0900

Hello David-san,

Thank you for reflecting my comments. I like the revised sentences.

I hope this draft will be published as an RFC soon.

Best regards,

Take

From: Black, David [mailto:[email-masked]] 
Sent: Saturday, August 13, 2016 12:51 AM
To: Takeshi Takahashi <[email-masked]>;
[email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; Black, David
<[email-masked]>
Subject: RE: Secdir review of draft-ietf-nvo3-arch-06

Take-san,

Thank you for the review.   I've made changes to address all of your
comments in my working copy of this draft that will be posted as the -07
version next week.

The minor comment on information leakage affects both the data plane and
control plane and hence I've made changes to address it in two paragraphs in
the Security Considerations section.  Here are the revised versions of both
paragraphs:

For the data plane, tunneled application traffic may need protection against
being misdelivered, modified, or having its content exposed to an
inappropriate third party. In all cases, encryption between authenticated
tunnel endpoints and enforcing policies that control which endpoints and VNs
are permitted to exchange traffic can be used to mitigate risks.

[...]

Leakage of sensitive information about users or other entities associated
with VMs whose traffic is virtualized can also be covered by using
encryption for the control plane protocols and enforcing policies that
control which NVO3 components are permitted to exchange control plane
traffic.

Thanks, --David

From: Takeshi Takahashi [mailto:[email-masked]] 
Sent: Friday, August 12, 2016 11:11 AM
To: [email-masked]
<mailto:[email-masked]> 
Cc: [email-masked] <mailto:[email-masked]> ; [email-masked]
<mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> 
Subject: Secdir review of draft-ietf-nvo3-arch-06

[General summary]

This document is ready.

[Topic of this draft]

[Minor Comment]

[Editorial Comment]

Thank you.

Take