Subject: Re: [nvo3] AD review of draft-ietf-nvo3-arch-06

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 9 Aug 2016 00:31:04 +0000

Hi, David,

Please find my $0.02 on one of your points, inline.

On Jul 30, 2016, at 1:33 AM, Black, David <[email-masked]<mailto:[email-masked]>> wrote:

Hi Alia,

> I will optimistically send this document to IETF Last Call - but the authors do need to update this section and respond to my other concerns.

Thanks for doing this.  Regarding your Major concern:

>  i) I note that draft-ashwood-nvo3-operational-requirement-03 expired about 3 years ago.  Section 12 basically says that
> OAM is important and punts to this draft.  I believe that you will need more details.

Would it be acceptable to provide a little bit more in the way of details and then point to draft-ooamdt-rtgwg-ooam-requirement-01 ?
It seems preferable to have overlay OAM requirements discussions in the context of that draft rather than this NVO3 architecture draft.

FWIW, I do not think it is completely appropriate (or useful) for the (consensus-based) NVO3 Architecture to point to a draft from a Design Team, not adopted or validated by a WG.

If it’s OK to punt, what’s the benefit in saying “details on draft-ooamdt-rtgwg-ooam-requirement-01” (which scopes itself as a larger superset than NVO3) as opposed to “details in the future”?

Thanks,

— Carlos.

For your first minor concern:

>    1) Please add C-VID to the terminology.  It is used without context in 3.1.1.

I think we should rewrite that sentence to just eliminate the C-VID acronym, e.g.,

OLD
   Note that the handling of C-VIDs has additional complications, as
   described in Section 4.2.1 below.
NEW
  Note that there are additional considerations when VLAN tags are used to
  identify both the VN and a Tenant System VLAN within that VN,
  as described in Section 4.2.1 below.

Everything else appears to be useful editorial suggestions.

Thanks, --David

From: Alia Atlas [mailto:[email-masked]]
Sent: Friday, July 29, 2016 6:14 PM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: AD review of draft-ietf-nvo3-arch-06

First, I would like to thank the authors, David, Jon, Larry, Marc, and Thomas, for their work on this draft and pushing it to completion.

As is customary, I have done my AD review of draft-ietf-nvo3-arch-06 before progressing it.  I do apologize for the delay in my review; I had a lot of documents show up quite quickly this winter and spring.

My primary concern is around the operational and management considerations.  My detailed review is below.   I will optimistically send this document to IETF Last Call - but the authors do need to update this section and respond to my other concerns.  If they are timely, then this can make it onto the IESG telechat on August 18.

Major:

   i) I note that draft-ashwood-nvo3-operational-requirement-03 expired about 3 years ago.  Section 12 basically says that OAM is important and punts to this draft.  I believe that you will need more details.

Minor:

   1) Please add C-VID to the terminology.  It is used without context in 3.1.1.

    2)In Sec 4.1:  "While there may be APIs between the NVE and hypervisor to support necessary interaction, the details of such an API are not in-scope for the IETF to work on."
Could this be softened to "not specifically in-scope for the NVO3 WG to work on"?  If there were agreement that the NVE and hypervisors need interoperability, I could see APIs being in scope.

  3) It looks like work on draft-ietf-nvo3-dataplane-requirements-03 has been abandoned (which is fine).  Please remove the reference.

Nits:

a) In Sec 3.4, it says "in use today".  Replace with "in use in 2016" or the like - since the RFC will live for a long time and not be updated with "today" systems.

Regards & Thanks,
Alia
_______________________________________________
nvo3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nvo3

---

From: "Black, David" <[email-masked]>
Date: Wed, 10 Aug 2016 01:27:34 +0000

Hi Carlos,

Thanks for the input, even if it didn’t make my day ;-).

> FWIW, I do not think it is completely appropriate (or useful) for the (consensus-based) NVO3 Architecture to point to a draft from
> a Design Team, not adopted or validated by a WG.

Ok, there goes that plan :-(.  Some new text will have to be written from scratch ... it’ll get sent here (NVO3 list) for review.

>  If it’s OK to punt, what’s the benefit in saying “details on draft-ooamdt-rtgwg-ooam-requirement-01” (which scopes itself as
> a larger superset than NVO3) as opposed to “details in the future”?

Alia has made it clear that it is *not* OK to punt, and I think she’s right about that.

Thanks, --David

From: Carlos Pignataro (cpignata) [mailto:[email-masked]]
Sent: Monday, August 08, 2016 8:31 PM
To: Black, David
Cc: Alia Atlas; [email-masked]; [email-masked]
Subject: Re: [nvo3] AD review of draft-ietf-nvo3-arch-06

Hi, David,

Hi Alia,

Thanks,

— Carlos.

OLD

Thanks, --David

Major:

Minor:

Nits:

Regards & Thanks,
Alia