Subject: [nvo3] WG last call for draft-ietf-nvo3-use-case-09

From: "Bocci, Matthew (Nokia - GB)" <[email-masked]>
Date: Tue, 6 Sep 2016 10:14:15 +0000

This email begins a two week working group last call for draft-ietf-nvo3-use-case-09.txt.

Please review the draft and post any comments to the NVO3 working group list.

If you have read the latest version of the draft but have no comments and believe it is ready for publication as an Informational RFC, please also indicate so to the WG email list.

This working group last call will close on Tuesday 20th September 2016.

Best regards

Matthew and Sam

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 6 Sep 2016 20:13:54 -0700

Matthew,

I’ve read the draft and believe that it is ready to be published as an
informational RFC.

Thanks,
Andy

On Tue, Sep 6, 2016 at 3:14 AM, Bocci, Matthew (Nokia - GB) <
[email-masked]> wrote:

> If you have read the latest version of the draft but have no comments and
> believe it is ready for publication as an Informational RFC, please also
> indicate so to the WG email list.
>
>
>
> _______________________________________________
> nvo3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nvo3
>
>

---

From: Hui Deng <[email-masked]>
Date: Wed, 7 Sep 2016 12:08:53 +0800

Hello all,
I have read the updated draft recent published, believe it should move forward now, so +1
thanks
DENG HuiFrom: [email-masked]
To: [email-masked]
Date: Tue, 6 Sep 2016 10:14:15 +0000
Subject: [nvo3] WG last call for draft-ietf-nvo3-use-case-09

 
 
Best regards
 
Matthew and Sam

---

From: Lucy yong <[email-masked]>
Date: Wed, 7 Sep 2016 23:46:43 +0000

As a co-author, I support publishing it as an informational RFC.

Lucy

From: nvo3 [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Nokia - GB)
Sent: Tuesday, September 06, 2016 5:14 AM
To: NVO3
Subject: [nvo3] WG last call for draft-ietf-nvo3-use-case-09

Best regards

Matthew and Sam

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 8 Sep 2016 01:21:38 +0000

I have read the latest version of this draft and believe it’s ready for publication as an informational RFC.

Best regards,
Xiaohu

发件人: nvo3 [mailto:[email-masked]] 代表 Bocci, Matthew (Nokia - GB)
发送时间: 2016年9月6日 18:14
收件人: NVO3
主题: [nvo3] WG last call for draft-ietf-nvo3-use-case-09

Best regards

Matthew and Sam

---

From: Joe Touch <[email-masked]>
Date: Wed, 7 Sep 2016 19:48:22 -0700

I support this doc as an Informational RFC as well.

Joe

On 9/7/2016 4:46 PM, Lucy yong wrote:
>
> /As a co-author, I support publishing it as an informational RFC./
>
> / /
>
> /Lucy/
>
> / /
>
> *From:*nvo3 [mailto:[email-masked]] *On Behalf Of *Bocci,
> Matthew (Nokia - GB)
> *Sent:* Tuesday, September 06, 2016 5:14 AM
> *To:* NVO3
> *Subject:* [nvo3] WG last call for draft-ietf-nvo3-use-case-09
>
>  
>
> If you have read the latest version of the draft but have no comments
> and believe it is ready for publication as an Informational RFC,
> please also indicate so to the WG email list.
>
>  
>
> This working group last call will close on Tuesday 20^th September 2016.
>
>  
>
> Best regards
>
>  
>
> Matthew and Sam
>
>
>

---

From: Tom Herbert <[email-masked]>
Date: Wed, 7 Sep 2016 20:20:09 -0700

I support this draft and believe it is ready for publication.

Tom

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 8 Sep 2016 16:28:47 +0000

Linda

Best regards

Matthew and Sam

---

From: "Reith, Lothar" <[email-masked]>
Date: Fri, 9 Sep 2016 08:35:36 +0000

Dear all,

in section 4.3 there is a reference to “Figure 3 below”, however the referenced figure is undertitled as “Figure 2” and a figure 3 does not exist.

I suggest to correct the reference to the figure as “Figure 2 below”.

Besides this minor flaw I have a question regarding what is shown in this figure combined with the suggestion to consider some clarification text.

It is not clear to me if the shown L2VNs named VNx, VNy and VNz are nested in the shown L3 VNa and if yes how that is reflected in the respetive identifier relations (or not at all reflected in the identifier relations such as VNI).

So in a nutshell, my question is: Is there something like “nested VNIs” (in particular regarding L2 VNIs nested in L3 VNIs) or not?

I like to not that clarity about identifier relations is absolutely critical when it comes to the associated data modelling.

Best Regards, Lothar

For ease of reference please find below the portion of the figure which my question relates to:

I ...+....                   |..|
                  +-------: L3 VNa :---------+        LANs
                +-+-+      ........          |
                |LB |          |             |     Enterprise Site
                +-+-+          |             |
               ...+...      ...+...       ...+...
              : L2VNx :    : L2VNy :     : L2VNz :
               .......      .......       .......
                 |..|         |..|          |..|
                 |  |         |  |          |  |
               Web App.     Mail App.      VoIP App.

Von: nvo3 [mailto:[email-masked]] Im Auftrag von Bocci, Matthew (Nokia - GB)
Gesendet: Dienstag, 6. September 2016 12:14
An: NVO3 <[email-masked]>
Betreff: [nvo3] WG last call for draft-ietf-nvo3-use-case-09

Best regards

Matthew and Sam

---

From: David Allan I <[email-masked]>
Date: Fri, 9 Sep 2016 23:21:28 +0000

I’m happy with the current draft…

Cheers
Dave

From: nvo3 [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Nokia - GB)
Sent: Tuesday, September 06, 2016 3:14 AM
To: NVO3 <[email-masked]>
Subject: [nvo3] WG last call for draft-ietf-nvo3-use-case-09

Best regards

Matthew and Sam

---

From: Lucy yong <[email-masked]>
Date: Mon, 12 Sep 2016 13:32:43 +0000

Hi Lothar,

Please see inline below.

From: nvo3 [mailto:[email-masked]] On Behalf Of Reith, Lothar
Sent: Friday, September 09, 2016 3:36 AM
To: Bocci, Matthew (Nokia - GB); NVO3
Subject: Re: [nvo3] WG last call for draft-ietf-nvo3-use-case-09

Dear all,

[Lucy] Ack. Thanks.

I like to not that clarity about identifier relations is absolutely critical when it comes to the associated data modelling.
[Lucy] Section 4.3 intends describing virtual Data Center service and showing an abstraction view of virtual Data Center. It does not describe how DC operator construct individual NVO3 networks to realize it. I agree that data model is important for a solution but that should be addressed in a solution draft. A Virtual Data Center may contain multiple overlay networks that may be interconnected and some service functions. I will make this indent more clear in next version.

IMO: a virtual data center should contain one address space. It could assign a subnet for each application of a customer.

Thanks/Regards,
Lucy

Best Regards, Lothar

I ...+....                   |..|

Von: nvo3 [mailto:[email-masked]] Im Auftrag von Bocci, Matthew (Nokia - GB)
Gesendet: Dienstag, 6. September 2016 12:14
An: NVO3 <[email-masked]<mailto:[email-masked]>>
Betreff: [nvo3] WG last call for draft-ietf-nvo3-use-case-09

Best regards

Matthew and Sam

---

From: "Reith, Lothar" <[email-masked]>
Date: Tue, 13 Sep 2016 07:10:37 +0000

Hi Lucy,

okay.

As I trust a lot in Dave Allen’s judgement, I could even live with getting it out the door as it is.

Lothar

Von: Lucy yong [mailto:[email-masked]]
Gesendet: Montag, 12. September 2016 15:33
An: Reith, Lothar <[email-masked]>; Bocci, Matthew (Nokia - GB) <[email-masked]>; NVO3 <[email-masked]>
Betreff: RE: WG last call for draft-ietf-nvo3-use-case-09

Hi Lothar,

Please see inline below.

Dear all,

Thanks/Regards,
Lucy

Best Regards, Lothar

I ...+....                   |..|

Best regards

Matthew and Sam

---

From: Olufemi Komolafe <[email-masked]>
Date: Thu, 15 Sep 2016 10:18:18 +0000

I think the draft is OK but I’ve got a few comments below:

Section 1: Why are these the  use cases considered?   I think a better justification of why these use cases are considered representative or even significant will enhance the draft.

Section 3.1: Perhaps add a better definition of vGW

Section 4: Is this statement 100% accurate: "Operators no longer need to worry about the constraints of the DC physical network configuration when creating VMs and configuring a virtual network."?

Section 4.1: This section is potentially very interesting and perhaps should be fleshed out some more; some of the issues arising from interworking between different technologies are interesting and perhaps worthy of further discussion.  However, there are some suggestions that some DCs are highly homogenised in terms of deployed hardware and technology so perhaps also mention this possibility?

Section 4:3: "DC Provider operators"? In fact, draft uses both "DC provider" or "DC operator" throughout.  Is there a difference?  If so, perhaps state the difference.  If not, perhaps pick one and use it consistently in the draft?

Regards,
Femi

From: nvo3 [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Nokia - GB)
Sent: Tuesday, September 06, 2016 11:14 AM
To: NVO3 <[email-masked]>
Subject: [nvo3] WG last call for draft-ietf-nvo3-use-case-09

Best regards

Matthew and Sam

---

From: Haoweiguo <[email-masked]>
Date: Fri, 16 Sep 2016 05:08:31 +0000

Hi,

I have read through the latest version of this draft, i think it is in good shape and can be ready for publication as an informational RFC.

Thanks,

weiguo

________________________________
From: David Allan I [[email-masked]]
Sent: Saturday, September 10, 2016 7:21
To: Bocci, Matthew (Nokia - GB); NVO3
Subject: Re: [nvo3] WG last call for draft-ietf-nvo3-use-case-09

Cheers
Dave

Best regards

Matthew and Sam

---

From: Lucy yong <[email-masked]>
Date: Fri, 16 Sep 2016 19:38:14 +0000

Hi Femi,

Thank you for the comment. Please see inline below.

From: nvo3 [mailto:[email-masked]] On Behalf Of Olufemi Komolafe
Sent: Thursday, September 15, 2016 5:18 AM
To: Bocci, Matthew (Nokia - GB); NVO3
Subject: Re: [nvo3] WG last call for draft-ietf-nvo3-use-case-09

Section 1: Why are these the  use cases considered?   I think a better justification of why these use cases are considered representative or even significant will enhance the draft.
[Lucy] Section 1 is introduction that highlight NVO3 motivation and its enabled applications. The rest of sections describes some use cases and justification.

Section 3.1: Perhaps add a better definition of vGW
[Lucy] ack. Will do in next version.

Section 4: Is this statement 100% accurate: "Operators no longer need to worry about the constraints of the DC physical network configuration when creating VMs and configuring a virtual network."?
[Lucy] This is a goal at least. When DC service provider offers IaaS to customers and allows a customer to create its own cloud on DC service provider infrastructure, DC provider zero touch provisioning is the goal,  and no DC physical network configuration change is a “MUST” to achieve this goal.

Section 4.1: This section is potentially very interesting and perhaps should be fleshed out some more; some of the issues arising from interworking between different technologies are interesting and perhaps worthy of further discussion.  However, there are some suggestions that some DCs are highly homogenised in terms of deployed hardware and technology so perhaps also mention this possibility?
[Lucy] What would you like to add here?

Section 4:3: "DC Provider operators"? In fact, draft uses both "DC provider" or "DC operator" throughout.  Is there a difference?  If so, perhaps state the difference.  If not, perhaps pick one and use it consistently in the draft?
[Lucy] Thanks to point out this. DC Provider means that a company offers cloud services to consumers. DC operators are roles who are responsible to construct and manage cloud service instances in their life-cycle and manage the infrastructure for running these applications . One is from consumer perspective, another is from DC and service operation perspective. Any service provider company has these two aspects: easy for customer to get a service and easy for operator to manage the service. Make a sense? If yes, I will make it clear in next version.

Thanks,
Lucy

Regards,
Femi

From: nvo3 [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Nokia - GB)
Sent: Tuesday, September 06, 2016 11:14 AM
To: NVO3 <[email-masked]<mailto:[email-masked]>>
Subject: [nvo3] WG last call for draft-ietf-nvo3-use-case-09

Best regards

Matthew and Sam

---

From: "Chenhao (philips)" <[email-masked]>
Date: Sun, 18 Sep 2016 00:41:00 +0000

Dear all,

I have read the latest version of this draft and I believe it is ready for publication as an Informational RFC.
Thanks.

Best regards,
Hao
From: nvo3 [mailto:[email-masked]] On Behalf Of Bocci, Matthew (Nokia - GB)
Sent: Tuesday, September 06, 2016 6:14 PM
To: NVO3
Subject: [nvo3] WG last call for draft-ietf-nvo3-use-case-09

Best regards

Matthew and Sam

---

From: "Yuxiang (Yolanda)" <[email-masked]>
Date: Sun, 18 Sep 2016 01:50:20 +0000

Hi all,

         I’ve read the “draft-ietf-nvo3-use-case-09.txt”, and support the publication of the Informational RFC.

B.R.
Yolanda Yu

Best regards

Matthew and Sam

---

From: Olufemi Komolafe <[email-masked]>
Date: Mon, 19 Sep 2016 10:49:49 +0000

Lucy,

Please see inline….

From: Lucy yong [mailto:[email-masked]]
Sent: Friday, September 16, 2016 8:38 PM
To: Olufemi Komolafe <[email-masked]>; Bocci, Matthew (Nokia - GB) <[email-masked]>; NVO3 <[email-masked]>
Subject: RE: WG last call for draft-ietf-nvo3-use-case-09

Hi Femi,

Section 1: Why are these the  use cases considered?   I think a better justification of why these use cases are considered representative or even significant will enhance the draft.
[Lucy] Section 1 is introduction that highlight NVO3 motivation and its enabled applications. The rest of sections describes some use cases and justification.
[Femi]:  Yeah, I understand your point but I was wondering if you can state why you picked these particular use cases and scenarios.   i.e. do you consider these to be the most likely use cases?  Or the most complex/interesting use cases?  If so, why?

[Femi]: OK.

[Femi]: Fair enough.

Section 4.1: This section is potentially very interesting and perhaps should be fleshed out some more; some of the issues arising from interworking between different technologies are interesting and perhaps worthy of further discussion.  However, there are some suggestions that some DCs are highly homogenised in terms of deployed hardware and technology so perhaps also mention this possibility?
[Lucy] What would you like to add here?
[Femi]: Perhaps expand the discussion  on the VXLAN/NVGRE/VLAN interworking example to highlight some of the issues/benefits when different NVO3 overlays are used within the same DC?  And state how likely you think such use cases are likely to be?

Section 4:3: "DC Provider operators"? In fact, draft uses both "DC provider" or "DC operator" throughout.  Is there a difference?  If so, perhaps state the difference.  If not, perhaps pick one and use it consistently in the draft?
[Lucy] Thanks to point out this. DC Provider means that a company offers cloud services to consumers. DC operators are roles who are responsible to construct and manage cloud service instances in their life-cycle and manage the infrastructure for running these applications . One is from consumer perspective, another is from DC and service operation perspective. Any service provider company has these two aspects: easy for customer to get a service and easy for operator to manage the service. Make a sense? If yes, I will make it clear in next version.
[Femi]: Makes sense; thanks for clarifying.

Regards,
Femi

Thanks,
Lucy

Regards,
Femi

Best regards

Matthew and Sam

---

From: Lucy yong <[email-masked]>
Date: Mon, 19 Sep 2016 14:10:11 +0000

Hi Femi,

[Lucy] Please see inline below.

Section 1: Why are these the  use cases considered?   I think a better justification of why these use cases are considered representative or even significant will enhance the draft.
[Lucy] Section 1 is introduction that highlight NVO3 motivation and its enabled applications. The rest of sections describes some use cases and justification.
[Femi]:  Yeah, I understand your point but I was wondering if you can state why you picked these particular use cases and scenarios.   i.e. do you consider these to be the most likely use cases?  Or the most complex/interesting use cases?  If so, why?
[Lucy] I see your concern. We can point out that these use cases represent DC service provider interests and vision for their cloud services. Some use cases are relative easy to be implemented technically; and some may be challenges and require a new technology to enable that.

Section 4.1: This section is potentially very interesting and perhaps should be fleshed out some more; some of the issues arising from interworking between different technologies are interesting and perhaps worthy of further discussion.  However, there are some suggestions that some DCs are highly homogenised in terms of deployed hardware and technology so perhaps also mention this possibility?
[Lucy] What would you like to add here?
[Femi]: Perhaps expand the discussion  on the VXLAN/NVGRE/VLAN interworking example to highlight some of the issues/benefits when different NVO3 overlays are used within the same DC?  And state how likely you think such use cases are likely to be?
[Lucy] Section 4.1 states two reasons for the needs of supporting multiple technologies in a DC. One is for DC migration time; another is no all applications to be good to run on virtual machines. This is not that DC Operators like to use multiple technologies, it is that they have to use them for these reasons. IMO: that is clear enough.

Thanks,
Lucy

Regards,
Femi

Thanks,
Lucy

Regards,
Femi

Best regards

Matthew and Sam

---

From: Olufemi Komolafe <[email-masked]>
Date: Mon, 19 Sep 2016 14:33:20 +0000

Lucy,

OK, fair enough.  Sounds good to me.

Regards,
Femi

From: Lucy yong [mailto:[email-masked]]
Sent: Monday, September 19, 2016 3:10 PM
To: Olufemi Komolafe <[email-masked]>; Bocci, Matthew (Nokia - GB) <[email-masked]>; NVO3 <[email-masked]>
Subject: RE: WG last call for draft-ietf-nvo3-use-case-09

Hi Femi,

Thanks,
Lucy

Regards,
Femi

Thanks,
Lucy

Regards,
Femi

Best regards

Matthew and Sam