Subject: [nvo3] Geneve implementations

From: Daniel Migault <[email-masked]>
Date: Thu, 22 Jun 2017 17:00:53 -0400

Hi,

I am wondering if there are any implementations of Geneve where inserting
an option can easily be done. This is mostly for proof of concept.

Yours,
Daniel

---

From: "Ganga, Ilango S" <[email-masked]>
Date: Fri, 23 Jun 2017 03:46:29 +0000

Hi Daniel,

Yes, you can take a look at OVN under Open vSwitch project (openvswitch.org). The logical port numbers are carried in a Geneve TLV. Here is high level documentation available at the following URL.
http://openvswitch.org/support/dist-docs/ovn-architecture.7.html

Regards,
Ilango

From: nvo3 [mailto:[email-masked]] On Behalf Of Daniel Migault
Sent: Thursday, June 22, 2017 2:01 PM
To: [email-masked]
Subject: [nvo3] Geneve implementations

Hi,
I am wondering if there are any implementations of Geneve where inserting an option can easily be done. This is mostly for proof of concept.

Yours,
Daniel